Visualizzazione risultati 1 fino 7 di 7

Discussione: Problema SSL con WordPress self-installed

  1. #1
    lightnovelita non  connesso Utente Blog
    Data registrazione
    06-09-2022
    Messaggi
    5

    Predefinito Problema SSL con WordPress self-installed

    Ho scaricato WordPress 6.0.2 dal sito ufficiale in Italiano di WordPress, ho caricato tutti i file dello file unzippato sul server tramite FTP client (FileZilla), ho installato correttemente WordPress inserendo tutti i dati del dB, vado in wp-admin e vado nelle impostazioni in Site Health e mi dice che il mio sito non supporta HTTPS anche se dal pannello attivato in automatico, clicco sul pulsante per modificare il sito per l'HTTPS e adesso mi da errore di connessione al server provando ad accedere al mio sito. Come mai? Cos' successo esattamente? Come posso risolvere?

  2. #2
    lightnovelita non  connesso Utente Blog
    Data registrazione
    06-09-2022
    Messaggi
    5

    Predefinito

    AGGIORNAMENTO: Come consigliato dalla pagina di errore che mi appariva ho cancellato tutti i cookie e i dati del browser e la home del mio sito adesso visualizzata correttamente e funziona anche l'HTTPS, ma se provo a inserire wp-admin mi da nuovamente quell'errore di prima.

  3. #3
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    20,339

    Predefinito

    In una installazione "originale" di WordPress, oltre ad abilitare HTTPS lato AlterVista occorre impostare WordPress per usare HTTPS: vedi qui: https://forum.it.altervista.org/how/...prio-sito.html

    Ciao!

  4. #4
    lightnovelita non  connesso Utente Blog
    Data registrazione
    06-09-2022
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    In una installazione "originale" di WordPress, oltre ad abilitare HTTPS lato AlterVista occorre impostare WordPress per usare HTTPS: vedi qui: https://forum.it.altervista.org/how/...prio-sito.html

    Ciao!
    Ho aggiunto il codice nel mio .htaccess e modificato nome. in lightnovelita. come indirizzo ma ancora non riesco ad accedere a /wp-admin

  5. #5
    frasidipace non  connesso AlterGuru
    Data registrazione
    07-05-2010
    Messaggi
    1,281

    Predefinito

    Salve,
    da pannello Altervista acceda a PHPMyAdmin e selezioni la tabella wp_options (il prefisso della tabella potrebbe essere diverso).
    Nella riga con id 1 e option_name = siteurl verifichi se l'url in option_value sia valorizzato con https. Se valorizzato con http lo modifichi.
    Analogamente faccia la stessa cosa alla riga con id 37 e option_name = home.
    Fatto ci, pulisca la cache del browser e riprovi l'accesso a wp-admin.
    Prima di fare modifiche faccia un bacqup del DB.

    Saluti
    Ultima modifica di frasidipace : 23-09-2022 alle ore 10.24.13

  6. #6
    lightnovelita non  connesso Utente Blog
    Data registrazione
    06-09-2022
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Salve,
    da pannello Altervista acceda a PHPMyAdmin e selezioni la tabella wp_options (il prefisso della tabella potrebbe essere diverso).
    Nella riga con id 1 e option_name = siteurl verifichi se l'url in option_value sia valorizzato con https. Se valorizzato con http lo modifichi.
    Analogamente faccia la stessa cosa alla riga con id 37 e option_name = home.
    Fatto ci, pulisca la cache del browser e riprovi l'accesso a wp-admin.
    Prima di fare modifiche faccia un bacqup del DB.

    Saluti
    Ho appena controllato tutti gli id e hanno tutti gli HTTPS. Continuo a non comprendere che succede al mio blog.

  7. #7
    GraphOGLRisorse non  connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,365

    Predefinito

    Salve,
    a me risulta che il tentativo di accesso a wp-admin restituisca un loop di redirect.

    Pu riportare il contenuto del file .htaccess?

    PS. Quando si riscontra un qualsiasi errore, sarebbe sempre bene ripostare o mostrare (con immagine) eventuali messaggi di errore. Nel caso che non siano presenti messaggi ed una situazione che consenta di mostrare un'immagine del priblema, resta comunque una buona pratica descrivere il pi dettagliatamente ed accuratamente possibile il comportamento riscontrato.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 23-09-2022 alle ore 14.47.51

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •