Visualizzazione risultati 1 fino 28 di 28
Like Tree7Likes
  • 1 Post By alemoppo
  • 1 Post By alemoppo
  • 1 Post By alemoppo
  • 1 Post By alemoppo
  • 1 Post By alemoppo
  • 1 Post By alemoppo
  • 1 Post By alemoppo

Discussione: Traffico mensile esaurito

  1. #1
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito Traffico mensile esaurito

    Ho questo sito (http://www.celarda.altervista.org/index.htm ) amatoriale che riporta i dati della mia stazione meteo dal 2007, e il traffico mensile non mai andato oltre al 5% di quello messo a disposizione da altervista. Oggi per la prima volta il sito stato bloccato per superamento traffico mensile: ho incrementato di 10GB per rendere ancora visibile il sito. Ho anche altro sito meteo amatoriale (http://www.meteocelarda.altervista.org/index.htm) su cui carico altra stazione meteo e i file caricati sono identici all'altro sito. Nel secondo il traffico mensile attorno al 4% : come possibile che uno superi la quota mensile e l'altro sia solo al 4% ? Come eventualmente posso fare per sapere la causa? Grazie in anticipo ad eventuali risposte

  2. #2
    GraphOGLRisorse non  connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,617

    Predefinito

    Salve,
    perch ha scritto in una discussione del 2016 per poi aprirne un seconda? traffico esaurito anche dopo aumento.# 1459274

    E' inutile creare pi dicussioni dupplicati, non serve a ridurre i tempi di risposta, semmai, serve a fare confusione.

    Le suggerisco di continuare qui, visto che anche pi dettagliata la sua spiegazione e attendere la rispota dello staff.

    Cordiali saluti.

  3. #3
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Hai gi attivato l'antifurto banda?

    Ti ricordo inoltre che esiste l'account alterBlog (wordPress) con banda e spazio illimitati.

    Ciao!
    celarda likes this.

  4. #4
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Mi ero permesso di intervenire ad una discussione gi aperta e prima che aumentassi il mio traffico a 40Gb; poi pensandoci bene, mi sembrava pi opportuno aprire una mia discussione riportando i fatti e chiedendo a qualche responsabile/esperto come era possibile questo fatto ....

  5. #5
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Hai gi attivato l'antifurto banda?

    Ti ricordo inoltre che esiste l'account alterBlog (wordPress) con banda e spazio illimitati.

    Ciao!
    No non ho mai attivato l'antifurto banda; ho per 2 associazioni meteo amatoriali che prendono un file dal mio sito per pubblicare temperature minime e Massime sulla loro pagina. Se attivo l'antifurto banda possono queste associazioni continuare a prelevare questo file (che un file .txt) ? Grazie per l'aiuto

  6. #6
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Salve,
    perch ha scritto in una discussione del 2016 per poi aprirne un seconda? traffico esaurito anche dopo aumento.# 1459274

    E' inutile creare pi dicussioni dupplicati, non serve a ridurre i tempi di risposta, semmai, serve a fare confusione.

    Le suggerisco di continuare qui, visto che anche pi dettagliata la sua spiegazione e attendere la rispota dello staff.

    Cordiali saluti.
    Mi scuso per questo,ma dopo aver scritto su una discussione aperta da altro utente ,e dopo aver provveduto ad aumentare il mio traffico mensile portandolo a 40GB, mi sembrava opportuno aprire una nuova discussione anche per cercare di capire come mai era successo questo consumo "anomalo" di traffico mai accaduto in oltre 13 anni

  7. #7
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Da ieri sera ho attivato l'antifurto banda come consigliato da alemopoppo; nonostante questo, ho notato per che in poco meno di 24 ore il traffico utilizzato stato di circa 2GB. L'altro mio sito Meteoamatoriale ,con l'invio stessi dati ho consumato solo 1.2GB ....... possibile capire come mai questa differenza di consumi?

  8. #8
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Citazione Originalmente inviato da celarda Visualizza messaggio
    L'altro mio sito Meteoamatoriale ,con l'invio stessi dati ho consumato solo 1.2GB ....... possibile capire come mai questa differenza di consumi?
    Il sito che da problemi di banda celarda.altervista.org ?

    Ciao!
    celarda likes this.

  9. #9
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Il sito che da problemi di banda celarda.altervista.org ?

    Ciao!
    Si proprio il sito che hai citato(celarda.altervista.org)ancora oltre 2GB di traffico in 24 ore; mentre l'altro sito (meteocelarda.altervista.org ) non mi da nessun problema.
    Ora ho provato ad eliminare il file index.html di Weather Display Live (Flash Player) che mostrava in tempo reale le condizioni meteo: l'unico file differente tra i 2 siti
    Ultima modifica di celarda : 19-10-2020 alle ore 10.12.02

  10. #10
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da celarda Visualizza messaggio
    Si proprio il sito che hai citato(celarda.altervista.org)ancora oltre 2GB di traffico in 24 ore; mentre l'altro sito (meteocelarda.altervista.org ) non mi da nessun problema.
    Ora ho provato ad eliminare il file index.html di Weather Display Live (Flash Player) che mostrava in tempo reale le condizioni meteo: l'unico file differente tra i 2 siti
    Niente neanche dopo aver attivato l'antifurto banda e tolto dal sito l'invio della pagina index.html di Weather Display Live (Flash Player),si fermato questo strano consumo di traffico mensile. Per me sarebbe un vero peccato dover rinunciare alla pubblicazione dei dati meteo dopo 13 anni ininterrotti dove al massimo consumavo il 5/6% di traffico mensile, e non sapere per quale motivo succede questa anomalia.

  11. #11
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Visto come sta andando il consumo traffico mensile, e non sapendo quali pesci pigliare per capire dove sia il problema, non mi resta probabilmente che aumentare "di nuovo" il traffico disponibile. Facendo 2 conti ho visto e calcolato che il consumo giornaliero di circa 2.7GB,domanda: se io aumento di 10GB fino al raggiungimento di 100GB mensili ,il prossimo mese e i mesi seguenti i 100GB mensili restano a disposizione o vengono azzerati mensilmente? Grazie in anticipo per eventuale risposta

  12. #12
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Chiedo ancora un vostro aiuto: sono ormai alla fine del traffico mensile consentito (anche se ho aumentato a 40GB la banda disponibile) e provando a fare un confronto (ultima spiaggia) con l'altro mio sito dove il consumo meno di 5GB, ho notato una differenza nei file: qui( www.celarda.altervista.org )ho il file "Il file .htaccess" che non ho nel sito( www.meteocelarda.altervista.org ).....che mi consigliate? Provo a cancellare questo file? Confido nel vostro aiuto
    Ultima modifica di celarda : 20-10-2020 alle ore 20.12.04

  13. #13
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Citazione Originalmente inviato da celarda Visualizza messaggio
    il prossimo mese e i mesi seguenti i 100GB mensili restano a disposizione o vengono azzerati mensilmente?
    I dati acquistati rimarranno disponibili. Ho gi chiesto verifiche da parte di AlterVista per vedere cosa causa tutto questo utilizzo di banda.

    Ciao!
    celarda likes this.

  14. #14
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    I dati acquistati rimarranno disponibili. Ho gi chiesto verifiche da parte di AlterVista per vedere cosa causa tutto questo utilizzo di banda.

    Ciao!
    Grazie1000 : quindi prevedendo che domani il mio traffico mensile sia nuovamente esaurito(quasi sicuramente), dovr ( e lo far) acquistarne altri 10GB, arrivando ad averne in questo mese di Ottobre in Totale 50 a disposizione . Sperando che questi 50GB mi bastino questo mese, il 1 di Novembre ritorner ad avere nuovamente 50GB di traffico disponibile?

  15. #15
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Analizzando il tuo caso, il problema sembra essere causato dallo script che modifica l'immagine della webcam: questo script quadruplica la dimensione dell'immagine. Puoi mostrare i sorgenti cos da capire come mai l'immagine generata cos grande?

    Inoltre, hai CloudFlare attivo? CloudFlare aiuta a risparmiare banda del sito.

    Ciao!
    celarda likes this.

  16. #16
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Analizzando il tuo caso, il problema sembra essere causato dallo script che modifica l'immagine della webcam: questo script quadruplica la dimensione dell'immagine. Puoi mostrare i sorgenti cos da capire come mai l'immagine generata cos grande?

    Inoltre, hai CloudFlare attivo? CloudFlare aiuta a risparmiare banda del sito.

    Ciao!
    Un grazie1000 di nuovo a te alemoppo, per l'interessamento al mio caso; se mi dici come fare per mostrare i sorgenti dell'immagine lo far con grande piacere. Mi sembra per strano che il consumo sia dovuto all'immagine della webcam, in quanto la stessa identica immagine viene pubblicata anche nell'altro sito ( http://www.meteocelarda.altervista.org/index.htm ); la foto viene scattata da una fotocamera e tramite programma invia la stessa immagine ai miei 2 siti meteoAmatoriali.......ora provo a vedere se ho CloudFlare attivo, e caso mai lo attivo come mi hai suggerito.
    Ultima modifica di celarda : 21-10-2020 alle ore 16.55.53

  17. #17
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Ciao alemoppo, mi sono incuriosito e sono andato a vedere i miei 2 siti: in questo dove la banda mensile viene consumata e si esaurisce in fretta, l'immagine webcam.jpg misura 196044 bytes e in .PHP 1550 bytes ....(contro i 196850 bytes e in .PHP 1550 bytes dell'altro sito che non ha problema di banda).

  18. #18
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Da quando ho attivato CloudFlare(poco dopo) non mi si aggiorna pi il sito: potrebbe essere una coincidenza? Adesso ho provato a disattivare CloudFlare.........ho paura che da incompetente adesso sto combinando un p di casino; speriamo non aver combinato nulla di grave

  19. #19
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Con CloudFlare si attiva la cache: normale quindi che non vedi le pagine aggiornate. Volendo, solo per l'immagine puoi forzare ad aggiornarla come spiegato qui.

    Attivando e disattivando CloudFlare non dovresti comunque "creare danni".


    se mi dici come fare per mostrare i sorgenti dell'immagine lo far con grande piacere.
    Puoi mostrarmi il codice? Cos vediamo se c' qualcosa che non va e al pi come sistemare.

    Ciao!
    celarda likes this.

  20. #20
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Con CloudFlare si attiva la cache: normale quindi che non vedi le pagine aggiornate. Volendo, solo per l'immagine puoi forzare ad aggiornarla come spiegato qui.

    Attivando e disattivando CloudFlare non dovresti comunque "creare danni".



    Puoi mostrarmi il codice? Cos vediamo se c' qualcosa che non va e al pi come sistemare.

    Ciao!
    Come faccio a mostrarti il codice? Dove lo prendo? Dopo aver disattivato Cloudfare il sito tornato ad aggiornarsi
    Ultima modifica di celarda : 21-10-2020 alle ore 22.28.57

  21. #21
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    normale che il sito tornato ad aggiornarsi dopo aver disabilitato CloidFlare; ti consiglio di riattivare CloudFlare mostrando l'immagine con un parametro random come indicato.

    Per mostrarmi il codice, vai su gestione file, clicca su "modifica" in corrispondenza del file "webcam.php", quindi mostra qui il codice che visualizzi.

    Ciao!
    Ultima modifica di alemoppo : 23-10-2020 alle ore 00.40.16
    celarda likes this.

  22. #22
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Dovrebbe essere questo:

    <?php

    $nome_immagine="webcam.jpg"; // file contenente l'immagine
    $nome_testo="testo.txt"; // file contenente le scritte

    $fp = fopen($nome_testo,"r")
    or die("impossibile aprire il file testo.txt.");
    $testo_sinistra=fgets($fp,100); // nella prima riga la scritta allineata a sinistra
    $testo_destra=fgets($fp,100); // nella seconda riga la scritta allineata a destra
    if ( $testo_destra = "data" )
    {
    setlocale(LC_TIME,"it_IT");
    $testo_destra=strftime ("%a %d %b %Y %H:%M:%S", filemtime($nome_immagine));
    }
    fclose($fp);

    header("Content-type: image/png");

    $im = imagecreatefromjpeg($nome_immagine);
    //$black = imagecolorallocate($im, 0, 0, 0);
    //$white = imagecolorallocate($im, 255, 255, 255);
    $colore_barra = imagecolorallocate($im, 1, 0, 128); // colore della barra formato RGB
    $colore_testo = imagecolorallocate($im, 255, 255, 255); // idem per testo
    $x=imagesx($im);
    $y=imagesy($im);

    $font = "VeraBd.ttf";
    $size = 8; // dimensione del testo
    $altezza_barra = 20; // dimensione della barra


    imagefilledrectangle($im, 0, $y-$altezza_barra, $x-1, $y-1, $colore_barra);

    $bbox = imagettfbbox ($size, 0, $font, $testo_sinistra);
    $dy = (($bbox[1] - $bbox[7]) / 2);
    imagettftext($im, $size, 0, 5, $y-($altezza_barra / 2) + $dy - 1, $colore_testo, $font, $testo_sinistra);

    $bbox = imagettfbbox ($size, 0, $font, $testo_destra);
    $dx = ($bbox[2] - $bbox[0]);
    imagettftext($im, $size, 0, $x-5-$dx, $y-($altezza_barra / 2) + $dy - 1, $colore_testo, $font, $testo_destra);


    imagepng($im);
    imagedestroy($im);

    ?>

  23. #23
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Ciao alemoppo, ho messo nel post precedente il file sorgente seguendo le tue indicazioni; incuriosito poi sono andato a prendere lo stesso file "webcam.php" sull'altro mio sito ,ed effettivamente confrontandoli non sono uguali (mi sembra) ecco l'altro file:
    <?php

    $nome_immagine="webcam.jpg"; // file contenente l'immagine
    $nome_testo="testo.txt"; // file contenente le scritte

    $fp = fopen($nome_testo,"r")
    or die("impossibile aprire il file testo.txt.");
    $testo_sinistra=fgets($fp,100); // nella prima riga la scritta allineata a sinistra
    $testo_destra=fgets($fp,100); // nella seconda riga la scritta allineata a destra
    if ( $testo_destra = "data" )
    {
    setlocale(LC_TIME,"it_IT");
    $testo_destra=strftime ("%a %d %b %Y %H:%M:%S", filemtime($nome_immagine));
    }
    fclose($fp);

    header("Content-type: image/png");

    $im = imagecreatefromjpeg($nome_immagine);
    //$black = imagecolorallocate($im, 0, 0, 0);
    //$white = imagecolorallocate($im, 255, 255, 255);

  24. #24
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Il secondo script solo la prima parte del primo script (completo). Il secondo script non completo e non credo sia funzionante.

    In ogni caso, stai leggendo una immagine jpeg, per poi rappresentarla in png. Ti consiglierei di mantenere il formato originale, quindi sostituisci:
    Codice PHP:
    header("Content-type: image/png"); 
    con:
    Codice PHP:
    header("Content-Type: image/jpeg"); 
    e

    Codice PHP:
    imagepng($im); 
    con:
    Codice PHP:
    imagejpeg($im); 
    Controlla poi il peso delle immagini generate.

    Ciao!
    celarda likes this.

  25. #25
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Il secondo script solo la prima parte del primo script (completo). Il secondo script non completo e non credo sia funzionante.

    In ogni caso, stai leggendo una immagine jpeg, per poi rappresentarla in png. Ti consiglierei di mantenere il formato originale, quindi sostituisci:
    Codice PHP:
    header("Content-type: image/png"); 
    con:
    Codice PHP:
    header("Content-Type: image/jpeg"); 
    e

    Codice PHP:
    imagepng($im); 
    con:
    Codice PHP:
    imagejpeg($im); 
    Controlla poi il peso delle immagini generate.

    Ciao!
    Ciao, ti aggiorno sulla situazione: a met pomeriggio ho cancellato il primo script e vi ho copiato all'interno il secondo . Stamattina ho controllato il consumo banda e sceso dai 2.7/2.9GB a circa 0.9GB .....il secondo script funziona....vedremo domani.Intanto grazie alemoppo per i tuoi interventi a questo mio problema. IN EFFETTI PERO' il secondo non completo (fatto copia/incolla non completo). Mi sono per accorto, che nel sito celarda.altervista.org era presente anche un secondo file "webcam.php.txt" oltre al file "webcam.php"....ieri pomeriggio ho eliminato quello ".php.txt"
    Ultima modifica di celarda : 24-10-2020 alle ore 10.46.32

  26. #26
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    AGGIORNAMENTO DEL PROBLEMA: credo di aver risolto il problema eliminano il file " webcam.php.txt"(non capisco come mai questo file si trovasse sul mio sito) ,e lasciato il file originale "webcam.php": la banda mensile consumata nelle ultime 24 ore stata di 0.1GB. Un grazie ad alemoppo che mi ha dato molti suggerimenti per risolvere il mio problema

  27. #27
    celarda non  connesso Utente giovane
    Data registrazione
    21-03-2007
    Messaggi
    32

    Predefinito

    Ho atteso fino ad oggi per valutare se il problema di esaurimento banda mensile fosse risolto: ebbene posso dire con quasi "assoluta "certezza di aver risolto il problema(anche con l'aiuto di alemoppo. Sulla base di quanto mi successo, mi sentirei di dare un consiglio ad altervista: all'apertura del problema sarebbe molto utile ( a richiesta) individuare il/i file che consumano banda e causano il problema.....in poche parole informare l'utente dove sia il problema che causa il consumo anomalo.

  28. #28
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,143

    Predefinito

    Citazione Originalmente inviato da celarda Visualizza messaggio
    Hmi sentirei di dare un consiglio ad altervista: all'apertura del problema sarebbe molto utile ( a richiesta) individuare il/i file che consumano banda e causano il problema.....in poche parole informare l'utente dove sia il problema che causa il consumo anomalo.
    Mi sembra ti sia stato detto:

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Analizzando il tuo caso, il problema sembra essere causato dallo script che modifica l'immagine della webcam: questo script quadruplica la dimensione dell'immagine.
    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •