Pagina 2 di 2 PrimoPrimo 12
Visualizzazione risultati 31 fino 58 di 58

Discussione: Inserimento immagine nella newsletter di feedburner: come fare?

  1. #31
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Funziona! Funziona! Sono troppo contenta! Erano mesi che gli stavo dietro! Bravo! Ora ho due domande da farti, anzi 3:
    1) Dici che funziona anche senza cancellare il feed e ricrearlo da capo? Perché così facendo perdiamo gli iscritti e naturalmente nessuno di noi lo vuole...
    2) IMPORTANTE: posso fare la prova sul blog ufficiale? Se mi rispondi di si mi devi però anche promettere che, nel caso succedesse qualcosa, puoi ripristinare tutto e far tornare il blog esattamente com'è.
    3) Gli altri sono informati del fatto che funzioni, ma come mi avevi detto di fare non ho diffuso questo metodo. Posso dire che lo integrerai nel prossimo aggiornamento? Oppure (se mi dai il benestare) dopo aver fatto la modifica al mio blog ufficiale (e verificato che funzioni tutto bene) posso dire di procedere come ho fatto io?
    Queste sono le ultime cose che ti chiedo, promesso! Ma solo per ora ;D Grazie Niccolò!

  2. #32
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Chiedo scusa, per sbaglio l'ho pubblicato due volte...se rispondi solo a uno basta eh! :D

  3. #33
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    1) Gli iscritti al feed non li perdi, quelli alla newsletter non so. Non è necessario ricreare il feed da capo, te l'ho fatto fare, altrimenti non vedevi la modifica. Puoi semplicemente scrivere nuovi post e, appena feedburner legge dal blog il feed aggiornato, dovrebbe allinearsi.
    2) Imposta un backup per stanotte e fallo domani, così in caso di problemi lo puoi ripristinare direttamente dal pannello di altervista.
    3) Sono al vaglio soluzioni diverse per la newsletter. Al momento non ti so dire quale sia la più semplice da adottare. Se vuoi, puoi diffondere pure questo metodo, l'importante è prestare molta attenzione alla modifica del functions.php, altrimenti di rischia di dover fare la procedura di ripristino.

  4. #34
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Ultimissimi due chiarimenti e poi questa volta giuro che chiudo qui il discorso. Annullando il feed e ricreandolo da capo ho perso gli iscritti alla NL (ovvero la mia iscrizione, che poi era l'unica). Se non lo cancello ma integro semplicemente functions.php con questa nuova porzione di codice e apporto le modifiche del caso a feedburner (tolgo il riassunto) e al blog (impongo il riassunto), in teoria non dovrei perdere gli iscritti alla NL, giusto? Questa era la prima domanda.
    Seconda domanda: A quanto capisco ci vorrà del tempo per vagliare la soluzione migliore di una NL nei blog...nel caso decidessi di far uscire un aggiornamento comprensivo di questa integrazione sarebbe un problema facilmente rimediabile per chi avesse già optato per la sua adozione?
    Grazie da parte di tutti per la tua preziosa guida. Dopo queste ultime due risposte chiudo definitivamente questo capitolo (sperando che non succeda qualcosa domani).

  5. #35
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Alla prima domanda non so risponderti con certezza perché non ho mai usato la NL di feedburner. Però non vedo perché dovresti perdere gli iscritti visto che ti limiti a togliere il riassunto senza toccare altro su feedburner. Direi che non dovrebbero esserci problemi.

    Per la seconda domanda, nel caso venisse adottata questa soluzione, integrandola nel nostro plugin, sarebbe sufficiente rimuovere il codice dal functions.php del tema per essere a posto.

  6. #36
    silvanaincucina non è connesso Utente AlterBlog
    Data registrazione
    22-06-2011
    Messaggi
    102

    Predefinito ho seguito alla lettera tutto, ma...

    Niccolò, ho seguito alla lettera tutto il procedimento, ma quando incollo il codice in funzioni php, alla fine di tutto, poi mi compare in alto nel blog, tutto il codice inserito..sbaglio qualcosa?

  7. #37
    silvanaincucina non è connesso Utente AlterBlog
    Data registrazione
    22-06-2011
    Messaggi
    102

    Predefinito ho capito dove sbagliavo...

    Ho capito che dovevo inserire il codice prima dell'ultimo simbolino che chiude..immagino..ho visto e provato..tutto bene grazie e scusa della fretta che ho sempre...non avevo letto bene tutto quello spiegato.....grazie comunque..

  8. #38
    silvanaincucina non è connesso Utente AlterBlog
    Data registrazione
    22-06-2011
    Messaggi
    102

    Predefinito buongiorno Niccolò...vorrei chiederti..

    Buongiorno Niccolò, stamattina la NL è arrivata con l'immagine, però io in Media mi sono accorta di avere le dimensioni delle miniature 120x90, mentre nel blog di prova, (stesso tema) Altherviste Theme è impostata a 150x150..in effetti la foto che compare nella NL è piccolina, allora stamattina ho modificato in Media le dimensioni della miniatura, più grandi (come sopra) poi salvato. Ti chiedo: ora le immagini saranno più grandi dalla prossima NL? Poi, ho sbagliato a modificare ora le dimensioni? Grazie e buona giornata!

  9. #39
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Si, dovrebbe funzionare. Non da subito perché il feed viene tenuto in cache da feedburner, ma a partire dal prossimo articolo dovrebbe avere le nuove dimensioni. Il codice inserisce nel feed le miniature per evitare di avere immagini tutte diverse tra loro come dimensioni.

  10. #40
    silvanaincucina non è connesso Utente AlterBlog
    Data registrazione
    22-06-2011
    Messaggi
    102

    Predefinito

    Grazie mille Niccolò ..

  11. #41
    silvanaincucina non è connesso Utente AlterBlog
    Data registrazione
    22-06-2011
    Messaggi
    102

    Predefinito solo un'ultima domanda e poi giuro che non ti infadistidisco più Niccolò

    Niccolò, c'è il modo si ingrandire un pochino l'immagine nel post della homepage? Abbi pazienza con me, ho 58 anni e lavoro al PC da 1 anno e mezzo circa, ho tanta voglia però di imparare e non sai quante volte mi sono letta i tutorial WordPress, ...e porta pazienza se le domande che ti pongo non sono proprio al meglio a livello di comprensione immediata, ma però voglio restare al passo e migliorare... : buona giornata!

  12. #42
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Non è possibile senza mettere mano al codice e, ad ogni aggiornamento, dovresti rimodificare tutto. Per il momento me lo segno come richiesta, magari in futuro riusciamo a migliorare il tema in tal senso.

  13. #43
    silvanaincucina non è connesso Utente AlterBlog
    Data registrazione
    22-06-2011
    Messaggi
    102

    Predefinito Grazie

    Grazie ancora della tua disponibilità Niccolò..

  14. #44
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Niccolò sai niente se sia possibile inviare una newsletter occasionale con articoli scelti a propria discrezione con feedburner? Qualcuno ha detto di averlo fatto senza sapere come, ma a me sembra impossibile a meno che ci si sia arrivati in modo molto macchinoso e complicato...ma non mi sembra questo il caso. Impossibile esserci riusciti smanettando a casaccio, vero? Puoi smentirmi?

  15. #45
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Al massimo potrebbero esserci più articoli in una sola email se si posta diverse volte al giorno.

  16. #46
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Sì, questo gliel'ho detto anch'io. Immagino che si sia sbagliata. Sul web ho trovato degli articoli che spiegano come fare, ma sono troppo complessi e se uno avesse seguito quelle procedure si ricorderebbe eccome di averlo fatto. Ciao, grazie

  17. #47
    GnamGnamPlus non è connesso Utente AlterBlog
    Data registrazione
    30-04-2012
    Messaggi
    7

    Predefinito

    Ciao Niccolò,
    ho letto e riletto le istruzioni... ho seguito tutto alla lettera ma il risultato è stato questo:

    Fatal error: Cannot redeclare add_thumbnail_to_feeds() (previously declared in /membri/gnamgnamplus/gnamgnamplus/wp-content/plugins/altervista-optimizer/altervista-optimizer.php:174) in /membri/gnamgnamplus/gnamgnamplus/wp-content/themes/altervista/functions.php on line 613

    e ho dovuto fare il ripristino...

    Non capisco il problema...

  18. #48
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    il messaggio di errore indica che hai inserito due volte il codice.

    Cannot redeclare add_thumbnail_to_feeds() (previously declared in ....

    Significa che non può dichiarare di nuovo una funzione già dichiarata in precedenza e quindi da errore. Attenzione quando si inserisce codice nel file functions.php che si rischia di rompere il blog e dover fare il ripristino.

  19. #49
    GnamGnamPlus non è connesso Utente AlterBlog
    Data registrazione
    30-04-2012
    Messaggi
    7

    Predefinito

    Risolto, grazie! :)

  20. #50
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Buongiorno Niccolò,
    rieccomi con il solito problema. Giovedì scorso ho fatto l'aggiornamento del blog e mi sembrava che le immagini + riassunto nel feed non avessero subito variazioni. In realtà non è così perché le immagini sono scomparse (ho guardato sia con chrome che firefox). naturalmente ho reinserito il codice e impostato il riassunto lato wordpress esattamente come prima, ma non ho risolto niente. Mi puoi aiutare?

  21. #51
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Dimenticavo di dire che ho anche cancellato i dati di navigazione per essere sicura che la visualizzazione non fosse quella in memoria

  22. #52
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Io vedo le immagini nel tuo feed

  23. #53
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Hai ragione, ora le vedo anch'io. Dovevo aspettare più tempo. Grazie

  24. #54
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    Niccolò, sono sicura che c'era una discussione a proposito ma non riesco a trovarla. Mi daresti, per favore, il codice da inserire per modificare la percentuale dello spazio dei titoli in testata? In seguito all'aggiornamento sono riposizionati su due righe, cosa che non mi piace. Grazie

  25. #55
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Anche tu che usi come voce del menu "Paese che vai... ricetta che trovi"... ci credo che finisce su due righe.

    cerca in aspetto->editor->style.css #branding #access e #branding hgroup, quindi modifica le percentuali di larghezza.

  26. #56
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    l'ho anche ridimensionato rispetto a quello che pensavo di usare :D

  27. #57
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    comunque, a meno che tu non l'abbia aggiunto nell'ultimo aggiornamento, in teoria lo dovrei mettere a mano come l'altra volta :)

  28. #58
    lemanidimanu non è connesso Utente AlterBlog
    Data registrazione
    14-03-2012
    Messaggi
    58

    Predefinito

    ho fatto, ho fatto. sono riuscita a rinvenire il codice dell'altra volta e ce l'ho messo. ciao!

Pagina 2 di 2 PrimoPrimo 12

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •