Visualizzazione risultati 1 fino 10 di 10

Discussione: phpbb 3.0.11 https no banner pubblicitari

  1. #1
    bitbay non è connesso Utente AlterForum
    Data registrazione
    15-04-2013
    Messaggi
    20

    Question phpbb 3.0.11 https no banner pubblicitari

    Buongiorno a tutti/e
    mi aiutate a capire come mai nella mia installazione di phpbb 3.0.11 abilitando il protocollo https non si visualizzano i banner pubblicitari altervista e adsense?
    Grazie mille

  2. #2
    L'avatar di silvermaledetto
    silvermaledetto non è connesso AlterGuru 2500
    Data registrazione
    01-03-2007
    Residenza
    Provincia di Modena
    Messaggi
    4,600

    Predefinito

    Ma io ne vedo in quantità, ad esser sincero.
    Io ne ho... visti forum che voi umani non potreste immaginarvi... PhpBB3 in panne al largo dei database MySQL di Orione... E ho visto i TAG [B] balenare nel buio vicino al postreply di Tannhäuser.... E tutti quei... momenti andranno perduti nel tempo... Come... lacrime... nella pioggia... È tempo... di backuppare....

  3. #3
    bitbay non è connesso Utente AlterForum
    Data registrazione
    15-04-2013
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da silvermaledetto Visualizza messaggio
    Ma io ne vedo in quantità, ad esser sincero.
    perchè adesso https è disattivo, il sito per ora sta funzionando in http

  4. #4
    L'avatar di silvermaledetto
    silvermaledetto non è connesso AlterGuru 2500
    Data registrazione
    01-03-2007
    Residenza
    Provincia di Modena
    Messaggi
    4,600

    Predefinito

    Io sono passato a https senza problemi, dopo tanto tempo che trascuravo il forum.
    Certo io uso una versione 3.0.12 che faccio vedere al PCA come 3.0.14, per non avere avvisi di versione da aggiornare.
    Con una 3.0.11. dovresti avere avvisi di errore che risolverai con modifica in
    phpBB3/includes/acp/acp_main.php, come ho già postato,la versione 3.0.11. ha una marea di bug risolti con le successive.
    Ho aperto anche una discussione su come aggiornare engine PHP per forum come il tuo.
    Io ne ho... visti forum che voi umani non potreste immaginarvi... PhpBB3 in panne al largo dei database MySQL di Orione... E ho visto i TAG [B] balenare nel buio vicino al postreply di Tannhäuser.... E tutti quei... momenti andranno perduti nel tempo... Come... lacrime... nella pioggia... È tempo... di backuppare....

  5. #5
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,181

    Predefinito

    Citazione Originalmente inviato da bitbay Visualizza messaggio
    perchè adesso https è disattivo, il sito per ora sta funzionando in http
    Salve,
    in realta https è sempre attivo, manca solo il redirect (o riscrittura) via .htaccess.

    Comunque confermo che con l'erogazione del sito in https risulta un problema con i banner:



    Cordiali saluti.

  6. #6
    bitbay non è connesso Utente AlterForum
    Data registrazione
    15-04-2013
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Salve,
    in realta https è sempre attivo, manca solo il redirect (o riscrittura) via .htaccess.

    Comunque confermo che con l'erogazione del sito in https risulta un problema con i banner:



    Cordiali saluti.
    cosa dovrei inserire in .htaccess?

  7. #7
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,181

    Predefinito

    Per il redirect verso https basta aggiungere nel .htaccess:

    Codice:
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} off
    RewriteRule .* https://NomeSito.altervista.org%{REQUEST_URI} [L,R=301]
    Però lei ha un AlterForum, quindi con phpBB di AlterVista che dovrebbe avere il redirect automaitzzato attivabile tramite il pannello di controllo, se non sbaglio (che dovrebbe ciò che aveva fatto in precedenza). Per cui non dovrebbe essere necessario modificare manualmente il file .htaccess.

    Ad ogni modo, il sito è accessibile sia in http che in https. Visto chè è presente il problema con l'erogazione dei banner in https, direi di aspettare per il redirect e lasciarlo al momento accessibile anche da http.

    Attenda qui risposta dallo staff per eventuali riscontri.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 01-04-2022 alle ore 20.00.19

  8. #8
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,968

    Predefinito

    Nella versione HTTPS a me risultano problemi di mixed content: ho provato sia da chrome sia da firefox e il tuo sito in HTTPS lo visualizzo così:



    In HTTP invece lo visualizzo correttamente.

    Infatti, nella versione HTTPS, vedo riferimenti ad HTTP, come già dalla quarta riga:
    Codice HTML:
    <!-- jQuery Pack for phpBB -->
    <script type="text/javascript">window.jQuery || document.write("\x3Cscript src='http://bitbay.altervista.org/jquerypack/jquery.js'>\x3C/script>");</script>
    Ciao!

  9. #9
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,181

    Predefinito

    Riguardando meglio effettivamente, ho fatto caso che i banner hanno il codice vecchio con l'url in http.

    Codice:
    /* <![CDATA[ */
    document.write('<s'+'cript type="text/javascript" src="http://ad.altervista.org/js.ad/size=728X90/r='+new Date().getTime()+'"><\/s'+'cript>');
    /* ]]> */
    Quindi bitbay dal pannello di controllo, sostituisca i vecchi codici dei banner con quelli nuovi e il problema dovrebbe risolversi.

    Anche per i link in http delle altre risorse vanno modificati in da http ad https.

    Cordiali saluti.

  10. #10
    bitbay non è connesso Utente AlterForum
    Data registrazione
    15-04-2013
    Messaggi
    20

    Predefinito

    Grazie a tutti, ho risolto, sembra che funzionano tutti i banner adesso e non sembra più esserci il problema di mixed content

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •