Visualizzazione risultati 1 fino 8 di 8

Discussione: Problemi con installazione Joomla

  1. #1
    lcrpclab non è connesso Neofita
    Data registrazione
    22-02-2024
    Messaggi
    7

    Predefinito Problemi con installazione Joomla

    Buongiorno a tutti. Qualche giorno fa ho provato a trasferire su Altervista il backup del mio precedente sito che era fatto con Joomla. Soltanto che quando provo ad installare Joomla (nella prima schermata quando si deve scegliere la lingua) mi dà i seguenti "messaggi":

    Notice: Array to string conversion in /membri/lcrpclab/libraries/joomla/registry/registry.php on line 342

    Notice: Array to string conversion in /membri/lcrpclab/libraries/joomla/registry/registry.php on line 342

    Notice: Array to string conversion in /membri/lcrpclab/libraries/joomla/registry/registry.php on line 342

    Warning: count(): Parameter must be an array or an object that implements Countable in /membri/lcrpclab/libraries/joomla/application/application.php on line 481

    Spero che possiate aiutarmi. Grazie a tutti.

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    22,314

    Predefinito

    Hai caricato l'ultima versione di Joomla? Quale versione di PHP stai utilizzando su AlterVista?

    Ciao!

  3. #3
    lcrpclab non è connesso Neofita
    Data registrazione
    22-02-2024
    Messaggi
    7

    Predefinito

    Ho provato a installare la vecchia versione di Joomla, ovvero la 2.5.8 perché il mio sito era fatto con questa versione, ma non me la fa installare. Quindi adesso ho installato l'ultima versione di Joomla e l'installazione è andata a buon fine. Solo che nonostante abbia caricato su Altervista il backup, il mio vecchio sito non "c'è". Ma chiedo a voi, se il sito era fatto con la vecchia versione di Joomla 2.5.8, allora il backup non funziona anche con la nuova versione di Joomla? E se fosse così, significa che non potrei più avere il mio vecchio sito qui su Altervista? Grazie davvero a chi mi aiuterà e spero di avere spiegato bene il problema.

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    22,314

    Predefinito

    Joomla 2.5.8 è del 2012.

    Ai tempi c'erano altre tecnologie, come ad esempio mysql 5.6. Su AlterVista siamo a Mysql 8.

    Ti consiglio di installare in locale Joomla2.5.8 con le caratteristiche richieste, quindi eseguire l'upgrade ad esempio con questo plugin, come mi ha indicato @GraphOGLRisorse proprio oggi!

    Una volta che hai la versione aggiornata del backup, potrai importarlo su AlterVista.

    Ciao!

  5. #5
    lcrpclab non è connesso Neofita
    Data registrazione
    22-02-2024
    Messaggi
    7

    Predefinito

    Grazie mille per le risposte.
    Ho portato in locale il backup del mio sito con le caratteristiche richieste e funziona tutto, anche se quando apro il sito (in locale) mi da questi messaggi:
    Strict Standards: mktime(): You should be using the time() function instead in C:\xampp\htdocs\sito\plugins\system\vvisit_counter \vvisit_counter.php on line 32

    Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\sito\plugins\system\vvisit_counter \helper\vvisit_counter.php on line 28

    Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\sito\plugins\system\vvisit_counter \helper\vvisit_counter.php on line 120

    Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\sito\plugins\system\vvisit_counter \helper\vvisit_counter.php on line 123

    Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\sito\plugins\system\vvisit_counter \vvisit_counter.php on line 46

    Sapete come mai e come posso risolvere?

    Inoltre, il plugin che mi hai dato per eseguire l'upgrade è a pagamento. Ne conosci qualcuno di questo tipo gratuito?

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    22,314

    Predefinito

    Purtroppo non conosco Joomla così bene. Ti consiglierei di chiedere sul supporto Joomla (Forum).

    Puoi provare altrimenti ad eseguire aggiornamenti "parziali", nel senso dalla 2.5.8 alla (ad esempio) 2.5.28, poi 3.0, 3.5, 4.0 etc...

    Ciao!
    Ultima modifica di alemoppo : 07-03-2024 alle ore 20.08.22

  7. #7
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    4,079

    Predefinito

    Citazione Originalmente inviato da lcrpclab Visualizza messaggio
    Strict Standards: Only variables should be assigned by reference in C:\xampp\htdocs\sito\plugins\system\vvisit_counter \vvisit_counter.php on line 46
    Salve,
    quel messaggio non è relativo nello specifico a Joomla ma all'uso di Strict Standards in PHP. Può essere risolto disabilitandolo dal file php.ini.

    Presumedo in locale l'uso di PHP 5.x:
    Codice:
    error_reporting = E_ALL & ~E_NOTICE & ~E_STRICT
    Citazione Originalmente inviato da lcrpclab Visualizza messaggio
    Inoltre, il plugin che mi hai dato per eseguire l'upgrade è a pagamento. Ne conosci qualcuno di questo tipo gratuito?
    Mi scuso, mi era sfuggito quel dettaglio.

    La migrazione alla versione 4.x può essere fatta dalla 2.5.x alla 3.10.x e poi alla 4.x. Qui c'è la guida che spiega come fare tutti i passaggi: https://docs.joomla.org/Planning_for...mla_2.5_to_4.x

    Purtroppo alternative gratuite e valide non sembrano esserci. (o almeno non le trovate)

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 07-03-2024 alle ore 02.38.43

  8. #8
    lcrpclab non è connesso Neofita
    Data registrazione
    22-02-2024
    Messaggi
    7

    Predefinito

    Grazie ragazzi per i vostri consigli.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •