Visualizzazione risultati 1 fino 16 di 16

Discussione: attivare drupal

  1. #1
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito attivare drupal

    Anni fa, avevo un altersito con Drupal.
    Non ho potuto pi seguirlo e, ovviamente, stato rimosso.
    Vorrei riprovarci, mi aspettavo di vedere tra gli strumenti a disposizione i vari CMS...
    Invece si attivato per default alterblog con wordpress. ho "convertito" in altersito ma non trovo il link per attivare Drupal, occorre fare l'installazione manuale?? Magari mi ricordo male io, ma quella volta bastava cliccare sul link!!

  2. #2
    GraphOGLRisorse non  connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,181

    Predefinito

    Salve,
    lei siricorda bene, ma da inzio del 2021 AlterVista ha mantenuto il supporto come CMS modificato/migliorato solo per Wodrpress. Quindi attulmente tutti gli altri CMS vanno installati manualmente.

    Cordiali saluti.

  3. #3
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    Intanto grazie del chiarimento, pensavo di essere impazzito io...

    Quindi ho provato a procedere con l'installazione di Drupal 7.3.25 (ho bisogno di questa versione per recuperare un tentativo fatto qualche tempo fa e salvato in locale), copiato gli zip, l'esecuzione dello script di installazione si blocca per problemi sui requisiti, segnalando quanto segue:

    Unicode library Error
    Multibyte string input conversion in PHP is active and must be disabled. Check the php.ini mbstring.http_input setting. Please refer to the PHP mbstring documentation for more information.
    Ho fatto vari tentativi di modifica del file .htaccess ma non sembra influenzare il funzionamento...

    Dove sto sbagliando???
    Grazie.

  4. #4
    GraphOGLRisorse non  connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,181

    Predefinito

    Quali sono i tentativi che ha fatto con .htaccess?

    Ha provato anche cos?
    Codice:
    php_value mbstring.http_input pass
    php_value mbstring.http_output pass
    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 03-03-2022 alle ore 16.48.05

  5. #5
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,968

    Predefinito

    Di "noto", drupal7 ha questo problema. Non ho mai incontrato quell'errore.

    Se dovesse persistere fammi sapere.

    Ciao!

  6. #6
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    gia nel pacchetto scaricato da drupal presente il file .htaccess con queste configurazioni per php
    # PHP 5, Apache 1 and 2.
    Codice:
    <IfModule mod_php5.c>
      php_flag magic_quotes_gpc                 off
      php_flag magic_quotes_sybase              off
      php_flag register_globals                 off
      php_flag session.auto_start               off
      php_value mbstring.http_input             pass
      php_value mbstring.http_output            pass
      php_flag mbstring.encoding_translation    off
    </IfModule>
    Che comprendono quelle suggerite, ho provato a spostare il file nella root ma non cambiato nulla.
    Per verificare la funzionalit del parametro ho creato una pagina https://xpe.altervista.org/drupal-7.32/info.php
    dove i parametri in questione risultano cosi:

    mbstring.http_input no value no value
    mbstring.http_output no value no value
    quindi parrebbero non impostati, ma lo script di installazione di drupal segnala quanto sopra.... bho

    Anzi, ho installato apache + php localmente, impostando .htaccess cosi:


    php_flag mbstring.encoding_translation Off
    php_value mbstring.http_input pass
    php_value mbstring.http_output pass
    il phpinfo() mi riporta il valore "pass", facendo la stessa cosa su altervista mi riporta il valore "no value"
    Ultima modifica di xpe : 04-03-2022 alle ore 12.53.28

  7. #7
    GraphOGLRisorse non  connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    3,181

    Predefinito

    Forse dipende dalla vesione di php, visto che secondo il manuale tali specifiche risultano deprecate, probabilmente da php 7.x ed prevista la rimozione per versioni future.

    Provi impostando php 7.1 e/o 5.6, quindi verifichi dalla sua pagina di prova, quella che esegue il phpinfo().

    Cordiali saluti.

  8. #8
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,968

    Predefinito

    Citazione Originalmente inviato da xpe Visualizza messaggio
    Drupal 7.3.25 (ho bisogno di questa versione per recuperare un tentativo fatto qualche tempo fa e salvato in locale)
    Non consigliato comunque provare ad installare una tale versione: la 7.3 del 2011.
    Ho cercato quella versione ma ho trovato solo la 7.3. Hai modo di indicarmi dove procurarmi la 7.3.25?

    Per una versione cos vecchia, forse dovresti impostare PHP 5.6, anche se ti consiglierei di installarlo in locale ed effettuare il tentativo.

    Grazie,
    Ciao!

  9. #9
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    Le versioni di Drupal sono tutte disponibili sul sito ufficiale, in particolare la 7.30 qui
    https://www.drupal.org/project/drupal/releases/7.30
    e tutti gli upgrade sono disponibili nella pagina.

    Hai ragione che ci possa essere un problema a dialogare con mysql 8, ma altervista ha messo a disposizione delle patch apposite.

  10. #10
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    La cosa strana che in locale, ho una installazione apache con php 7.4.27 nella quale questi parametri vengono correttamente gestiti con .htaccess, quindi avevo il dubbio che il problema fosse su altervista

  11. #11
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,968

    Predefinito

    Citazione Originalmente inviato da xpe Visualizza messaggio
    Quindi ho provato a procedere con l'installazione di Drupal 7.3.25 (ho bisogno di questa versione per recuperare un tentativo fatto qualche tempo fa e salvato in locale
    Citazione Originalmente inviato da xpe Visualizza messaggio
    in particolare la 7.30 qui
    Scusami ma non sto capendo: non necessitavi della 7.3.25? (questa in particolare non ero riuscito a trovare).

    Ciao!

  12. #12
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Scusami ma non sto capendo: non necessitavi della 7.3.25? (questa in particolare non ero riuscito a trovare).

    Ciao!
    la 7.32 qui https://www.drupal.org/project/drupal/releases/7.32
    ho messo il link alla release principale 7.30 con *e tutti gli upgrade sono disponibili nella pagina* intendevo che nella pagina, sulla dx, sono elencati tutti gli upgrade relativi alla 7.x

  13. #13
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,968

    Predefinito

    Citazione Originalmente inviato da xpe Visualizza messaggio
    Quindi ho provato a procedere con l'installazione di Drupal 7.3.25
    Citazione Originalmente inviato da xpe Visualizza messaggio
    Le versioni di Drupal sono tutte disponibili sul sito ufficiale, in particolare la 7.30 qui
    Citazione Originalmente inviato da xpe Visualizza messaggio
    Ancora non ho capito quale versione vuoi installare.
    Per l'ultimo link che hai mostrato la 7.32; ho provato ad installarlo e si installato correttamente.

    Ho impostato PHP6.5 ed applicato le modifiche indicate sul tutorial.

    Prova a ripetere l'installazione, o descrivimi la procedura che stai utilizzando cos da poter riprodurre l'errore.

    Ciao!

  14. #14
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    L'ambiente altervista il seguente:
    - apache nella versione predefinita da Altervissta
    - PHP 7.3.25 -la versione standard di Altervista (credo)
    - Drupal 7.32 (versione che girava sul vecchio sito che non funziona pi)

    L'unica cosa che ho fatto scaricare Drupal 7.32 e uploadare lo zip scompattandolo nella cartella Drupal-7.32
    Tu hai installato php 6.5, perch? come si fa? non pensavo fosse possibile modificare la versione di php.
    Anche se sul vecchio sito c'era php 7.3

    Grazie

  15. #15
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    19,968

    Predefinito

    Ho scritto male, scusami, in realt intendevo la versione PHP5.6; puoi modificare la versione PHP da qui.

    Il motivo che siccome si tratta di una versione molto vecchia, probabilmente utilizzare una versione di PHP vecchia aumenta le probabilit di funzionamento del CMS. Non escludo per che possa funzionare anche con PHP7.3.

    Ti consiglierei di procedere cos:

    • procurati lo zip di drupal 7.32
    • Estrai l'archivio in locale
    • Sostituisci i file con quelli indicati qui
    • Ricomprimi il tutto in file .zip (quindi avrai uno zip drupal modificato)
    • Decidi se impostare PHP5.6 o lasciare PHP7.3, con la 5.6 a me ha funzionato.
    • Vai sulla gestione files -> Invia Files -> clicca su "Invia archivi compressi".
    • Avvia l'installazione normalmente, non ho trovato problemi con questa procedura.


    Ciao!

  16. #16
    xpe
    xpe non  connesso Utente Blog
    Data registrazione
    28-02-2022
    Messaggi
    9

    Predefinito

    Tutto chiarissimo,
    appena ho tempo ci provo e ti faccio sapere.

    Grazie e Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •