Visualizzazione risultati 1 fino 3 di 3

Discussione: Aggiornamento a SPIP 4.1

  1. #1
    L'avatar di cralasa
    cralasa non è connesso Neofita
    Data registrazione
    03-04-2017
    Residenza
    Livorno
    Messaggi
    12

    Predefinito Aggiornamento a SPIP 4.1

    Buonasera a tutti.
    Questa mattina ho tentato di aggiornare SPIP dalla versione 3.2 alla 4.1, passando prima per la 4 per portare php dalla versione 7.3 alla 8.
    Il primo aggiornamento è andato bene, ma quando ho installato l'ultima versione disponibile l'intero sito è diventato non visualizzabile (infatti ora ho messo un cartello di lavori in corso).
    Cercando di capire cosa fosse andato storto mi sono imbattuto nei requisiti minimi della versione (colpa mia che avrei dovuto verificare prima), che sono questi:
    • Compatibilità PHP: 7.4 - 8.1
    • Estensioni PHP: xml, gd2, (mysqli | (pdo, pdo_sqlite)), sodium, zip, zlib, Phar


    Rispetto a quelli della versione precedente (compatibilità PHP: 7.3 - 8.0, estensioni PHP: xml, gd2, (mysqli | (pdo, pdo_sqlite))), ho fatto caso che sodium, zip, zlib, Phar sono stati aggiunti.
    Supponendo che il mio problema siano le estensioni e non altro, la domanda é: sono disponibili su Altervista? E nel caso come posso attivarle? Oppure l'unica via é tornare alla versione precedente?
    Mille grazie

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    20,077

    Predefinito

    Citazione Originalmente inviato da cralasa Visualizza messaggio
    sono disponibili su Altervista?
    Sono disponibili tranne "sodium". Puoi visualizzare le estensioni disponibili ad esempio così (visualizza sorgente pagina):
    Codice PHP:
    <?php
    print_r
    (get_loaded_extensions());
    Citazione Originalmente inviato da cralasa Visualizza messaggio
    E nel caso come posso attivarle?
    È possibile attivarle solamente da Altervista. Farò presente della tua necessità così da poter valutare di attivarla, in futuro.
    Per il momento ti consiglierei di rimanere con la versione precedente.

    Hai modo di indicarmi dove sono indicate quelle estensioni necessarie? Nel loro sito trovo informazioni solamente riguardante la versione 3.0, grazie.

    Ciao!
    Ultima modifica di alemoppo : 27-05-2022 alle ore 20.42.43

  3. #3
    L'avatar di cralasa
    cralasa non è connesso Neofita
    Data registrazione
    03-04-2017
    Residenza
    Livorno
    Messaggi
    12

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    È possibile attivale solamente da Altervista. Farò presente della tua necessità così da poter valutare di attivarla, in futuro.
    Per il momento ti consiglierei di rimanere con la versione precedente.
    Mille grazie per la risposta, mi metterò al lavoro per ripristinare la versione precedente.

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Hai modo di indicarmi dove sono indicate quelle estensioni necessarie? Nel loro sito trovo informazioni solamente riguardante la versione 3.0, grazie.
    Certo, trovi tutto qui: https://www.spip.net/fr_article4351.html.

    Grazie ancora e buona giornata!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •