Visualizzazione risultati 1 fino 14 di 14

Discussione: Problema immaginne in condivisioni su facebook

  1. #1
    lapennamagica non è connesso Utente giovane
    Data registrazione
    22-05-2010
    Messaggi
    95

    Predefinito Problema immaginne in condivisioni su facebook

    Chiedo scusa, ma ho un piccolo problemino, che non so come risolvere, poichè non so neanche come si è verificato. Fino aqualche gionrno fa, quando condividevo su facebook qualcosa dal blog, dove non c'era l'immagine, veniva messa di default, quella del blog, che è nella sidebar in alto a destra, (cioè la solita penna con i quasretti per intenderci)Da oggi, invece viene inserita, quella delle headbar...che chiaramente, essendo più grande, viene tagliata. Come risolvo? Anche perché quando provo a condividere, l'anteprima mi mostra l'immagine giusta, ma poi quando il post è pubblicato cambia.Inoltre questo avviene solo quando condivido col "pulsante" di facebook, dal blog, se copio e incollo il link della pagina su facebook, questo non succede. Con altri social invece è tutto ok. Chiedo ancora scusa, ma di queste cose ci capisco poco, spero nella risposta per poter risolvere, e ringrazio anticipatamente.
    Ultima modifica di lapennamagica : 07-11-2017 alle ore 11.39.11

  2. #2
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,438

    Predefinito

    Negli articoli sul tuo blog non specifichi un'immagine in evidenza, quindi WordPress non indica a Facebook quale immagine deve mostrare nell'anteprima e questo ne sceglie una secondo dei suoi criteri.
    Io ti consiglierei di inserire almeno un'immagine su ciascun articolo, ed in particolare sceglierne una da mettere in evidenza per lo stesso.

  3. #3
    lapennamagica non è connesso Utente giovane
    Data registrazione
    22-05-2010
    Messaggi
    95

    Predefinito

    ok, grazie del consiglio. Il problema, è che non posso scegliere un'immagine per ogni articolo, visto che per lo più scrivo racconti o poesie. Ad ogni modo, vorrei capire perché prima, veniva impostata automaticamente l'immagine della sidebar, e ora prende quella dell'headbar. E perché se invece copio l'url della pagina e lo incollo, su facebook, l'unica immagine che trova è quella della sidebar, che poi è quella giusta. Non c'è un modo per tornare a come era prima? Cioè che quando condividevo veniva prese l'immagine della sidebar?

  4. #4
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,438

    Predefinito

    Immagino che sia un problema di Facebook.
    Puoi provare ad inserire nelle impostazioni del plugin Yoast SEO l'indirizzo dell'immagine che vuoi venga impostata come immagine di anteprima nel caso in cui non sia specificata un'immagine in evidenza per l'articolo in questione.
    Inserisci l'indirizzo dell'immagine nella sezione Impostazioni standard che trovi nella scheda Facebook, nella pagina Social (sotto SEO) nel pannello di amministrazione di WordPress.

  5. #5
    lapennamagica non è connesso Utente giovane
    Data registrazione
    22-05-2010
    Messaggi
    95

    Predefinito

    Ho seguito il tuo consiglio, di cui ti ringrazio. Purtroppo il problema persiste, e forse dippende proprio da facebook, anche perché si è verificato da un giorno all'altro. Quindi per ora, l'unica soluzione è copiare l'url della pagina, da condividere e poi ricopiarlo nello stato di facebook( ad ora è l'unico metodo che funzioni). Non ci sono altre cose che si possono fare, giusto? Ancora grazie.

  6. #6
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,562

    Predefinito

    Se si ha CloudFlare e si modifica un file, bisogna svuotare la sua cache... Svuota la cache di wordpress, CloudFlare e del browser .. Pagina AMP, aiuto!
    Testimonianza cache CloudFlare
    Attivazione HTTPS su Wordpress scaricato dal sito ufficiale
    Ultima modifica di darbula : 07-11-2017 alle ore 23.53.33

  7. #7
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,438

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Se si ha CloudFlare e si modifica un file, bisogna svuotare la sua cache... Svuota la cache di wordpress, CloudFlare e del browser .. Pagina AMP, aiuto!
    Testimonianza cache CloudFlare
    Attivazione HTTPS su Wordpress scaricato dal sito ufficiale
    Il sito di Lapennamagica ha CloudFlare attivo, ma non è necessario vuotare la sua cache. CloudFlare tiene in cache solo file statici, con specifiche estensioni (https://support.cloudflare.com/hc/en...static-content), quindi per chi fa un uso normale di WordPress non è necessario effettuare mai lo svuotamento della cache di CloudFlare.

  8. #8
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,562

    Predefinito

    karl94 sono d'accordo con la tua linea di principio ma vedila in questo modo.. "Io sono un utente abituato al semplice click per la piattaforma che utilizzo" Dunque non potrò conoscere come funziona una cache.. Detto questo chi non ha mai modificato o cancellato un immagine nel proprio blog? Dunque è buona norma vuotare tutte le cache (wordpress, CloudFlare, browser) per possibili problemi futuri :) ... Alla fine lo svuotamento non crea problemi ma anzi può correggerli.
    Ultima modifica di darbula : 08-11-2017 alle ore 14.04.02

  9. #9
    lapennamagica non è connesso Utente giovane
    Data registrazione
    22-05-2010
    Messaggi
    95

    Predefinito

    Ok, grazie ad entrambi per l'aiuto, ma inizio a credere che il problema riguardi esclusivamente Facebook, anche se non capiscoo perché col copia-incolla dell'url non succede. Ho provato a svuotare le cache, ho porvato a inserire l'immagine, all'interno delle impostazioni standard...ma il problema resta. Poi, non so, con gli altri social non mi accade solo con facebook, e dopo la pubblicazione...bho...quello che non mi spiego è perchè ha smesso di funionare, da un giorno all'altro. Vorrei tanto conoscere la causa, ma probabilmente dipende da Facebook...Ancora grazie.

  10. #10
    ViaggiArte non è connesso Utente AlterBlog
    Data registrazione
    31-03-2016
    Messaggi
    37

    Predefinito

    anche io ho problemi di condivisione immagini: molte volte è tutto ok ma quando accade provo a correggere utilizzando developers.facebook.com/tools/debug/og/object/, ma ultimamente sempre più spesso anche con questo strumento non riesco ad ottenere nulla e mi viene restituita risposta
    "Share App ID Missing The 'fb:app_id' property should be explicitly provided, Specify the app ID so that stories shared to Facebook will be properly attributed to the app. Alternatively, app_id can be set in url when open the share dialog."
    ho windows7, non ci sono spazi nel nome file, è indicato l'indirizzo Seo per l'immagine facebook, infine nel developers.facebook.com/tools/debug/og/object/ è indicata un'og:image corretta ma doppia ma difforme da quella indicata alla fine dopo la sccritta "Questi sono i contenuti che verranno inclusi in caso di condivisione"
    potrebbe dipendere dalle ultime variazioni di indirizzo http/s o di sito sicuro/non sicuro?
    saluti a tutti, grazie in anticipo a chi mi risponderà
    Ultima modifica di ViaggiArte : 07-12-2017 alle ore 11.29.08

  11. #11
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,553

    Predefinito

    @ViaggiArte: potrebbe essere un problema di facebook. Puoi comunque indicare un elemento da condividere che da problemi?

    Ciao!

  12. #12
    ViaggiArte non è connesso Utente AlterBlog
    Data registrazione
    31-03-2016
    Messaggi
    37

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    @ViaggiArte: potrebbe essere un problema di facebook. Puoi comunque indicare un elemento da condividere che da problemi?

    Ciao!
    ne indico due per i quali ho provato anche ad aggiornare la condivisione dell'allegato attraverso facebook:

    https://viaggiarte.altervista.org/ch...ino-dettaglio/

    https://viaggiarte.altervista.org/il...-dei-castighi/

  13. #13
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,553

    Predefinito

    Ho fatto alcune prove:

    Riguardo al primo link, facebook prelevava un'immagine vecchia probabilmente che aveva in cache: facendo debug penso di aver risolto: controlla se il problema persiste (a volte occorre premere "esegui lo scraping di nuovo" più volte, non soltanto una).

    Riguardo al secondo link, facebook ha un comportamento strano: se provo a condividerlo dalla home non ho problemi, se invece lo condivido andando nel mio profilo personale, l'immagine non appare. Questo temo proprio che sia un problema di facebook.

    Ciao!
    Ultima modifica di alemoppo : 07-12-2017 alle ore 14.00.20

  14. #14
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,562

    Predefinito

    Per aggiornare la cache di facebook si va dal debug e poi fetch scraping ecc io ho usato lo strumento di invalidamento batch ma non credo che abbia influito tanto.. Io non riscontro alcun problema per il secondo link... Però nel caso si usa una cache (av-cache e CloudFlare) e la foto viene modificata rimanendo sulla stessa url o (cambia in questo caso si avranno due foto su due url diverse se si accede manualmente a tale risorsa dato che solo l'ultima sarà per facebook) si deve anche vuotare tali cache..
    EDIT: Riguardo a fb:app_id Ciò non interferisce con la possibilità di condividere post su Facebook, ma potrebbe limitare la possibilità di utilizzare le funzioni di Facebook come Insights .https://kb.yoast.com/kb/warning-fb-a...the-meta-tags/
    https://www.facebook.com/insights indica che insights è obsoleto.
    Ultima modifica di darbula : 07-12-2017 alle ore 22.53.52

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •