Visualizzazione risultati 1 fino 2 di 2
Like Tree1Likes
  • 1 Post By alemoppo

Discussione: Problema funzionamento iframe

  1. #1
    Guest

    Predefinito Problema funzionamento iframe

    Buongiorno, mettendo online il mio sito web, ho notato che gli iframe indirizzati ad altri siti non funzionano più, mentre con i test in locale era tutto ok. Ho già sbloccato i permessi per le connessioni server to server nel pannello delle impostazioni di AlterVista. Cosa può essere? È qualche blocco di AlterVista (soprattutto sui domini free) o potrebbero esserci altri problemi?
    Grazie mille

    Ecco i link alle pagine:
    pallavoloremedello.altervista.org/classifica.php

    pallavoloremedello.altervista.org/risultati.php
    Ultima modifica di pallavoloremedello : 05-09-2018 alle ore 11.06.35 Motivo: Aggiunto link

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,433

    Predefinito

    Spesso i siti bloccano il poter includere loro pagine in iframe di altri siti settando nell'header X-Frame-Options. Nel tuo caso, non vedo però questa proprietà settata nel sito che vuoi includere, quindi non saprei dirti perché non funziona.

    Visto che l'inclusione avviene lato client, le connessioni server to server non centrano nulla (e nemmeno l'hosting). Visto però che hai attivato le connessioni server 2 server, potresti fare uno scriptino PHP che va a leggere la pagina che desideri, eventualmente rielaborando i dati, quindi mostrarli nel formato che vuoi.

    Ciao!
    pallavoloremedello likes this.

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •