Visualizzazione risultati 1 fino 15 di 15
Like Tree2Likes
  • 1 Post By alemoppo
  • 1 Post By unitresar

Discussione: php extension per moodle

  1. #1
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito php extension per moodle

    Vorrei fare l'upgrade alla nuova versione di moodle che ho installato su altervista, ma non ci riesco perché appena faccio partire l'upgrade ottengo questo messaggio bloccante:

    Intl extension is required to improve internationalization support, such as locale aware sorting and international domain names.

    Ricevo anche i seguenti messaggi che però, per ora, sono di tipo warning:
    - The xmlrpc extension is useful for web services and Moodle networking
    - Installing the optional SOAP extension is useful for web services and some plugins.
    - PHP opcode caching improves performance and lowers memory requirements, OPcache extension is recommended and fully supported.

    Come posso superare il problema?

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    L'estensione Intl non è installata su AlterVista, ma si sta valutando l'abilitazione ma non possiamo dir nulla riguardo alle tempistiche.

    Prova abilitando l'xmlrpc a fondo pagina di "impostazioni->Attiva XML-RPC"

    Ciao!

  3. #3
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito

    Grazie per la risposta.
    Allora aspetterò che l'estensione venga installata! Come farò a controllare se e quando verrà installata?
    Non ho però capito in quali impostazioni devo andare per attivare XML-RPC.
    Ultima modifica di unitresar : 25-03-2018 alle ore 10.52.54

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    L'indicazione che ti ho dato è valida solo per wordpress di AlterVista.
    Se utilizzi la versione originale, devi agire lato .htaccess, vedi qui: Disattivazione default di xmlrpc.php

    Ciao!

  5. #5
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito

    OK, grazie mille!
    Resta la domanda: quando l'estensione Intl verrà installata, come farò a capirlo?
    ciao

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    Ti farò sapere, scriverò qui.

    Ciao!

  7. #7
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito

    Ok! Grazie ancora! Terrò d'occhio la discussione.
    ciao

  8. #8
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,237

    Predefinito

    Comunico che ora sono disponibili intl e gmp (quest'ultimo solo con php7).

    Ciao!
    unitresar likes this.

  9. #9
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Comunico che ora sono disponibili intl e gmp (quest'ultimo solo con php7).

    Ciao!
    Perfetto! Ho installato moodle 3.6 sul mio sito e tutto ha funzionato perfettamente! Grazie!
    alemoppo likes this.

  10. #10
    profantonangeli non è connesso Utente AlterBlog
    Data registrazione
    12-09-2018
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da unitresar Visualizza messaggio
    Perfetto! Ho installato moodle 3.6 sul mio sito e tutto ha funzionato perfettamente! Grazie!
    Come hai fatto?
    Io ci ho provato e mi dà i seguenti errori:

    mysql_full_unicode_support#File_format
    questo test deve passare con successo

    Il database utilizza il formato file Antelope. Per avere un supporto completo UTF-8 sia con MySQL sia con MariaDB è necessario utilizzare il formato file Barracuda. Per favore convertire le tabelle in formato Barracuda. Per dettagli sulla conversione, consultare la documentazione MySQL full unicode support.

    -------

    mysql_full_unicode_support#Large_prefix
    questo test deve passare con successo

    Per avere un supporto completo UTF-8 sia in MySQL sia in MariaDB è necessario impostare 'innodb_large_prefix' a 'ON'. Per maggiori informazioni consultare la documentazione.


    Purtroppo ho constatato che questi parametri non possono essere modificati tramite phpMyAdmin !!!

  11. #11
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito

    Io non ho fatto nulla di particolare. Mi par di capire che il tuo formato dati sia incompatibile con Moodle.
    Posso solo aggiungere che dalla pagina di gestione del data base ho attivato il motore innodb e ho attivato i trigger. Per il resto ho usato tutte le impostazioni di default fornite da altervista.
    Prova a controllare in phpmyadmin la Collation della connessione del server io ce l'ho impostata a utf8mb4_general_ci.
    I miei parametri sono i seguenti:
    Server del Database
    Server: Localhost via UNIX socket
    Tipo di server: MySQL
    Versione del server: 5.6.33-log - MySQL Community Server (GPL)
    Versione protocollo: 10
    Utente: unitresar@localhost
    Codifica caratteri del server: UTF-8 Unicode (utf8)
    Web server
    Apache
    Versione del client del database: libmysql - 5.6.33
    Estensione PHP: mysqli

  12. #12
    profantonangeli non è connesso Utente AlterBlog
    Data registrazione
    12-09-2018
    Messaggi
    5

    Predefinito

    Ho la stessa tua configurazione tranne che per i trigger che ho attivato ora.
    Ma tu hai fatto un upgrade o installato da zero?
    Io sto installando direttamente moodle 3.6 senza averlo già installato prima in una versione precedente.
    Se hai fatto un aggiornamento, da quale versione moodle sei partito?

  13. #13
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito

    Citazione Originalmente inviato da profantonangeli Visualizza messaggio
    Se hai fatto un aggiornamento, da quale versione moodle sei partito?
    Io ho fatto l'upgrade dalla 3.4. Ero ferma in attesa che altervista attivasse php7 e intl.
    Nelle impostazioni PHP ho scelto php7 perché il default di altervista è php5.6 mentre php 7 è necessario dalla versione 3.4 di moodle.
    Devi anche abilitare le connessioni server to server in fondo alla pagina della scheda "modifica sorgente .htaccess"

  14. #14
    profantonangeli non è connesso Utente AlterBlog
    Data registrazione
    12-09-2018
    Messaggi
    5

    Predefinito

    Grazie. Ho poi risolto facendo un'installazione con versione più vecchia e poi eseguendo upgrade in successione. E' l'unica via.

  15. #15
    unitresar non è connesso Neofita
    Data registrazione
    21-06-2016
    Messaggi
    9

    Predefinito


Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •