Visualizzazione risultati 1 fino 14 di 14

Discussione: Invia Mail non funziona

  1. #1
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Exclamation Invia Mail non funziona

    Salve,
    ho configurato il sito con joomla 3.9 e ho necessità di un attivare un modulo contatti per ricevere le mail degli utenti. Effettuando le dovute prove, nonostante il messaggio di corretto invio, non ricevo alcuna mail, neanche in copia.
    Anche la funzione "invia mail di prova" dalla configurazione globale mi restituisce il messaggio di corretto invio, senza tuttavia ricevere nulla.
    Ho controllato la casella spam. Non ho un indirizzo gmail. Ho provato sia con la mail personale che con l'alias, senza risultato. Ho provato PHP mail, Sendmail e SMTP con identici risultati. Ho anche un account sendgrid, ma anche lì... nulla.
    Qualcuno può aiutarmi? Grazie in anticipo.

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,312

    Predefinito

    SMTP non può funzionare su AlterVista perché le uniche porte aperte sono la 80 e 443. Puoi inviare email tramite mail() di PHP o servizi esterni come SendGrid (per sendgrid dovrai abilitare la connessione server to server).

    In ogni caso, questo test funziona?

    Ciao!

  3. #3
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Predefinito

    Ciao, anzitutto grazie per la risposta e per le informazioni!
    Direi che no, il test non funziona.
    Non so se ho eseguito correttamente: ho inserito lo script in un articolo pubblicato nella prima pagina (il sito è vuoto) e non succede nulla, nessuna mail e nemmeno messaggi di errore.
    Riproverò con sendgrid, però domani, oggi non ne posso più

    Ciao,
    Stefano

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,312

    Predefinito

    Il test si esegue così:

    -Crei un Nuovo file con estensione .php
    -Incolli il codice di esempio come indicato (modificando email etc).
    -Apri quel file da un browser (navighi scrivendo il nome del file .php creato.

    Fammi sapere.

    Ciao!

  5. #5
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Predefinito

    Ciao,
    il test non funziona. Ho provato in locale (aprendo il file col browser) e online caricando la pagina nel sito.
    In locale non succede nulla (firefox visualizza una pagina vuota, chrome il sorgente)
    Online appare il messaggio "email inviata correttamente" ma la mail non arriva (ovviamente ho controllato lo spam).

    Ciao, grazie!

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,312

    Predefinito

    In locale non può funzionare. Se è apparso un il messaggio di corretto invio, probabilmente è un errore del servizio di posta. Puoi indicarmi l'ora in cui hai provato ad inviare l'email?

    Ciao!

  7. #7
    GraphOGLRisorse è connesso ora Altervistiano Junior
    Data registrazione
    14-02-2015
    Messaggi
    511

    Predefinito

    Salve platamona,
    Ha sostituito tuaemail@dominio.it con un indirizzo email reale?

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 12-06-2020 alle ore 16.06.57

  8. #8
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Predefinito

    Ciao,
    @alemoppo: l'ora dovrebbe essere fra le 15:25 e le 15:30.
    @GraphOGLRisorse: si ho sostituito col mio indirizzo di posta personale, e il "from" con l'alias altervista.

    Grazie per le risposte!
    Stefano

  9. #9
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Predefinito

    Aggiornamento:
    ho provato un diverso indirizzo email (diverso provider) e funziona!! Sia il test che il modulo "contatti" di joomla.
    Per la precisione:
    provider non funzionante: tiscali
    provider funzionante: yahoo

    Ora resta da vedere perché...!
    Ciao

  10. #10
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,312

    Predefinito

    Citazione Originalmente inviato da platamona Visualizza messaggio
    provider non funzionante: tiscali
    provider funzionante: yahoo
    Dovresti chiedere al provider non funzionante come mai non ricevono le email.
    Lato AlterVista chiederò di verificare ma mi sembra che le email vengano inviate correttamente.

    Ciao!

  11. #11
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,312

    Predefinito

    Puoi scrivermi l'email (parzialmente offuscata) @tiscali a cui stavi inviando i messaggi?
    Grazie,

    Ciao!

  12. #12
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Predefinito

    Ciao,
    purtroppo contattare l'assistenza di tiscali pare facile come vincere al superenalotto...
    la mail è:
    s.xxxxxxxs@tiscali.it
    Non so se possa andarti bene così.. Altrimenti fammi sapere
    Ciao e grazie,
    Stefano

  13. #13
    platamona non è connesso Neofita
    Data registrazione
    22-04-2003
    Messaggi
    19

    Predefinito

    Aggiornamento: come già sapevo, l'assistenza tiscali è latitante. Nessuna risposta.
    Riassunto: tiscali non funziona; yahoo funziona alla grande. Non so perché, ma me ne dovrà fare una ragione..
    Ciao!

  14. #14
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,312

    Predefinito

    Purtroppo l'unica via è appunto cercare di contattare Tiscali e chiedere spiegazioni.

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •