Visualizzazione risultati 1 fino 5 di 5

Discussione: Errore accesso

  1. #1
    MassimoBertocci non è connesso Neofita
    Data registrazione
    23-08-2010
    Messaggi
    27

    Predefinito Errore accesso

    Buonasera, era un po’ di tempo che non controllavo il mio sito www.massimobertocci.it ed ad oggi se si digita l’indirizzo appare questo errore:

    Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /membri/massimobertocci/index.php/includes/framework.php:21 Stack trace: #0 /membri/massimobertocci/index.php/index.php(22): require_once() #1 {main} thrown in /membri/massimobertocci/index.php/includes/framework.php on line 21

    Qualcuno gentilmente può aiutarmi a capire cosa è successo?
    Ultima modifica di MassimoBertocci : 28-05-2021 alle ore 23.45.23

  2. #2
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,924

    Predefinito

    Salve,
    probailmente è stato fatto l'aggionamento nel server del database a MySQL 8.

    set_magic_quotes_runtime() è stata deprecata in php 7.4 e rimossa in php 8. Da ciò, suppongo che il sito faccia uso di un codice php non recente o comunque misto e quindi non pienamente compatibile con MySQL 8.

    La soluzine migliore è di aggiornare il codice php del sito.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 29-05-2021 alle ore 01.30.55

  3. #3
    MassimoBertocci non è connesso Neofita
    Data registrazione
    23-08-2010
    Messaggi
    27

    Predefinito

    Grazie mille domani provo

  4. #4
    SpaziHorror non è connesso Neofita
    Data registrazione
    10-05-2010
    Messaggi
    3

    Predefinito

    Salve sono disperato ieri controllando il mio sito web http://wwww.spazihorror.altervista.org mi da i seguenti errori:

    Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /membri/spazihorror/includes/framework.php:21 Stack trace: #0 /membri/spazihorror/index.php(22): require_once() #1 {main} thrown in /membri/spazihorror/includes/framework.php on line 21


    Come posso risolvere non vorrei perdere tutto, da dove prelevo il file php per aggiornarlo?

    grazie in anticipo...

  5. #5
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,924

    Predefinito

    Salve,
    Quale versione di php le risulta? (qui)
    Può provare impostando una versione precedente.

    Citazione Originalmente inviato da SpaziHorror Visualizza messaggio
    Come posso risolvere non vorrei perdere tutto, da dove prelevo il file php per aggiornarlo?
    Non esiste un file php generico per farlo. Se il sito è fatto con CSM/applicativo và aggiornato scaricando una versione del medesimo dal rispettivo sito ufficiale. Se invece il codice del sito è scritto manualmente, và aggiornato manualmente secondo le moderne specifiche.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 14-10-2021 alle ore 17.49.03

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •