Visualizzazione risultati 1 fino 5 di 5

Discussione: Anomalia nella visualizzazione del sito

  1. #1
    bahairimini non  connesso Neofita
    Data registrazione
    29-10-2011
    Messaggi
    3

    Predefinito Anomalia nella visualizzazione del sito

    Salve,
    il link al dominio di secondo livello https://www.bahairimini.it non mi carica correttamente il sito.
    A questo link invece il sito funziona http://bahairimini.altervista.org
    Cos' cambiato? Funzionava anche il link al dominio di secondo livello. Mi potreste aiutare?
    Grazie,
    Saluti
    Roco Manzi
    Ultima modifica di bahairimini : 06-11-2023 alle ore 18.20.57

  2. #2
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    21,982

    Predefinito

    Dovresti configurare HTTPS su Joomla: senza HTTPS, il dominio funziona correttamente.
    Prova come indicato qui: https://www.joomla.it/faq-joomla-3/4...-in-https.html

    Ciao!

  3. #3
    bahairimini non  connesso Neofita
    Data registrazione
    29-10-2011
    Messaggi
    3

    Predefinito

    Ciao, grazie per la risposta.
    Ho provato a seguire le istruzioni sul sito indicato:
    - attivato HTTPS nel pannello di amministrazione del sito (ora mi dice "HTTPS abilitato")
    - modificato file configuration.php, var $live_site = 'https://www.bahairimini.it';
    - aggiunte nell'.HTACCESS le seguenti due istruzioni dopo RewriteEngine On
    RewriteCond %{HTTPS} OFF
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    Ho cancellato la cache di Chrome
    Non sembra essere cambiato nulla

    C' qualcos'altro che posso controllare?
    Grazie in anticipo per il vostro aiuto.

    Rocco

  4. #4
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    21,982

    Predefinito

    Credo che il motivo sia questa riga:
    Codice HTML:
    <base href="http://bahairimini.altervista.org/joomla/" />
    Andrebbe sostituita in "https://". Non so su Joomla come fare, qui dicono occorra procedere dal database, ma si tratta di una discussione molto vecchia (2017).

    Ciao!

  5. #5
    bahairimini non  connesso Neofita
    Data registrazione
    29-10-2011
    Messaggi
    3

    Predefinito

    Ciao, sono riuscito a risolvere il problema modificando la pagina index.php del mio template (/joomla/template/<mio_template>).
    Ho aggiunto, proprio sotto il tag <head> la stringa:
    <base href="https://www.bahairimini.it/joomla/" />

    Grazie mille!
    Saluti
    Rocco

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •