Visualizzazione risultati 1 fino 6 di 6

Discussione: Articoli inaccessibili - Pagina 404

  1. #1
    crespano non è connesso Neofita
    Data registrazione
    27-06-2011
    Messaggi
    3

    Predefinito Articoli inaccessibili - Pagina 404

    Buongiorno a tutti,
    oggi, dopo qualche settimana che non accedevo al sito che gestisco, ho scoperto che non è più accessibile alcun articolo, solo gli articoli.
    Mi spiego meglio:
    - gli articoli nel back-end ci sono tutti;
    - i menù che puntano ad elementi diversi dagli articoli funzionano correttamente;
    - il problema è nella visualizzazione degli stessi sul front-end: non vengono trovati.
    Cercando di aprire una pagina contenente un articolo, appare il messaggio standard "404 - Articolo #52 non trovato" di Joomla.
    Sembra quasi che sia stato disattivato l'elemento "articolo", ma io non ho toccato niente...
    Avete qualche idea su cosa potrebbe aver bloccato gli articoli (e solo quelli)?
    Grazie in anticipo per ogni suggerimento.

  2. #2
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,660

    Predefinito

    Salve,
    facendo un controllo delle cache di Google negli degli articoli, quello con la data aggiornata più di recente, risale al 28 Luglio 2021. Supponendo che il problema si sia verificato per tutti gli articoli nello stesso momento, il periodo da analizza sarebbe tra il 28 Luglio 2021 e oggi.

    Ha fatto qualche modifca particolare in questo periodo?

    Inoltre, ho trovato la pagina crespano.altervista.org/joomla/archivio/video-educativi che resta bianca e mostra un messaggio di errore:
    Fatal error: Call to undefined method JDatabaseMySQL::stderror() in /membri/crespano/joomla/components/com_content/models/category.php on line 337
    Sta usando plugin di protezione o che modficano i link?
    Provi disattivndo uno ad uno tutti i plugin.

    Che versione di Joomla sta usando?

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 11-08-2021 alle ore 13.24.13

  3. #3
    crespano non è connesso Neofita
    Data registrazione
    27-06-2011
    Messaggi
    3

    Predefinito

    Ringraziando dei suggerimenti, aggiungo alcune informazioni e test che ho fatto nel frattempo:
    Le uniche modifiche dal 28 luglio ad oggi sono state nel testo dell'articolo dell'homepage.
    L'errore dei video-educativi, probabilmente c'è da tempo: sono anni che nessuno entra in quella pagina.
    Il sito è vecchissimo (usa Joomla 1.5.22) ma per lo scopo per cui viene usato non ha mai avuto problemi (avevo anche provato la migrazione al 2.5, ma all'epoca mi dava degli errori e avevo ripristinato la 1.5.22).
    Moduli e plugin non vengono toccati da anni.

    Ho invece fatto una prova (che forse avrei dovuto fare prima ), creando un nuovo articolo...
    Appare il seguente errore in fase di salvataggio:

    Codice:
    500 - E' avvenuto un errore
    DB function failed with error number 1292
    Incorrect datetime value: '0' for column 'checked_out_time' at row 1 SQL=INSERT INTO `avjos_content` ( `id`,`title`,`alias`,`introtext`,`fulltext`,`state`,`sectionid`,`mask`,`catid`,`created`,`created_by`,`created_by_alias`,`checked_out`,`checked_out_time`,`publish_up`,`publish_down`,`attribs`,`version`,`metakey`,`metadesc`,`metadata`,`access` ) VALUES ( '0','test','test','
    
    \r\n prova
    
    ','','1','6','0','41','2021-08-11 13:54:49','63','','0','0','2021-08-11 13:54:49','0000-00-00 00:00:00','show_title=\nlink_titles=\nshow_intro=\nshow_section=\nlink_section=\nshow_category=\nlink_category=\nshow_vote=\nshow_author=\nshow_create_date=\nshow_modify_date=\nshow_pdf_icon=\nshow_print_icon=\nshow_email_icon=\nlanguage=\nkeyref=\nreadmore=','1','','','robots=\nauthor=','0' )
    Ho pensato fosse un problema esclusivo dei nuovi articoli, invece l'errore si presenta anche risalvando i vecchi articoli, mentre l'ultima volta che sono stati editati, ovviamente, non c'erano errori.
    Considerando che non ho cambiato codice php e neppure impostazioni e/o versione DB, perché adesso segnala un errore nella query, mentre a luglio non c'era?

  4. #4
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,660

    Predefinito

    Controlli (da qui) se è stato eseguito l'aggornamento del tatabase MySQL alla versione 8.0.

    Joomla 1.5.22 è molto vecchio, la versione 1.5 risale a Settembre 2012.

    Le suggerisco anche per questione di sicurezza, di aggiornare Joomla almeno alla 3.6, che ah comunque qualche anno. La cosa migliore sarebbe ad ogni modo di passare direttamete all'ultima versione.

    Cordiali saluti.

  5. #5
    crespano non è connesso Neofita
    Data registrazione
    27-06-2011
    Messaggi
    3

    Predefinito

    Sì, la versione MySQL è la 8.0: il problema è la versione del DB?
    Forse è il caso che provi ad aggiornare Joomla... comunque prima conviene che risolva il problema degli articoli o è indifferente? Oppure si risolve il problema aggiornando Joomla?
    Grazie mille, pur lavorando nel settore IT, non mi occupo di queste cose (e del corso di Basi di Dati fatto all'università, 20 anni fa, ho vaghi ricordi! )

  6. #6
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,660

    Predefinito

    Citazione Originalmente inviato da crespano Visualizza messaggio
    Forse è il caso che provi ad aggiornare Joomla... comunque prima conviene che risolva il problema degli articoli o è indifferente? Oppure si risolve il problema aggiornando Joomla?
    Credo che sia correlato all'aggiornamento di MySQL, quindi dovrebbe sistemarsi con l'aggiornamento.

    Essendo una versione molto vecchia, eventualmente provi a fare un aggiornamento progressivo delle versioni, così da evitare problemi legati a modifiche della gestione del database che intercorrono tra alcune versioni di Joomla.

    Citazione Originalmente inviato da crespano Visualizza messaggio
    pur lavorando nel settore IT, non mi occupo di queste cose (e del corso di Basi di Dati fatto all'università, 20 anni fa, ho vaghi ricordi! )
    Beh, in 20 anni php è cambiato abbastanza, quindi quelle basi andrebbero aggiornate per restare al passo con l'elevoluzione del linguaggio.

    ordiali saluti.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •