Visualizzazione risultati 1 fino 7 di 7

Discussione: Moodle 3.9

  1. #1
    creativeproject non è connesso Neofita
    Data registrazione
    11-09-2020
    Messaggi
    1

    Predefinito Moodle 3.9

    Buongiorno,
    ho letto i post dedicati all'installazione di Moodle su Altervista: ho variato il file install.php per la cartella moodledata, ho attivato innodb ma quando tento di installare Moodle (versione 3.9) mi dà i seguenti messagi di errore e non mi fa andare avanti nell'installazione:

    mysql_full_unicode_support#File_format this test must pass

    Your database uses Antelope as the file format. Full UTF-8 support in MySQL and MariaDB requires the Barracuda file format. Please switch to the Barracuda file format. See the documentation MySQL full unicode support for details.

    mysql_full_unicode_support#Large_prefix
    this test must pass

    For full support of UTF-8 both MySQL and MariaDB require you to change your MySQL setting 'innodb_large_prefix' to 'ON'. See the documentation for further details.

    Come posso risolvere? ho assolutamente bisogno di usare moodle per elearning.
    Grazie mille

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    20,339

    Predefinito

    Purtroppo ad per ora non è possibile risolvere questo problema. Potresti cercare altri applicativi equivalenti a Moodle.

    In ogni caso, entro la fine dell'anno potrebbe essere risolto questo problema, ma non so fornire tempistiche più precise.

    Ciao!
    Ultima modifica di alemoppo : 14-09-2020 alle ore 23.36.57

  3. #3
    paccsito non è connesso Utente AlterBlog
    Data registrazione
    16-12-2020
    Messaggi
    1

    Predefinito

    nessuna soluzione???

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    20,339

    Predefinito

    Ricevi gli stessi errori? Hai abilitato mysql8?

    Ciao!

  5. #5
    corsifantino non è connesso Utente AlterBlog
    Data registrazione
    09-04-2021
    Messaggi
    5

    Predefinito

    Io anche non riesco ad installare moodle, ho fatto tutti i passaggi come descritto nelle varie discussioni, ogni volta che cerco di installare l'ultima versione di moodle arrivato alla fine mi dice che è variato il mio indirizzo IP e che non posso procedere. Mentre se provo ad installare versioni precedenti tipo 3.7 mi compare l'errore:
    ERROR!!! The code you are using is OLDER than the version that made these databases!

  6. #6
    primi235711 non è connesso Neofita
    Data registrazione
    08-09-2010
    Messaggi
    2

    Angry

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Ricevi gli stessi errori? Hai abilitato mysql8?

    Ciao!
    Anche io ho dei problemi per l' installazione di Moodle 4.0. Con mysql8 comunque Moodle richiede una versione di MariaDB più alta di quella disponibile su Altervista e poi l' installazione rileva la solita cronica mancanza di estensioni PHP che potrebbero essere utili a Moodle ma non ci sono.

    Sono quindici anni che mantengo il mio sito Moodle su Altervista e siamo tantissimi docenti che, insieme e grazie ad Altervista, sopperiamo ad un' offerta che dovrebbe esserci da parte del MPI. Detto questo però non è difficile osservare che Mondadori ha un consistente interesse nell' editoria scolastica e potrebbe mettere in evidenza il ruolo che ha avuto in questi anni ospitando su Altervista centinaia di siti scolastici.

    Si tratterebbe di affiancare a Wordpress un Moodle gestito magari ad un prezzo simile e vedere di farlo rientrare nelle spese per l' aggiornamento. Invece, tristemente, i gestori di siti Moodle trascinano i loro giorni aspettando che Altervista soddisfi i requisiti minimi per la nuova versione di Moodle. Requisiti minimi per cui "non si è in grado di indicare una tempistica precisa".

    Ma che modo di fare è? Prova ad andare a dire ai genitori che per la consegna dei compiti in classe corretti "non siamo in grado di indicare una tempistica precisa".

    Così facendo trasformate quella che sarebbe un' ottima occasione editoriale in una vergognosa trascuratezza del tutto simile a quella del MPI.

    Consiglerei ad alemoppo di passare questo intervento al suo capufficio che lo passi al suo responsabile su su per la catena gerarchica fino a che si trovi qualcuno che ha contatti con chi si occupa di editoria scolastica e sia in grado di vedere il biz di cui vi sto parlando.

    Spero che così vi daranno qualche risorsa per occuparvi di Moodle. Senza trascurare poi il fatto che tutte queste scuole che usano M$ Teams o G$$gle Classroom conferiscono tonnellate di dati, probabilmente sensibili, a queste multinazionali che non hanno i server in UE come voi. Questo non lo nota nessuno?
    Ultima modifica di primi235711 : 22-09-2022 alle ore 09.13.05

  7. #7
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    20,339

    Predefinito

    In realtà son riuscito ad installare moodle 4.0.4+ .
    Ho:
    • Creato la cartella "moodledata" bloccata con file .htaccess (semplicemente scrivendo "deny from all" nel file .htacess di questa cartella)
    • Caricato moodle (l'archivio estratto)
    • modificata la riga 325 del file "install.php" da così:
      Codice PHP:
      } else if (is_dataroot_insecure()) { 
      a così:
      Codice PHP:
      } else if (0) { 
    • Impostato PHP8 da qui
    • Avviato l'installazione (visitando la pagina di moodle)
    • Durante l'installazione, impostare la cartella dei dati con quella creata nel punto precedente, protetta da .htaccess


    Probabilmente nei prossimi giorni scriverò una guida a riguardo, perché in effetti non è proprio "plug&play". I passaggi comunque son quelli indicati sopra.

    Se si sceglie di utilizzare MySQL e non mariaDB, non dovrebbe dar problemi.

    Ciao!
    Ultima modifica di alemoppo : 22-09-2022 alle ore 21.30.02

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •