Pagina 1 di 2 12 UltimoUltimo
Visualizzazione risultati 1 fino 30 di 47

Discussione: Problemi di autenticazione IFTTT - Wordpress

  1. #1
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Exclamation Problemi di autenticazione IFTTT - Wordpress

    Il servizio di Wordpress di ifttt.com non si connette pi al mio sito www.coralriff.net e non riesco a capire la causa.
    Ho provato a cambiare le password dell'utente sul sito e del profilo su wordpress.com, a disconnettere e riconnettere Jetpack, a controllare Cloudflare, https (Jetpack dice "Outbound HTTPS not working")e server to server, autenticazione a due passaggi, disinstqllqre IFTTT Bridge e reinstallarlo etc ma non ho cavato un ragno dal buco.
    Per favore, potete darmi una mano?
    Ultima modifica di coralriff : 16-10-2017 alle ore 14.22.16 Motivo: Attivazione notifica email

  2. #2
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Sul dominio di secondo livello non hai un https attivo mentre qui l'https non si capisce se sia attivo https://nick.altervista.org/ dove nick va sostituito con l'username di altervista in pratica fa un redirect a http.. Cmq. Non ho capito il tuo problema.. Scusami.
    Ultima modifica di darbula : 16-10-2017 alle ore 16.10.17

  3. #3
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Sul dominio di secondo livello non hai un https attivo mentre qui l'https non si capisce se sia attivo https://nick.altervista.org/ dove nick va sostituito con l'username di altervista in pratica fa un redirect a http.. Cmq. Non ho capito il tuo problema.. Scusami.
    Proprio oggi ho trovato un articolo che parla di Jetpack e Cloudflare ed ho seguito le istruzioni per configurare Cloudflare in modo da permettere a Jetpack di funzionare ma, niente, l'errore ancora li.
    Il mio problema che uso ifttt per la condivisione di video da YouTube al sito e poi quella dei post su tutti i social ma non riesco a riconnettere il servizio di Wordpress a IFTTT.. Se non connetto Ifttt al sito tutto cio' non funziona piu'. Se mi si inceppa questo meccanismo per me una rogna. Grazie comunque per rispondere.
    Ultima modifica di coralriff : 17-10-2017 alle ore 15.21.07

  4. #4
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Io vedo i video da YouTube e posso condividere tale video anche con i social. Ambedue funzionano nel sito... Hai svuotato la cache del browser?
    Ultima modifica di darbula : 17-10-2017 alle ore 16.05.31

  5. #5
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Io vedo i video da YouTube e posso condividere tale video anche con i social. Ambedue funzionano nel sito... Hai svuotato la cache del browser?
    Si si, quello che gi c' funziona. Il problema che adesso pi nulla verr automaticamente condiviso da e su coralriff.altervista.org finch non riusciro' a riconnettere Ifttt al sito.
    Ho provato ad effettuare l'accesso con un altro paio di users con diritti di amministrazione ma non funziona.




  6. #6
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Ancora non sono riuscito a trovare alcuna soluzione. Penso sia qualcosa che ha a che vedere con Jetpack, https e xmlrpc. Qualcuno pu aiutarmi per favore?

  7. #7
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Nessuno mi risponde o prova ad aiutarmi da 5 giorni. Siete tutti troppo occupati o qual' il problema? Non avete idea di come aiutarmi a risolvere? un problema di cui non gliene frega niente a nessuno? Ho sbagliato forum o categoria? Perch non sto ricevendo alcuna assistenza?

  8. #8
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito


  9. #9
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    http://www.coralriff.net/ un dominio di secondo livello... Per caso hai abilitato l'upgrade dello spazio web?
    ... Mi rispondo da solo :D se visito il dominio di secondo livello vengo reindirizzato su quello di terzo livello (cio con .altervista.org finale) vuole dire che non sei con l'upgrade dello spazio web.. In wordpress.org devi crearti un account che si connetta a nick.altervista.org ifttt anch'esso dovr connettersi a tale indirizzo)..
    Jetpack e Ifttt richiedono che il file xmlrpc.php sia accessibile in altervista puoi abilitarlo da wordpress->impostazioni->generali (o comunque da impostazioni..
    Il fatto che jetpack ti informa che il traffico https in uscita non funziona influente (al momento ho trovato la soluzione solo per installazioni di wordpress.org)..
    Comunque sappi che altervista sconsiglia l'uso di jetpack perch crea problemi...
    Ultima modifica di darbula : 30-10-2017 alle ore 16.01.40

  10. #10
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    da anni che uso Jetpack e fino a qualche settimana fa tutto funzionava a meraviglia.
    Jetpack collegato a uno dei profili amministrativi del sito tramite il mio account di Wordpress.com.
    L'url che metto in Ifttt coralriff.altervista.org e i dati di accesso sono quelli di Wordpress.com. Ho resettato tutte le password sia sui profili amministrativi del sito che su Wordpress.com per essere sicuro che quella che immetto su Ifttt sia giusta.
    Ho provato ad effettuare l'accesso sia con i vari username che le relative email.
    Il file xmlrpc era attivo e lo ancora.

  11. #11
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    http://coralriff.altervista.org/wp-a...tpack-debugger qui tutto OK? (Se tutto OK anche il file xmlrpc.php sar OK)..
    Uhm io ho installato il plugin ifttt creato un account gi ho un applet di default (l'avviso via e-mail).. Ma da wordpress non so come configurarlo mi compare solo una form :D ... Io questo plugin lo trovo in impostazioni ifttt bridge for WordPress..
    Questo plugin ho scaricato https://it.wordpress.org/plugins/ifttt-bridge/
    Ultima modifica di darbula : 30-10-2017 alle ore 16.43.43

  12. #12
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    No, non tutto ok... il sito adesso non funziona proprio. "Too many redirects". Non ho accesso nemmeno al pannello di Wordpress.
    Su Ifttt non c' granch da configurare, devi solo effettuare l'accesso con i dati richiesti e poi puoi creare le varie applets.

  13. #13
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Comunque, sicuramente il fatto dei redirects dovuto all'HTTPS. Adesso dal pannello di Altervista ho cliccato per riattivare e non ho pi l'errore, dice che sar attivo nelle prox 24h...

  14. #14
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Dopo l'attivazione di CloudFare e clicchi attiva https una frase normale... Uhm https sar attivo entro 24 ore (guarda dopo 4 ore).. CloudFlare per il piano gratuito provvede al certificato entro 24 ore (piano a pagamento 4 ore)...
    Si normale che ricevi un redirect in https dato che altervista inserisce una regola con il mod_rewrite ... Regola sbagliata RewriteCond %{HTTP:X_FORWARDED_PROTO} !https
    Cosa vuole dire? Quando tale header diverso dal valore https fai il redirect.. Quindi anche se non esiste quel header si esegue il redirect.. (non esister quel header solo quando non nemmeno attivo CloudFlare)..
    Le impostazioni che trovi su wordpress altervista sono solo locali (possono differire dalle reali impostazioni del sito CloudFlare).. Dunque devi utilizzare solo il pannello wordpress per modificare CloudFlare (attiva/disattiva CloudFlare attiva/disattiva https esempio non esaustivo ma che rende l'idea che i cambiamenti devono essere effettuati da wordpress)..
    Cosa sta succedendo con i redirect nel dettaglio: dal tuo browser digiti http://coralriff.altervista.org/ altervista fa un redirect a https://coralriff.altervista.org/ CloudFlare non ha ancora pronto il certificato e ti riporta a http http://coralriff.altervista.org/.. I redirect si sistemeranno una volta che https sar attivo.
    Ultima modifica di darbula : 31-10-2017 alle ore 12.23.08

  15. #15
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Ora l'https attivo e se cerco di aprire il sito, con http o https, continua a darmi errore. Non posso n vedere il sito n accedere al pannello di Wordpress.
    Ultima modifica di coralriff : 31-10-2017 alle ore 14.54.45

  16. #16
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Devi impostare https solo da wordpress lascia perdere il sito CloudFlare...
    WordPress pu funzionare solo se dal suo pannello attivi CloudFlare e https
    Ultima modifica di darbula : 31-10-2017 alle ore 14.55.47

  17. #17
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Devi impostare https solo da wordpress lascia perdere il sito CloudFlare...
    Ah si scusa, ho appena modificato il mio ultimo post, aggiungendo che non ho accesso nemmeno al pannello di Wordpress. Il sito di Cloudflare non me lo sto proprio ca**ndo :-)

  18. #18
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Scusami se non mi fido, puoi farmi uno screenshot dal pannello CloudFlare? Se prima hai detto che non puoi accedere al pannello di amministrazione e se non accedi da CloudFlare... Con quale miracolo riesci a dire che l'https attivo?
    Se vero che non hai toccato nulla da CloudFlare e dopo 24 ore il problema non ti si risolve, accedi al pannello dal sito CloudFlare e richiedi l'attivazione https.
    Ultima modifica di darbula : 31-10-2017 alle ore 15.10.14

  19. #19
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Ho appena effettuato l'accesso al sito di Cloudflare e il sito risulta registrato e attivo adesso... ti giuro che non sono stato io! :-D

  20. #20
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Non riesco ad inviarti lo screenshot... ho provato da Google Drive e da https://imgbb.com/ ma non li carica... se lo metto sul sito non puoi vederlo perch il browser non te lo apre... consigli?

  21. #21
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

  22. #22
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Si mandami un allegato alla mia alias e-mail oppure potrei spiegarti come postare immagini di siti esterni qui sul forum... Cmq. Rileggiti il mio ultimo messaggio agisci di conseguenza... Se hai dubbi ne parliamo

  23. #23
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    https://www.cloudflare.com/a/crypto/...altervista.org qui lo status active?
    PS. Cancella quella immagine da Drive e altre fonti :)
    Ultima modifica di darbula : 31-10-2017 alle ore 15.20.21

  24. #24
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Lo status attivo. Ok cancello, grazie :-)

    Nel frattempo ho fatto lo screenshot della pagina "Crypto"... dicevi che puoi consigliarmi come embeddare qui le immagini da siti esterni senza troppe rotture. Sono "tutt'occhi"... :-)

  25. #25
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    come postare le foto in questo forum ti credo uhm sto pensando al motivo perch non ti fa connettere.... Se non hai toccato nulla da CloudFlare ne attivazione https e/o always use https il tuo errore strano

  26. #26
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    L'https l'ho riattivato dal pannello di Altervista, visto che da quello di Wordpress non riuscivo ad accedere. "Always use https" su Cloudflare attivo... lo disattivo?

  27. #27
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Non va attivato da CloudFlare gli utilizzatori di wordpress by altervista devono usare CloudFlare e https solo dal proprio applicativo wordpress (altrimenti non si vedr il sito)... Si disattiva always use https (c' gi una regola nel file .htaccess)
    Ultima modifica di darbula : 31-10-2017 alle ore 16.28.21

  28. #28
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    Ok, da Cloudflare ho disattivato "Always use https" e ora posso vedere il sito, solo che non usa l'https. Se vado su https://coralriff.altervista.org va automaticamente su http://coralriff.altervista.org

  29. #29
    darbula non  connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,962

    Predefinito

    Mi puoi fornire il contenuto del file .htaccess? Umh credo impostazioni>avanzate e poi modifica file

  30. #30
    coralriff non  connesso Utente AlterBlog
    Data registrazione
    05-05-2012
    Messaggi
    68

    Predefinito

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    SetEnv AV_WP_SKIP_XMLRPC off
    # END WordPress



    # # av:Words
    SetEnv AV_WORDS 0

    # # av:Toolbar
    SetEnv AV_TOOLBAR 0

    # # av:Banner
    SetEnv AV_BANNER 0

    # # av:PHP-RG
    php_flag register_globals on

    # # av:php5-engine
    AddHandler av-php5 .php

Pagina 1 di 2 12 UltimoUltimo

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •