Visualizzazione risultati 1 fino 14 di 14

Discussione: Mettere css a link mailto

  1. #1
    albertifoto non è connesso Utente
    Data registrazione
    31-03-2019
    Messaggi
    102

    Predefinito Mettere css a link mailto

    Ho messo un css a mailto, ma non lo applica. Sugli altri link funziona

    Codice HTML:
    <a class="css" href="mailto:email@gmail.com?subject=Info">contattami</a>

  2. #2
    GraphOGLRisorse non è connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,002

    Predefinito

    Salve,
    In quale pagina risiede il link dove riscontra il problema?

    Cordiali saluti.

  3. #3
    albertifoto non è connesso Utente
    Data registrazione
    31-03-2019
    Messaggi
    102

    Predefinito

    Sono i 2 link Contattami:

    https://albertifoto.altervista.org/prezzi/

  4. #4
    GraphOGLRisorse non è connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,002

    Predefinito

    A me quei link risultano essere apparire come gli altri.



    Cordiali saluti.

  5. #5
    albertifoto non è connesso Utente
    Data registrazione
    31-03-2019
    Messaggi
    102

    Predefinito

    Si, ma se tu li clicchi dovrebbero prendere il visited

    Codice:
    a.links:link {color: #0f80ff !important; font-size: 1em; text-decoration: underline;}
    a.links:visited {color: #2db001 !important; font-size: 1em; text-decoration: underline;}
    a.links:hover {color: #ff0000 !important; font-size: 1em; text-decoration: underline;}

  6. #6
    GraphOGLRisorse non è connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,002

    Predefinito

    Non è la classe css che non viene applicata, ma la condizione css di link visitato che non ha effetto se si usa mailto.

    Come può vedere in questo esempio: EsempioMailtoCss.html

    Cordiali saluti.

  7. #7
    albertifoto non è connesso Utente
    Data registrazione
    31-03-2019
    Messaggi
    102

    Predefinito

    Perché il tuo è diventato verde e il mio no?

  8. #8
    GraphOGLRisorse non è connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,002

    Predefinito

    Nel codice del mio esempio, ho usato una sola classe link.

    Se sta usando già la calsse di riferimento link "a" non può applicare nella stessa pagina le proprietà in modo differente a seconda dei link.

    Può risolvre il problema però, inserendo il link in un div:
    Codice HTML:
    <style>
    .test > a:link { color: yellow;}
    .test > a:visited {color: gray;}
    .test > a:hover {color: red;}
    .test > a:active {color: yellow;}
    } 
    </style>
    
    <div class="test">
    <a href="mailto:email@gmail.com?subject=Info">contattami</a>
    </div>
    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 05-02-2021 alle ore 22.25.16

  9. #9
    albertifoto non è connesso Utente
    Data registrazione
    31-03-2019
    Messaggi
    102

    Predefinito

    Non funziona su Wordpress, lo lascio come prima.

  10. #10
    GraphOGLRisorse non è connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,002

    Predefinito

    La nuova classe css impostata come nell'ultimo esempio, in Wordpress dovrebbe esserre aggiunta da aspetto -> css personalizzato. Nella pagina, è da aggiungere solo il div che la richiama e che racchiude il link.

    Cordiali saluti.

  11. #11
    albertifoto non è connesso Utente
    Data registrazione
    31-03-2019
    Messaggi
    102

    Predefinito

    Ho usato il file css Child e nella pagina ho messo il div. Che non funziona è solo il visited.

  12. #12
    GraphOGLRisorse non è connesso AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    2,002

    Predefinito

    L'ultimo esempio, fa riferimento al fatto di poter usare più stili a seconda del link nella stessa pagina, non al fatto che il link sia stato visitato o meno.

    Come menzionato in precedenza, con mailto non funziona l'assegnazioe del link visitato.

    I link vengono indentificati come visitati(visited), soltatno se l'attributo href viene memorizzato nella cronologia del browser. Quindi con mailto non può funzionare.

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 06-02-2021 alle ore 03.49.48

  13. #13
    Guest

    Predefinito

    non riesco a creare un nuovo forum. Perchè?

  14. #14
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,614

    Predefinito

    Citazione Originalmente inviato da tuttodownload Visualizza messaggio
    non riesco a creare un nuovo forum. Perchè?
    Intendi dire che non riesci a creare una nuova discussione?

    Vai sulla homepage del forum, quindi seleziona la sezione che ritieni più idonea al tuo problema e premi il tasto "Scrivi nuova discussione":

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •