Visualizzazione risultati 1 fino 18 di 18

Discussione: Installazione Prestashop 1.6.1.9

  1. #1
    acq
    acq non  connesso Neofita
    Data registrazione
    26-11-2016
    Messaggi
    9

    Exclamation Installazione Prestashop 1.6.1.9

    Buonagiorno a tutti, sto cercando di installare Prestashop 1.6.1.9 sul mio dominio altervista, ma con scarsi risultati, ho fatto tutto ci che ho trovato nei seguenti link:

    Prestashop installazione interrotta al 67% errore installazione moduli

    e

    problemi con prestashop su altervista 1.6.06

    ma probabilmente manco qualche passaggio senza rendermene conto...
    Di seguito ricapitolo tentativi e risultati:

    con PHP 5.6 e Prestashop 1.6.1.9:

    Ho settato la connessione server to server inviando l'sms:





    Ho quindi modificato il file classe/tools.php come segue:



    ho rimosso tutte le tabelle del db, ed ho fatto partire nuovamente il setup, risultato:



    -----------------------------------------------------------------------------------------------------------------


    con PHP 5.2 e Prestashop 1.6.1.9:

    Ho settato la connessione server to server inviando l'sms:





    Ho quindi modificato il file classe/tools.php come segue:



    ho rimosso tutte le tabelle del db, ed ho fatto partire nuovamente il setup, risultato:



    In ambo i casi vengono create le tabelle nel DB, ma con il PHP 5.6 il numero di tabelle minore rispetto al PHP 5.2.
    Qualcuno saprebbe indicarmi dove sbaglio? grazie 1000 a tutti voi.
    Buona giornata.

  2. #2
    acq
    acq non  connesso Neofita
    Data registrazione
    26-11-2016
    Messaggi
    9

    Predefinito

    Naturalmente ho provato ad installare anche la versione 1.7, ma qui si va di male in peggio, abilitato il PHP 5.6 e la connessione server to server nelle prime fasi del setup viene visualizzatio il seguente worning:



    proseguendo con l'istallazione viene visualizzato il messaggio:



    Qualcuno ha risposte al mistero dell'installazione di Prestashop? GRAZIEEEEE!!!!

  3. #3
    acq
    acq non  connesso Neofita
    Data registrazione
    26-11-2016
    Messaggi
    9

    Predefinito

    Nessuna risposta? Ragazzi..... C' nessuno sul forum? nessuna dritta?

  4. #4
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,115

    Predefinito

    Quei warning li puoi ignorare, io sono riuscito ad installare correttamente PrestaShop 1.7. Il passaggio di creazione del database per qualche ragione molto lungo e lo script va talvolta in timeout, riprova ad eseguire l'installazione.

  5. #5
    acq
    acq non  connesso Neofita
    Data registrazione
    26-11-2016
    Messaggi
    9

    Predefinito

    Ciao karl94, ho provato 4 volte a far ripartire il setup ma non va mi sai dire se da qualche parte posso variare il timeout?
    Grazie.

  6. #6
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,115

    Predefinito

    Purtroppo Prestashop crea molte tabelle (213) e questa operazione richiede un po' di tempo.
    Ritenta di nuovo: se ti mostra ancora l'errore 500 nel passaggio della creazione delle tabelle non chiudere la pagina, controlla con phpMyAdmin se tutte le 213 tabelle nel database sono state create, quindi se il database a posto ritorna nella pagina di installazione e fai eseguire gli altri passaggi eseguendo il codice
    Codice:
    process_install(process_steps[current_step=2])
    dalla console web degli strumenti di sviluppo integrati nel browser (la puoi aprire con CTRL+SHIFT+K su Firefox, o con CTRL+SHIFT+J su Chrome).
    Ultima modifica di karl94 : 10-04-2017 alle ore 14.10.24

  7. #7
    acq
    acq non  connesso Neofita
    Data registrazione
    26-11-2016
    Messaggi
    9

    Predefinito

    Grazie Karl94, la procedura ha funzionato alla grande!

  8. #8
    cosdrip non  connesso Neofita
    Data registrazione
    07-04-2017
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Purtroppo Prestashop crea molte tabelle (213) e questa operazione richiede un po' di tempo.
    Ritenta di nuovo: se ti mostra ancora l'errore 500 nel passaggio della creazione delle tabelle non chiudere la pagina, controlla con phpMyAdmin se tutte le 213 tabelle nel database sono state create, quindi se il database a posto ritorna nella pagina di installazione e fai eseguire gli altri passaggi eseguendo il codice
    Codice:
    process_install(process_steps[current_step=2])
    dalla console web degli strumenti di sviluppo integrati nel browser (la puoi aprire con CTRL+K su Firefox, o con CTRL+J su Chrome).
    Ciao a tutti.
    Ho provato a seguire le indicazioni di questo post ma Ctrl+J mi apre la lista dei Download...
    Controllando nel database mi si sono create solo 211 tabelle. Come posso risolvere? :/

  9. #9
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,115

    Predefinito

    La scorciatoia corretta CTRL+SHIFT+J, ho corretto il mio messaggio precedente.

  10. #10
    cosdrip non  connesso Neofita
    Data registrazione
    07-04-2017
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    La scorciatoia corretta CTRL+SHIFT+J, ho corretto il mio messaggio precedente.
    Grazie mille.
    Effettuata l'operazione da te consigliata non ho risolto molto...


    Premetto che le tabelle create da prestashop sono 211 anzich 213.

    Ora, dopo aver eseguito quel comando mi si aggiunta la scritta rossa "Create default shop and languages"

    Non che quegli errori, piuttosto che trascurarli, avrei dovuto risolverli?

    Come?

    Grazie in anticipo.
    Ultima modifica di cosdrip : 12-04-2017 alle ore 13.56.59

  11. #11
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,115

    Predefinito

    Devi attivare InnoDB dal pannello di controllo di AlterVista.

  12. #12
    cosdrip non  connesso Neofita
    Data registrazione
    07-04-2017
    Messaggi
    5

    Unhappy

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Devi attivare InnoDB dal pannello di controllo di AlterVista.
    Bene, sembra che stiamo migliorando... :)

    Gli errori presenti nell'ultima immagine allegata non sono stati risolti ma ora, usando la console di Firefox e inserendo il codice da te suggeritomi, siamo andati molto avanti.
    Per forse non basta... L'errore continua cos:

    1: HTTP 200 - parsererror -
    Fatal error: Uncaught exception 'ICanBoogie\CLDR\ResourceNotFound' with message 'Path not defined: supplemental/codeMappings.' in /membri/cosdrip/vendor/icanboogie/cldr/lib/WebProvider.php:77 Stack trace: #0 /membri/cosdrip/vendor/icanboogie/cldr/lib/ProviderChainTrait.php(43): ICanBoogie\CLDR\WebProvider->provide('supplemental/co...') #1 /membri/cosdrip/vendor/icanboogie/cldr/lib/ProviderChainTrait.php(43): ICanBoogie\CLDR\FileProvider->provide('supplemental/co...') #2 /membri/cosdrip/vendor/icanboogie/cldr/lib/Repository.php(124): ICanBoogie\CLDR\RunTimeProvider->provide('supplemental/co...') #3 /membri/cosdrip/vendor/icanboogie/cldr/lib/Supplemental.php(95): ICanBoogie\CLDR\Repository->fetch('supplemental/co...') #4 /membri/cosdrip/src/Core/Cldr/Repository.php(301): ICanBoogie\CLDR\Supplemental->offsetGet('codeMappings') #5 /membri/cosdrip/src/Core/Cldr/Repository.php(226): PrestaShop\PrestaShop\Core\Cldr\Repository->isCurrencyValid('EUR') #6 /membri/cosdrip/classes/Currency.php(135): PrestaShop\PrestaShop\Core\Cldr\Re in /membri/cosdrip/vendor/icanboogie/cldr/lib/WebProvider.php on line 77


    Mi sbaglio? Posso continuare?
    Aggiungo che ora le tabelle sono 226.

  13. #13
    cosdrip non  connesso Neofita
    Data registrazione
    07-04-2017
    Messaggi
    5

    Predefinito

    Mi correggo: non posso continuare

  14. #14
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,115

    Predefinito

    Hai sbloccato le connessioni server to server?

  15. #15
    cosdrip non  connesso Neofita
    Data registrazione
    07-04-2017
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Hai sbloccato le connessioni server to server?
    Perdonami ma... come?

  16. #16
    Guest

    Predefinito

    ancora problemi con prestashop?
    io personalmente,su altro indirizzo altervista
    http://esperimentidrupal.altervista....shop/index.php
    l'ho installato qualche giorno fa insieme a opencart e abantecart e drupal
    tutto ok grazie altervista ti amo

  17. #17
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,115

    Predefinito

    Citazione Originalmente inviato da cosdrip Visualizza messaggio
    Perdonami ma... come?
    http://it.help.altervista.org/w/Conn...e_la_whitelist

  18. #18
    testpre non  connesso Utente AlterBlog
    Data registrazione
    07-06-2017
    Messaggi
    1

    Predefinito

    Ragazzi buon pomeriggio, ho lo stesso problema con prestashop. Versione 1.7. Ho sbloccato anche le connessioni server to server ma nulla.
    HTTP 200 - parsererror -
    Fatal error: Uncaught exception 'ICanBoogie\CLDR\ResourceNotFound' with message 'Path not defined: supplemental/codeMappings.' in /membri/testpre/vendor/icanboogie/cldr/lib/WebProvider.php:77 Stack trace: #0 /membri/testpre/vendor/icanboogie/cldr/lib/ProviderChainTrait.php(43): ICanBoogie\CLDR\WebProvider->provide('supplemental/co...') #1 /membri/testpre/vendor/icanboogie/cldr/lib/ProviderChainTrait.php(43): ICanBoogie\CLDR\FileProvider->provide('supplemental/co...') #2 /membri/testpre/vendor/icanboogie/cldr/lib/Repository.php(124): ICanBoogie\CLDR\RunTimeProvider->provide('supplemental/co...') #3 /membri/testpre/vendor/icanboogie/cldr/lib/Supplemental.php(95): ICanBoogie\CLDR\Repository->fetch('supplemental/co...') #4 /membri/testpre/src/Core/Cldr/Repository.php(301): ICanBoogie\CLDR\Supplemental->offsetGet('codeMappings') #5 /membri/testpre/src/Core/Cldr/Repository.php(226): PrestaShop\PrestaShop\Core\Cldr\Repository->isCurrencyValid('EUR') #6 /membri/testpre/classes/Currency.php(135): PrestaShop\PrestaShop\Core\Cldr\Re in /membri/testpre/vendor/icanboogie/cldr/lib/WebProvider.php on line 77


    Questo il problema che mi da, si blocca al 45%. E da stamattina che provo ma nulla.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •