Visualizzazione risultati 1 fino 20 di 20

Discussione: Problema modifica CSS e programmazione

  1. #1
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito Problema modifica CSS e programmazione

    Salve a tutti, ho 2 problemi che mi stanno rendendo la vita impossibile con il mio blog altervista/wordpress.

    1) Non riesco a modificare style.css nel mio tema. Se lo faccio sia da pannello altervista che da ftp le modifiche non si vedono sul sito. Ho provato a cancellare e disattivare la cache cloudflare e del browser ma nulla
    2) Ho rimosso la stringa CRON da un file perché gli strumenti per webmaster di google dicevano che causava redirect e questo da problemi nell'indice. Però adesso non riesco più a programmare gli articoli per la pubblicazione fra un tot di tempo, mi dice sempre programmazione saltata

    Potreste aiutarmi? Non so più come uscirne

  2. #2
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Citazione Originalmente inviato da tech4d Visualizza messaggio
    1) Non riesco a modificare style.css nel mio tema. Se lo faccio sia da pannello altervista che da ftp le modifiche non si vedono sul sito. Ho provato a cancellare e disattivare la cache cloudflare e del browser ma nulla
    Perché dovresti modificare manualmente quel file? Se hai del codice CSS da aggiungere usa la sezione CSS personalizzato, modificare i file del tema è sconsigliabile (dopo un aggiornamento per esempio perderesti tutte le modifiche).
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    2) Ho rimosso la stringa CRON da un file perché gli strumenti per webmaster di google dicevano che causava redirect e questo da problemi nell'indice.
    Che tipo di preoblemi esattamente, puoi indicare qualche dettaglio in più?
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    Però adesso non riesco più a programmare gli articoli per la pubblicazione fra un tot di tempo, mi dice sempre programmazione saltata
    Per quella funzionalità è necessario arrivare i cronjob di WordPress, così come per tante altre.

  3. #3
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    1) Non essendo un esperto di CSS non so come si modifichi il template attraverso il CSS personalizzato. Su style.css posso ad esempio cambiare la dimensione dei caratteri cambiando un numerino, ma con il CSS personalizzato che è un campo vuoto cosa dovrei fare?
    2) Ho disattivato il CRON eliminando la stringa define('ALTERNATE_WP_CRON', true); nel file sull'ftp perchè facendo una analisi sul mio sito con uno strumento per verificare i problemi mi ha dato questo errore (si veda wp_cron nell'url):

    This page redirects to another URL
    in response header: http://tech4d.altervista.org/2016/04...41931152343750
    In Meta Tags: Not set
    Via Javascript: None found
    Disable the redirect if you want this page to rank

    Ora capisco che per programmare gli articoli ci vuole per forza quella stringa, ma essendo che quella stringa mi preclude il posizionamento su Google come posso risolvere? (Mi scuso per l'ignoranza)
    Ultima modifica di tech4d : 26-04-2016 alle ore 16.12.45

  4. #4
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Citazione Originalmente inviato da tech4d Visualizza messaggio
    1) Non essendo un esperto di CSS non so come si modifichi il template attraverso il CSS personalizzato. Su style.css posso ad esempio cambiare la dimensione dei caratteri cambiando un numerino, ma con il CSS personalizzato che è un campo vuoto cosa dovrei fare?
    Devi scrivere un'intera regola CSS, usando il medesimo selettore e ridefinendo la proprietà in questione. Se indichi un esempio concreto ti posso dare indicazioni più precise.
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    facendo una analisi sul mio sito con uno strumento per verificare i problemi
    Quale strumento hai usato di preciso?
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    Ora capisco che per programmare gli articoli ci vuole per forza quella stringa, ma essendo che quella stringa mi preclude il posizionamento su Google come posso risolvere? (Mi scuso per l'ignoranza)
    Dove avresti letto che non permette ai motori di ricerca di indicizzare la pagina? Dai uno sguardo ai vari blog WordPress che sono ospitati su AlterVista: tutti hanno attivi i cronjob di WordPress e sono perfettamente indicizzati.

  5. #5
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    1) Esempio CSS:
    Codice:
    h1 { font-size: 39px; line-height: 1.2; }
    h2 { font-size: 38px; line-height: 1.2; }
    h3 { font-size: 34px; line-height: 1.2; }
    h4 { font-size: 30px; line-height: 1.2; }
    Ecco la porzione di style.css. Vorrei cambiare la dimensione del font dei tag H1 da 39 a 35px (per esempio), come dovrei fare nel CSS personalizzato?

    2) Lo strumento che mi da quell'errore è OnPage.org, ma anche inserendo i link del sito nella Search Console per testarli (nella sezione Visualizza come Google) mi esce sempre "Parziale" e a volte "Redirezionato". Lo so che su altri siti non è così ma non riesco a capire perchè sul mio lo è. Ho eliminato quasi tutti i banner, cambiato tema e ho pochi plugin installati che tra l'altro usano tutti. Non riesco proprio a capire.
    Ultima modifica di karl94 : 26-04-2016 alle ore 16.23.06 Motivo: Formattazione

  6. #6
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Citazione Originalmente inviato da tech4d Visualizza messaggio
    1) Esempio CSS:
    Codice:
    h1 { font-size: 39px; line-height: 1.2; }
    h2 { font-size: 38px; line-height: 1.2; }
    h3 { font-size: 34px; line-height: 1.2; }
    h4 { font-size: 30px; line-height: 1.2; }
    Ecco la porzione di style.css. Vorrei cambiare la dimensione del font dei tag H1 da 39 a 35px (per esempio), come dovrei fare nel CSS personalizzato?
    Ricopia nella sezione CSS personalizzato la porzione di codice che hai riportato qua e modifica direttamente lì i valori.
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    2) Lo strumento che mi da quell'errore è OnPage.org, ma anche inserendo i link del sito nella Search Console per testarli (nella sezione Visualizza come Google) mi esce sempre "Parziale" e a volte "Redirezionato". Lo so che su altri siti non è così ma non riesco a capire perchè sul mio lo è. Ho eliminato quasi tutti i banner, cambiato tema e ho pochi plugin installati che tra l'altro usano tutti. Non riesco proprio a capire.
    Questo tipo di redirezionamento non causa problemi ai motori di ricerca. Puoi spiegare quale problema stai cercando di risolvere? Su Google il tuo sito è correttamente indicizzato.

  7. #7
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    1) Ho appena provato come mi hai suggerito con il CSS personalizzato, il sito rimane invariato senza nessuna modifica, lo stesso succede togliendo la cache di Cloudflare e cambiando browser.
    2) Il problema principale che sto cercando di risolvere è il seguente. Il sito appare sì indicizzato, ma quando pubblico gli articoli non si indicizzano. Sono io che vado a mettere il link di ogni singolo articolo su search console ogni giorno (a questo link https://www.google.com/webmasters/to...bmit-url?hl=it) per farli indicizzare. E molti degli articoli spariscono dall'indice dopo pochi giorni. Questa cosa va avanti da mesi, da quando ho aperto il blog. Credevo si sarebbe risolta col tempo, ma nulla. Se non è cron il problema allora qual è? Ho visto siti pieni di plugin e pubblicità ma perfettamente indicizzati, invece il mio blog Altervista praticamente vuoto non ne vuole proprio sapere...

  8. #8
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Citazione Originalmente inviato da tech4d Visualizza messaggio
    1) Ho appena provato come mi hai suggerito con il CSS personalizzato, il sito rimane invariato senza nessuna modifica, lo stesso succede togliendo la cache di Cloudflare e cambiando browser.
    Potrebbe esserci qualche plugin che interferisce, puoi provare a disabilitarli tutti temporaneamente?
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    2) Il problema principale che sto cercando di risolvere è il seguente. Il sito appare sì indicizzato, ma quando pubblico gli articoli non si indicizzano.
    È normale che non compaiano subito, possono essere necessarie alcune ore o alcuni giorni.
    Citazione Originalmente inviato da tech4d Visualizza messaggio
    E molti degli articoli spariscono dall'indice dopo pochi giorni.
    Come verifichi di preciso l'indicizzazione di un articolo?

  9. #9
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    1) Plugin tutti disattivati e riprovato a cambiare il CSS, ancora nulla di fatto.
    2) Ci ho provato ad aspettare ore per più articoli ma nulla. Tanti siti gli articoli li indicizzano subito... Se deve metterci giorni l'indicizzazione praticamente non serve a nulla...
    3) Per verificare l'indicizzazione scrivo il titolo dell'articolo su google con a fianco il nome del sito, quando li indicizzo io con il link sopra appaiono sempre, ma quando non lo faccio non sono mai apparsi. Oppure uso site:nome

    Metaforizzando sembra che questo sito sia praticamente in coma e senza un apparente motivo...

  10. #10
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Puoi mantenere tutti i plugin disabilitati per qualche minuto, in modo che possa verificare?
    Per adesso sistemiamo questo problema, poi ci occupiamo dell'indicizzazione.

  11. #11
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    Ok li ho disattivati di nuovo. Partiamo da ora.

  12. #12
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Riattivali pure. Potrebbe essere il tema, stiamo effettuando le verifiche del caso.

  13. #13
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    No, non è il tema, sembra che il campo del CSS personalizzato sia completamente vuoto, puoi verificare? Stiamo sempre parlando dell'account da cui scrivi, tech4d giusto?

  14. #14
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    Si scusami avevo svuotato il campo CSS personalizzato prima di disattivare i plugin, non sapevo servisse. Ora i plugin sono disattivati e nel campo CSS ho inserito le stringhe. Scusa ancora

  15. #15
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Adesso il codice è correttamente inserito e funzionante. In alcuni casi però ci sono regole CSS che hanno priorità maggiore rispetto a quelle che hai inserito. Quali sarebbero i titoli di cui vorresti cambiare le dimensioni, di preciso?

  16. #16
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    A me non sembra funzionante... Vorrei modificare gli h1. Nel codice che ho inserito ho modificato h1, h2, h3 e h4, però sul sito non è apparsa nessuna modifica nella grandezza dei titoli...

    Mi correggo: in h3 le modifiche si vedono, ma in h1 (titolo dell'articolo e titoli nel widget a destra) non si vedono
    Ultima modifica di tech4d : 26-04-2016 alle ore 18.14.58

  17. #17
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,631

    Predefinito

    Come ti ho scritto, per quei titoli ci sono regole più specifiche, che hanno la precedenza rispetto a quelle che hai scritto tu.
    Per esempio, per i titoli degli articoli il tema usa il selettore #content .post .article-content .entry-title, che è più specifico del semplice h2 (sono h2, h1 solo nella pagina dell'articolo singolo, ma tu usa il selettore che ti ho riportato).
    Nella barra laterale invece ci sono degli h4, eccessivamente grandi attualmente. Rimuovi poi le modifiche che hai apportato al file style.css, ci sono ancora e possono poi crearti problemi.
    Per quanto riguarda l'indicizzazione, ho provato a cercare su Google l'estratto di ogni articolo visibile nella pagina principale del tuo blog, e ho riscontrato problemi solo con l'articolo Top 5 migliori droni economici 2016.
    Nella console di ricerca Google cosa leggi nella sezione Errori di scansione o Risorse bloccate?

  18. #18
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    Grazie davvero, sono riuscito a correggere gli h4 rendendoli di una grandezza accettabile. Ora resta solo il problema maggiore della non indicizzazione.

    Ecco cosa vedo negli errori di scansione:

    Aprendo l'errore esce scritto questo:

    Dettagli errore

    Ultima scansione: 06/02/16
    Data primo rilevamento: 06/02/16
    L'URL di destinazione non esiste, tuttavia il server non restituisce un errore 404 (file non trovato).

    In risorse bloccate vedo questo:

    Nessuna risorsa bloccata rilevata. Assicurati di selezionare tutte le varianti del sito.

    Ribadisco che però gli articoli li ho sempre indicizzati io e non si sono mai indicizzati automaticamente, e in Visualizza come Google appare sempre Parziale... Uso anche una sitemap ma nulla http://tech4d.altervista.org/xmlsitemap.xml

  19. #19
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    P.S. nella sezione Sitemap appare questo
    276 Inviato
    217 Indicizzati

  20. #20
    tech4d non è connesso Utente giovane
    Data registrazione
    01-01-2016
    Messaggi
    30

    Predefinito

    Update: se dovesse essere d'aiuto, stamattina ho pubblicato un nuovo articolo e non l'ho indicizzato manualmente, e come sempre adesso non è nell'indice Google

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •