Visualizzazione risultati 1 fino 10 di 10

Discussione: Visualizzare quale argomento stanno guardando gli ospiti online

  1. #1
    Guest

    Predefinito Visualizzare quale argomento stanno guardando gli ospiti online

    Ciao a tutti, ho un altersito con phpbb 3.0.10.
    Quando visualizzo la lista degli ospiti non vedo ne da dove questi provengano (ad esempio google, magari capendo anche quali chiavi di ricerca mi avvalorano di più) ne quale argomento stiano guardando (per capire quale post faccia più successo), ma si vede solamente il forum che stanno visualizzando.
    Esiste una MOD, o un'impostazione particolare che mi faccia vedere queste due cose? Grazie in anticipo!

  2. #2
    L'avatar di silvermaledetto
    silvermaledetto non è connesso AlterGuru 2500
    Data registrazione
    01-03-2007
    Residenza
    Provincia di Modena
    Messaggi
    4,595

    Predefinito

    Per lP esistono tanti programmini anche online che li tracciano più o meno profondamente, per tutto il resto mastercard
    Io ne ho... visti forum che voi umani non potreste immaginarvi... PhpBB3 in panne al largo dei database MySQL di Orione... E ho visto i TAG [B] balenare nel buio vicino al postreply di Tannhäuser.... E tutti quei... momenti andranno perduti nel tempo... Come... lacrime... nella pioggia... È tempo... di backuppare....

  3. #3
    Guest

    Predefinito

    Grazie mille!! Utilissimo come al solito =)

  4. #4
    Guest

    Predefinito

    Avrei un altro problema riguardo questa mod, che riscontrai anche con un altra simile. Per impostare il testo da visualizzare nelle statistiche (del tipo: sta visualizzando il topic TOT nel forum TOT) la mod dice di modificare il file language/en/common.php aggiungendo queste due voci:
    Codice:
    	'READING_TOPIC_TOPIC'		=> 'Reading topic %2$s in %1$s',
    da aggiungere dopo:
    Codice:
    		'READING_TOPIC'				=>
    E
    Codice:
    	'REPLYING_MESSAGE_TOPIC'	=> 'Replying to message in topic %2$s in %1$s',
    da aggiungere dopo
    Codice:
    	'REPLYING_MESSAGE'			=>
    Intanto c'è una cosa che mi fa rimanere scettico, ossia secondo il modder io dovrei fare una cosa del genere:
    Codice:
    	'REPLYING_MESSAGE'			=> 	'REPLYING_MESSAGE_TOPIC'	=> 'Replying to message in topic %2$s in %1$s','Replying to message in %s',
    ma a me sembra più coerente così (premetto che non conosco il linguaggio php)
    Codice:
    		'REPLYING_MESSAGE'			=> 'Replying to message in %s',
    	'REPLYING_MESSAGE'			=> 	'REPLYING_MESSAGE_TOPIC'	=> 'Replying to message in topic %2$s in %1$s','Replying to message in %s',
    Infatti facendo come diceva lui non riuscivo più a visualizzare il sito (vedevo una schermata bianca). A questo punto ho fatto come mi sembrava più coerente.
    Un'altro problema è che metto le stringhe in language/en poi sul sito non vedo scritto niente (dove dovrebbe esserci "Reading topic: TOT in: TOT")
    A questo punto ho provato a fare questo lavoro in language/it cercando di mettere delle frasi in italiano. Si sono riscontrati due problemi:
    1. Il "CHI C'E IN LINEA" che fa proprio iniziare le statistiche non si vedeva più bene ma si vedeva tipo così "CHI C'&%?%£$A'è in linea" (ho messo dei segni a caso ma era all'incirca così). Questo problema ho realizzato che fosse dovuto all'apostrofo (non lo riconosceva più) quindi ho tolto l'apostrofo lasciando "CHI C E' IN LINEA" e quel problema si è risolto.
    2. Si vede un errore:
    Codice:
    [phpBB Debug] PHP Warning: in file [ROOT]/viewonline.php on line 538: sprintf() [function.sprintf]: Too few arguments
    in realtà l'errore varia (ad esepio una volta è in /Viewonline un altra in functions.php) ma resta sempre scritto alla fine "Too Few Arguments"
    A questo punto ho provato a mettere le stringhe in language/it/common.php ma lasciandole in lingua inglese, ma sempre lo stesso problema
    Come posso fare? Grazie
    Ultima modifica di davydownloads : 18-08-2013 alle ore 11.59.54

  5. #5
    L'avatar di silvermaledetto
    silvermaledetto non è connesso AlterGuru 2500
    Data registrazione
    01-03-2007
    Residenza
    Provincia di Modena
    Messaggi
    4,595

    Predefinito

    Non ho mai installato tale mod e adesso ho poco tempo per approfondirla, ma quando si installano modifiche che richiedono di editare i file del linguaggio, è ovvio che devi editare anche i file della cartella it e tali file di linguaggio richiedono espressamente codifica UTF-8 senza BOM... questa è la primissima cosa da farsi.
    Io ne ho... visti forum che voi umani non potreste immaginarvi... PhpBB3 in panne al largo dei database MySQL di Orione... E ho visto i TAG [B] balenare nel buio vicino al postreply di Tannhäuser.... E tutti quei... momenti andranno perduti nel tempo... Come... lacrime... nella pioggia... È tempo... di backuppare....

  6. #6
    Guest

    Predefinito

    cosa sarebbe la codifica UTF-8 senza BOM?
    EDIT: Ho cercato su internet e mi pare di aver capito che non bisogna mettere vocali accentate o apostrofi e io non le ho messe! Comunque l'errore "Too Few Arguments" continua ad apparire, in particolare dopo che modifico/invio un argomento (dopo sparisce) o quando guardo gli utenti online ... In ogni caso se il problema fosse solo quella scritta in alto potrei anche sopportarlo, il problema però è che quando c'è quell'errore tutti i caratteri si ingrandiscono e diventa fastidioso...
    Ultima modifica di davydownloads : 19-08-2013 alle ore 14.36.27

  7. #7
    L'avatar di silvermaledetto
    silvermaledetto non è connesso AlterGuru 2500
    Data registrazione
    01-03-2007
    Residenza
    Provincia di Modena
    Messaggi
    4,595

    Predefinito

    Ma hai modificato qualche cosa in functions.php?
    Ti converrebbe disistallare la mod rimettere il file originale estratto da una nuova installazione ( o da un backup preMOD, in cui era funzionante ) e reinstallare la MOD.
    Ultima modifica di silvermaledetto : 19-08-2013 alle ore 17.04.02
    Io ne ho... visti forum che voi umani non potreste immaginarvi... PhpBB3 in panne al largo dei database MySQL di Orione... E ho visto i TAG [B] balenare nel buio vicino al postreply di Tannhäuser.... E tutti quei... momenti andranno perduti nel tempo... Come... lacrime... nella pioggia... È tempo... di backuppare....

  8. #8
    Guest

    Predefinito

    Ho già provato, e poi è un errore che mi capita con tutte le mods dove vado a modificare common.php. Comunque no, non ho modificato /functions.php (l'ho modificato tempo fa per installare altre mod, ma non avevo avuto nessun errore) perchè la mod chiedeva di modificare solo /viewonline.php e language/en/common.php
    Per capire quale dei due dà errore poi, ho sostituito viewonline.php con un viewonline puro e mai modificato (preso dal download di php 3.0.10,la mia versione). Ma l'errore continuava a manifestarsi.... quindi direi che il problema è questo benedetto common.php.
    Comunque per sicurezza riprovo a reinstallare tutto e ti dico! Grazie per l'attenzione :)

    EDIT: Ho reinstallato tutto, ho lasciato il testo in inglese anche in "it". L'unico problema riscontrato è la scritta "CHI C'E IN LINEA" che come prima si è riempita di caratteri strani. Ho comunque risolto anche quel problema. Per ora non vedo errori in cima al sito! Ti faccio sapere anche domani se il problema si è definitivamente risolto.

    EDIT2: Come non detto, l'errore è tornato ed'è sempre lo stesso :(
    Codice:
    [phpBB Debug] PHP Warning: in file [ROOT]/viewonline.php on line 535: sprintf() [function.sprintf]: Too few arguments
    Guarda anche tu http://davydownloads.altervista.org/viewonline.php
    Ultima modifica di davydownloads : 19-08-2013 alle ore 19.54.48

  9. #9
    L'avatar di silvermaledetto
    silvermaledetto non è connesso AlterGuru 2500
    Data registrazione
    01-03-2007
    Residenza
    Provincia di Modena
    Messaggi
    4,595

    Predefinito

    Prendi il file che devi inserire nel linguaggio e aprilo con un editor di testi che abbia codifica UTF-8 senza BOM, tipo il gratuito Notepad ++ per windows o Coda per Mac OsX poi salvali e utilizza quelli.
    Poi controlla il funzionamento.
    Io ne ho... visti forum che voi umani non potreste immaginarvi... PhpBB3 in panne al largo dei database MySQL di Orione... E ho visto i TAG [B] balenare nel buio vicino al postreply di Tannhäuser.... E tutti quei... momenti andranno perduti nel tempo... Come... lacrime... nella pioggia... È tempo... di backuppare....

  10. #10
    Guest

    Predefinito

    L'ho fatto un minuto fa e per ora nessun errore... Non voglio cantare vittoria però ho già notato una cosa buona: il "CHI C'E IN LINEA" è rimasto intatto è non è diventato un ammasso di caratteri :) Riscrivo tra mezzora per vedere se davvero il problema è risolto!

    EDIT: Ancora nessun errore! :):) Grazie mille dell'aiuto
    Ultima modifica di davydownloads : 20-08-2013 alle ore 13.57.01

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •