Visualizzazione risultati 1 fino 7 di 7

Discussione: Da HTTP a HTTPS non reindirizza o problemi per troppi reindirizzamenti

  1. #1
    Guest

    Predefinito Da HTTP a HTTPS non reindirizza o problemi per troppi reindirizzamenti

    Ciao a tutti, ho creato un sito semplice, quindi nessun Wordpress o Joomla installati, ho attivato dal pannello di controllo di altervista l'Https ed è tutto ok.

    Ho verificato l'indirizzo manualmente https://www.tig3r.altervista.org e funziona perfettamente, mi sono informato un po' sul web e ho capito che per reindirizzare da HTTP a HTTPS devo creare un file .htaccess con un codice al suo intero. Ho provato sia da gestione file sia da file e caricamento tramite FTP ma il risultato è sempre lo stesso, NON riesco a farlo funzionare.

    Ho guardato qui nel forum di supporto, ho provato a inserire i codici letti come questo , ho provato a dare un occhiata anche in Google, ho trovato tanti codici, molto simili ma che mi generano errori di troppi reindirizzamenti o mi resta normale.

    Senza linkarmi altrove, esiste una soluzione? Potete aiutarmi? Grazie

  2. #2
    darbula è connesso ora AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,080

    Predefinito

    Ciao e benvenuto, questo forum predilige del codice in modo da poter "verificare" l'eventuale errore , domandare è lecito, rispondere è cortesia!! Difficilmente troverai qualcuno dello staff ad aiutarti nei tuoi problemi, quindi il rispetto mi sembra il minimo. Nella regola .htaccess ti serve la versione di php da utilizzare e il RewriteEngine impostato su On.
    Questo codice imposta php 5.6 e fa il redirect da richieste http con la cartella "secure/" ed altro se presente (.*).
    Codice:
    # # av:php5-engine
    AddHandler av-php56 .php
    
    RewriteEngine On
    # This will enable the Rewrite capabilities
    
    RewriteCond %{HTTPS} !=on
    # This checks to make sure the connection is not already HTTPS
    
    RewriteRule ^/?secure/(.*) https://%{SERVER_NAME}/secure/$1 [R,L]
    # This rule will redirect all users who are using any part of /secure/ to the same location but using HTTPS.
    # i.e.  http://www.example.com/secure/ to https://www.example.com/secure/
    # This means if you dont want to force HTTPS for all directories you can force it for a specific sub-section of the site.
    espressione regolare ^/? significa la presenza o no del carattere slash (la root in altervista non viene riportata dentro il RewriteRule) dovresti togliere il "secure/" ed opzionalmente la variabile di apache %{} . poiché parliamo di siti web che possono iniziare con www o senza ricordatelo nel caso di richieste ajax (si potrebbe settare il domain nick.altervista.org nel javascript) Poiché la cache può influire nelle modifiche ti consiglio di vuotare cache browser e cloudflare

  3. #3
    Guest

    Predefinito

    Grazie per avermi risposto darbula, ho provato a fare come mi hai suggerito, ho impostato il php da pannello alla versione 5.6 e poi ho aggiunto il codice con i tuoi suggerimenti finali:
    Codice:
    # # av:php5-engine
    AddHandler av-php56 .php
    
    RewriteEngine On
    # This will enable the Rewrite capabilities
    
    RewriteCond %{HTTPS} !=on
    # This checks to make sure the connection is not already HTTPS
    
    RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]
    # This rule will redirect all users who are using any part of /secure/ to the same location but using HTTPS.
    # i.e.  http://www.example.com/secure/ to https://www.example.com/secure/
    # This means if you dont want to force HTTPS for all directories you can force it for a specific sub-section of the site.
    Ho aspettato qualche minuto ma continua a darmi problemi:
    La pagina tig3r.altervista.org non funziona

    tig3r.altervista.org ti ha reindirizzato troppe volte.
    Prova a cancellare i cookie.
    ERR_TOO_MANY_REDIRECTS

  4. #4
    darbula è connesso ora AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,080

    Predefinito

    Questo tipo di errore indica che esegue troppo reindirizzamenti (sempre lo stesso redirect).
    Ti succede quando usi il link https? (dovrei attivare https ma potremmo scoprirlo insieme come risolvere) a me senza il https attivo trasforma i link http in https.
    Ultima modifica di darbula : 26-03-2017 alle ore 05.06.17

  5. #5
    Guest

    Predefinito

    Mi succede quando digito www.tig3r.altervista.org" nella barra degli indirizzi. (ora non da l'errore perchè ho rimosso il codice nel .htaccess)
    L'https l'ho attivato dal pannello, risulta attivato, infatti se si forza dalla barra degli indirizzi "https://tig3r.altervista.org" funziona.

  6. #6
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Questa la soluzione da me adottata su wordpress: loop causa https
    Vedi se puoi ricavarne qualcosa di utile per la tua circostanza :)
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  7. #7
    Guest

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Questa la soluzione da me adottata su wordpress: loop causa https
    Vedi se puoi ricavarne qualcosa di utile per la tua circostanza :)
    Grazie dark, levando le stringhe di upload e wordpress, sembrerebbe funzionare.

    Posto la soluzione in caso qualcuno si imbatta nel mio stesso errore:
    Codice:
    # # av:php5-engine
    AddHandler av-php56 .php
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    ## Force +https://*
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule ^(.*)$ https://tig3r.altervista.org/$1 [R=301,L]
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •