Visualizzazione risultati 1 fino 11 di 11

Discussione: [joomla] htaccess o non htaccess? [era: Errore pagina index]

  1. #1
    Guest

    Predefinito [joomla] htaccess o non htaccess? [era: Errore pagina index]

    Salve a tutti, ho cercato casi simili al mio nel forum ma nonostante il titolo sia lo stesso in vari casi in nessuno si parla di quanto accaduto a me.

    Dunque fino a pochi giorni fa il mio sito funzionava perfettamente (www.ilviandante.org) oggi carica normalmente l'home page ma qualsiasi sottosezioni io cerco di aprire (da paesaggistica a ricerca o statistiche) mi da sempre

    Pagina index mancante

    La cartella /content/section/4/26/ non contiene una pagina index.

    Devi creare una pagina che si chiami index.html, index.htm oppure index.php (tutto minuscolo).
    http://www.altervista.org
    Quanto segue a "La cartella" etc varia a seconda della sezione che clicco ma al momento tutte danno lo stesso errore (tranne l'homepage appunto apparentemente funzionante). Qualcuno sa dirmi se si tratta di qualcosa di momentaneo o meno? risolvibile o meno? Preciso anche che i file contenuti nell'ftp ci sono ancora e sembrano inalterati.

  2. #2
    L'avatar di funcool
    funcool non è connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non lì, qui!
    Messaggi
    15,433

    Predefinito

    Sembra che ci sia un problema con il file .htaccess. Hai per caso disattivato il mod_rewrite?
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    «Tu mi dai fastidio perché ti credi tanto un Dio!» «Bè, dovrò pur prendere un modello a cui ispirarmi, no?» Woody Allen

  3. #3
    Guest

    Predefinito

    Non ho modificato nessuna impostazione. Posso provare a controllare questo mod_rewrite che ammetto non ho idea di dove cercare ^^'

    Guardando il file hts non sembra ci siano problemi
    ## Can be commented out if causes errors, see notes above.
    Options +FollowSymLinks

    #
    # mod_rewrite in use

    RewriteEngine On


    # Uncomment following line if your webserver's URL
    # is not directly related to physical file paths.
    # Update Your Joomla!/MamboDirectory (just / for root)

    # RewriteBase /
    Ultima modifica di ilpellegrino : 30-01-2008 alle ore 12.06.41

  4. #4
    L'avatar di dementialsite
    dementialsite non è connesso Super Moderatore
    Data registrazione
    19-10-2004
    Residenza
    fuori Padova
    Messaggi
    5,046

    Predefinito

    Citazione Originalmente inviato da ilpellegrino Visualizza messaggio
    Non ho modificato nessuna impostazione. Posso provare a controllare questo mod_rewrite che ammetto non ho idea di dove cercare ^^'
    Nel tuo pannello di controllo, sezione "Risorse e upgrades"...

    Stammi bene...
    Le questioni tecniche hanno risposte migliori nel forum pubblico, non trovi?

    When you don't know your next step... improvise

    ALTERVISTA WANTS YOU!
    Vuoi diventare moderatore su AlterVista? Scopri come...

  5. #5
    L'avatar di funcool
    funcool non è connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non lì, qui!
    Messaggi
    15,433

    Predefinito

    Al posto di:
    Codice:
    # RewriteBase /
    Prova a mettere:
    Codice:
    RewriteBase /
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    «Tu mi dai fastidio perché ti credi tanto un Dio!» «Bè, dovrò pur prendere un modello a cui ispirarmi, no?» Woody Allen

  6. #6
    Guest

    Predefinito

    Cioè una cosa che prima era gratuita ora va attivata? Prima di spenderci soldi vorrei essere sicuro che le cose stanno così
    Ultima modifica di ilpellegrino : 30-01-2008 alle ore 12.34.29

  7. #7
    L'avatar di dreadnaut
    dreadnaut non è connesso Super Moderatore
    Data registrazione
    22-02-2004
    Messaggi
    5,950

    Predefinito

    uhm, per quanto ne so' il supporto .htaccess non è mai stato gratuito - se non lo attivi non funziona

    se prima funzionava e non l'avevi attivato, allora il problema non è li

    p.s. però, se non sbaglio il tuo sito è Joomla no? quindi userebbe l'htaccess...
    chezDreadnaut
    "Un <BR/> è impuro, punto."
    "I <P>&nbsp;</P> non hanno diritto di esistere."

  8. #8
    Guest

    Predefinito

    Ha sempre funzionato perfettamente fino ad oggi.

  9. #9
    L'avatar di dreadnaut
    dreadnaut non è connesso Super Moderatore
    Data registrazione
    22-02-2004
    Messaggi
    5,950

    Predefinito

    joomla non so' proprio. Sposto in sezione apposita e vediamo se qualcuno ne sa' di più in giornata
    chezDreadnaut
    "Un <BR/> è impuro, punto."
    "I <P>&nbsp;</P> non hanno diritto di esistere."

  10. #10
    L'avatar di funcool
    funcool non è connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non lì, qui!
    Messaggi
    15,433

    Predefinito

    Se non vuoi spendere AlterCents per attivare il mod_rewrite dovresti poter utilizzare i link "normali".
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    «Tu mi dai fastidio perché ti credi tanto un Dio!» «Bè, dovrò pur prendere un modello a cui ispirarmi, no?» Woody Allen

  11. #11
    Guest

    Predefinito

    A parte che non vanno nemmeno i link normali, non è stata cambiata alcuna impostazione. Prima cliccando sulla voce di menu si apriva la pagina corrispondente ora da quell'errore. Lo da anche utilizzando il link completo.


    EDIT: Non c'è un supporto a cui chiedere direttamente? solo questo forum?

    edit: ahem avrei bisogno di risolvere il problema con un certa celerità. Se nessuno può rispondermi qui c'è qualcuno che può farlo? Il problema non è mio ne di impostazioni dato che il sito impostato nel medesimo modo su un altro spazio funziona. Idee? A chi devo rivolgermi?

    Non era affatto un up, se devo dire qualcosa di nuovo e nel frattempo nessuno ha risposto cosa devo fare? aspettare la grazia da parte di qualcuno? il mio sito non sta funzionando e non c'è uno staff che si degna di darmi una risposta chiara. Per essere sicuri che questo non risulti un "up" ci aggiungo un info nuova, me ne vado fuori dalle scatole, mi spiace solo che avevo già abbondantemente comprato spazio e servizi, soldati buttati, vedrò se ci sarà il modo di recuperarli. Grazie davvero per l'efficiente e puntuale supporto -_-

    Quanto detto sopra non vale naturalmente se qualcuno si degna di darmi una risposta chiara e possibilmente risolutiva ad un problema
    1. improvviso
    2. che ho avuto solo con altervista

    Fosse anche solo: si devi per forza comprare il servizio mod-rewrite. Perchè se permettete non spendo altri soldi in una cosa che non sono affatto sicuro (e nemmeno nessuno di voi a quanto pare) mi risolva il problema
    Ultima modifica di ilpellegrino : 31-01-2008 alle ore 10.45.17

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •