Pagina 2 di 2 PrimoPrimo 12
Visualizzazione risultati 31 fino 57 di 57

Discussione: Passare da sito autoprodotto a WordPress senza perdere il vecchio sito si può?

  1. #31
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Non temere (senza disattivare CloudFlare o senza disattivare https di CloudFlare o senza disattivare https di Altervista , questa circostanza è vera se non abilitato CloudFlare ma dal pannello di controllo Altervista o comunque abilitato di Default è il certificato creato da parte di Altervista) fai backup dei tuoi file e database e aggiungi al tuo file wp-config.php una riga prima del require_once (che troverai in basso)
    Codice PHP:
    $_SERVER['HTTPS'] = 'on'
    poi da Really Simple SSL impostalo (correttamente altrimenti aggiungi nuovamente il codice) e rimuovi la riga di codice precedente inserita.
    Fatto tutto ma quando tolgo quella riga da wp-config.php il sito non è accessibile di nuovo...

  2. #32
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    Uhm richiede un'analisi più attenta sono spiacente non ho il tempo necessario.
    Reinserisca il codice.
    Questa volta i css, Javascript cioè il sorgente html visualizzato tramite opzioni sviluppatori dal suo browser Chrome risulta in https o ancora in http? (Ovviamente dalla barra degli indirizzi usi https poiché sta sovraccaricando con $_SERVER['HTTPS'] = 'on';)
    Ultima modifica di darbula : 12-10-2021 alle ore 00.43.40

  3. #33
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Uhm richiede un'analisi più attenta sono spiacente non ho il tempo necessario.
    Reinserisca il codice.
    Questa volta i css, Javascript cioè il sorgente html visualizzato tramite opzioni sviluppatori dal suo browser Chrome risulta in https o ancora in http? (Ovviamente dalla barra degli indirizzi usi https poiché sta sovraccaricando con $_SERVER['HTTPS'] = 'on';)
    Non uso Chrome.
    Comunque tutti i link nel codice html sono https.
    Che vuol dire che sto sovraccaricando con $_SERVER['HTTPS'] = 'on';?!

  4. #34
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    @darbula
    Mi viene un dubbio: il certificato SSL è attivo sulla root dove è presente il vecchio sito, ma anche questo non reindiirzza correttamente ed appare non sicuro, anche se dal browser si rileva la presenza del certificato.
    Come si comporta il plugin di Wordpress in questi casi?
    Forse bisogna intervenire sul sito presente in root?

    Grazie

  5. #35
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    Beh dalla versione x (non ricordo ma al massimo 4 mesi fa) del plugin Really Simple SSL per motivi di sicurezza non valida i certificati autofirmati secondo il codice dello sviluppatore si dovrà aggiungere manualmente $_SERVER['https'] se nel tuo browser o tramite la pagina di test "https://www.ssllabs.com/ o https://your-domain.com/wp-content/plugins/really-simple-ssl/ssl-test-page.php" sei sicuro di 1) utilizzare https nella barra degli indirizzi e 2) il browser o la pagina di test ti indica che almeno https è attivo.
    Lui usa WordPress in sottocartella (ho già verificato prima e dopo il mio primo messaggio) senza forzare https tramite riscrittura .htaccess.
    Ecco la guida di Really Simple SSL https://really-simple-ssl.com/knowle...re-i-have-ssl/
    (Il problema non dipende né da parte di Altervista né da WordPress né da Really Simple SSL, anzi per me sicurezza indica migliorato).
    Quando crei una variabile la si memorizza in memoria poi dipende dal codice della tua applicazione (se il plugin Really Simple SSL non effettua ulteriori controlli e dunque la variabile $_SERVER['https'] = 'on'; indica erroneamente https anche se nella barra degli indirizzi è in http. Come detto in precedenza il plugin se ne lava le mani e penso probabilmente non applica ulteriori controlli nel caso di certificato autofirmato).
    Ultima modifica di darbula : 12-10-2021 alle ore 22.12.35

  6. #36
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Beh dalla versione x (non ricordo ma al massimo 4 mesi fa) del plugin Really Simple SSL per motivi di sicurezza non valida i certificati autofirmati secondo il codice dello sviluppatore si dovrà aggiungere manualmente $_SERVER['https'] se nel tuo browser o tramite la pagina di test "https://www.ssllabs.com/ o https://your-domain.com/wp-content/plugins/really-simple-ssl/ssl-test-page.php" sei sicuro di 1) utilizzare https nella barra degli indirizzi e 2) il browser o la pagina di test ti indica che almeno https è attivo.
    Lui usa WordPress in sottocartella (ho già verificato prima e dopo il mio primo messaggio) senza forzare https tramite riscrittura .htaccess.
    Ecco la guida di Really Simple SSL https://really-simple-ssl.com/knowle...re-i-have-ssl/
    (Il problema non dipende né da parte di Altervista né da WordPress né da Really Simple SSL, anzi per me sicurezza indica migliorato).
    Quando crei una variabile la si memorizza in memoria poi dipende dal codice della tua applicazione (se il plugin Really Simple SSL non effettua ulteriori controlli e dunque la variabile $_SERVER['https'] = 'on'; indica erroneamente https anche se nella barra degli indirizzi è in http. Come detto in precedenza il plugin se ne lava le mani e penso probabilmente non applica ulteriori controlli nel caso di certificato autofirmato).
    Non mi risulta che il plugin non funzioni correttamente con certificato autofirmato. Utilizzo il plugin su varie installazioni di Wordpress su Altervista, e ne ho attivato uno avanti ieri senza aver alcun tipo di problema e senza agire su config.php.

    Saluti

  7. #37
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    @darbula
    Mi viene un dubbio: il certificato SSL è attivo sulla root dove è presente il vecchio sito, ma anche questo non reindiirzza correttamente ed appare non sicuro, anche se dal browser si rileva la presenza del certificato.
    Non capisco cosa vuol dire... Il sito https://radioigor.altervista.org risulta nel browser avere la connessione sicura.

  8. #38
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Non mi risulta che il plugin non funzioni correttamente con certificato autofirmato. Utilizzo il plugin su varie installazioni di Wordpress su Altervista, e ne ho attivato uno avanti ieri senza aver alcun tipo di problema e senza agire su config.php.

    Saluti
    Ma dovrei tenere sempre quel plug-in?!?!?! Su altri siti WordPress gestito da AlterVista non ho quel plug-in e https funziona da solo!

  9. #39
    GraphOGLRisorse non è connesso AlterGuru 2500
    Data registrazione
    14-02-2015
    Messaggi
    2,660

    Predefinito

    Citazione Originalmente inviato da radioigor Visualizza messaggio
    Ma dovrei tenere sempre quel plug-in?!?!?! Su altri siti WordPress gestito da AlterVista non ho quel plug-in e https funziona da solo!
    L'account a cui si riferisce è di tipo AlterSito(Hosting con file manager) in cui ha installato Wordpress in versione originale.

    Negli altri siti, secondo quanto menziona, ha Wordpress versione AlterVista che è una versione modificata, quindi differente da quella originale. Tale vairiante di wordpress, è gestita da AlterVista ed è attivabile semplicemnte con un clik.

    Come menzionato in precedenza, al momento Wordpress versione AlterVista è disponibile solo con account di tipo AlterBlog(Hosting Wordpress gestito).

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 13-10-2021 alle ore 01.03.48

  10. #40
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    @radioigor si dovrai mantenere tale codice, anche WordPress gestito (bacheca amministrativa WordPress->abilita https) aggiunge $_SERVER['HTTPS'] e forza https tramite riscrittura .htaccess. Quel codice è il linguaggio per dire a WordPress https attivo.
    @frasidipace anche lo sviluppatore nella guida suggerisce l'aggiunta manuale del codice, io ho scavato più in fondo e non riesco a far funzionare tale codice (adattandolo al minimo indispensabile e mi restituisce false) https://github.com/Really-Simple-Plu...icate.php#L239 (non ricordo la ricerca esatta ma è il metodo più sicuro per verificare il certificato). Che poi analizzando con il manuale online di php usa errorcontext deprecato da php 7.2 e non ritorna correttamente all'errore nativo di php.
    In realtà anche con $_SERVER['HTTPS] in wp-config.php funziona, però non risolve l'eventuale contenuto misto (dentro il sorgente HTML esiste http al posto di https) e anche il sovraccarico se dalla barra degli indirizzi si usa http, comunque un cliente può inviare l'intestazione (e quindi falsificare) se non si controlla l'origine "vabbè dettagli".
    Ultima modifica di darbula : 13-10-2021 alle ore 08.22.03

  11. #41
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    @frasidipace anche lo sviluppatore nella guida suggerisce l'aggiunta manuale del codice, io ho scavato più in fondo e non riesco a far funzionare tale codice (adattandolo al minimo indispensabile e mi restituisce false) https://github.com/Really-Simple-Plu...icate.php#L239 (non ricordo la ricerca esatta ma è il metodo più sicuro per verificare il certificato). Che poi analizzando con il manuale online di php usa errorcontext deprecato da php 7.2 e non ritorna correttamente all'errore nativo di php.
    In realtà anche con $_SERVER['HTTPS] in wp-config.php funziona, però non risolve l'eventuale contenuto misto (dentro il sorgente HTML esiste http al posto di https) e anche il sovraccarico se dalla barra degli indirizzi si usa http, comunque un cliente può inviare l'intestazione (e quindi falsificare) se non si controlla l'origine "vabbè dettagli".
    Non voglio insisitere più di tanto, ma su tutte le installazioni di Wordpress che ho su Altervista, compreso quella attivata qualche giorno fa, non ho mai aggiunto codice in config.php ed ha sempre funzionato tutto.

    @radioigor può allegare lo screenshot della configurazione del plugin?
    Proverei anche a far riscrivrere .htaccess mediante Impostazioni->Permalink, Semplice e salvare, Nome articolo e salvare.

    Grazie

    Saluti

  12. #42
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Non voglio insisitere più di tanto, ma su tutte le installazioni di Wordpress che ho su Altervista, compreso quella attivata qualche giorno fa, non ho mai aggiunto codice in config.php ed ha sempre funzionato tutto.

    @radioigor può allegare lo screenshot della configurazione del plugin?
    Proverei anche a far riscrivrere .htaccess mediante Impostazioni->Permalink, Semplice e salvare, Nome articolo e salvare.

    Grazie

    Saluti
    https://pasteboard.co/0Sq8FnYlxcbH.png

  13. #43
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Dallo screenshot il plugin risulta configurato correttamente.
    Ha provato a reimpostare i permalink per far riscrivere il file .htaccess?

    Saluti

  14. #44
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Dallo screenshot il plugin risulta configurato correttamente.
    Ha provato a reimpostare i permalink per far riscrivere il file .htaccess?

    Saluti
    Non ho ben capito dove devo farlo.

  15. #45
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da radioigor Visualizza messaggio
    Non ho ben capito dove devo farlo.
    Attrverso la voce di menu di Wordpress Impostazioni->Permalink. Settate su "Semplice" e salvare, poi settare su "Nome articolo" e salvare.

    Saluti

  16. #46
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Attrverso la voce di menu di Wordpress Impostazioni->Permalink. Settate su "Semplice" e salvare, poi settare su "Nome articolo" e salvare.

    Saluti
    Fatto, tolto $_SERVER['HTTPS'] = 'on'; e di nuovo il sito non funziona, rimesso $_SERVER['HTTPS'] = 'on'; e funziona correttamente.
    A questo punto perché non posso semplicemente lasciare tale codice? Con gli aggiornamenti potrebbe sparire?

  17. #47
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Adesso sta reindirizzando correttamente verso https ed i browsers indicano connessione sicura, quindi c'era un problema di riscrittura .htaccess risolto mediante la reimpostazione dei permalink.
    Ora il sito dovrebbe funzionare anche senza quella riga di codice che, ad ogni modo, non sarà sovrascritta a seguito aggiornamento Wordpress poiché tale aggiornamento non sovrascrice il config.php.

    Saluti

  18. #48
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Adesso sta reindirizzando correttamente verso https ed i browsers indicano connessione sicura, quindi c'era un problema di riscrittura .htaccess risolto mediante la reimpostazione dei permalink.
    Ora il sito dovrebbe funzionare anche senza quella riga di codice che, ad ogni modo, non sarà sovrascritta a seguito aggiornamento Wordpress poiché tale aggiornamento non sovrascrice il config.php.

    Saluti
    Ripeto, togliendo
    $_SERVER['HTTPS'] = 'on';
    ricevo come errore su https://radioigor.altervista.org/wordpress/
    La pagina non funziona
    radioigor.altervista.org ti ha reindirizzato troppe volte.
    Prova a cancellare i cookie.
    ERR_TOO_MANY_REDIRECTS

  19. #49
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    È normale $_SERVER['HTTPS'] = 'on'; è il linguaggio di WordPress che indica https attivo. Senza di esso pensa sia in http anche se effettivamente nella barra degli indirizzi è in https. Really Simple SSL riscrive WP_HOME WP_SITEURL nel database in https (poi il codice php non trova $_SERVER['HTTPS'] erroneamente crede è http, effetua un redirect a https generando un ciclo infinito poiché si ripete sempre). Il tema può aggiungere altro codice per indicare https.
    Il sorgente di WordPress è basato sulla velocità del codice (in teoria), non prevede ogni scenario possibile in alcuni tratti.
    @frasidipace puoi creare una pagina di nome test1234.php con tale codice tratto dalla verifica adottata da Really Simple SSL?
    Codice PHP:
    <?php
    error_reporting
    (-1);
            function 
    get_certinfo$url )
            {
                    
    $url 'https://'.str_replace(array('https://''http://'), ''$url);

                    
    $original_parse parse_url($urlPHP_URL_HOST);
                    if (
    $original_parse) {
                        
    $get stream_context_create(array('ssl' => array('capture_peer_cert' => TRUE'capture_peer_cert_chain' => TRUE'verify_peer' => TRUE)));
                        if ( 
    $get ) {
            if (
    false === ($handle = @fopen($url'rb'false$get))) {
                return 
    null;
            }

            
    // Close non authenticated connection without reading any content.
            
    fclose($handle);
            
    $handle null;

                            
    set_error_handler('custom_error_handling');
                            
    $read stream_socket_client("ssl://" $original_parse ":443"$errno$errstr5STREAM_CLIENT_CONNECT$get);
                            
    restore_error_handler();

                            if ( !
    $read ){
                                
    $certinfo 'no-response';
                            }

                            if (
    $errno === && $read) {
                                
    $cert stream_context_get_params($read);
                                if ( isset(
    $cert['options']['ssl']['peer_certificate']) ) {
                                    
    $certinfo openssl_x509_parse($cert['options']['ssl']['peer_certificate']);
                                } else {
                                    
    $certinfo 'no-response';

                                }
                            }
                        }
                }

                if ( 
    $certinfo==='not-valid' ) return false;

                if (!empty(
    $certinfo)) return $certinfo;

                return 
    false;
            }

            
    /**
             * Catch errors
             *
             * @since 3.0
             *
             * @access public
             * @param       $errno
             * @param       $errstr
             * @param       $errfile
             * @param       $errline
             * @param array $errcontext
             *
             * @return bool
             */

            
    function custom_error_handling$errno$errstr$errfile$errline ) {
                return 
    true;
            }
    var_dump(get_certinfo('https://www.tuodominio.org'));
    @radioigor mantieni $_SERVER['HTTPS'] = 'on'; e il plugin Really Simple SSL è funziona tutto (il tuo problema è risolto). L'aggiornamento non modifica wp-config.php ma un plugin potrebbe (a seconda della fantasia dello sviluppatore, ma generalmente si limitano a impostare altre cose diverse da $_SERVER['HTTPS']). Quindi è come chiedere vincerò mai un milione di euro? (Solo se vinci puoi esserne certo, quindi solo se il plugin modifica wp-config.php puoi esserne certo).
    Ultima modifica di darbula : 16-10-2021 alle ore 00.24.25

  20. #50
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    @frasidipace puoi creare una pagina di nome test1234.php con tale codice tratto dalla verifica adottata da Really Simple SSL?
    Intendi una pagina Wordpress con il tuo codice PHP? Se sì, devo generare un template contenente il codice ed associarlo ad una pagina.

  21. #51
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    Se altervista hosting è sufficiente il copia incolla in gergo è chiamato codice php, uso due funzioni e il var_dump stampa l'output su browser se il file creato si chiama test1234.php dovrò digitare https://miodominio.org/test1234.php nella barra dell'indirizzo nel mio browser.
    Ultima modifica di darbula : 16-10-2021 alle ore 00.37.46

  22. #52
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Se altervista hosting è sufficiente il copia incolla in gergo è chiamato codice php, uso due funzioni e il var_dump stampa l'output su browser.
    Ok, prova. Restituisce NULL.

    Aspetta, ma l'ultima riga del codice va modificata con l'URL del sito?
    Ultima modifica di frasidipace : 16-10-2021 alle ore 00.53.08

  23. #53
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Ok, prova. Restituisce NULL.

    Aspetta, ma l'ultima riga del codice va modificata con l'URL del sito?
    Si scusa ho dimenticato di specificarlo, null può indicare che file_get_contents per qualche motivo non funziona (abilita le connessioni esterne dal pannello altervista Server To Server senza restrizioni).
    Ultima modifica di darbula : 16-10-2021 alle ore 08.15.32

  24. #54
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Si scusa ho dimenticato di specificarlo, null può indicare che file_get_contents per qualche motivo non funziona (abilita le connessioni esterne dal pannello altervista Server To Server senza restrizioni).
    Fatto! Restituisce string(11) "no-response"

  25. #55
    radioigor non è connesso Neofita
    Data registrazione
    25-12-2011
    Messaggi
    20

    Predefinito

    @radioigor mantieni $_SERVER['HTTPS'] = 'on'; e il plugin Really Simple SSL è funziona tutto (il tuo problema è risolto). L'aggiornamento non modifica wp-config.php ma un plugin potrebbe (a seconda della fantasia dello sviluppatore, ma generalmente si limitano a impostare altre cose diverse da $_SERVER['HTTPS']). Quindi è come chiedere vincerò mai un milione di euro? (Solo se vinci puoi esserne certo, quindi solo se il plugin modifica wp-config.php puoi esserne certo).
    Dunque sto a posto così e speriamo che funzioni sempre.
    Grazie.

  26. #56
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,488

    Predefinito

    Citazione Originalmente inviato da frasidipace Visualizza messaggio
    Fatto! Restituisce string(11) "no-response"
    Grazie mille per il test, non capisco perché a te di default il plugin Really Simple SSL senza aggiungere manualmente $_SERVER['HTTPS'] ti funziona. Quel codice è la verifica del certificato autofirmato che non ti funziona e ti da no-response. Vabbè dettagli.
    @radioigor figurati, quando necessita ritorni o apra una nuova discussione.

  27. #57
    frasidipace non è connesso Utente
    Data registrazione
    07-05-2010
    Messaggi
    190

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Grazie mille per il test, non capisco perché a te di default il plugin Really Simple SSL senza aggiungere manualmente $_SERVER['HTTPS'] ti funziona. Quel codice è la verifica del certificato autofirmato che non ti funziona e ti da no-response. Vabbè dettagli.
    In realtà non ho mai letto di dover aggiungere codice al config.php dopo aver installato il plugin Really Simple SSL, che infatti mi funziona su varie installazioni.
    L'unica cosa che viene consigliata, al fine di evitare l'installazione di un plugin di terze parti, è l'aggiunta al file .htaccess del seguente codice (se il sito è su server web Apache):

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

    Ciao

Pagina 2 di 2 PrimoPrimo 12

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •