Visualizzazione risultati 1 fino 19 di 19

Discussione: [wordpress] perchè l'aggiornamento automatico non funziona?

  1. #1
    gerasimone non è connesso Utente giovane
    Data registrazione
    09-03-2004
    Messaggi
    91

    Predefinito [wordpress] perchè l'aggiornamento automatico non funziona?

    Buongiorno,
    vorrei provare a capire a livello teorico perchè l'aggiornamento automatico di wordpress o dei suoi plugin non funziona, capito che non è un problema di curl, quindi di prendere il plugin dal loro server, sembrerebbe che non si possa poi scrivere qui si altervista.
    Qualcuno potrebbe aiutarmi a capire?
    grazie a tutti
    gerablog! ---- usa Geraagle al posto di eMule o Torrent! ---- JSTooltip plugin 4 wordpress

  2. #2
    L'avatar di saitfainder
    saitfainder non è connesso Sëniör Stäff
    Data registrazione
    06-12-2002
    Residenza
    Torino
    Messaggi
    8,715

    Predefinito

    Da poco esiste la possibilità di aggiornare automaticamente Wordpress e di installare automaticamente i plugin. E' però necessario effettuare una piccola modifica al sorgente:

    * Aprire il file wp-admin/includes/file.php
    * Cercare
    Codice:
    touch($filename);
    * e sostituire con
    Codice:
    $file = fopen($filename, 'w');
    fclose($file);
    * Salvare

    Le nuove installazioni di Wordpress dal pannello comprendono già questa modifica.
    Ultima modifica di saitfainder : 09-03-2009 alle ore 13.00.28


    «È una mia peculiarità distorcere la verità e inventarne di nuove.»
    «I tuoi orientamenti hanno su di me un effetto prossimo allo zero.»


  3. #3
    L'avatar di eudemonico
    eudemonico non è connesso Staff Redazione
    Data registrazione
    28-09-2008
    Messaggi
    547

    Predefinito

    il sorgente si raggiunge: pannello di controllo -> altersito -> gestione file -> poi apri la cartella del blog, con il percorso indicato da Saitfainder

  4. #4
    gerasimone non è connesso Utente giovane
    Data registrazione
    09-03-2004
    Messaggi
    91

    Predefinito

    @saitfainder
    interessante, non lo sapevo!
    grazie per le info :-)

    edit
    io ho preso una versione di wordpress dal sito uficiale, ho fatto questa modifica e comunque non mi funziona.... continua a chiedermi l'accesso ftp e qualsiasi cosa metto mi da errore.... idee?
    Ultima modifica di gerasimone : 09-03-2009 alle ore 19.23.29
    gerablog! ---- usa Geraagle al posto di eMule o Torrent! ---- JSTooltip plugin 4 wordpress

  5. #5
    coggi non è connesso Neofita
    Data registrazione
    09-05-2007
    Messaggi
    9

    Predefinito

    Salve ho lo stesso problema.

    Ho installato oggi wordpress e la modifica come detto da saifainder è già inclusa. Tuttavia non mi riesce di aggiornare.
    Ho messo come nome host sia localhost che l'indirizzo ****.altervista.org
    come nome il mio nome utente e come password la stessa che uso per tutto(ftp,pannello,forum)

    tuttavia non funziona :(

  6. #6
    L'avatar di saitfainder
    saitfainder non è connesso Sëniör Stäff
    Data registrazione
    06-12-2002
    Residenza
    Torino
    Messaggi
    8,715

    Predefinito

    Allora, via FTP è inutile affannarsi perché tanto non funziona sicuramente. Quindi non provate a inserire dati perché non ne caverete niente.

    Quale operazione state tentando di fare? Aggiornare il blog o installare un plugin? Se avete aggiornato il blog la modifica va rifatta perché viene sovrascritta. Insomma, spiegate meglio la sequenza delle operazioni che avete eseguito. Abbiamo testato più volte in questi giorni e se viene fatto tutto per bene funziona tutto.


    «È una mia peculiarità distorcere la verità e inventarne di nuove.»
    «I tuoi orientamenti hanno su di me un effetto prossimo allo zero.»


  7. #7
    coggi non è connesso Neofita
    Data registrazione
    09-05-2007
    Messaggi
    9

    Predefinito

    Io ho provato sia per aggiornare wordpress, sia per aggiornare un plugin.

    Non faccio tanti passaggi, nel primo caso

    1)Premo su Aggiorna sotto la tab Strumenti
    2)Premo su Aggiorna Automaticamente
    3)a questo punto mi chiede nome host, nome utente , password , tipo di connessione (FTP o FTPS)

    Nel secondo

    1)Premo su Plugin
    2)Su quelli dove me lo segnala premo "Aggiorna Automaticamente"
    3)a questo punto mi chiede nome host, nome utente , password , tipo di connessione (FTP o FTPS)

    E in entrambi i casi al momento in cui provo ad inserire dei dati al punto 3 mi da sempre errore. Sbaglio qualcosa?

    Grazie

    Edit : Inoltre ho notato che quando inserisco qualche informazione nel campo "nome host" o anche lasciandolo vuoto, una volta che poi premo aggiorna, nella pagina seguente di errore modifica da solo il suddetto campo aggiungendo l'indirizzo del mio blog..come se gli restasse "in memoria" boh non so se può aiutare questa cosa :) (Testato sia sulla pagina aggiornamento blog che sull'aggiornamento plugin)
    Ultima modifica di coggi : 10-03-2009 alle ore 12.17.52

  8. #8
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,021

    Predefinito

    coggi:

    abbiamo verificato il caso specifico, e il problema pare legato all'abilitazione di php5

    La modifica suggerita da saitfainder per ora non risolve ancora il problema su php5, sebbene a breve sarà possibile accedere a queste funzionalità anche su php5.

    Dovresti provare a riportare il tutto sotto php4

    La stessa cosa vale per gerasimone
    Ultima modifica di Gianluca : 10-03-2009 alle ore 12.19.08
    Gianluca

  9. #9
    coggi non è connesso Neofita
    Data registrazione
    09-05-2007
    Messaggi
    9

    Predefinito

    Ah capito, quindi cmq in teoria se io riporto il tutto su php4, faccio i vari aggiornamenti, e riporto su php5 non dovrei avere problemi giusto?

    Cmq grazie per la pronta risposta :)

  10. #10
    gerasimone non è connesso Utente giovane
    Data registrazione
    09-03-2004
    Messaggi
    91

    Predefinito

    ah ok, ora mi è chiaro, vorrà dire che continuerò ad aggiornarlo manualmente per ora fino ad una prossima notizia da parte vostra.
    grazie per l'aiuto, celere come sempre.
    bye
    gerablog! ---- usa Geraagle al posto di eMule o Torrent! ---- JSTooltip plugin 4 wordpress

  11. #11
    arcigaycuneo non è connesso Neofita
    Data registrazione
    12-11-2008
    Messaggi
    7

    Predefinito

    Com'è la situazione ora?
    Dovrebbe già funzionare anche su PHP5?
    Perché in caso affermativo sulla nostra installazione qualcosa va storto

  12. #12
    Guest

    Predefinito

    ora con wordpress 2.8 non funziona in nessun modo

  13. #13
    arcigaycuneo non è connesso Neofita
    Data registrazione
    12-11-2008
    Messaggi
    7

    Predefinito

    Magnifico, era proprio quello che ci voleva.
    Speriamo arrivi una soluzione, perché è un sistema veramente funzionale...

  14. #14
    blogcomputer non è connesso Neofita
    Data registrazione
    07-05-2009
    Messaggi
    8

    Predefinito

    Ciao, con Wordpress 2.8 non funziona!!!

    C'è una soluzione?

  15. #15
    nrgjack non è connesso Utente
    Data registrazione
    05-06-2008
    Messaggi
    105

    Predefinito

    sto provando a passare a 2.8.2

    mi confermate che non funziona ancora l'aggiornamento automatico nemmeno per voi o
    sono solo io ad aver problemi?

  16. #16
    gattoassociati non è connesso Neofita
    Data registrazione
    03-02-2004
    Messaggi
    1

    Predefinito

    Ciao a tutti
    neanche a me funziona l'aggiornamento automatico dei plugin
    Ho la versione 2.8.2

  17. #17
    L'avatar di theshabby
    theshabby non è connesso Utente
    Data registrazione
    18-06-2008
    Messaggi
    149

    Predefinito

    ragazzi, con calma si risolverà tutto, se non sbaglio verrà scritta una news sia nel forum sia nel blog di AV.

    e vi consiglio vivamente di aggiornare manualmente: è il miglior metodo


    Ciao
    Info Network Blogs + Social Network + Forum + Chat + Sala Giochi Arcade
    (@ll with One Sign Up)


  18. #18
    L'avatar di nosatispassion
    nosatispassion non è connesso Utente giovane
    Data registrazione
    09-10-2008
    Messaggi
    60

    Predefinito

    Speriamo che il prossimo aggiornamento di Wordpress non arrivi prima dei prossimi 3 mesi, almeno! (Che stress!) ;)

  19. #19
    fotoemozioni non è connesso Neofita
    Data registrazione
    03-02-2008
    Messaggi
    1

    Predefinito

    Concordo, è uno stress allucinante.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •