Visualizzazione risultati 1 fino 19 di 19

Discussione: wordpress e plugin "1blogcacher"

  1. #1
    Guest

    Predefinito [wordpress] wp-cache et similia non fungono

    Volevo installare il plugin suddetto (http://1blogcacher.com/) per tenere "leggere" le queries al db da parte dei visitatori, ma qualunque cosa io faccia mi compare (col plugin attivo) questo messaggio:
    Codice:
    Destination host forbidden
    <!-- Loaded originally in 0.43 seconds (2008-05-10, 18:44:52). -->
    che pare essere stato creato automagicamente o da altervista oppure dal plugin medesimo.

    Purtroppo sono in un circolo vizioso: ho solo 400 AC quindi non posso fare granché.

    Se pastrocchio troppo come admin esaurisco in un lampo le queries permessami.

    E prima di ridurmi a 0AC attivando il supporto htaccess vorrei essere sicura che sia veramente necessario...

    Un aiutino? Magari suggeritemi un plugin WP per il caching che funzioni davvero su altervista :)

    grazie in anticipo.
    tcd.
    Ultima modifica di cyberdeaf : 16-05-2008 alle ore 23.34.29 Motivo: (cambiato titolo x rispettare regole forum)

  2. #2
    Guest

    Predefinito

    Non e' che voglio "tirare" su questa discussione ma visto che vorrei traslocare qui il mio blog, mi serve veramente il caching, per essere sicura di non lasciare in brache di tela i miei visitatori solo perché magari ho finito tutti gli ac per "mantenere" un db di classe 2 e sono troppo taccagna per tirarli fuori io di tasca mia.

    Le ho provate tutte, veramente, ma ho come la sensazione che il caching non sia ben visto dai server di altervista (sarò paranoica io, va'.)

    ri-tcd.

    Ho buttatoammare 1blogcacher e installato i plugin: AskApache Crazy Cache, WP Super Cache. Entrambi mi dicono che sono funzionanti, ma insistono a dirmi che non hanno ancora cachato un bel gnente.

    Un aiutino per favore? ^_^
    Ultima modifica di cyberdeaf : 15-05-2008 alle ore 23.11.26

  3. #3
    Guest

    Unhappy

    Citazione Originalmente inviato da cyberdeaf Visualizza messaggio
    Ho buttatoammare 1blogcacher e installato i plugin: AskApache Crazy Cache, WP Super Cache. Entrambi mi dicono che sono funzionanti, ma insistono a dirmi che non hanno ancora cachato un bel gnente.

    Un aiutino per favore? ^_^
    Arieccomi, testarda e cocciuta. MOLTO. Sono enne giorni che ci litigo. E non è che abbia avuto molte ore di sonno nel frattempo.

    Spero che quello che ho scoperto possa finalmente tornare utile a chi avrà in futuro la mia stessa esigenza: forzare un caching delle pagine dinamiche LATO SERVER, per risparmiare il più possibile sulle queries al database [mica scriverete un post nuovo nel vostro blog ogni 5 minuti, no???] e dilazionare il più possibile la necessità di passare a un db di classe superiore -- anche se questo forse allo staff di altervista forse non va molto giù?

    Per farla breve:
    Ho fatto veramente di tutto tipo
    • spostare il contenuto di wordpress nella directory principale (ovvero in "/"),
    • aggiornare wordpress alla 2.5.1,
    • rinominare la cartella wordpress in php5,
    • provare le varie permutazioni di combinazioni tra plugin attivi e disattivati (tipo mastermind) ecc.,
    • ho anche pure cambiato tema...


    Il risultato è che ho scoperto solo una cosa, finora.
    A quanto pare i server di altervista sono stati configurati per NON abilitare mai (neanche se glie lo chiedo in phpese fluente) la compressione "trasparente" (e meno male che non hanno disabilitato l'uso della funzione php_info )

    Codice:
    Directive	Local Value	Master Value
    zlib.output_compression	Off	Off
    zlib.output_compression_level	-1	-1
    zlib.output_handler	no value	no value

    Ebbasta. Questa è stata l'unica cosa che ho capito.

    Per semplificarmi le cose ho deciso di disattivare tutti gli altri plugin incluso il plugin di AskApache Crazy Cache e lasciar attivo solo WP Super Cache.

    in teoria, ma PROPRIO in teoria, dopo esser usciti dal login come admin, dopo aver cancellato i cookies e dopo aver cancellato e disattivato la cache del browser, dovrei vedere nel sorgente in fondo al listato qualcosa tipo: <!-- super cache --> or <!-- super cache gz -->

    Il bello è che non vedo neanche quest'altro, neanche ad avere i cookies in memoria.
    <!-- Cached page served by WP-Cache -->

    In pratica QUALCOSA fa credere al/ai plugin di essere stati attivati, ma in realtà NON sono attivi. O lo sono solo a metà: perché nella cartella cache (quella di wordpress, non quella del browser) trovo solo files come questo: "wp-cache-19c00247712195548040ac55adf1bc90.meta"

    Va be', se avete tempo e voglia passateci voi da 'sto sito e date un'occhiata al suo sorgente html e ditemi se almeno voi lo vedete...

    grazie.
    tcd.

  4. #4
    Guest

    Predefinito

    Moderatore, cancella pure tutta questa thread. E' evidente che non c'è nessun altro interessato a questo genere di problematiche.

    Ho intenzione di azzerare tutto (ho già fatto un backup del htaccess e un dump sql da phpmyadmin) e ricominciare da zero, installando a mano l'ultimissima versione di wordpress (da www.wordpress-it.it).

    Se il problema del mancato caching delle pagine dinamiche si ripresenterà cercherò di scrivere un messaggio più articolato e dettagliato (titolo incluso.)

    tcd.

  5. #5
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    cyberdeaf:

    non penso sia mancanza di interesse ma probabilmente nessuno fino ad ora ha avuto qualcosa da aggiungere per aiutarti.

    Leggendo il primo post ti consiglierei di rimuovere la whitelist per le connessioni server to server (lo fai nella sezione risorse e upgrades).
    Gianluca

  6. #6
    Guest

    Predefinito

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    cyberdeaf:
    non penso sia mancanza di interesse ma probabilmente nessuno fino ad ora ha avuto qualcosa da aggiungere per aiutarti.
    In effetti, anche questo è possibile, soprattutto perché per come avevo scritto il messaggio iniziale non ero stata molto dettagliata...

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    Leggendo il primo post ti consiglierei di rimuovere la whitelist per le connessioni server to server (lo fai nella sezione risorse e upgrades).
    Già fatto, ma non ha risolto granché. Oltre alla rimozione della whitelist avevo anche upgradato il db mysql alla classe 2 ed abilitato il htaccess. la gestione dei sottodomini è quella di base (www.ecc.ecc. su / e basta, null'altro.)

    leggendo in giro e sfruculiando nel codice php di wordpress ne ho desunto che il meccanismo di caching di base (wp_cache) non dovrebbe richiedere le funzioni della zlib di php(4/5). Quindi non capisco perché diamine non voglia cachare nemmeno con la funzione base di caching interna a wordpress.

    Normalmente a questo punto, da brava informatica, tiro un qualche oggetto contundente contro il muro più vicino, tiro qualche urlaccio e... RICOMINCIO DACCAPO, con più calma :)

    tcd.

  7. #7
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Farò qualche test sul plugin in questione (non adesso perchè sono già in costume)
    Così almeno saremo in due a fare delle prove
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  8. #8
    Guest

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Farò qualche test sul plugin in questione (non adesso perchè sono già in costume)
    Così almeno saremo in due a fare delle prove
    beato te

    Comunque, aspetta a fare i test sui plugin. Falli solo se per qualche colpo di 3 ti funziona il caching di base di wordpress (che, se ho capito bene, si attiva inserendo nel wp-config.php "define('WP_CACHE', true);" almeno PRIMA del require_once finale).

    Il motivo? se non funge wp_cache, dubito che pure supercache e il resto della famigliola di plugin possano fungere, visto che si "appoggiano" ad esso e ne estendono le funzionalità.

    tcd (che va a reinstallare a _manina_ ed exnovo il wordpress 2.5.1 italiano, senza usare il bottone di altervista)

    update:
    Anche con la reinstallazione di wordpress 2.5.1 e la disattivazione di tutti i plugins e l'uso non solo del define('WP_CACHE', true), ma anche del "define('ENABLE_CACHE', true);", continuo a non vedere traccia di caching. A 'sto punto me so' messa a guardare nel codice, nel loro bug tracker e cosi' via andando. Dopo aver constatato come la documentazione su questa cosa del caching, su wordpress.org, fosse incoerente e non esplicitamente allineata alle versioni di wordpress, ho deciso di chiedere maggiori lumi sul loro forum (su wordpress.org).

    Spero mi rispondano prima del mio pensionamento :D

    Intanto mi fermo qua, con lo smanazzamento. Ho già guardato troppo codice php aggratisse per oggi, e devo ancora portare avanti quello per cui mi pagano!!!

    Vorrà dire che il trasloco del mio blog verrà rimandato.
    Ultima modifica di cyberdeaf : 17-05-2008 alle ore 19.35.19

  9. #9
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Allora: il plugin non l'ho provato ma ho fatto qualche sana ricerca per wp252 e la cache.
    Qui: http://www.wordpress-it.it/forum/topic/7240 dicono chiaramente che wordpress di suo non ha un supporto cache e quindi la stringa nel config serve solo se si installa il plugin wp-cache.
    Invece di usare wp-cache dovresti provare http://ocaoimh.ie/wp-super-cache/ (un evoluzione/ottimizzazione di wp-cache).
    Prova a vedere se risolvi con questo
    PS ovviamente, prima di installare wp-supercache, rimuovi (onde evitare conflitti) eventuali precedenti plugin per la cache.
    Ultima modifica di darkwolf : 18-05-2008 alle ore 02.57.26
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  10. #10
    Guest

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Allora: il plugin non l'ho provato ma ho fatto qualche sana ricerca per wp252 e la cache.
    Qui: http://www.wordpress-it.it/forum/topic/7240 dicono chiaramente che wordpress di suo non ha un supporto cache e quindi la stringa nel config serve solo se si installa il plugin wp-cache.
    Invece di usare wp-cache dovresti provare http://ocaoimh.ie/wp-super-cache/ (un evoluzione/ottimizzazione di wp-cache).
    Prova a vedere se risolvi con questo
    PS ovviamente, prima di installare wp-supercache, rimuovi (onde evitare conflitti) eventuali precedenti plugin per la cache.
    Al volo (avevo scritto un messaggio più articolato ma la mia sessione è andata in time out e mi sono persa tutto quanto GRRR)

    Comunque, non avevo attivato nessun altro plugin in seguito alla reinstallazione ex-novo. Ho installato il WP-SuperCache, ma non funge proprio per nulla. Continua a non cachare un bel niente.

    L'autore nel suo readme.txt dice che:
    You should have mod mime, mod rewrite and fancy permalinks enabled. PHP safe mode should be disabled. If any of those are missing or off you can still use the slower WP-Cache part of the plugin.
    ok, allora a questo punto chiedo ai gestori se:
    1. mod_mime c'è e si può modificare via .htaccess o no
    2. il php4 e/o php5 hanno il safe mode attivato o no.
    se il safe mode è attivo probabilmente dovro' andare a chmoddare/chownare i files pertinenti al WP supercache...

    Grazie per l'aiuto :)

  11. #11
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Il safemode mi risulta abilitato, per il mod_mime aspetta info dai più esperti
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  12. #12
    Guest

    Predefinito

    dal phpinfo, a leggere meglio, pare che in apache il mod mime sia tra i moduli caricati. ergo, IN TEORIA, anche con il php safe mode on, comunque, i requisiti perche' il WP super cache funga ci sono. Invece non funge, neanche a chmoddare a 777 la cartella della cache.

    E anche nel forum inglese in wordpress.org sono perplessi dal fatto che la cache non funga. (il link è: http://wordpress.org/support/topic/176780?replies=19)

    Domani provo ad aggiungere in wp-config.php il define relativo al debugging, anche se non sarà mai la stessa cosa di un log vero e proprio :)

    Buonanotte.

  13. #13
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    cyberdeaf:

    aspettiamo tue notizie per approfondire in merito
    Gianluca

  14. #14
    Guest

    Predefinito

    Citazione Originalmente inviato da Gianluca Visualizza messaggio
    cyberdeaf:
    aspettiamo tue notizie per approfondire in merito
    Eh, scusami se sono sparita un po', ma ho avuto da fare RL :p

    Comunque, in tutta sincerità non ci sto capendo piu' nulla di nulla :(
    i vari htaccess sono a posto, i settaggi pure, i define anche,
    ho provato anche il chmod via ftp (a 775 prima e a 777 poi) sulla dir della cache.

    Ma nisba, ciccia, non si vede nessun segno di caching.

    Adesso ho attivato il
    Codice PHP:
    define('WP_DEBUG',true); 
    nel wp-config, mo' piglio 'na lanterna e vado a guardare nel codice :/

  15. #15
    Guest

    Predefinito Così, per curiosità...

    Dopo aver provato un altro plugin per la cache e aver constato che non fungeva neanche quello, mi è venuto un sospetto...

    ...ovvero che siano state disabilitate le funzioni della famiglia ob_*(), come minimo...

    Non è che avete disabilitato determinate funzioni dal php.ini globale relativo al php4? (io al lavoro l'ho fatto sul server che gestisco )

    Se sì, si potrebbe sapere QUALI, in modo che uno almeno sappia dove cercarle nel codice php incriminato e scrivere al loro posto degli workaround?

    O magari fatene uno sticky, se non c'è già, nel forum appropriato

    (suppongo che siano state disabilitate anche nel php.ini del php5, vero?)

    Tutto questo cercare di far funzionare il caching di wordpress alla "cieca" sta diventando MOLTO frustrante.

    tcd.

  16. #16
    L'avatar di giuseppeiemma
    giuseppeiemma non è connesso AlterGuru
    Data registrazione
    28-02-2007
    Residenza
    Milano
    Messaggi
    1,314

    Predefinito

    Ho provato a utilizzare (copiando e incollando il codice da http://it2.php.net/manual/it/function.ob-start.php e http://it2.php.net/manual/it/functio...t-contents.php) ob_start() e ob_get_contents() non sembra siano state disabilitate (almeno queste due funzioni)...

  17. #17
    Guest

    Predefinito

    Citazione Originalmente inviato da giuseppeiemma Visualizza messaggio
    Ho provato a utilizzare (copiando e incollando il codice da http://it2.php.net/manual/it/function.ob-start.php e http://it2.php.net/manual/it/functio...t-contents.php) ob_start() e ob_get_contents() non sembra siano state disabilitate (almeno queste due funzioni)...
    Guarda, io non vorrei essere costretta a dover conoscere prima di tutto da cima a fondo il funzionamento dell'intero wordpress per poter capire cos'è che impedisce al plugin di WP Super Cache di fare il suo lavoro.

    Ho fatto una provina con un altro plugin (hyper cache) che ha una struttura apparentemente più semplice, trasformando un "ob_start('funzionechiamata()');" in "funzionechiamata();" e aveva iniziato a popolare la cache come doveva fare, il problema è che poi mi sono arenata perché non capivo come fare a "richiamare" il CONTENUTO della pagina da cachare per infilarlo dentro la cache, perché evidentemente si appoggiava a variabili globali definite altrove all'interno di wordpress.

    Ora tu mi dici che hai fatto una provina e secondo te le funzioni che hai chiamato sono attive.

    Io ho fatto un'altra provina per capire se alcune delle funzioni interne a wordpress fallivano per via di un path assoluto (solitamente richiamato e definito all'interno di wp-config) andato a donnine allegre o no, ma non sembra sia quella la causa.

    Di conseguenza il "difetto" deve risiedere da qualche altra parte. probabilmente all'interno di qualche funzione/classe che definisce i vari hooks forniti da WP per chi volesse creare sistemi di caching.

    Ergo, sarebbe carino sapere se quelli di altervista hanno effettivamente disabilitato l'accesso a determinate funzioni e, se sì, quali...

    (OT: da un phpinfo su php5 vedo che da li' hanno proprio tolto il modulo di mysqli -- !!!!!!!!! non è che io sia tanto d'accordo, ma tant'è, i server li gestiscono loro ).

    P.S.: in estremissima sintesi, per quel che ho capito io, WordPress NON FA NESSUN CACHING DI SUO, SE NON QUELLO DELLE QUERY PIU' RIPETITIVE, AFFIDANDOSI ALL'APC INTERNO A PHP. PER IL RESTO FORNISCE COMUNQUE DEI HOOKS A CHI VOLESSE SCRIVERE PLUGINS /PEZZI DI CODICE X IL CACHING FISICO. Sempre per quello che ho capito io eh.

    basta, per oggi mi sono anche snervata pure troppo con queste cose :(

  18. #18
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    cyberdeaf:

    Il php4 sulla tua macchina è stato aggiornato, questo aggiornamento dovrebbe correggere i problemi riscontrati con ob_start() e ob_get_contents(), qualora fosse così il tutto sarà esteso all'intera community.

    Rimaniamo in attesa di un feedback in merito.
    Gianluca

  19. #19
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Essendo sullo stesso server mi sono permesso di fare una prova (dopo aver avuto conferma di aggiornamento dall'info.php).
    Ed ecco il risultato a pochi minuti dall'attivazione di wp-supercache:



    -
    Peccato che così le citazioni random diventino praticamente statiche...
    -
    NB: il plugin mi da solo quest'avviso:



    E non mi è molto chiaro
    -
    PS: lascio il plugin per eventuali test (Gianluca), presto lo rimuoverò in quanto oltre a non essere strettamente necessario per me (database 6°liv) mi limita su alcuni aspetti del blog (citazioni random, banner???, ecc..).
    Ultima modifica di darkwolf : 28-05-2008 alle ore 04.13.41
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •