Visualizzazione risultati 1 fino 18 di 18

Discussione: problema con nextgen gallery (plug-in wordpress)

  1. #1
    Guest

    Predefinito problema con nextgen gallery (plug-in wordpress)

    Non riesco assolutamente a far funzionare questo plug-in ( nextgen gallery ) che in un altro host funziona tranquillamente senza settare nulla...
    Mi è venuto in mente quindi, non è che non funziona grazie a qualche altro blocco di AV?
    Dal pannello del plug-in sembra che dovrebbe andare perchè tutto ciò che è impostato da voi dovrebbe essere a posto poichè il plug-in richiede:
    # PHP 4.3.7 or higher e c'è
    # GD 2 Library e c'è
    # Freetype Support (for Watermark) è opzionale
    # Safe-Mode Off (for more function) è off
    # Memory limit should 16MB or more è a 64 quindi maggiore

    Che mi dite? vi prego non so più dove sbatter la testa...

  2. #2
    Ospite Guest

    Predefinito

    Safe-Mode Off (for more function) è off
    Safe-Mode su AlterVista è ON.
    Essendo "for more function" credo si tratti comunque di un requisito opzionale richiesto soltanto da alcune funzioni disabilitabili (non conosco lo script, è così?).
    In ogni caso "Non riesco assolutamente a far funzionare..." mi sembra troppo generico, cosa non riesci a fare nello specifico?

  3. #3
    Guest

    Predefinito

    si scusa...
    in poche parole ogni volta che creo una categoria non riesce a crearmi le cartelle nonostante io abbia settato i permessi a 777 (come richiesto) alla cartella madre della galleria.
    Comunque ho letto che è off dal pannello di controllo del plug-in che mi riporta questo:
    Impostazioni Server

    * Sistema Operativo : Linux
    * Server : Apache
    * Memoria in uso : 8.79 MByte
    * Versione MYSQL : 4.1.22-standard-log
    * Modo SQL : Non impostato
    * Versione PHP : 4.4.8-dev
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : Off
    * PHP Memory Limit : 64M
    * PHP Max Upload Size : 3M
    * PHP Max Post Size : 4M
    * PHP Max Script Execute Time : 15s

  4. #4
    Ospite Guest

    Predefinito

    Citazione Originalmente inviato da japgalaxy Visualizza messaggio
    si scusa...
    in poche parole ogni volta che creo una categoria non riesce a crearmi le cartelle nonostante io abbia settato i permessi a 777 (come richiesto) alla cartella madre della galleria.
    jap ho il tuo stesso identico problema sui permessi per creare la cartella della galleria .... anche a me mi nega questa possibilità.

    questo è il warning che vedo quando creo una galleria :

    " Impossibile settare i permessi della cartella wp-content/gallery/test! "

  5. #5
    Guest

    Predefinito

    esattamente lo stesso mio problema che si verifica solo qui su AV...

    EDIT:
    nessuno sa aiutarmi? sarà qualche problema dell'host perchè ripeto da un'altra parte funziona correttamente... Mi aiutate a capire se è risolvibile?
    Ultima modifica di seneca : 05-12-2007 alle ore 19.11.42

  6. #6
    L'avatar di seneca
    seneca non è connesso Super Moderatore
    Data registrazione
    18-12-2004
    Residenza
    la Città Eterna
    Messaggi
    8,376

    Predefinito

    Non mi viene in mente nulla. Se però provassi a creare prima da pannello la cartella, poi ti da errore?


    -- Aut Roma Aut Nihil!

  7. #7
    Guest

    Predefinito

    scusa per il doppio post, ma non mi ero accorto che l'ultima risposta fosse la mia...
    comunque di quale cartella parli? la cartella di una singola nuova galleria?

    EDIT:
    cmq se la creo prima ovviamente mi dice questo: "Cartella /wp-content/screenshot/nuova già esiste!"
    Ultima modifica di japgalaxy : 05-12-2007 alle ore 19.46.15

  8. #8
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    japgalaxy:

    Quell'errore è quindi bloccante?
    Dove si trova esattamente all'interno del tuo spazio la cartella base in cui vanno ad annidarsi quelle appena create?
    Gianluca

  9. #9
    Guest

    Predefinito

    si quell'errore non permette di far nulla in quanto non riuscendo a crearsi le cartelle il plug-in non si crea la galleria corrispondente nel proprio database, quindi crearla a mano non serve...
    Come impostato dal programma la cartella madre delle gallerie è:
    "wp-content/gallery/" a cui ho assegnato i permessi 777 come richiesto dal programma...

    P.s.: attualmente mi sono accomodato con un altro plug-in quindi per me non è un'urgenza però non sono l'unico ad aver avuto questo problema, quindi magari per loro è più urgente... ;-)

  10. #10
    Guest

    Predefinito

    ciao a tutti, anche voi usate wordpress?
    Sto provando anche io ad installare il plugin nextgen, e come gli altri ho questo problema delle gellerie.

    Secondo voi non è possibile crearle manualmente? Altrimenti dovrò cercare un altro software per le foto.
    Grazie


    EDIT:
    Ho trovato sul ''sito del produttore'' questo post, ma a me non ha dato esito positivo.

    Look in nggallery, remove this :
    // get value for safe mode
    if ((gettype(ini_get('safe_mode')) == 'string')) {
    // if sever did in in a other way
    if (ini_get('safe_mode') == 'off') define('SAFE_MODE', FALSE);
    else define('SAFE_MODE', ini_get('safe_mode'));
    } else
    define('SAFE_MODE', ini_get('safe_mode'));

    and insert this
    define('SAFE_MODE', FALSE);
    Suggerimenti?
    Ultima modifica di seneca : 18-12-2007 alle ore 22.01.26

  11. #11
    L'avatar di seneca
    seneca non è connesso Super Moderatore
    Data registrazione
    18-12-2004
    Residenza
    la Città Eterna
    Messaggi
    8,376

    Predefinito

    E che errore ti viene restituito in questo caso?


    -- Aut Roma Aut Nihil!

  12. #12
    Guest

    Predefinito

    Citazione Originalmente inviato da seneca Visualizza messaggio
    E che errore ti viene restituito in questo caso?
    Ancora lo stesso che avevo in precedenza. Sarebbe interessante sapere altri utenti di altervista, con Wordpress+NextGen, se risolvono oppure no.

    L'errore comunque è:
    Unable to set directory permissions wp-content/gallery/prova_gallery


    Edit: Aggiungo un'informazione riportata nel pannello di amministrazione
    NextGEN gallery is stored in the tables wp_ngg_pictures, wp_ngg_album, wp_ngg_tags, wp_ngg_pic2tags and wp_ngg_album
    Ultima modifica di fotosensibile : 19-12-2007 alle ore 01.58.03

  13. #13
    claudegps non è connesso Neofita
    Data registrazione
    11-12-2006
    Messaggi
    2

    Predefinito

    Citazione Originalmente inviato da fotosensibile Visualizza messaggio
    Sarebbe interessante sapere altri utenti di altervista, con Wordpress+NextGen, se risolvono oppure no.
    Io ho risolto!

    1 - Commenti tutti i comandi chmod (nei files addgallery.php e pclzip.lib.php)

    2 - Nel file nggallery.php metti cosi':

    // Permission settings ############################################
    define('NGGFOLDER_PERMISSION', 0775);
    define('NGGFILE_PERMISSION', 0666);

    (in pratica cambi solo da 0777 a 0775)

    Cosi' a me funziona. Ciao

    Aggiungo: se volete vedere il risultato www.claudegps.altervista.org (andate su screenshots)
    Ultima modifica di claudegps : 03-01-2008 alle ore 15.48.16

  14. #14
    Guest

    Talking

    Citazione Originalmente inviato da claudegps Visualizza messaggio
    Io ho risolto!

    1 - Commenti tutti i comandi chmod (nei files addgallery.php e pclzip.lib.php)

    2 - Nel file nggallery.php metti cosi':

    // Permission settings ############################################
    define('NGGFOLDER_PERMISSION', 0775);
    define('NGGFILE_PERMISSION', 0666);

    (in pratica cambi solo da 0777 a 0775)

    Cosi' a me funziona. Ciao

    Aggiungo: se volete vedere il risultato www.claudegps.altervista.org (andate su screenshots)
    grazie, ora funziona anche a me

  15. #15
    Guest

    Predefinito

    Scusate, ma cosa intendete di preciso con "commentare tutti i comandi chmod"?
    Io ho provato a mettere // davanti a tutti i @chmod (anche negli if) ma mi da errori.
    Cmq mi è scomparso anche il bottone per inserire le immagini nell'editor di testo.
    Qualcuno sa aiutarmi?
    Grazie

  16. #16
    L'avatar di funcool
    funcool non è connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non lì, qui!
    Messaggi
    15,433

    Predefinito

    Per commentare devi aggiungere le due slash all'inizio della riga.
    Codice PHP:
    // chmod(...); 
    Hai fatto anche l'altra modifica? Che errori ti vengono restituiti?
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    «Tu mi dai fastidio perché ti credi tanto un Dio!» «Bè, dovrò pur prendere un modello a cui ispirarmi, no?» Woody Allen

  17. #17
    Guest

    Predefinito

    Ok, adesso funziona anche a me.
    Colgo l'occasione per prvi un'altra domanda.
    Quali sono i tags utilizzati da questo plugin?
    Da quanto ho capito:

    [gallery=ID] inserisce la galleria ID in un articolo

    Ci sono altri tags?

    P.s. Mi sarebbe utili saperli visto che scrivo i miei articoli da blog desk

  18. #18
    gerasimone non è connesso Utente giovane
    Data registrazione
    09-03-2004
    Messaggi
    91

    Predefinito

    [album=ID]
    li trovi nella guida del plugin.
    ciao
    gerablog! ---- usa Geraagle al posto di eMule o Torrent! ---- JSTooltip plugin 4 wordpress

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •