Visualizzazione risultati 1 fino 13 di 13

Discussione: problema con Worpdress 2,2 Ita

  1. #1
    Guest

    Predefinito problema con Worpdress 2,2 Ita

    mi manca solo la bestemmia in cirillico...e poi le ho provate tutte :(

    Avevo WP 2.1 in inglese. Funzionava tutto alla grande....finchè ieri ho deciso di passare all'ultima versione localizzata in italiano....

    ho seguito la procedura che ho trovato qui sul WiKi....

    e puf! ecco cosa mi appare:

    Fatal error: main() [function.require]: Failed opening required 'ABSPATH/wp-admin/upgrade-functions.php' (include_path='.:') in /membri/kakyuu/blog/wp-admin/upgrade.php on line 7

    che è successo? cosa devo fare?

    aiuto...

    ho un 56K...e ho lavorato tutt'oggi per poi vedere tutto in fumo... :'(

  2. #2
    Guest

    Predefinito

    Secondo me hai inserito qualche percorso errato...
    Entra nel tuo pannello di AV e prova a controllare dove sta la cartella wp-admin.

    Ciao

  3. #3
    Guest

    Talking

    Citazione Originalmente inviato da Kakyuu
    mi manca solo la bestemmia in cirillico...e poi le ho provate tutte :(

    Avevo WP 2.1 in inglese. Funzionava tutto alla grande....finchè ieri ho deciso di passare all'ultima versione localizzata in italiano....

    ho seguito la procedura che ho trovato qui sul WiKi....

    e puf! ecco cosa mi appare:

    Fatal error: main() [function.require]: Failed opening required 'ABSPATH/wp-admin/upgrade-functions.php' (include_path='.:') in /membri/kakyuu/blog/wp-admin/upgrade.php on line 7

    che è successo? cosa devo fare?

    aiuto...

    ho un 56K...e ho lavorato tutt'oggi per poi vedere tutto in fumo... :'(
    Sicuro di aver seguito la guida? questo errore ti appare quando fai l'aggiornamento, oppure ad aggiornamento concluso?
    La riga 7 del file upgrade.php riporta:
    Codice PHP:
    require('../wp-config.php');
    timer_start(); 
    Sicuro di aver rinominato il file wp-config-sample.php in wp-config.php?

  4. #4
    Guest

    Predefinito

    Citazione Originalmente inviato da giuseppeiemma
    Secondo me hai inserito qualche percorso errato...
    Entra nel tuo pannello di AV e prova a controllare dove sta la cartella wp-admin.

    Ciao
    la posizione è giusta...ho utilizzato un programma di FTP per spostare i files...

    Citazione Originalmente inviato da roratonet
    Sicuro di aver seguito la guida? questo errore ti appare quando fai l'aggiornamento, oppure ad aggiornamento concluso?
    La riga 7 del file upgrade.php riporta:
    Codice PHP:
    require('../wp-config.php');
    timer_start(); 
    Sicuro di aver rinominato il file wp-config-sample.php in wp-config.php?
    il problema parte quando digito sulla barra l'indirizzo http://kakyuu.altervista.org/blog/wp-admin/install.php

    lo stesso errore appare quando digito http://kakyuu.altervista.org/blog/wp-admin/upgrade.php

    il file l'ho configurato e rinominato...ma non so più che fare
    Ultima modifica di Kakyuu : 20-07-2007 alle ore 18.43.15 Motivo: aggiunto un quote

  5. #5
    Guest

    Exclamation

    1) controlla che sia presente il file /blog/wp-admin/admin-functions.php e nel caso, sostituiscilo con una nuova copia che trovi nel pacchetto del 2.2!
    2) hai controllato di aver utilizzato il file CONFIG nuovo, invece di quello vecchio?
    3) controlla il chmod della cartella WP-ADMIN...settala a 772!

    Se è tutto ok, prova a modificare questa riga del file upgrade-functions.php
    Codice PHP:
    require_once(ABSPATH '/wp-admin/admin-functions.php'); 
    in
    Codice PHP:
    require_once(ABSPATH 'wp-admin/admin-functions.php'); 
    Fammi sapere se ti dà un errore diverso!
    Ultima modifica di roratonet : 20-07-2007 alle ore 18.52.04

  6. #6
    Guest

    Predefinito

    niente da fare

    Warning: main() [function.main]: Unable to access /membri/kakyuu/blog/../wp-admin/admin-functions.php in /membri/kakyuu/blog/wp-admin/upgrade-functions.php on line 5

    Warning: main(/membri/kakyuu/blog/../wp-admin/admin-functions.php) [function.main]: failed to open stream: No such file or directory in /membri/kakyuu/blog/wp-admin/upgrade-functions.php on line 5

    Fatal error: main() [function.require]: Failed opening required '/membri/kakyuu/blog/../wp-admin/admin-functions.php' (include_path='.:') in /membri/kakyuu/blog/wp-admin/upgrade-functions.php on line 5

  7. #7
    Guest

    Predefinito

    Citazione Originalmente inviato da Kakyuu
    Warning: main() [function.main]: Unable to access /membri/kakyuu/blog/../wp-admin/admin-functions.php in /membri/kakyuu/blog/wp-admin/upgrade-functions.php on line 5

    Warning: main(/membri/kakyuu/blog/../wp-admin/admin-functions.php) [function.main]: failed to open stream: No such file or directory in /membri/kakyuu/blog/wp-admin/upgrade-functions.php on line 5

    Fatal error: main() [function.require]: Failed opening required '/membri/kakyuu/blog/../wp-admin/admin-functions.php' (include_path='.:') in /membri/kakyuu/blog/wp-admin/upgrade-functions.php on line 5
    Questi ../ non devono esserci, controlla di aver settato correttamente ABSPATH.

  8. #8
    Guest

    Predefinito

    Citazione Originalmente inviato da tuttoeniente2
    Questi ../ non devono esserci, controlla di aver settato correttamente ABSPATH.
    abspath?

    Scusa l'ignoranza ma...dove lo trovo?

    [edit]

    ok...trovato....ma...è settato in modo corretto?

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>
    Ultima modifica di Kakyuu : 20-07-2007 alle ore 19.17.43 Motivo: edit

  9. #9
    Guest

    Talking

    controlla
    Codice PHP:
    define('ABSPATH'dirname(__FILE__).'/'); 
    in wp-config.php

  10. #10
    Guest

    Predefinito

    Citazione Originalmente inviato da roratonet
    controlla
    Codice PHP:
    define('ABSPATH'dirname(__FILE__).'/'); 
    in wp-config.php
    l'ho trovato...ma guardando qua e la su internet ho visto che è settato in modo giusto...

    ma allora perchè a me non funziona?

  11. #11
    Guest

    Red face

    Ti conveniva fare l'upgrade della versione inglese, e poi installare e configurare la lingua italiana...dato che i dati sono tutti salvati nel database, prova a reinstallare wordpress 2.2 in inglese sovrascrivendo tutti i file utili e vedi se funziona! Appena hai la base funzionante installi la lingua italiana! E' un pò come formattare, risolvi tutti i problemi

  12. #12
    Guest

    Predefinito

    Ti consiglierei di fare, in ogni caso, un backup del database
    Ciao

  13. #13
    Guest

    Predefinito

    grazie a tutti voi per l'aiuto

    Roratonet, ho fatto come mi hai suggerito: dopo aver effettuato il backup del database, ho installato WP in inglese e successivamente ho installato il pacchetto della lingua italiana.

    ora funziona, devo ripristinare il tema "Redoable" ed è tutto ok

    ancora mille grazie a tutti

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •