Visualizzazione risultati 1 fino 2 di 2

Discussione: Problema con Social Login (OneAll)

  1. #1
    animeandco non Ŕ connesso Neofita
    Data registrazione
    14-04-2019
    Messaggi
    2

    Exclamation Problema con Social Login (OneAll)

    Salve a tutti,
    di recente ho deciso di permette l'iscrizione al blog tramite una serie di Social.

    Ho dunque pensato di cercare su internet qualche plugin che mi permettesse di farlo e ho trovato il plugin Social Login della OneAll.

    Ho dunque proceduto all'installazione e alla relativa configurazione. Ho, dunque, creato l'utente sul sito dell'azienda e ho ottenuto le chiavi dell'API.

    Quando vado per˛ nelle configurazione del plugin, dopo aver impostato le credenziali, clicco sul pulsante Verify API Settings ottengo il seguente messaggio di errore.

    Codice HTML:
    Could not contact API. Are outbound requests on port 443 allowed?
    Ho fatto delle ricerche e ho trovato due threads, sempre qui sul forum di Altervista:

    • Il primo messaggio che ho trovato consigliava solo di disabilitare la whitelist delle connessioni Server To Server
    • Il secondo, in inglese, era la risposta di un'amministratore che diceva di aver aggiunto alla whitelist il dominio della OneAll


    Dato che stavo provando a connetermi ai Server con la Whitelist (per scaramanzia) ho disabilitato l'opzione, ho aspettato un'oretta circa, ho fatto la connessione ma comunque dava errore. (Poi ho riattivato la connessione ai Server to Server solo Whitelist e ho aspettato)

    Ho anche provato a giocare con le opzioni della API (anche se fin da subito avevo il sentore che sarebbe stato infruttuoso).

    C'Ŕ qualcuno che Ŕ riuscito a connettersi con l'API? se si potreste spiegarmi come avete fatto?

    Grazie anticipatamente
    Ultima modifica di animeandco : 12-06-2019 alle ore 09.36.50

  2. #2
    L'avatar di alemoppo
    alemoppo non Ŕ connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,612

    Predefinito

    Sbloccando le connessioni server to server (whitelist), Ŕ possibile effettuare richieste esterne tramite la porta 443, quindi dovrebbe funzionare.

    Ti consiglierei di chiedere allo sviluppatore del plugin se conosce il problema.

    Ciao!

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •