Visualizzazione risultati 1 fino 23 di 23

Discussione: Redirect, non riesco più a entrare nel pannello di controllo

  1. #1
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito Redirect, non riesco più a entrare nel pannello di controllo

    Sto migrando il mio blog da blogger a altervista e devo aver sbagliato qualcosa nel redirect, ogni volta che tento di accedere a wp-admin mi va su una pagina del blog.
    https://meravigliosonatale.altervist...atale/wp-admin.

    Cosa posso fare?

  2. #2
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Se provi ad effettuare il login dalla pagina principale AlterVista (in alto a destra) riesci ad accedere correttamente?

    Se no, prova con la modalità di ripristino.

    Ciao!

  3. #3
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    la modalità di ripristino ha risolto il problema! grazie! :)
    già che ci sono, posso chiederti come potrei fare a migrare correttamente le pagine statiche di blogger? non ho avuto problemi con i post normali, ma non riesco a trovare un modo per le pagine statiche... ho provato a fare redirect diretto della singola pagina, ma evidentemente non ha funzionato... ^^" avresti qualche suggerimento?

  4. #4
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Esiste un tutorial, stai seguendo quello?

    Ciao!

  5. #5
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    esattamente quello! ma non funziona per le pagine statiche...
    Le pagine statiche di blogger hanno una fastidiosa /p/ tra il dominio e il nome dell'articolo 'http://meravigliosonatale.blogspot.com/p/aforismi-e-citazioni-sul-natale.html' che non so bene come bypassare. -_-

  6. #6
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Prova così:

    Sopra la riga:
    Codice:
    RewriteCond %{QUERY_STRING} blogger=http://NOMEBLOGBLOGSPOT.blogspot.it/(.*)$
    RewriteRule .* /NOMEBLOGGIALLOZAFFERANO/%1? [R=301,L]
    Aggiungi:
    Codice:
    RewriteCond %{QUERY_STRING} blogger=http://NOMEBLOGBLOGSPOT.blogspot.it/p/(.*)$
    RewriteRule .* /NOMEBLOGGIALLOZAFFERANO/%1? [R=301,L]
    (fammi sapere se funziona o se non funziona)

    Vedo però che non hai un blog GialloZafferano, quindi hai modificato opportunamente i codici? (sostituendo a blog.giallozafferano.it/nomeutente a nomeutente.altervista.org?
    inoltre ipotizzo che in questo codice che ti ho lasciato, non dovrebbe esserci la parte /nomegiallozafferano/ ).

    Ciao!
    Ultima modifica di alemoppo : 08-07-2018 alle ore 16.05.36

  7. #7
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    si, ho fatto le opportune modifiche.
    Il problema comunque adesso persiste... La cosa mi lascia piuttosto perplessa, però.
    Ho ripristinato il sistema a prima del problema una prima volta. Ok, ha funzionato: sono riuscita a rientrare nel pannello di controllo senza problemi, ho fatto di nuovo gli aggiornamenti che mi mancavano e non mi ha dato problemi finchè non sono andata di nuovo su Seo> impostazioni.

    Il problema li si è ripresentato; l'url torna ad essere 'https://meravigliosonatale.altervista.org/aforismi-e-citazioni-sul-natale/wp-admin/admin.php?page=wpseo_dashboard'.
    Allora ho provato a fare un ripristino ad una data più vecchia, mi sono detta: ok, forse avrò fatto qualche casino anche prima. Allora ho ripristinato all'ultimo login, che è stato una 20ina di giorni fa.
    Riprovo ad andare alle impostazioni di SEO e stesso problema.
    Allora ho disinstallato, eliminato e reinstallato SEO da zero. Niente. Stesso problema. Cosa può essere successo? Non succede con tutte le dierctory; succede solo quando provo ad andare nelle impostazioni e nelle notifiche...

    ho fatto adesso un piccolo check, e anche il menù e le statistiche non vanno... non riesco però a trovare una soluzione, nè una possibile causa al problema... o.O

    Come risolvo?
    Ultima modifica di meravigliosonatale : 08-07-2018 alle ore 16.49.38

  8. #8
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Ma quindi il problema si verifica quando modifichi il file .htaccess?

    Ciao!

  9. #9
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    si! non mi fa proprio entrare nella maschera di modifica! e non capisco come mai, avendo ripristinato tutto a prima di metterci sopra le mani...

  10. #10
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Quindi il problema è in Seo->Strumenti->Modifica file ?

    Oppure appena premi su "seo"?

    e anche il menù e le statistiche non vanno
    Intendi Aspetto->Menu e Bacheca->Statistiche? Quando clicchi in quelle pagine l'url viene modificato in https://meravigliosonatale.altervist...seo_dashboard?

    Non riesci quindi ad accedere alla modifica del file .htaccess? Se riesci, prova ad eliminare le righe che hai aggiunto e provare se il problema persiste.

    Ciao!

  11. #11
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    il problema si presenta:

    -quando clicco su sul simbolo di Seo dalla headbar e dalla sidebar del pannello di controllo:

    http://i68.tinypic.com/333xxuc.png

    -quando vado su seo -> generale
    -quando vado su seo -> impostazioni

    -le statistiche non vanno dalla headbar delle singole pagine. Dalla sidebar del pannello di controllo funzionano.


    Non riesco a modificare niente...

    non riesco ad accedere alla sezione per poter modificare i file .htaccess
    provando inoltre a cliccare su link del vecchio blog il redirect continua a funzionare, il che vuol dire che probabilmente il ripristino non ha riportato le cose alla normalità.




    (grazie davvero di cuore, per il tempo, la pazienza e la gentilezza... )
    scusa, non mi ero resa conto di non averti ancora ringraziato... :P
    Ultima modifica di meravigliosonatale : 08-07-2018 alle ore 18.15.14

  12. #12
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Se nemmeno la modalità di ripristino risolve, faccio intervenire qualcuno nel tuo account, però purtroppo visto che oggi è domenica occorrerà aspettare almeno domani.

    Ciao!

  13. #13
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    Si, allora... credo sia meglio!
    grazie ancora di cuore! ^_^

  14. #14
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Potresti provare eliminando la cache o con un altro browser per vedere se il problema persiste?

    Ciao!

  15. #15
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    cache eliminata.
    Adesso funziona tutto perfettamente!

    Grazie di cuore!


    Ho ancora il problema delle pagine statiche, ma per quello provo con la tua soluzione... nel caso dovessi fare di nuovo casini torno qui... ^^" ancora grazie... :)

  16. #16
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Ottimo, bene.

    Fammi sapere se avrai problemi.

    Ciao!

  17. #17
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Prova così:

    Sopra la riga:
    Codice:
    RewriteCond %{QUERY_STRING} blogger=http://NOMEBLOGBLOGSPOT.blogspot.it/(.*)$
    RewriteRule .* /NOMEBLOGGIALLOZAFFERANO/%1? [R=301,L]
    Aggiungi:
    Codice:
    RewriteCond %{QUERY_STRING} blogger=http://NOMEBLOGBLOGSPOT.blogspot.it/p/(.*)$
    RewriteRule .* /NOMEBLOGGIALLOZAFFERANO/%1? [R=301,L]
    (fammi sapere se funziona o se non funziona)

    Vedo però che non hai un blog GialloZafferano, quindi hai modificato opportunamente i codici? (sostituendo a blog.giallozafferano.it/nomeutente a nomeutente.altervista.org?
    inoltre ipotizzo che in questo codice che ti ho lasciato, non dovrebbe esserci la parte /nomegiallozafferano/ ).

    Ciao!

    non funziona con le pagine statiche... -_-

    non mi elimina la /p/ e non capisco perchè... :/

    questo è il codice che ho inserito: ho sbagliato qualcosa?
    # BEGIN Blogger mobile redirect
    RewriteCond %{QUERY_STRING} blogger=https://meravigliosonatale.blogspot.com/p/(.*)$
    RewriteRule .* /https://meravigliosonatale.altervista.org/%1? [R=301,L]
    RewriteCond %{QUERY_STRING} blogger=https://meravigliosonatale.blogspot.com/(.*)$
    RewriteRule .* /https://meravigliosonatale.altervista.org/%1? [R=301,L]
    RewriteCond %{QUERY_STRING} m=1(.*)$
    RewriteRule (.*) $1?%1 [R=301,L]
    # END Blogger mobile redirect

  18. #18
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Puoi indicarmi una pagina statica che da problemi? In realtà non credo sia il codice .htaccess il problema (puoi anche eliminare le 2 righe che ti ho indicato).

    Ciao!

  19. #19
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Puoi indicarmi una pagina statica che da problemi? In realtà non credo sia il codice .htaccess il problema (puoi anche eliminare le 2 righe che ti ho indicato).

    Ciao!
    tutte le pagine statiche che ho su blogger e che voglio reindirizzare su altervista non funzionano.

    Ad esempio:

    http://meravigliosonatale.blogspot.c...ul-natale.html
    Questa è una delle pagine che vorrei reindirizzare. La pagina in cui vorrei andasse è questa:
    https://meravigliosonatale.altervist...oni-sul-natale


    un altro problema che noto adesso è che le pagine non hanno il permalink configurato come i normali post. (non si concludono con .html)

    questo anche è un problema che non so come risolvere...

  20. #20
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Per il problema del /p/, la cosa più "pulita" è effettuare un redirect come spiegato qui (ovvero impostare l'url di arrivo errata ed effettuare il redirect all'url senza il /p/ ).

    Per il permalink, come li hai impostati? Vorresti il .html alla fine?

    Ciao!

  21. #21
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    oh! ottima soluzione, grazie... :D
    Così prendo uno per uno i link che non funzionano e li reindirizzo esattamente dove e come voglio! grazie! ^_^

    I permalink sono personalizzati così: meravigliosonatale.altervista.org/%year%/%monthnum%/%postname%.html


    per gli articoli normali funzionano benissimo, le pagine no, ma con la soluzione qui sopra non è più un problema! :D grazie! :D

  22. #22
    L'avatar di alemoppo
    alemoppo è connesso ora Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,585

    Predefinito

    Posso chiederti come mai vuoi che ci sia l'estensione .html? Ti suggerirei di utilizzare "Nome articolo"; ovviamente ogniuno è libero di fare come crede meglio.

    Ciao!

  23. #23
    meravigliosonatale non è connesso Utente AlterBlog
    Data registrazione
    07-01-2018
    Messaggi
    12

    Predefinito

    sarebbe meglio, vero? ho cambiato in .html per poter fare il redirect più facilmente, ma effettivamente usando il plugin che mi hai dato posso creare un gruppo e migrarli direttamente tutti senza starci troppo a pensare, esattamente come ho fatto con le pagine...

    Domani provo! ^_^

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •