Pagina 2 di 2 PrimoPrimo 12
Visualizzazione risultati 31 fino 59 di 59

Discussione: grossi problemi col sito

  1. #31
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    si, in vari dimensioni. comunque quella immagine funziona. ho linkato due articoli dove invece le immagini non si vedono. ho cercato nei file le illustrazioni legate a questa pagina https://cronachedelgattosulfuoco.alt...n-dimenticato/ ma non si trova in wp uploads 2016-12. non capisco però cosa possa essere successo

    EDIT:

    qui invece https://cronachedelgattosulfuoco.alt...-vs-symbaraum/ le illustrazioni nella cartella ci sono ma mi da che non può caricare le immagini e se ci clicco mi da We cannot complete this request, remote data could not be fetched
    Ultima modifica di alemoppo : 23-12-2017 alle ore 02.21.56 Motivo: Non fare post consecutivi: modifica i messaggi.

  2. #32
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    11,917

    Predefinito

    Utilizzavi qualche plugin per mostrare le immagini?
    Quelle immagini puntano a al dominio i1.wp.com.
    Se le hai tra i tuoi backup, penso faresti prima a modificare gli articoli e ricaricare le immagini. Altrimenti prova reinstallando il plugin che utilizzavi come slider di immagini.

    Ciao!
    Ultima modifica di alemoppo : 23-12-2017 alle ore 03.47.24

  3. #33
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Quel dominio (che fa parte di jetpack) indica che dovrebbero essere hostate per sempre nel loro spazio web.. Info
    @cronachedelgattosulfuoco al fine di mogliorare il supporto, rispondi alle domande di alemoppo
    Ti consiglio di abilitare il file xmlrpc.php da impostazioni generali (WordPress AV), disattiva l'hotlink per 2 minuti, il tempo che riverifichi le due url.
    Se dopo tutto questo trambusto non riesci a vedere i file locali che possiedi nel tuo server tramite il CDN images (i0.wp.com i1.wp.com i2.wp.com) apri un ticket verso jetpack e gli spieghi che hai fatto una nuova installazione sullo stesso dominio url..
    Ultima modifica di darbula : 23-12-2017 alle ore 08.52.29

  4. #34
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    utilizzavo photon di jetpack.

    ho abilitato il file xmlrpc.php ma non so come disattivare temporeanemente l'hotlink

    ho intato contattato jetpack che mi ha rispsoto così

    Anne (Automattic)

    Dec 23, 16:25 UTC

    Hey there,

    Thanks for reaching out! I dug into this example of photon:

    https://i2.wp.com/cronachedelgattosu...20%2C155&ssl=1

    I found that this indeed shows that error. This is happening though because the main image won't load either:

    https://cronachedelgattosulfuoco.alt...fferenti-4.jpg

    You'll need to make sure this image can load first and foremost in order for Photon to work! I'd recommend contacting your host to help with this.

  5. #35
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Ti hanno risposto che innanzitutto deve caricare la risorsa remota (via https) dal tuo sito (cioè deve anche esistere tale percorso e file localmente).
    hotlink agira via user agent, purtroppo in altervista è fisso nick.altervista.org/ip.ip.ip.ip (compatible MSEI 1.0).. puoi commentare l'user-agent che trovi nel tuo file .htaccess? '# #' così si commenta.
    Ecco il plugin hotlink https://wordpress.org/plugins/thirstyaffiliates/ che combacia con il tuo codice htaccess
    Tu affermi che in questo articolo le immagini esistono fisicamente, se provi manualmente la url è ricevi un errore 404 può essere un incompatibilità tra un plugin o tema per il plugin in uso thirstyaffiliates.. C'è anche scritto nel link che ti ho citato prima. qui per comodità
    EDIT: https://cronachedelgattosulfuoco.alt...fferenti-4.jpg qui indica che in CloudFlare c'è il blocco su hotlink ... Piu info https://support.cloudflare.com/hc/en...Protection-do-
    A questo punto ti chiedo di disabitare il caricamento dell'immagine da Photon (fai il contrario per come indica la guida che ho postato)
    Ultima modifica di darbula : 23-12-2017 alle ore 23.17.43

  6. #36
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    scusate ma dopo due settimane sono rientrato nel sito per vedere di aggiustarlo.
    1) come si commenta l'user agent del file .htaccess?
    2) ho diasstivato thirsty affiliates ma anche così non cambia niente
    3) ho disattivato e riattivato temi e plugin senza risolvere niente
    4) ho sbloccato su cloudflare il blocco dell'hotlink e ho disabilitato photon ma senza successo

    cosa posso fare?

  7. #37
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Si commenta #spazio# posta nuovamente il tuo .htaccess solo con le modifiche che hai espresso nel tuo ultimo post... Prova la modalità di sviluppo CloudFlare

  8. #38
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    # # av:Toolbar
    SetEnv AV_TOOLBAR 0

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?yourdomain.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?bing.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?yahoo.com [NC]
    RewriteRule \.(jpg|jpeg|png|gif|svg)$ http://dropbox.com/hotlink-placeholder.jpg [NC,R,L]
    # #


    ho attivato la modalità di sviluppo di cloudflare

  9. #39
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    L'esclusione è tramite refer.. in
    Codice:
    !^http(s)?://(www\.)?yourdomain.com [NC]
    Devi sostituirlo con
    Codice:
    !^http(s)?://(www\.)?cronachedelgattosulfuoco.altervista.org [NC]
    Crea un nuovo articolo e vediamo se si vede questa foto (poi pensiamo ai vecchi articoli)
    Ultima modifica di darbula : 10-01-2018 alle ore 14.55.40

  10. #40
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    ho pubblicato un nuovo articolo. l'immagine in evidenza non si vede mentre quelle nell'articolo si...

  11. #41
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Posta la url altrimenti sai solo tu di cosa parli... L'immagine in evidenza come le altre foto sul tuo blog potrebbero riportare il dominio di Photon (ma con il blocco hotlink non ti funzionava)..
    Cmq.. attualmente tramite .htaccess stai bloccando le foto..
    1)Disabilità e cancella qualsiasi cosa riguardi hotlink
    2)Abilita Photon
    3)Se le immagini si vedono, abilita hotlink di cloudflare
    4)Ricordati che per ogni modifica (aggiornamento o creazioni di nuove foto) dovrai disabilitare hotlink (poi quando uploadi le foto lo riattivi)
    Ps. Nota.. Anche se aggiorni una tua foto ma che sia già presente nello stesso percorso del dominio Photon, non vedi i cambiamenti ma solo la vecchia foto.
    Ultima modifica di darbula : 11-01-2018 alle ore 14.45.33

  12. #42
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    https://cronachedelgattosulfuoco.alt...2018/01/13131/ questo ì l'articolo pubblicato ora.

    ho abilitato photon
    gli hotlink a parte cloudflare da dvoe li posso disattivare?

  13. #43
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Abilita il file xmlrpc.php se non è abilitato (come ho scritto post fa)..
    La tua immagine non è cambiata con il dominio Photon ma è sempre altervista.
    Altervista non blocca alcun accesso alle foto , quindi sai solo tu quello che fai con i tuoi plugin..
    Rimuovi quelle regole .htaccess (e il plugin abbinato ad esso... Ovviamente stiamo parlando per gli hotlink).
    Da yoast seo sezione social ecc.. che tipo di foto è impostata per le immaggini in evidenza? (Percorso url please) oppure ti riferisci che crei un nuovo articolo inserisci un immagine in evidenza ma la vedi solo dopo aver pubblicato l'articolo?
    Ultima modifica di darbula : 11-01-2018 alle ore 15.54.05

  14. #44
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    abilitato file xmlrpc

    inserisco l'iimagine in evidenza ma no appare nella home https://cronachedelgattosulfuoco.altervista.org/blog/

    quali regole .htaccess devo eliminare?

    # # av:Toolbar
    SetEnv AV_TOOLBAR 0

    RewriteEngine on
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?cronachedelgattosulfuoco.altervista.org [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?google.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?bing.com [NC]
    RewriteCond %{HTTP_REFERER} !^http(s)?://(www\.)?yahoo.com [NC]
    RewriteRule \.(jpg|jpeg|png|gif|svg)$ http://dropbox.com/hotlink-placeholder.jpg [NC,R,L]
    # #

  15. #45
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    1) Abilita https se non attivo http://cronachedelgattosulfuoco.alte...oudflare_https
    2)devi eliminare iniziando dal RewriteEngine On e fino alla fine del RewriteRule abbinati al refer.
    Nel codice htaccess manca il riferimento dell'abilitazione del file xmlrpc.php.. Prova disattivandolo da impostazioni generali e successivamente lo riattivi..

    Il problema che descrivi si tratta delle thumbnail che dovrebbero essere supportate dal tema in uso... Prima usavi un altro tema? Perché la documentazione dice così (non modificare alcunché al tuo blog) https://codex.wordpress.org/it:Rifer...post_thumbnail (link dove c'è scritto l'immaggine in evidenza)
    Dopo riposta il file htaccess completo.. (Ovviamente oltre a disabilitare il plugin hotlink devi anche eliminarlo)
    Ultima modifica di darbula : 12-01-2018 alle ore 14.25.25

  16. #46
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    il plugin hotlink non c'è l'ho fra i miei. questi sono i plugin attivi
    https://drive.google.com/file/d/1U8F...w?usp=sh aring

    ora htaccess + così

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    SetEnv AV_WP_SKIP_XMLRPC off
    # END WordPress

    # # av:php5-engine
    AddHandler av-php5 .php

    # BEGIN AV_HTTPS
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} off
    RewriteRule .* https://cronachedelgattosulfuoco.altervista.org%{REQUEST_U RI} [L,R=301]
    # END AV_HTTPS

  17. #47
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Finalmente il tuo htaccess è corretto... Per quanto riguarda le miniature non saprei indicarti di meglio, però il tuo tema li supporta perché altrimenti non li faceva vedere... Boh sarà un impostazione del tema o forse utilizzavi un plugin per gestire gli articoli ecc..
    1)Puoi provare editando il tuo ultimo articolo?
    Attualmente dove vengono mostrati gli ultimi articoli hanno immagini (percorso differente) ma non dentro l'articolo (altro percorso)https://i0.wp.com/cronachedelgattosu...ti-6.jpg?ssl=1 ..
    2)Verifica come proposto da alemoppo grossi problemi col sito

    Esempio per l'articolo citato da alemoppo .. Questa è la foto degli ultimi articoli presente nel dominio Photon https://i2.wp.com/cronachedelgattosu...20%2C155&ssl=1 ma se tolgo i2.wp.com/ (cioè vado direttamente sul tuo sito) non la trovo.
    Ultima modifica di darbula : 12-01-2018 alle ore 20.07.26

  18. #48
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    però ora mi sta dando errore 500

  19. #49
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Può trattarsi di un errore nel file .htaccess (temporaneamente rinomina in 1htaccess)..
    Cmq via FTP hai sempre accesso ... Potresti controllare ugualmente

  20. #50
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    c' l'immagine http://cronachedelgattosulfuoco.alte...fferenti-4.jpg però mi da errore 500. come si rinomina il file htaccess?

    quando vado sull'editor di htaccess mi da all'inizio

    Scrivi le direttive Apache nell'area sottostante, affinchè non si visualizzi un errore 500 e per non incorrere nei più comuni errori di sintassi

  21. #51
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Devi usare filezilla e tramite il menu a tendina abiliti i file nascosti (cioè quelli che iniziano con il punto) dalla cartella blog..
    La url del tuo dominio comprensiva di "_" fa visualizzare la foto.
    Cmq sono due link immagine uno per gli ultimi articoli e l'altra immaggine dentro l'articolo (blabla6.jpg non blabla4.jpg come appare negli ultimi articoli). Cioè questa con il _ http://cronachedelgattosulfuoco.alte...fferenti-6.jpg
    hai messo "_" questa cartella come contenitore ma esiste anche una cartella blog? Se si devi copiare le foto "_/blog/wp-content/uploads/data/fileboh.jpg" nella cartella "/blog/wp-content/uploads/data/fileboh.jpg"
    Ultima modifica di darbula : 13-01-2018 alle ore 15.49.39

  22. #52
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    _/blpg/wp-content/uploads/data/ non esiste. Inoltre come posso copiare? da filezilla?

  23. #53
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Data non esiste con quel nome ma esisterà come "data anno giorno ecc." è pure scontato... Fai una ricerca su google ;) ... Non si preparano più pappe..
    Copia il contenuto di _/blog/wp-content/uploads/ nella cartella del tuo PC poi la uppi nella cartella priva "_" alla posizione /blog/wp-content/uploads/
    Ultima modifica di darbula : 13-01-2018 alle ore 15.52.00

  24. #54
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    sorry, hai ragione. ho comunque copiato http://cronachedelgattosulfuoco.alte...fferenti-6.jpg nella cartella "/blog/wp-content/uploads/2017/10 ma se provo ad aprire quella immagine da lì mi da error ERR_TOO_MANY_REDIRECTS

    EDIT: per copiarlo, l'ho scaricato e poi ho usato filezilla per copiarlo nell'altra cartella
    Ultima modifica di cronachedelgattosulfuoco : 13-01-2018 alle ore 15.51.44

  25. #55
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Esistono tutti e due i percorsi "_/blog" e "blog"? Cmq.. controlla che alla cartella blog/wp-content/uploads/2017/10/i-miei-elfi-sono-differenti-6.jpg (ti dice redirect perché non la trova) (controlla da gestione file).
    Ultima modifica di darbula : 13-01-2018 alle ore 15.59.38

  26. #56
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    buonissime notizie però. se le copio però le vedo sull'articolo. ho provato a copiare un altra immagine e funziona :) :) :) esistono due percorsi: "_/blog" e "blog" le immagini sono su "_/blog ma se le sposto su blog si vedono :)
    Ultima modifica di cronachedelgattosulfuoco : 13-01-2018 alle ore 15.59.15

  27. #57
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Bene ... Prova ad editare l'ultimo articolo e poi con il browser chrome e la modalità in incognito visualizz gli ultimi articoli e vediamo se appare l'immagine in evidenza..
    Tienimi aggiornato sulla foto degli elfi (se hai controllato è c'è nel percorso giusto).
    Adesso la foto all'articolo degli elfi si vede https://cronachedelgattosulfuoco.alt...no-differenti/ (sta pure sul dominio Photon) invece se si prova manualmente nel tuo dominio si riceve un redirect... (Non incide per la visualizzazione nei tuoi articoli ma solo se si prova a verificare manualmente il percorso della foto) Da filezilla tramite il menu a tendina abilita i file nascosti e controlla sé c'è un htaccess in una qualsiasi cartella (ovviamente dopo la cartella uploads) per il percorso della foto degli elfi.
    Ultima modifica di darbula : 13-01-2018 alle ore 16.43.13

  28. #58
    cronachedelgattosulfuoco non è connesso Utente giovane
    Data registrazione
    03-09-2014
    Messaggi
    32

    Predefinito

    Finalmente il sito funziona perfettamente. Volevo ringraziare Alemoppo e Darbula per l'aiuto e la pazienza :)

  29. #59
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,599

    Predefinito

    Prego figurati... Se tutte le tue foto sono su un CDN images ti consiglio di contattare loro dicendo ma se tolgo le mie foto una volta uploadate sul Photon.. Si vedranno per sempre? (Così puoi impostare qualcosa tramite htaccess per quelle foto e non consumi mai banda per le foto del tuo dominio)(ovviamente per un nuovo upload devi togliere la restrizione tramite htaccess altrimenti non viene caricato su Photon..).. Ciao
    Ultima modifica di darbula : 15-01-2018 alle ore 12.21.04

Pagina 2 di 2 PrimoPrimo 12

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •