Visualizzazione risultati 1 fino 10 di 10

Discussione: Problema caricamento dei media

  1. #1
    isibisitgbots non è connesso Neofita
    Data registrazione
    04-09-2017
    Messaggi
    17

    Predefinito Problema caricamento dei media

    E' da qualche giorno che ho un problema con il caricamento dei media sul mio sito WordPress: in pratica carico l'immagine ma quando vado ad inserirla da qualche parte è come se non esistesse e non avessi mai caricato l'immagine.

    Inoltre non riesco a modificare i file del mio tema, ricevendo questo errore:

    Ho provato a seguire le istruzioni sul Codex di WordPress ma non è cambiato nulla.

  2. #2
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,558

    Predefinito

    Problema con la sovrascrittura dei files
    Il redirect JavaScript dalla tua root al tuo blog va cambiato poiché non consideri https... Puoi intervenire anche dal file .htaccess root e file .htaccess /blog/ per forzare l'uso di https.
    Di solito i file della libreria media va a finire in wp-content/uploads/atro_percorso/ ecc tu dove tenti di inserirli?
    Ultima modifica di darbula : 26-11-2017 alle ore 22.12.55

  3. #3
    isibisitgbots non è connesso Neofita
    Data registrazione
    04-09-2017
    Messaggi
    17

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Problema con la sovrascrittura dei files
    Il redirect JavaScript dalla tua root al tuo blog va cambiato poiché non consideri https... Puoi intervenire anche dal file .htaccess root e file .htaccess /blog/ per forzare l'uso di https.
    Io ho https attivato, ma non ho attivato la riscrittura dei link in https.
    In breve cosa dovrei fare?

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Di solito i file della libreria media va a finire in wp-content/uploads/atro_percorso/ ecc tu dove tenti di inserirli?
    Sì li inserisco nella cartella predefinita da te citata.

  4. #4
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,558

    Predefinito

    Non devi attivare la riscrittura in https (quella offerta dal pannello WordPress by AV o da CloudFlare o dal pannello altervista per il tuo sito)..
    Andiamo per ordine... Sai abilitare la modalità di sviluppo situata da gestisci CloudFlare dal tuo applicativo WordPress by AV? Fallo e prova con l upload di una nuova immagine..
    Poi postami il contenuto dei file htaccess (root e blog)
    Ultima modifica di darbula : 26-11-2017 alle ore 22.47.31

  5. #5
    isibisitgbots non è connesso Neofita
    Data registrazione
    04-09-2017
    Messaggi
    17

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Non devi attivare la riscrittura in https (quella offerta dal pannello WordPress by AV o da CloudFlare o dal pannello altervista per il tuo sito)..
    Andiamo per ordine... Sai abilitare la modalità di sviluppo situata da gestisci CloudFlare dal tuo applicativo WordPress by AV? Fallo e prova con l upload di una nuova immagine..
    Poi postami il contenuto dei file htaccess (root e blog)
    Io ho installato WP originale, ho appena attivato la modalità di sviluppo.
    Nel file .htaccess del mio sito wordpress ho le impostazioni di default di wordpress.

  6. #6
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,558

    Predefinito

    Si ho visto dopo il tuo codice sorgente, poi mi spieghi come l'hai abilitato per https... Io ho fatto diversi post qui ma attualmente solo uno è perfettamente aggiornato..
    Posta se adesso riesci a uploadare e vedere le nuove foto?
    Poi postami il tuo .htaccess (ovviamente fatti una copia di backup di tale file e non toccarlo per nessun motivo).

  7. #7
    isibisitgbots non è connesso Neofita
    Data registrazione
    04-09-2017
    Messaggi
    17

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Si ho visto dopo il tuo codice sorgente, poi mi spieghi come l'hai abilitato per https... Io ho fatto diversi post qui ma attualmente solo uno è perfettamente aggiornato..
    Posta se adesso riesci a uploadare e vedere le nuove foto?
    Poi postami il tuo .htaccess (ovviamente fatti una copia di backup di tale file e non toccarlo per nessun motivo).
    Essendo un utente AlterSito ho abilitato l'HTTPS tramite il pannello (Risorse>HTTPS).

    File .htaccess
    Codice:
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    
    
    # END WordPress
    
    #Qua c'è il codice per proteggere wp-config, se ti interessa dimmelo.
    Ultima modifica di isibisitgbots : 26-11-2017 alle ore 23.32.56

  8. #8
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,558

    Predefinito

    Ti descriverlo una lista numerata di quello che devi fare..
    1)Recupera la password dal sito https://www.cloudflare.com/a/forgot-password il nick di di tutti gli esempio deve essere sostituito con il proprio username di altervista anche per le url.. Esempio e-mail nick@altervista.org website nick.altervista.org
    2)https://www.cloudflare.com/a/crypto/nick.altervista.org disattiva
    Codice:
    Automatic HTTPS Rewrites
    3)https://www.cloudflare.com/a/overvie...altervista.org sotto il tuo dominio clicca su
    Codice:
    Quick Actions
    e seleziona
    Codice:
    Development Mode
    4)https://www.cloudflare.com/a/profile da Global Api key clicca
    Codice:
    View Api Key
    copia la chiave di questa schermata ti servirà in seguito.
    5)https://www.cloudflare.com/a/page-ru...altervista.org creiamo una regola di bypass per l'area amministrativa di wordpress per come descritto qui https://jetpack.com/support/getting-...ck-cloudflare/ ma fermati al punto 3 dove ti dice di installare il plugin Cloudflare..
    6)Prima creati una copia di backup di wp-config.php e inserisci dopo i defime o il define WP_DEBUG
    Codice PHP:
    /* SSL */
    if(isset($_SERVER['HTTP_X_FORWARDED_PROTO'])) {
    define('FORCE_SSL_ADMIN'true);
    if(
    $_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https') {
    $_SERVER['HTTPS'] = 'on';
    $_SERVER['SERVER_PORT'] = 443;
    }

    si dovrebbe anche modificare le variabili $_SERVER e $_ENV DOCUMENT_ROOT
    7)installa il plugin CloudFlare attivato e inserisci la key del punto 4 clicca a tuo piacimento puoi impostare la cache automatica (questo plugin trasforma la variabile $_SERVER['REMOTE_ADDR'] nell'ip del visitatore/i e ovviamente fa altre modifiche..
    8)Da Settimgs->General nella dashboard cambia il prefisso http in https ... gli url qui non devono mai fingere con lo slash finale.
    9)https://www.cloudflare.com/a/crypto/nick.altervista.org scegli un impostazione per la tua sicurezza, leggi con attenzione... Puoi anche semplicemente usare Always Use HTTPS.
    Questo dovrebbe escludere anche problemi futuri..
    10)Se vuoi che tutti i visitatori siano re diretti al tuo blog mentre visualizzano la root io ti consiglio un file .htaccess posizionato alla root del sito
    Codice:
    # REDIRECT blog
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP:X-Forwarded-Proto} ^https$
    RewriteRule .* https://nick.altervista.org/wp/ [L,R=301]
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule .* http://nick.altervista.org/wp/ [L,R=301]
    </IfModule>
    # END REDIRECT
    mentre con il file html puoi impedire solo l'accesso dalla root o al file principale che nel tuo caso è "index.php".
    Spero che sia tutto chiaro ma se hai dubbi non esitare nel scrivere... Dato che sei un programmatore di bot telegram suppongo che hai la mente allenata e conosci l'inglese... Che dire buona avventura :)
    Ti ho fatto togliere la riscrittura verso https perché non funziona per wordpress, dovresti anche cambiare i link esterni (non appartenenti al tuo sito) in https... Ma provato dopo che hai fatto la mia modifica..
    Ovviamente la modalità di sviluppo dovrà restare attiva fino al termine del passaggio 10.

  9. #9
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,558

    Predefinito

    Se ancora non risolvi il motivo potrebbe essere dovuto a quanto descritto qui https://it.wordpress.org/support/top...ella-wp-admin/

  10. #10
    isibisitgbots non è connesso Neofita
    Data registrazione
    04-09-2017
    Messaggi
    17

    Predefinito

    Problema risolto e arcano svelato, avevo impostato la costante (define) della cartella wp content uploads come miosito.altervista.org/uploads, e ora correggendo le immagini sono tornate come prima.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •