Visualizzazione risultati 1 fino 23 di 23
Like Tree3Likes
  • 1 Post By karl94
  • 2 Post By alemoppo

Discussione: Importazione sito con Wordpress su Altervista.

  1. #1
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito Importazione sito con Wordpress su Altervista.

    Buongiorno a tutti,
    sto' cercando di portare sul ben piu' valido Altervista questo sito, fatto con Wordpress:
    http://www.vitealternative.com
    Ho solo username e password di amministrazione perche' il gestore del server chiude, non risponde ai messaggi privati e quindi nemmeno posso sapere i parametri per usare un ftp e tirare giu' tutte le cartelle. Come posso importare il sito di Wordpress direttamente dentro ad Altervista? Ho scaricato il database, provando a farne un file, ma non trovo come caricarlo nell'admin di Altervista del database, insomma sto' impazzendo. Avete idee o trucchi facili?
    Grazie e buona giornata.

  2. #2
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,648

    Predefinito

    Hai provato ad usare la funzione Importa? La trovi sotto Strumenti nel pannello di amministrazione di WordPress.

  3. #3
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Certo, ben prima di scrivere qui, solo che temo che il server abbia chissa' che settaggio. Nel sito ho quindi installato BackUpWordPress ed ho fatto un backoup totale del sito (ora scarico il file) di database, file, foto, articoli... Ma mi chiedo se posso importarlo dentro un Wordpress fatto su Altervista, e se si' come.

  4. #4
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,648

    Predefinito

    E cosa successo? Hai ricevuto un messaggio di errore?

  5. #5
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Quando provavo ad importare il sito dall'importazione in remoto di Wordpress inserivo correttamente l'indirizzo del sito, username e password. Stava qualche secondo a fare chissa' cosa, poi si resettava e tornava a chiedere i dati di accesso, con i campi vuoti. Dopo qualche tentativo mi ero stufato.

    Ho salvato tutto il sito con BackUpWordPress, ne ho ottenuto un file .zip da 345 megabyte circa, ora pero' non so' che fare dopo.

  6. #6
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,648

    Predefinito

    Allora accedi al vecchio blog, e sempre dalla sezione Strumenti esporta l'XML, quindi importalo sul nuovo blog.

  7. #7
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Ma cosi' perdo le numerosissime immagini, foto e schemi.

  8. #8
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,648

    Predefinito

    No, le immagini contenute negli articoli e nelle pagine vengono importate.

  9. #9
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Caspita, bene. Ed il database come lo carico?

  10. #10
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,648

    Predefinito

    Citazione Originalmente inviato da vitealt Visualizza messaggio
    Caspita, bene. Ed il database come lo carico?
    Con l'XML importi tutti i contenuti (articoli e pagine), gli utenti, i men, le categorie e i tag.
    Dovrai solo installare di nuovo i plugin ed il tema e personalizzarli.
    L'importazione manuale dei file ed il database sconsigliabile: pi semplice importare l'XML (e si incontrano meno problemi).
    vitealt likes this.

  11. #11
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Grazie, dopo cena ci provo.

  12. #12
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Non funziona e non e' colpa vostra, provvedero' diversamente ma nel frattempo vi ringrazio tutti.
    Buona serata.

  13. #13
    karl94 non  connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,648

    Predefinito

    Cosa non ha funzionato? Hai visualizzato un messaggio di errore?

  14. #14
    vitealt non  connesso Utente AlterBlog
    Data registrazione
    26-01-2017
    Messaggi
    8

    Predefinito

    Non importava dal file .xml ne' gli articoli ne' altro, ho rinunciato e sto' copiando tutto il sito.

  15. #15
    GionniweB non  connesso Utente AlterBlog
    Data registrazione
    19-04-2017
    Messaggi
    47

    Predefinito

    ciao a tutti, mi aggiungo alla discussione perch anch'io ho bisogno della funzione esporta/importa.
    ho fatto backup completo con esporta xml, importa nell'altro sito, ma vedo che i file sono rimasti nel sito d'origine...
    che passaggio mi manca?

  16. #16
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,433

    Predefinito

    La procedura che indichi, se portata a termine correttamente, copia i contenuti nel nuovo sito ma non elimina il vecchio, Se vuoi eliminare il vecchio dovrai procedere eliminandoli manualmente.

    Ciao!

  17. #17
    myblackbike non  connesso Utente AlterBlog
    Data registrazione
    22-03-2018
    Messaggi
    4

    Predefinito

    Ciao a tutti, scusate se posto qui dopo 3 mesi, ma ho una domanda proprio inerente.
    Ho importato il file XML di un vecchio sito wp su altervista, tramite la procedura consigliata qui sopra, ed e' terminata correttamente (cosi' ha detto, almeno).
    Infatti vedo il sito funzionare, con tutti gli articoli importati, ed e' gestibile da altervista.

    Pero' mancano delle foto, qualcosa risulta fuori posto nella grafica, qualche scritta e' sovrapposta e mancano alcuni riquadri (widget, forse ?)

    Ho accesso ad entrambi gli FTP, del vecchio sito e del nuovo su altervista, ma non essendo molto pratico di wp, non so bene cosa copiare e dove.

    Ho anche provato a copiare l'intero vecchio sito (circa 500 MB) su altervista, ma non ho risolto, forse c'e' qualche cartella spostata ?

    Suggerimenti ?

    Grazie, saluti !

  18. #18
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,433

    Predefinito

    Le immagini si trovano nella cartella "wp-content": copiale dal vecchio sito e incollale nel nuovo.

    Ciao!

  19. #19
    myblackbike non  connesso Utente AlterBlog
    Data registrazione
    22-03-2018
    Messaggi
    4

    Predefinito

    Grazie della risposta super-veloce, ho guardato in tutto il vecchio sito ma non trovo le immagini. Anche copiando l'intera cartella wp-content, e perfino l'intera root (a parte il config e poco altro), nulla da fare.
    Davvero strano... Altre idee ?

  20. #20
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,433

    Predefinito

    Il sito nuovo questo? http://myblackbike.altervista.org/

    In effetti alcune immagini non si visualizzano ma altre s.
    Immagino ci siano problemi di nomi differenti per le immagini, dovresti modificare il nome dell'immagine rendendolo uguale a quello incluso nell'articolo (guarda il nome dell'immagine dal percorso dell'immagine non trovata).

    Altrimenti purtroppo la soluzione migliore (ma peggiore in termini di tempo, dipende dal numero di articoli da revisionare) quello di reinserire le immagini.

    Ciao!

  21. #21
    myblackbike non  connesso Utente AlterBlog
    Data registrazione
    22-03-2018
    Messaggi
    4

    Predefinito

    Si, e' quello il sito nuovo. Uhm, bella dritta grazie, ho controllato, i nomi dei file immagine sono uguali ma i percorsi a volte sono differenti, alcuni puntano ancora al vecchio sito. C'e' un modo per sostituire i link sbagliati con quelli giusti in un colpo solo ? Cioe', praticamente dovrei cambiare solo quei percorsi da [nomesito.com] a [nomesito.altervista.org], a quanto ho capito, e poi dovrebbe andare tutto a posto automaticamente (le foto ci dovrebbero essere tutte, nel nuovo sito, e nelle loro giuste cartelle, almeno da un controllo sommario).

    E' giusto seguire questa strada, secondo te ?

    Grazie, ciao !
    Ultima modifica di myblackbike : 25-03-2018 alle ore 05.51.23

  22. #22
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,433

    Predefinito

    S, la strada corretta. Prova e dovrebbe funzionare, fammi sapere.

    Ciao!

  23. #23
    myblackbike non  connesso Utente AlterBlog
    Data registrazione
    22-03-2018
    Messaggi
    4

    Predefinito

    Ho provato, ma quel procedimento non funziona per tutte le foto, alcune hanno il percorso differente...
    Comunque ho sentito il proprietario, preferisce rifare il sito daccapo e forse cambieremo anche il tema ed altri dettagli, quindi per ora lo lascio cosi', in attesa di rifarlo.

    Grazie ancora per l'aiuto, sempre utile. Buona giornata, ciao !

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •