Visualizzazione risultati 1 fino 4 di 4

Discussione: Errore 500 htaccess

  1. #1
    Data registrazione
    20-09-2014
    Messaggi
    6

    Predefinito Errore 500 htaccess

    Salve, oggi aprendo il mio sito ho trovato l'errore 500

    Errore 500 :(

    Si è verificato un errore.

    Questo errore può presentarsi a causa di un file .htaccess sintatticamente scorretto, inserito da te o da un tuo script nella cartella corrente.

    Per tornare ad accedere via browser ai contenuti della cartella devi apire la gestione files nel pannello di controllo, cliccare sull'icona raffigurante i due ingranaggi e correggere o eliminare (lasciando il testo bianco) il file. Per maggiori informazioni sulle direttive supportate dai files .htaccess consulta l'help online sempre all'interno del pannello di controllo.
    Premetto che non tocco questo sito da più di 3 mesi, e non c'è nessun form o cose simili, perchè è solo un sito portfolio.
    Sono andato a controllare il file htaccess, e ho trovato la stringa corrotta
    Ho eliminato la prima riga fino al < e ora il sito sembra funzionare.
    Cosa ha provocato questa modifica?
    Avevo wordpress 4.1 ora aggiornato a 4.1.1

    #�����������������<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    # # av:php5-engine
    AddHandler av-php5 .php

    php_value post_max_size 20M
    php_value upload_max_filesize 20M
    php_value memory_limit 128M

    # # av:Toolbar
    SetEnv AV_TOOLBAR 0

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  2. #2
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Come vedi ci sono una serie di blocchi ripetuti, che plugin hai installato?

    Il tuo file .htaccess dovrebbe essere composto solo da:

    Codice:
    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # # av:php5-engine
    AddHandler av-php5 .php
    
    php_value post_max_size 20M
    php_value upload_max_filesize 20M
    php_value memory_limit 128M
    
    # # av:Toolbar
    SetEnv AV_TOOLBAR 0
    Gianluca

  3. #3
    Data registrazione
    20-09-2014
    Messaggi
    6

    Predefinito

    ho dato una "smagrita" al file come da te suggerito.
    e non mi funziona più la tool bar per entrare in amministrazione e simili...

  4. #4
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,605

    Predefinito

    Citazione Originalmente inviato da antoniogabrielebrancato Visualizza messaggio
    ho dato una "smagrita" al file come da te suggerito.
    e non mi funziona più la tool bar per entrare in amministrazione e simili...
    In che senso non funziona? Non la visualizzi? Riporta inoltre la lista dei plugin che hai attivi.

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •