Pagina 2 di 2 PrimoPrimo 12
Visualizzazione risultati 31 fino 43 di 43

Discussione: Timthumb.php su AlterVista [le miniature non funzionano]

  1. #31
    Data registrazione
    14-09-2012
    Messaggi
    10

    Predefinito

    Ma questo problema sarà cmq risolto vero ?
    oppure uno dovrà per forza fare la modifica?

  2. #32
    Guest

    Predefinito

    Salve Niccolò, io sono nuovo di Wordpress e non sono riuscito ad applicare questa guida per far funzionare le miniature che si ingrandiscono con un click.
    Ho Wordpress (Spectrum) e sono andato su >aspetto>editor di destra>thumb.php poi ho cercato la tua riga

    $docRoot = @$_SERVER['DOCUMENT_ROOT'];
    e lo sostituita con l'altro codice in cui tu hai aggiunto solo //
    Ma continua a non funzionare !!!
    Poi non capisco come faccio a capire in quale riga mi trovo, dove sono i numeri? Perché il codice l'avevo cercato facendo F3.

  3. #33
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    woothemes lavora soprattutto con le miniature di wordpress. timthumb è disattivato come impostazione predefinita. Hai impostato l'immagine in evidenza in tutti gli articoli?

  4. #34
    Guest

    Predefinito

    No, non ho impostato l'immagine in evidenza in tutti gli articoli. Il moderatore Wolf mi ha detto che il problema era il Plugin WordPress SEO, infatti adesso che l'ho disattivato le immagine si ingrandiscono quando le clicco. Però il Wordpress Seo non è una cosa indispensabile?

  5. #35
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Timthumb non c'entra nulla con l'effeto lightbox delle immagini. Ti rispondo sull'altro thread.

  6. #36
    Guest

    Exclamation

    Di recente ho aggiornato la pagina timthumb.php del tema che utilizzo...
    Mi sono da poco accorto che la versione mobile del sito presenta un inconveniente sulle icone degli articoli: Prima si vedevano le miniature, ora invece appare solo il riquadro e l'immagini sono scomparse...

    Sareste così gentili d'aiutarmi a capire il motivo... e magari suggerirmi una soluzione???... Grazie
    Ultima modifica di darkwolf : 12-01-2013 alle ore 12.25.15 Motivo: Fonte: http://forum.it.altervista.org/wordpress/173295-wp-touch-pro-new-post.html

  7. #37
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Codice:
    http://myipad.altervista.org/wp-content/plugins/katalyst-timthumb/timthumb.php
    C'è un timthumb anche nel plugin oltre che nel tema.

  8. #38
    Guest

    Thumbs up

    ..e chi l'aveva visto... Grazie!!

  9. #39
    Guest

    Predefinito Ancora questo problema

    Buonasera, spero che questo topic sia ancora valido perchè ho lo stesso problema.

    Sito: http://jessexperience.altervista.org/wordpress/

    Come potete notare non si vedono 1 delle immagini della slide e a destra le anteprime degli articoli in evidenza. In locale funziona quindi presumo il problema stia proprio nelle limitazioni di altervista.

    Premetto che nel file timthumb.php del mio tema non ho trovato la riga da modificare indicata nel primo post di questo topic.

    Ho copiato qui il contenuto di tale file, se può aiutare: http://pastebin.com/8SJ7KJKG

    Grazie

    Jessica

  10. #40
    Guest

    Predefinito

    Citazione Originalmente inviato da niccolotapparo Visualizza messaggio
    Molti temi utilizzano lo script timthumb.php per generare le miniature delle immagini. le ultime versioni non funziona correttamente sui nostri server ed è necessaria una piccola modifica.

    Alla linea 814 del file (per la versione 2.8.4 dello script, altrimenti nelle vicinanze) si deve commentare la seguente istruzione:
    Codice PHP:
    $docRoot = @$_SERVER['DOCUMENT_ROOT']; 
    diventa
    Codice PHP:
    //$docRoot = @$_SERVER['DOCUMENT_ROOT']; 
    In caso di ulteriori problemi potete scrivere direttamente qui sotto.
    Mi hai salvato la vita!

  11. #41
    Guest

    Predefinito

    Citazione Originalmente inviato da niccolotapparo Visualizza messaggio
    Molti temi utilizzano lo script timthumb.php per generare le miniature delle immagini. le ultime versioni non funziona correttamente sui nostri server ed è necessaria una piccola modifica.

    Alla linea 814 del file (per la versione 2.8.4 dello script, altrimenti nelle vicinanze) si deve commentare la seguente istruzione:
    Codice PHP:
    $docRoot = @$_SERVER['DOCUMENT_ROOT']; 
    diventa
    Codice PHP:
    //$docRoot = @$_SERVER['DOCUMENT_ROOT']; 
    In caso di ulteriori problemi potete scrivere direttamente qui sotto.
    Dopo 3 giorni di ricerche finalmente grazie al tuo aiuto ho risolto anche io il problema delle immagini sul sito, grazie di cuore.

  12. #42
    cookingdream non è connesso Utente AlterBlog
    Data registrazione
    27-01-2014
    Messaggi
    1

    Predefinito

    Io uso il tema dailyfood. Ho commentato la riga in ogettto ma continua a non visualizzare le immagini... ho provato sia con la 2.8 che con l'ultima versione sostituendo quindi quella presente nel tema, Stavo iniziando a debuggare un pò il codice provando a capire dove si blocca...
    http://cookingdream.altervista.org/w...220&zc=1&q=100
    Avete qualche idea? l'immagine chiaramente esiste provando direttamente il source....

  13. #43
    welcometorome non è connesso Neofita
    Data registrazione
    29-05-2013
    Messaggi
    1

    Predefinito

    Salve a tutti, sto impazzendo con queste miniature del tema Spectrum non riesco a visualizzare le immagini ne nella parte "Older Post" e neanche le miniature di un plugin che ho installato... Ecco il sito http://www.sanit.altervista.org
    AIUTATEMI!!! :((( non riesco a trovare una soluzione!

Pagina 2 di 2 PrimoPrimo 12

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •