Visualizzazione risultati 1 fino 7 di 7

Discussione: [Wordpress] ordine cronologico dei post in home page

  1. #1
    Guest

    Predefinito [Wordpress] ordine cronologico dei post in home page

    stranamente i miei post appaiono in ordine inverso, dal più vecchio, e li vorrei nell'ordine tradizionale.Tutti i settaggi sembrano a posto. Uso il tema Mistique. Forse dovrei modificare il codice? Quale file.php?

    Inoltre in impostazioni lettura ho settato:
    le pagine del blog visualizzano al massimo "1" articolo più recente.
    Eppure gli articoli continuano ad apparire tutti. Come mai?
    Ciao, grazie

  2. #2
    L'avatar di musicanapoli
    musicanapoli non è connesso Moderatore
    Data registrazione
    24-08-2007
    Residenza
    CT
    Messaggi
    2,044

    Predefinito

    Inoltre in impostazioni lettura ho settato:
    le pagine del blog visualizzano al massimo "1" articolo più recente.
    Eppure gli articoli continuano ad apparire tutti. Come mai?
    Forse perchè il tema non consente questa cosa...

    stranamente i miei post appaiono in ordine inverso, dal più vecchio, e li vorrei nell'ordine tradizionale.Tutti i settaggi sembrano a posto. Uso il tema Mistique. Forse dovrei modificare il codice? Quale file.php?
    Se hai il file index.php (entrando nel pannello amministrativo >> editor) posta qui il codice. Dovrebbe trattarsi solo di un problema di ASC o DESC, ma vediamo che codice c'è...

  3. #3
    Guest

    Predefinito

    Certo grazie, questo è il codice di index.php

    Codice PHP:
    <?php
     
    /* Mystique/digitalnature */
     
    get_header();
    ?>

      <!-- main content: primary + sidebar(s) -->
      <div id="main">
       <div id="main-inside" class="clear-block">

        <!-- primary content -->
        <div id="primary-content">
         <div class="blocks">
          <?php do_action('mystique_before_primary'); ?>
          <?php
           
    if (have_posts()):
            while (
    have_posts()):
             
    the_post();
             
    mystique_post();
            endwhile;

            
    mystique_pagenavi();
           else: 
    ?>
           <h1 class="title error"><?php _e("No posts found","mystique"); ?></h1>
           <p><?php _e("Sorry, but you are looking for something that isn't here.","mystique"); ?></p>

          <?php endif; ?>
          <?php do_action('mystique_after_primary'); ?>
         </div>
        </div>
        <!-- /primary content -->

        <?php get_sidebar(); ?>

       </div>
      </div>
      <!-- /main content -->

    <?php get_footer(); ?>
    EDIT
    grazie, risolto.
    era più semplice, dipendeva dal settaggio del post stesso in > articoli > modifica > box a destra "pubblica" > visibilità > mantieni sempre in prima pagina
    una volta tolto il flag, tutto è tornato a posto
    Ultima modifica di musicanapoli : 14-09-2010 alle ore 00.44.22 Motivo: Codice racchiuso tra i tags.

  4. #4
    avvocatonews non è connesso Utente AlterBlog
    Data registrazione
    18-12-2020
    Messaggi
    11

    Predefinito

    Io ho lo stesso problema, nel blog i post appaiono da quelli più vecchi, utilizzo il tema renè.
    Cosa fare?
    Grazie

  5. #5
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,603

    Predefinito

    Il problema persiste anche con gli altri temi?
    Hai per caso modificato/aggiornato gli articoli che ora appaiono "in alto" ultimamente?

    Ciao!

  6. #6
    avvocatonews non è connesso Utente AlterBlog
    Data registrazione
    18-12-2020
    Messaggi
    11

    Predefinito

    Con altri temi non saprei, non ho mai cambiato Renè. Si ho modificato/aggiornato gli articoli.

  7. #7
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    18,603

    Predefinito

    Il problema è che gli articoli che visualizzi "in alto" sono flaggati come "in evidenza", quindi prova impostando gli articoli non in evidenza.

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •