Visualizzazione risultati 1 fino 11 di 11

Discussione: [WP] Mi reindirizza ad un articolo invece che in HomePage

  1. #1
    L'avatar di cineocchio
    cineocchio non è connesso Utente
    Data registrazione
    09-08-2007
    Messaggi
    159

    Unhappy [WP] Mi reindirizza ad un articolo invece che in HomePage

    Ciao.

    Dopo aver pubblicato un nuovo articolo non è stato più possibile raggiungere la home. Perchè con www.cineocchio.com e con www.cineocchio.altervista.org mi reindirizza all'articolo pubblicato!

    Le impostazioni di Wordpress sono corrette, la home su altervista è impostata correttamente ed anche utilizzando un plugin di redirect non funziona, in quanto non riesce mai a completare il redirect perchè cliccando home va sull'articolo infame, se ci metto un redirect alla home prosegue però all'infinito senza soluzione e da errore.

    Prima andava tutto bene, non so perchè pubblicando questo articolo è successo questo. E' molto importante un aiuto.
    Ora sul sito troverete uno spazio con "pagina non trovata" perchè poi quell'articolo stazione attualmente in cestino su Wordpress.

    Sapete cosa può essere e come risolvere il problema?
    Grazie

  2. #2
    L'avatar di musicanapoli
    musicanapoli non è connesso Moderatore
    Data registrazione
    24-08-2007
    Residenza
    CT
    Messaggi
    2,044

    Predefinito

    Partiamo dal punto che non funziona solo il link della home page e della pagina cineocchio.altervista.org/wordpress/2010/08/05/scheda-film-burlesque-2010-steven-antin/
    Quindi i link delle pagine, degli articoli e delle categorie funzionano bene.

    Che si sia "rotto" da solo è improbabile, probabilmente avrai modificato/aggiunto qualcosa.

    Cancellando l'articolo della scheda film burlesque che succede?

    Non so cosa possa essere successo, però ti dico cosa andrei a guardare subito anche se non potrebbe c'entrare nulla.

    Hai modificato il file .htaccess?
    Hai inserito qualche script nell'articolo "Film burlesque"?
    Hai modificato qualche file del template?
    Hai aggiunto dei plugin di recente (quali)?

    Comunque io procederei come sempre:
    • Cambiare momentaneamente template + verificare se così funziona tutto
    • Disattivare tutti i plugin + verificare se così torna tutto alla normalità
    • Disattivare ad uno ad uno i plugin + verificare...
    • Cancellare l'articolo "film burlesque" + verificare se è tutto ok


    Prova intanto queste cose...

    Prima andava tutto bene, non so perchè pubblicando questo articolo è successo questo. E' molto importante un aiuto.
    Ora sul sito troverete uno spazio con "pagina non trovata" perchè poi quell'articolo stazione attualmente in cestino su Wordpress.
    Stando all'url, l'articolo lo hai pubblicato il 5 Maggio e te ne sei accorto ora, oppure lo hai pubblicato adesso però hai cambiato la data?
    Ma dentro a quell'articolo c'è solo testo, immagini e poi qualcos'altro?
    Ultima modifica di musicanapoli : 06-08-2010 alle ore 02.29.19

  3. #3
    L'avatar di cineocchio
    cineocchio non è connesso Utente
    Data registrazione
    09-08-2007
    Messaggi
    159

    Exclamation

    Grazie per l'intervento.

    Allora, non ho modificato nessun file e codice. Ho pubblicato ed è successo così (per la data non so dirti, mi pare di averlo pubblicato il giorno stesso in cui ho chiesto aiuto qui, al massimo il giorno prima e non il 5). Forse ho provato a cambiare data per vedere se funzionava, se no strano.

    All'interno dell'articolo vi era testo e immagini (c'era anche un codice HTML ma altro non era che un mio form che copia/incollavo ogni volta per le schede dei film).

    - L'articolo incriminato l'ho cancellato (anche dal cestino) ma non cambia nulla. (prima mi rimandava a quell'articolo invece che in home. Adesso, non essendoci più, mi da ovviamente l'errore "non trovato").
    Il fatto è proprio che il link http://www.cineocchio.altervista.org/wordpress pare come "sovrapposto" a http://cineocchio.altervista.org/wor...-steven-antin/ (cioè quello dell'articolo). Se digito il link della home, mi appare l'articolo (ora, il "non trovato).

    - Ho provato a cambiare tema e, seppur nelle anteprime vengano tutti visualizzati correttamente, una volta applicato permane lo stesso errore anche con il tema di default.

    - L'unica cosa è che ho aggiornato Wordpress e vi erano molti plugin da aggiornare ancora in vecchia versione. MA pubblicando un articolo precedente non era successo nulla, seppur avessi già aggiornato Wordpress e avevo gli stessi plugin di ora.
    Comunque ho aggiornato tutti i plugin e niente (non ne ho aggiunti di nuovi). In più...

    - Disattivando tutti i plugin il problema persiste.

    Sono in seria difficoltà, grazie per l'aiuto.

    edit: ho provato a rendere inattivi i link in questo post ma li inserisce automaticamente
    Ultima modifica di cineocchio : 08-08-2010 alle ore 20.33.49

  4. #4
    L'avatar di musicanapoli
    musicanapoli non è connesso Moderatore
    Data registrazione
    24-08-2007
    Residenza
    CT
    Messaggi
    2,044

    Predefinito

    1) Prova ad entrare in phpmyadmin >> wp_posts >> mostra >> ordine decrescente >> ordinato per ID
    E vedi qual è l'ultimo articolo che è stato pubblicato.

    2) Hai provato a scrivere e pubblicare un altro articolo? Dopo che scrivi un altro articolo, cosa succede in home page? (C'è sempre il titolo del vecchio articolo oppure del nuovo articolo?)

    Ho provato a cambiare tema e, seppur nelle anteprime vengano tutti visualizzati correttamente, una volta applicato permane lo stesso errore anche con il tema di default.
    Questo è strano...

    3) Il tuo ultimo backup a quanto tempo fa risale?

  5. #5
    L'avatar di cineocchio
    cineocchio non è connesso Utente
    Data registrazione
    09-08-2007
    Messaggi
    159

    Predefinito

    Grazie ancora, dunque...

    1) sono andato in PhpMyAdmin, in avWPposts e ho estratto un elenco dei post (spero bene) e questo è il risultato (in immagine):



    C'è anche l'articolo incriminato (burlesque) che avevo eliminato da Wordpress (anche dal cestino) ma ancora prima una voce vuota.
    Edit: mi accorgo che ci sono anche le immagini caricate. Dunque, forse, la voce vuota è proprio l'immagine che ho postato qui (non nominata)...

    2) Ho provato a pubblicare un nuovo articolo e la situazione rimane invariata.

    3) il mio Backup su AV risale a solamente al 08-08-2010 (mi sorprende, forse era in automatico...). In ogni caso, è successivo al misfatto
    Ultima modifica di cineocchio : 09-08-2010 alle ore 17.54.18

  6. #6
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    ho notato che la pagina home viene reindirizzata con un 301 moved permanently, il che è molto strano. Gli .htaccess sembrano a posto, quindi deve esserci un qualche errore interno di wordpress. Mi potresti indicare la lista di tutti i plugins installati?

  7. #7
    L'avatar di cineocchio
    cineocchio non è connesso Utente
    Data registrazione
    09-08-2007
    Messaggi
    159

    Predefinito

    Lista Plugin Installati (attivi e non attivi, in ordine alfabetico):

    - Advanced Most Recent Posts

    - Akismet

    - All in One SEO Pack

    - Comment Toolbar

    - Contact Form 7

    - Cryptographp (non attivo)

    - Custom Admin Branding

    - GD Star Rating (mi segnala, come al solito, "destination host forbidden)

    - Google XML Sitemaps

    - MiniMeta Widget (non attivo)

    - My Category Order

    - My Page Order

    - Redirection

    - Simply Exlude

    - Sociable

    - Sponsors Slideshow Widget

    - Stream Video Player (da aggiornare ma non compatibile)

    - Subscribe to Comments

    - TinyMCE Advanced

    - Wibiya Toolbar

    - Wordpress Database Backup

    - WP-Page Navi

    - WP-Polls

    - WP-Post Views

    - WP-User Online

    - wpSpoiler

    - Yet Another Related Posts Plugin

    (comunque avevo provato a disattivarli tutti e il problema rimaneva, ci sono molte info nei miei post precedenti).

    Comunque il tutto è molto strano si, soprattutto per come è avvenuto. Se avessi modificato qualcosa ci potrebbe stare (come già è successo) ma non saprei proprio dove mettere le mani ora per risolvere il problema.
    Grazie a tutti, spero che riusciamo a combinare qualcosa.

  8. #8
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    uhm, mi puzza Redirection...

    edit: Infatti qui viene segnalato il tuo problema:
    http://urbangiraffe.com/tracker/issues/show/891

    Ha risolto disattivandolo, però a te rimane lo stesso. è un problema disinstallarlo?
    Ultima modifica di niccolotapparo : 10-08-2010 alle ore 14.52.43

  9. #9
    L'avatar di cineocchio
    cineocchio non è connesso Utente
    Data registrazione
    09-08-2007
    Messaggi
    159

    Thumbs up problema plugin redirection

    Hai ragione. Mha, avevo disattivato tutti i plugin ma niente. Ho riprovato ancora e ho disattivato Redirectione adesso funziona bene la home page (anche senza disinstallarlo completamente).

    Peccato perchè mi aveva salvato da molti link errati che avevo aggiustato così. Dunque, almeno per ora, non è più possibile utilizzare il plugin Redirection sull'ultima versione di Wordpress? Vedrò se ce ne sono di simili, se già conoscete qualcosa, indicatela pure.

    In ogni caso, grazie mille a tutti e due!

    edit: chissà poi perchè fa così, anche perchè ho pubblicato un paio di articoli prima che il plugin desse questo problema...
    Ultima modifica di cineocchio : 10-08-2010 alle ore 15.37.50

  10. #10
    L'avatar di niccolotapparo
    niccolotapparo non è connesso AlterVista Staff
    Data registrazione
    06-07-2009
    Residenza
    Torino
    Messaggi
    3,303

    Predefinito

    Eh, credo che nemmeno gli sviluppatori sappiano perché. Dovresti seguire l'evolversi della situazione al link che ti ho mandato. Si tratta del bug-tracker del plugin. Immagino che sistemeranno il problema ed uscirà una nuova versione, ma chissà quando...
    Per quanto riguarda i plugins alternativi prova a vedere qui

  11. #11
    L'avatar di musicanapoli
    musicanapoli non è connesso Moderatore
    Data registrazione
    24-08-2007
    Residenza
    CT
    Messaggi
    2,044

    Predefinito

    @cineocchio: Nel frattempo ti volevo dire che se nel tuo blog pubblichi tanti articoli al giorno o alla settimana, potresti trovare utile il plugin WP DB Backup.
    Come effettuare il backup del database (guarda backup con il plugin)
    Invia un backup per e-mail ogni giorno o due volte al giorno o ogni ora o una volta a settimana, oppure un backup manuale scaricandolo sul tuo computer o inviandolo per e-mail.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •