Visualizzazione risultati 1 fino 11 di 11

Discussione: [validazione] Non riesco a correggere l'errore

  1. #1
    Guest

    Predefinito [validazione] Non riesco a correggere l'errore

    Non riesco a capire cosa dovrei correggere, o meglio che errori commetto che vengono segnalati qui: http://validator.w3.org/check?uri=ht...project.net%2F .
    Potreste aiutarmi a comprendere?

  2. #2
    L'avatar di miki92
    miki92 non è connesso AlterGuru 2500
    Data registrazione
    21-04-2007
    Residenza
    Procida (NA)
    Messaggi
    4,224

    Predefinito

    Nel tuo codice prova a sostituire questo:
    Codice HTML:
    <p>Se avete creato un vostro CMS e vorreste diffonderlo, anche se non ancora famoso, nella rete segnalatemelo.<br />
    <br />
    Nella sezione downloads ho aperto la sotto-categoria <b>I Vostri Cms</b>, dedicata proprio alla promozione dei nuovi cms, sia che essi siano forum, cms per la gestione dei contenuti, o di altro genere.<br />
    Per vedere il vostro cms nei downloads basterà scrivermi una mail all'indirizzo contenuto nella pagina delle <a href="info.php">Informazioni</a>, oppure chiederlo nei commenti di questo articolo.<br />
    Quale delle due opzioni scegliate dovrete includere nelle informazioni: <br />
    <ul>
    <li>Nome del CMS.</li>
    <li>Versione del CMS.</li>
    <li>Link al download del CMS o a una pagina contenente i download del cms.</li>
    </ul><br />
    Ciao!</p>
    Con questo:
    Codice HTML:
    <p>Se avete creato un vostro CMS e vorreste diffonderlo, anche se non ancora famoso, nella rete segnalatemelo.<br /><br />
    Nella sezione downloads ho aperto la sotto-categoria <b>I Vostri Cms</b>, dedicata proprio alla promozione dei nuovi cms, sia che essi siano forum, cms per la gestione dei contenuti, o di altro genere.<br />
    Per vedere il vostro cms nei downloads basterà scrivermi una mail all'indirizzo contenuto nella pagina delle <a href="info.php">Informazioni</a>, oppure chiederlo nei commenti di questo articolo.<br />
    Quale delle due opzioni scegliate dovrete includere nelle informazioni:</p><br />
    <ul>
    <li>Nome del CMS.</li>
    <li>Versione del CMS.</li>
    <li>Link al download del CMS o a una pagina contenente i download del cms.</li>
    </ul><br />
    <p>Ciao!</p>
    Apprezzi l'aiuto? Offrimi un caffè!

  3. #3
    L'avatar di dreadnaut
    dreadnaut non è connesso Super Moderatore
    Data registrazione
    22-02-2004
    Messaggi
    5,950

    Predefinito

    stai aprendo una lista <ul> all'interno di un elemento che non può contenerla, probabilmente manca uno di quelli suggeriti.

    In particolare, stai cercando di aprirla all'interno di un paragrafo <p>, quindi devi chiudere il paragrafo, inserire la lista, e poi riaprirlo per il testo successivo.

    In realtà dovresti chiudere e riaprire il paragrafo ogni volta che tu metti un <br/>, ma quello è un errore semantico che il validatore non ti segnala
    Ultima modifica di dreadnaut : 08-06-2008 alle ore 13.47.37
    chezDreadnaut
    "Un <BR/> è impuro, punto."
    "I <P>&nbsp;</P> non hanno diritto di esistere."

  4. #4
    Guest

    Predefinito

    Grazie a tutti e due, ho risolto tutto.Scusate il messaggio prcedente era quello predefinito delle risposte rapide del forum.
    Ultima modifica di phelpp : 08-06-2008 alle ore 15.28.28

  5. #5
    nrgjack non è connesso Utente
    Data registrazione
    05-06-2008
    Messaggi
    125

    Predefinito

    Posso intromettermi anche io ?

    ho provato avalidare il mio primo sito, http://nrgjack.altervista.org/main.php

    siccome lho fatto con l'editor di testo probabilmente ci sono parecchi errori, ma quel che mi stranisce è che molti sono dati dal codice per le statistiche accessy

    Codice HTML:
    <!-- Inizio Codice Shinystat -->
    <script type="text/javascript" language="JavaScript" src="http://codice.shinystat.com/cgi-bin/getcod.cgi?USER=kensei"></script>
    <noscript>
    <a href="http://www.shinystat.com/it" target="_top">
    <img src="http://www.shinystat.com/cgi-bin/shinystat.cgi?USER=kensei" alt="Statistiche gratis" border="0"></a>
    </noscript>
    <!-- Fine Codice Shinystat -->

    Codice:
    #  Error  Line 161, Column 109: end tag for "img" omitted, but OMITTAG NO was specified.
    …t="Statistiche gratis" border="0"></a>
    You may have neglected to close an element, or perhaps you meant to "self-close" an element, that is, ending it with "/>" instead of ">".
    # Info Line 161, Column 0: start tag was here.
    <img src="http://www.shinystat.com/cgi-bin/shinystat.cgi?USER=kensei" alt="Stati
    
    # Error Line 161, Column > 80: XML Parsing Error: Opening and ending tag mismatch: img line 161 and a.
    …shinystat.cgi?USER=kensei" alt="Statistiche gratis" border="0"></a>…
    
    # Error Line 162, Column 11: XML Parsing Error: Opening and ending tag mismatch: a line 160 and noscript.
    </noscript>
    
    # Error Line 171, Column 6: XML Parsing Error: Opening and ending tag mismatch: noscript line 159 and div.
    </div>
    
    # Error Line 173, Column 7: XML Parsing Error: Opening and ending tag mismatch: div line 13 and body.
    </body>
    
    # Error Line 174, Column 7: XML Parsing Error: Opening and ending tag mismatch: body line 12 and html.
    </html>
    
    # Error Line 174, Column 7: XML Parsing Error: Premature end of data in tag html line 2.
    </html>

    a me non torna come mai non valida il codice di shiny e poi anche gli ultim non so come mai O_o non vadan bene :D

    scusate ma sono un po niubbetto :D

    grazie a chi mi risp :D
    Ultima modifica di dreadnaut : 14-06-2008 alle ore 22.37.42 Motivo: + tag [html]

  6. #6
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Citazione Originalmente inviato da nrgjack Visualizza messaggio
    Codice:
    <!-- Inizio Codice Shinystat -->
    <script type="text/javascript" language="JavaScript" src="http://codice.shinystat.com/cgi-bin/...gi?USER=kensei"></script>
    <noscript>
    <a href="http://www.shinystat.com/it" target="_top">
    <img src="http://www.shinystat.com/cgi-bin/shi...gi?USER=kensei" alt="Statistiche gratis" border="0"></a>
    </noscript>
    <!-- Fine Codice Shinystat -->
    Cambialo così:
    Codice:
    <!-- Inizio Codice Shinystat -->
    <script type="text/javascript"
    src="http://codice.shinystat.com/cgi-bin/...gi?USER=kensei>
    </script>
    <noscript>
    <a href="http://www.shinystat.com/cgi-bin/shi...gi?USER=kensei"><img
    src="http://www.shinystat.com/cgi-bin/shi...gi?USER=kensei"
    alt="shinystat logo" /></a>
    </noscript> 
    <!-- Fine Codice Shinystat -->
    Ultima modifica di darkwolf : 14-06-2008 alle ore 23.02.26 Motivo: rimosso <p>-</p> :)
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  7. #7
    L'avatar di dreadnaut
    dreadnaut non è connesso Super Moderatore
    Data registrazione
    22-02-2004
    Messaggi
    5,950

    Predefinito

    riassumendo e spiegando il motivo: manca una barra in fondo al tag <img>. In xhtml tutti i tag aperti devono essere anche chiusi, ma alcuni tag come img, br, hr, etc. non hanno il corrispettivo tag di chiusura. Si definiscono perciò autochiusi, e si mette una barra alla fine, come ad esempio in <img src="..." ... /> o <br/>.

    Il paragrafo <p> aggiunto da Darkwolf può non essere necessario, o forse anche errato: dipende tutto da dove hai messo il codice per il contatore. Se la semplice aggiunta della barra elimina tutti gli errori, non lo mettere.

    @Darkwolf: collegandomi alla discussione da te aperta in Piazza, se la gente si trova davanti soluzioni senza sapere perché vanno bene o come funzionano, si abituerà così e non gli verrà neanche in mente di fare da se - i.e. RTFM.
    Ultima modifica di dreadnaut : 14-06-2008 alle ore 22.35.27
    chezDreadnaut
    "Un <BR/> è impuro, punto."
    "I <P>&nbsp;</P> non hanno diritto di esistere."

  8. #8
    nrgjack non è connesso Utente
    Data registrazione
    05-06-2008
    Messaggi
    125

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Cambialo così:
    Codice:
    <!-- Inizio Codice Shinystat -->
    <script type="text/javascript"
    src="http://codice.shinystat.com/cgi-bin/...gi?USER=kensei>
    </script>
    <noscript><p>
    <a href="http://www.shinystat.com/cgi-bin/shi...gi?USER=kensei"><img
    src="http://www.shinystat.com/cgi-bin/shi...gi?USER=kensei"
    alt="shinystat logo" /></a></p>
    </noscript> 
    <!-- Fine Codice Shinystat -->
    lo adoro quest'uomo:D

  9. #9
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Citazione Originalmente inviato da dreadnaut Visualizza messaggio
    Il paragrafo <p> aggiunto da Darkwolf può non essere necessario, o forse anche errato: dipende tutto da dove hai messo il codice per il contatore. Se la semplice aggiunta della barra elimina tutti gli errori, non lo mettere.
    Hai ragione, ho fatto un paio di ctrl+c e ctrl+v di fretta in quanto era pronta la cena e mamma diceva (muoviti che si raffredda )
    Comunque il tag <p> in quella circostanza non sembra creare problemi di sorta (almeno in termini di validazione) ma in effetti può benissimo non metterlo
    Citazione Originalmente inviato da dreadnaut Visualizza messaggio
    @Darkwolf: collegandomi alla discussione da te aperta in Piazza, se la gente si trova davanti soluzioni senza sapere perché o come funzionano, si abituerà così e non gli verrà neanche in mente di fare da se - i.e. RTFM.
    Sorry you have reason (vedi spiegazione sopra) :)
    Ultima modifica di darkwolf : 14-06-2008 alle ore 22.43.13
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  10. #10
    L'avatar di dreadnaut
    dreadnaut non è connesso Super Moderatore
    Data registrazione
    22-02-2004
    Messaggi
    5,950

    Predefinito

    Citazione Originalmente inviato da darkwolf Visualizza messaggio
    Comunque il tag <p> in quella circostanza non sembra creare problemi di sorta (almeno in termini di validazione)
    nello spezzone no, ma se lo spezzone è già dentro un <p> ad esempio, darebbe errore.

    Sorry you have reason (vedi spiegazione sopra) :)
    che letteralmente si traduce in "mi spiace che tu abbia una motivazione"
    chezDreadnaut
    "Un <BR/> è impuro, punto."
    "I <P>&nbsp;</P> non hanno diritto di esistere."

  11. #11
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Citazione Originalmente inviato da dreadnaut Visualizza messaggio
    nello spezzone no, ma se lo spezzone è già dentro un <p> ad esempio, darebbe errore.
    Corretto
    Citazione Originalmente inviato da dreadnaut Visualizza messaggio
    che letteralmente si traduce in "mi spiace che tu abbia una motivazione"
    Va bè so che non è necessario dirlo ma intendevo: "scusa, hai ragione"
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •