Visualizzazione risultati 1 fino 4 di 4

Discussione: The error was: utf8 "\xE0" does not map to Unicode

  1. #1
    Guest

    Predefinito The error was: utf8 "\xE0" does not map to Unicode

    Scusate il tiolo ma veramente non saprei che scriverci dato che non restituisce nessun nome o avviso esplicito, restituisce solamente l'errore che scriverò tra poco. Il mio problema è: quando vado a validare una pagina dinamica, cioè, è una pagina PHP contenente la funzione switch mi restituisce degli errori che on ho mai visto! E me lo fa in tutte le pagine in cui è presente appunto lo switch. Ecco la sorgente:

    Codice PHP:
    <?php

    switch ($_GET['nome']){
    case 
    "1":
        include(
    '***');
    break;

    case 
    "2":
        include(
    '***');
    break;

    case 
    "3":
        include(
    '***');
    break;

    case 
    "4":
        include(
    '***');
    break;

    case 
    "5":
        include(
    '***');
    break;

    case 
    "6":
        include(
    '***');
    break;

    case 
    "7":
        include(
    '***');
    break;

    case 
    "8":
        include(
    '***');
    break;

    case 
    "9":
        include(
    '***');
    break;

    case 
    "10":
        include(
    '***');
    break;

    case 
    "11":
        include(
    '***');
    break;

    case 
    "12":
        include(
    '***');
    break;

    case 
    "13":
        include(
    '***');
    break;

    case 
    "14":
        include(
    '***');
    break;

    case 
    "15":
        include(
    '***');
    break;

    case 
    "16":
        include(
    '***');
    break;

    case 
    "17":
        include(
    '***');
    break;

    case 
    "18":
        include(
    '***');
    break;

    case 
    "19":
        include(
    '***');
    break;

    default:
         print 
    "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\" \"http://www.w3.org/TR/html4/loose.dtd\">
    <html>
    <head>
    <title>***</title>
    <meta name=\"title\" content=\"***\">
    <meta name=\"description\" content=\"***\">
    <meta name=\"keywords\" content=\"***\">
    <meta name=\"author\" content=\"***\">
    <meta name=\"copyright\" content=\"***\">
    <meta http-equiv=\"Reply-to\" content=\"\">
    <meta http-equiv=\"content-language\" content=\"IT\">
    <meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\">
    <meta name=\"ROBOTS\" content=\"INDEX,FOLLOW\">
    <meta name=\"creation_Date\" content=\"05/29/2008\">
    <meta name=\"revisit-after\" content=\"7 days\">
    <link href=\"/style.css\" rel=\"stylesheet\" type=\"text/css\">
    </head>
    [...]"
    ;
     
      include(
    'sidebar.php');
      
      echo 
    " [....] ";
      include(
    'footer.php');
      
    break;
    }
    ?>
    Alla linea 78 c'è il break; dell case "19"
    • No Character Encoding Found! Falling back to UTF-8.
      None of the standards sources gave any information on the character encoding labeling for this document. Without encoding information it is impossible to reliably validate the document. As a fallback solution, the "UTF-8" encoding was used to read the content and attempt to perform the validation, but this is likely to fail for all non-trivial documents.
      Read the FAQ entry on character encoding for more details and pointers on how to fix this problem with your document.
    • Sorry, I am unable to validate this document because on line 78 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.
      The error was: utf8 "\xE0" does not map to Unicode


    Cosa devo fare per potermi validare la pagina? Non riesco prorpio a capire dove sia l'errore

  2. #2
    Guest

    Predefinito

    Devi guardare nel codice html, no in quello sorgente.

    Carica la pagina nel tuo browser e poi visualizzi in codice html.

    Ricevi l'errore dal validatore perche sicuramente hai fatto un copia&incolla...

    Ciao

  3. #3
    Guest

    Predefinito

    Avevo scritto così:
    Codice HTML:
    <meta http-equiv=\"Content-Type\" content=\"text/html; charset=\"text/html; charset=ISO-8859-1\">
    Invece andava così:

    Codice HTML:
    <meta http-equiv=\"Content-Type\" content=\"text/html; charset=ISO-8859-1\">
    Risolto! Grazie giuseppeiemma

  4. #4
    Guest

    Predefinito

    Prego

    PS: se mi chiamavi solo per nome non mi offendevo di certo

    Ciao

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •