Visualizzazione risultati 1 fino 16 di 16

Discussione: validare css Vs bottone altervista

  1. #1
    Guest

    Predefinito validare css Vs bottone altervista

    Ciao...sto validando il sito..(o almeno ci provo...)
    cmq andando qua http://validator.w3.org/check?uri=ht...Inline&group=0 vedete che mi da sempre un'errore simile..

    <td width="127" valign="top" bordercolor="#E6D9FF" bgcolor="#E6D9FF">

    il bordercolor...così ho letto qualcosa e ho fatto un css x quella tabella...ma c'è un problema se io dentro la tabella c'inserisco il codice javascript di altervista x farmi votare, la pagina nn si vede più in anteprima...(quando nn son collegata) mi dice che nn sono online...se invece lo tolgo si vede normalmente...xchè? cosa sbaglio??

  2. #2
    L'avatar di Bluroy
    Bluroy non è connesso Utente
    Data registrazione
    21-03-2005
    Residenza
    localhost
    Messaggi
    214

    Predefinito

    Citazione Originalmente inviato da giannissima Visualizza messaggio
    Ciao...sto validando il sito..(o almeno ci provo...)
    cmq andando qua http://validator.w3.org/check?uri=ht...Inline&group=0 vedete che mi da sempre un'errore simile..

    <td width="127" valign="top" bordercolor="#E6D9FF" bgcolor="#E6D9FF">

    il bordercolor...così ho letto qualcosa e ho fatto un css x quella tabella...ma c'è un problema se io dentro la tabella c'inserisco il codice javascript di altervista x farmi votare, la pagina nn si vede più in anteprima...(quando nn son collegata) mi dice che nn sono online...se invece lo tolgo si vede normalmente...xchè? cosa sbaglio??
    comunque la tua validazione e per il w3c e non per il css,comunque devi eliminare la stringa bordercolor="#E6D9FF".

    ciao
    Ultima modifica di Bluroy : 14-12-2007 alle ore 13.49.21

  3. #3
    Guest

    Predefinito

    forse nn hai capito...se elimino bordercolor la tabella diventa trasparente, e a me serve colorata, quindi ho letto che per avere la tabella colorata ed essere validata dal w3c devo inserire un css, e in effetti così funziona, non mi da nessun errore nella pagina, ma inserendo il codice javascript del bottone di altervista non vedo l'anteprima

  4. #4
    Guest

    Predefinito

    ma scusa, non ho capito una cosa: il problema è il javascript che non si vede o il bordercolor che non valida? Cioè, prima col bordercolor senza css il javascript si vedeva e ora col css no oppure prima era una questione di validazione e ora il problema è un altro?

  5. #5
    Guest

    Predefinito

    esattamente....prima senza css si vedeva ma nn era valido, ora è valido, ma non si vede...non si vede quando cerco di vedere l'anteprima...poi nn so online come funziona...ma io le cose le faccio sempre quando nn son collegata...quindi se nn lo vedo come faccio?

  6. #6
    L'avatar di Bluroy
    Bluroy non è connesso Utente
    Data registrazione
    21-03-2005
    Residenza
    localhost
    Messaggi
    214

    Predefinito

    ascolta, se mi dai il link del css che usi ti posso aiutare sempre che riguadi il css che tu hai impostato.
    ok?

  7. #7
    Guest

    Predefinito

    guarda io ne ho provati un paio e nn ne ha funzionato nemmeno uno...
    cmq uno è questo http://giannissima.altervista.org/unnamed2.css

  8. #8
    L'avatar di Bluroy
    Bluroy non è connesso Utente
    Data registrazione
    21-03-2005
    Residenza
    localhost
    Messaggi
    214

    Predefinito

    che programma usi per editare la tua pagina o le tue pagine???

  9. #9
    Guest

    Predefinito

    macromedia dreamweaver e l'anteprima la guardo con IE

  10. #10
    L'avatar di Bluroy
    Bluroy non è connesso Utente
    Data registrazione
    21-03-2005
    Residenza
    localhost
    Messaggi
    214

    Predefinito

    hai associato i file css che hai creato alla tabella?

    se usi dreamweaver basta che clicchi sulla tabella per evidenziarla poi su proprieta' selezioni la voce del foglio di stile e l'associ e quando fai il "carica" e dreamweaver ti chiede di caricare anche i file dipendenti clicchi si.
    Ultima modifica di Bluroy : 14-12-2007 alle ore 14.50.31

  11. #11
    Guest

    Predefinito

    si si ho associato tutto...
    nella prima parte ho messo <link href="unnamed2.css" rel="stylesheet" type="text/css">
    e proprio dove la tabella <table width="65" align="center" cellpadding="2" cellspacing="0" class="unnamed2">
    cmq ora che sono online ho provato a controllare e si vede bene.......mi da il problema solo quando nn son collegata

  12. #12
    L'avatar di Bluroy
    Bluroy non è connesso Utente
    Data registrazione
    21-03-2005
    Residenza
    localhost
    Messaggi
    214

    Predefinito

    Citazione Originalmente inviato da giannissima Visualizza messaggio
    si si ho associato tutto...
    nella prima parte ho messo <link href="unnamed2.css" rel="stylesheet" type="text/css">
    e proprio dove la tabella <table width="65" align="center" cellpadding="2" cellspacing="0" class="unnamed2">
    cmq ora che sono online ho provato a controllare e si vede bene.......mi da il problema solo quando nn son collegata
    probabilmente perche' il foglio di stile si trova online e non in locale!
    L'importante e' che online riconosca il foglio di stile.

  13. #13
    Guest

    Predefinito

    lo so...ma io quando modifico il sito nn son mai collegata...altra cosa, avevo fatto questo style css e me la faceva vedere l'anteprima, poi dopo 3 o 4 volte nemmeno quello faceva vedere più niente, boh...nn lo so

  14. #14
    L'avatar di Bluroy
    Bluroy non è connesso Utente
    Data registrazione
    21-03-2005
    Residenza
    localhost
    Messaggi
    214

    Predefinito

    dovresti crearti un server in locale che ti possa far vedere quello che si potrebbe vedere online,di base windows lo possiede ma e' un po' difficile da gestire per chi non sa' dove mettere le mani,io uso Abyss Web Server per i test in locale ma devi configurare php in windows e cosi' su due piedi e' un po' difficile per me da spiegare,mi sa che dovro' fare una guida!!

  15. #15
    L'avatar di dementialsite
    dementialsite non è connesso Super Moderatore
    Data registrazione
    19-10-2004
    Residenza
    fuori Padova
    Messaggi
    5,046

    Predefinito

    Citazione Originalmente inviato da giannissima Visualizza messaggio
    ...
    <td width="127" valign="top" bordercolor="#E6D9FF" bgcolor="#E6D9FF">
    ...
    Probabilmente l'errore che ti dà è che gli attributi valign, bordercolor e bgcolor sono stati deprecati in HTML. Prova così:
    Codice HTML:
    <td width="127" style="vertical-align:top;border:solid 1px #E6D9FF;background-color:#E6D9FF">
    Stammi bene...
    Le questioni tecniche hanno risposte migliori nel forum pubblico, non trovi?

    When you don't know your next step... improvise

    ALTERVISTA WANTS YOU!
    Vuoi diventare moderatore su AlterVista? Scopri come...

  16. #16
    Guest

    Predefinito

    Dementialsite mi sa che mi hai risolto il problema...ho provato e sembra funzionare bene....Grazie davvero

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •