Pagina 1 di 2 12 UltimoUltimo
Visualizzazione risultati 1 fino 30 di 58

Discussione: Errori di validazione W3C [era: Errori Html]

  1. #1
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito Errori Html

    Ciao. Qualcuno sa dirmi quali sono gli errori di codice html nella home page del mio sito http://www.bastardofuori.altervista.org

    Il validatore html mi da questi errori:

    http://validator.w3.org/check?uri=ht...00=1&verbose=1

    Fatemi sapere grazie

  2. #2
    L'avatar di heracleum
    heracleum non  connesso Utente storico
    Data registrazione
    21-01-2004
    Messaggi
    3,333

    Predefinito

    Dunque,
    innanzitutto apro il sorgente della tua home e mi salta subito all'occhio un errore fondamentale, ovvero la chiusura di </head> sta DOPO l'apertura di <body ...>
    e gi questo...
    Altra cosa, visto che nel sorgente html NON hai indicato nessun DOCTYPE non molto utile chiedere al validatore di dedurre da solo (detect automatically) Encoding e Doctype.
    Infatti nel link che hai proposto lui ha impostato di suo l'encoding UTF-8 (che va usato saggiamente) mentre nel tuo codice compaiono dei caratteri ascii "diretti" come le accentate, per es. la '". Questa cosa manda in palla (o meglio non gli tornano da subito i conti sull'encoding) il validatore e ti dice, controlla che caratteri hai scritto prima di procedere con la validazione utf-8.

    Quindi, visto che il tuo codice a prima vista non lo dichiarerei xhtml utf-8, diciamo che potresti dichiarare un doctype in testa pi "easy", meno rigoroso, del tipo HTML 4.01 Transitional con encoding iso-8859-1.
    Infatti se nmel validatore al posto dei "detect automatically" imposti questi come valori avrai un responso preciso sugli errori da correggere per avere quantomento un valido html4.01 transitional.
    Ecco il link:
    http://validator.w3.org/check?uri=ht...00=1&verbose=1
    Avvertimento: richiedere in privato questioni tecniche produrr inevitabilmente una supercazzola prematurata come risposta. (5 served)

  3. #3
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Qualcuno sa perch la tag del mio sito non si aggiorna automaticamente quando lasci un messaggio??? Mi sono spiegato?
    La stessa tag in altrii siti quando lasci un messaggio si aggiorna in automatico mostrando subito l'ultimo mess inserito. Rispondete grazie mille...

  4. #4
    L'avatar di heracleum
    heracleum non  connesso Utente storico
    Data registrazione
    21-01-2004
    Messaggi
    3,333

    Predefinito

    Nessun commento riguardo la risposta al topic iniziale?

    Per la seconda domanda, pernso sia docuto al fatto che hai cambiato tutti i nomi (magari usando un editor html, l'hai fatto a tua insaputa) agli IFRAMEs, visto che i due iframe di anim*italia tags devono avere dei nomi (attributo name="..") ben precisi ovvio che i due frame non riescono a "trovarsi" l'un l'altro, quindi niente reload.
    Dunque prova a cambiare:
    <iframe name='I1' ...
    in
    <iframe name="writ"

    e

    <iframe name='I2' ...
    in
    <iframe name="tags"

    Molto probabilmente si comporter come previsto.
    Avvertimento: richiedere in privato questioni tecniche produrr inevitabilmente una supercazzola prematurata come risposta. (5 served)

  5. #5
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Ho messo l'head ke mi hai suggerito... Mi potresti spiegare come inserire il doc?
    Cmq grazie per l'informazione sulla tag: ora si aggiorna!!!
    PS visto ke ci 6: ho provato molte volte a kiederti scambio linmk in home.. cosa ne dici? il mio sito quello della firma!
    Fammi sapere ciao

  6. #6
    L'avatar di heracleum
    heracleum non  connesso Utente storico
    Data registrazione
    21-01-2004
    Messaggi
    3,333

    Predefinito

    Per dichiarare il doctype non ci vuole nulla, basta scrivere come primissima riga del tuo codice html (ancora prima dunque del tag <html> ) una riga con il doctype che ti interessa, nel tuo caso consiglierei:
    Codice HTML:
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
    Non affatto rigido (come ad es. xhtml strict) ed retrocompatibile.

    Per la tagboard mi sembra che la soluzione ha funzionato.

    Per gli scambi link come detto anche in pm non ne faccio uso , grazie comunque.
    Avvertimento: richiedere in privato questioni tecniche produrr inevitabilmente una supercazzola prematurata come risposta. (5 served)

  7. #7
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Senti ma io vedo ke col validartore mi da tantissimi codice alla pagina che mi hai indicato! Sapresti indicarmi la via per aggiustare il tutto??

    Grazie ancora...

  8. #8
    L'avatar di stasera
    stasera non  connesso Utente giovane
    Data registrazione
    29-07-2006
    Messaggi
    95

    Predefinito

    Bisogna avere pazienza e correggere gli errori uno ad uno...

    Alcune cose che ho notato:
    • devi sostituire tutti gli "&" con &amp;". & viene usato in html per indicare l'inizio di un carattere speciale, per cui non pu essere usato direttamente.
    • il tag per gli script javascript dovrebbe essere <script type="text/javascript" src="file.js">
    • invece di <embed> (che non ufficiale) bisogna usare <object>
    • Per tutte le immagini bisogna indicare il testo alternativo con l'attributo alt="testo alternativo". Se l'immagine non ha bisogno di testo alternativo puoi usare alt=""


    Non demordere, all'inizio difficile, ma vedere il messaggio che dice che la tua pagina valida sempre una soddisfazione, soprattutto se il sito dinamico, o se hai dovuto modificare il tema di phpBB per renderlo valido! Poter mettere i banner del w3c con controllo sul referrer fa onore al sito e al webmaster.

  9. #9
    L'avatar di heracleum
    heracleum non  connesso Utente storico
    Data registrazione
    21-01-2004
    Messaggi
    3,333

    Predefinito

    Abbi pazienza,
    almeno il doctype in testa potevi aggiungerlo no?

    Ad ogni modo, indicando direttamente di basarsi su html4.01 transitional come avevo detto qualche msg sopra:
    http://validator.w3.org/check?uri=ht...00=1&verbose=1
    indica che hai 156 errori.
    Pensi sia possibile spiegarti passo passo come correggerteli tutti?
    Ad ogni modo sono molto chiari.

    Ed oltretutto, ti avevo gi detto che c' il tag <body> che si apre PRIMA della chiusura del </head>
    e non l'hai modificato...

    se non ti impegni tu pensa quanto pu essere motivato uno che gi ha indicato cosa non va..


    Quindi cerca di applicare i consigli che vengono dati e poi prenditi un po' di tempo e impegno per seguire le indicazioni del validatore.
    Avvertimento: richiedere in privato questioni tecniche produrr inevitabilmente una supercazzola prematurata come risposta. (5 served)

  10. #10
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Ma vedi che ho messo il tag </head> prima dell'alperture del body.. ora cos' ke nn va?
    Ora prover a correggere quello ke ha indicato "stasera" e poi ritorno per vedere cosa successo..

    PS nn avevo messo il doctype poik sto installando il forum e ho messo gi il link in home ma il forum ancora nn l'ho settato...cmq fa niente

    C sentiamo presto...

    Inoltre posso chiedervi solo quali sono gli errori che ci sono nel tag body???


    Ragazzi ho dimezzato gli errori ma quelli che sono rimasti non riesco proprio a capirli.. Mi date una mano?
    Risp Grazie
    Ultima modifica di bastardofuori : 01-10-2006 alle ore 15.41.39

  11. #11
    L'avatar di funcool
    funcool non  connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non l, qui!
    Messaggi
    15,433

    Predefinito

    Molto di quello che ti stato suggerito non lo hai fatto. Quali errori non riesci a capire?
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    Tu mi dai fastidio perch ti credi tanto un Dio! B, dovr pur prendere un modello a cui ispirarmi, no? Woody Allen

  12. #12
    L'avatar di heracleum
    heracleum non  connesso Utente storico
    Data registrazione
    21-01-2004
    Messaggi
    3,333

    Predefinito

    Metti questo ca***oooo di DOCTYPEeeeeeeeeeee!

    Mai vista na cosa del genere oh...
    e una e due e tre e quattro volte, vuoi mettere 'sto DOCTYPE in cima o no????

    Poi ci si stupisce se uno smette di rispondere....
    Avvertimento: richiedere in privato questioni tecniche produrr inevitabilmente una supercazzola prematurata come risposta. (5 served)

  13. #13
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Hey ma il doctype da una vita ke l'ho messo!!! Poi ci sno errori sulla chiusura del tag script ke mi dice ke nn stato aperto, ma come possibile???
    Inoltre mi da un errore sul codice del banner di altervista....
    E & nn l'ho cambiato poik nn un carattere ma presente in uno script! Lo devo cambiare lo stesso???

    Ripeto il doctype l'ho messo da ieri!!!

  14. #14
    L'avatar di stasera
    stasera non  connesso Utente giovane
    Data registrazione
    29-07-2006
    Messaggi
    95

    Predefinito

    C' ancora un </head> extra dopo <body>

    Inoltre ci sono gli eventi come oncontextmenu e onselectstart che non sono standard e non andrebbero usati.

    Il codice dei javascript meglio nasconderlo cosi:
    Codice HTML:
    <script type="text/javascript"><!--
    codice();
    altroCodice();
    //--></script>
    Cos non dovrebbe pi darti problemi nel codice per i banner, ma se continua ad arrabbiarsi puoi cambiarlo con &amp; che non succede niente.

    E' sempre meglio racchiudere i valori degli attributi tra le "virgolette"
    Ultima modifica di stasera : 01-10-2006 alle ore 20.14.52

  15. #15
    Guest

    Predefinito

    Se dai un'occhiata alla sorgente del tuo sito vedrai che il primo problema proprio l'</head> che non hai levato ..
    <html>
    <head>
    <title>[.:bastardifuori:.] by gokufg - Tutto il Gratis del Web - Home - Un aggiunta ai Webmaster !!! --------------------------------------------------------</title>
    <meta name='author' content='gokufg'>
    <meta name='title' content='[.:bastardifuori:.] by gokufg - Tutto il Gratis del Web - Home'>
    <meta name="description" content='Bel sito con giochi, programmi, trucchi e molto altro per webmaster tutto GRATIS!!!'>
    <meta name="keywords" content='..'>
    <meta name="Language" content="Italian">
    <meta http-equiv="Content-Language" content="it">
    <meta name="revisit-after" content="7 days">
    <meta name="ROBOTS" content="INDEX,FOLLOW">
    <meta name='copyright' content='gokufg'>
    <meta name="creation_Date" content="04/04/2006">
    <link rel='stylesheet' href='style.css'>
    </head>
    <script type=text/javascript src="files/rainbow.js"></script>
    <body oncontextmenu="return false" onselectstart="return false" ondragstart="return false" topmargin=0 leftmargin=0 rightmargin=0 style="text-align: center">
    </head>
    <table border="0" cellpadding="0" cellspacing="0" width="909" style="border-collapse: collapse">
    <tr><td align="center" width="909" bgcolor="#000000">
    .. forse prima di buttarti su un editor e sbulaccare dovresti copiarti la sorgente su un notepad e leggertela bene
    Ultima modifica di salemuccia : 02-10-2006 alle ore 12.18.48

  16. #16
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    </head> tolto.. gli errori stanno diminuendo ora sono 44! Vi ringrazio..
    Mi spiegato cosa nn va bene al tag di chiusura dello script?? non si deve mettere???

    Inoltre sapete dove posso trovare la guida per inserire un body perfetto visto ke mi da molti errori x quel tag?
    Ultima modifica di bastardofuori : 02-10-2006 alle ore 19.10.27

  17. #17
    L'avatar di stasera
    stasera non  connesso Utente giovane
    Data registrazione
    29-07-2006
    Messaggi
    95

    Predefinito

    Nel primo script forse si arrabbia perch non hai messo le virgolette in type="text/javascript", oppure perch l'hai messo tra </head> e <body>, e l non puoi mettere niente. Devi decidere: o prima di </head> o dopo <body> (questo dipende da cosa deve fare lo script).

    Per il body devi togliere gli eventi onselectstart e ondragstart che non servono a niente, e anche topmargin, leftmargin ecc non sono riconosciuti o non servono (se ti aspetti che facciano qualcosa, prova a trovare qualcosa di equivalente da mettere dentro style="...")

  18. #18
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    PEr quanto riguarda onselectstart e ondragstart del body quei parametri servono per nn far selezionare le frasi e disabilitare il tasto destro...A qualcosa sevono..quindi nn vorrei toglierli...
    Non c nulla di alternativo a quei parametri?

  19. #19
    L'avatar di stasera
    stasera non  connesso Utente giovane
    Data registrazione
    29-07-2006
    Messaggi
    95

    Predefinito

    Citazione Originalmente inviato da bastardofuori
    PEr quanto riguarda onselectstart e ondragstart del body quei parametri servono per nn far selezionare le frasi e disabilitare il tasto destro...
    Vedi, te l'ho detto che non servono a niente...

    Ci sono migliaia di modi per riuscire comunque a copiare il testo o vedere il sorgente della pagina (ad esempio usando Firefox). Sono semplicemente fastidiosi, e ti consiglio di toglierli.

  20. #20
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Vabb se uno esperto va a vedere il sorgente altrimenti nn copia niente...cmq valuter sul fatto di toglierli...
    Mentre per lo script dei banner di altervista perk mi da degli errori?

  21. #21
    L'avatar di stasera
    stasera non  connesso Utente giovane
    Data registrazione
    29-07-2006
    Messaggi
    95

    Predefinito

    Quando un documento contiene vari errori, il parser riconosce bene il primo errore, poi cercando di correggerlo pu andare in tilt e riconoscere errori dove non ce ne sono, oppure pu non riconoscere alcuni errori.

    Inizia a correggere gli errori precedenti, poi se quel tag continua a non piacergli vediamo cosa c' che non va!

  22. #22
    Guest

    Predefinito

    Citazione Originalmente inviato da bastardofuori
    Vabb se uno esperto va a vedere il sorgente altrimenti nn copia niente...cmq valuter sul fatto di toglierli...
    Mentre per lo script dei banner di altervista perk mi da degli errori?
    no no .. ti confermo che anche un'imbranata [io] se naviga con firefox pu leggere e copiare tutto alla grande anche da siti fatti da professionisti.
    Alle fine dei conti ti appesantiscono ed incasinano solamente.
    Buon lavoro!

  23. #23
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Allora ho tolto ci ke dava fastidio nell'haed ma ora nn cambiato quasi niente: 37 errori.. cosa posso fare per gli script dove ci sono moltissimi errori?

  24. #24
    L'avatar di stasera
    stasera non  connesso Utente giovane
    Data registrazione
    29-07-2006
    Messaggi
    95

    Predefinito

    Devi mettere le virgolette in type="text/javascript"!

  25. #25
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Ho messo le virgolette a tutti gli script...Gli errori sono scesi a 29!!
    SApete come potrei correggere gli altri?? il tag marquee xk mi d tutti glegli errori???

  26. #26
    L'avatar di funcool
    funcool non  connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non l, qui!
    Messaggi
    15,433

    Predefinito

    Il tag marquee un tag proprietario, se vuoi un codice valido lo devi togliere e sostituire con uno script in JavaScript.
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    Tu mi dai fastidio perch ti credi tanto un Dio! B, dovr pur prendere un modello a cui ispirarmi, no? Woody Allen

  27. #27
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Nn so ke sign tag proprietario.. cmq mi potresti passare lo script cosi tolgo ancora qualke altro errore?

  28. #28
    L'avatar di funcool
    funcool non  connesso Utente storico
    Data registrazione
    05-02-2004
    Residenza
    Qui... Non l, qui!
    Messaggi
    15,433

    Predefinito

    Tag proprietario significa che un tag inventato da qualcuno (in questo caso Internet Explorer) e non riconosciuto dal W3C.
    Per lo script basta fare una ricerca su Google.
    Mattia vi manda a FunCool - Matriz - Directory Gogol - Sfondo rosso per la Birmania
    Tu mi dai fastidio perch ti credi tanto un Dio! B, dovr pur prendere un modello a cui ispirarmi, no? Woody Allen

  29. #29
    L'avatar di bastardofuori
    bastardofuori non  connesso AlterGuru
    Data registrazione
    04-04-2006
    Messaggi
    1,535

    Predefinito

    Ok.. visto ke il marquee redo di poterlo risolvere degli altri errori cosa sapete dirmi?
    Ancora grazie a tutti...

    EDIT: Rag ho cercato su google lo script sul tag marquee ma ho trovato solo uno script ke mi manda il testo da destra a sinistra...a me interessa da sotto a sopra... sapete qualcosa voi?


    FunCool: Non fare UP, usa il tasto Edita.
    Ultima modifica di funcool : 09-10-2006 alle ore 19.24.09

  30. #30
    L'avatar di heracleum
    heracleum non  connesso Utente storico
    Data registrazione
    21-01-2004
    Messaggi
    3,333

    Predefinito

    Prova questo:
    http://www.hypergurl.com/verticaltext.html
    ma ce ne sono veramente migliaia, basta che cerchi su google "vertical scrolling javascript"
    Avvertimento: richiedere in privato questioni tecniche produrr inevitabilmente una supercazzola prematurata come risposta. (5 served)

Pagina 1 di 2 12 UltimoUltimo

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •