Visualizzazione risultati 1 fino 25 di 25

Discussione: target"_top" non si valida

  1. #1
    Guest

    Predefinito target"_top" non si valida

    Ho HTML5 utf-8 W3C non lo valida

    C'è un'alternativa (senza toglierlo)?

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Dovresti farlo tramite javascript, perché html5 non può creare nuove finestre. Vedi qui.

    Ciao!

  3. #3
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Dovresti farlo tramite javascript, perché html5 non può creare nuove finestre. Vedi qui.

    Ciao!
    Avendo comprato il 2° livello, mi da errore di validazione anche sul frame che applicate voi, che io non so dove sia.

    Io chiedo: offrite questo servizio di 2° livello, non potete modificare le vostre maschere e testarle anche con HTML5?

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Ah, questa domanda bisogna rigirarla allo staff . Probabilmente qualcuno risponderà. Anche se il sito non è validato per quel motivo, non è un gran errore. Ovviamente fa sempre piacere avere un sito validato al 100%.

    Ciao!

  5. #5
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Ah, questa domanda bisogna rigirarla allo staff . Probabilmente qualcuno risponderà. Anche se il sito non è validato per quel motivo, non è un gran errore. Ovviamente fa sempre piacere avere un sito validato al 100%.

    Ciao!
    Ma ti dirò di più, con questo sito verifico se il mio è a posto: http://www.tuttowebmaster.eu/seo/checkup-sito.php

    ho notato mi da risultati diversi se verifico fra il 2° e il 3° livello.

  6. #6
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,626

    Predefinito

    L'attributo target è ammesso da HTML5. Nel tuo caso il problema è che tu non hai inserito uno spazio tra i vari attributi, come ben spiegato dal messaggio di errore.
    http://validator.w3.org/check?uri=ht...Inline&group=0

  7. #7
    Guest

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    L'attributo target è ammesso da HTML5. Nel tuo caso il problema è che tu non hai inserito uno spazio tra i vari attributi, come ben spiegato dal messaggio di errore.
    http://validator.w3.org/check?uri=ht...Inline&group=0
    Hai validato un altro sito, se valido www.gruppoalveo.it da i soliti 3 errori del frame che avete messo (e non testato prima di inserirlo nei sito 2° livello)

  8. #8
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Ops, nei messaggi precedenti ho sbagliato perché ho letto "_blank" invece di "_top" nel titolo. "_top" è un attributo ammesso (come anche "_blank").

    Gli errori che ricevi sono riferiti agli attributi di <frameset>, e immagino siano indispensabili per i vecchi browser.

    Meglio avere il sito visibile anche nei vecchi browser o avere il sito che passa la validazione? .
    La validazione serve per avere un'idea su possibili errori, ma quando sai che quell'errore deve esserci per altri motivi, puoi sorvolarlo. Non c'é alcuna controindicazione ad avere errori nel validatore: http://validator.w3.org/check?uri=google.com . L'importante è sapere quali sono.

    Ciao!
    Ultima modifica di alemoppo : 14-07-2014 alle ore 23.52.49

  9. #9
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Ops, nei messaggi precedenti ho sbagliato perché ho letto "_blank" invece di "_top" nel titolo. "_top" è un attributo ammesso (come anche "_blank").

    Gli errori che ricevi sono riferiti agli attributi di <frameset>, e immagino siano indispensabili per i vecchi browser.

    Meglio avere il sito visibile anche nei vecchi browser o avere il sito che passa la validazione? .
    La validazione serve per avere un'idea su possibili errori, ma quando sai che quell'errore deve esserci per altri motivi, puoi sorvolarlo. Non c'é alcuna controindicazione ad avere errori nel validatore: http://validator.w3.org/check?uri=google.com . L'importante è sapere quali sono.

    Ciao!
    Lo so, ma quel frameset mi da errore anche quando faccio il checkup del sito http://www.tuttowebmaster.eu/seo/checkup-sito.php

    Gli admin dovrebbero crearne 2 o 3 e uno si scegli a quella più adatta al proprio sito.

  10. #10
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Non trovo l'errore in quel sito del frameset!
    L'unica cosa che trovo riferita ai frame è:
    Codice:
    Attenzione! La pagina usa frame, difficilmente indicizzabile dai motori di ricerca. Per milgiorare le possibilità di indicizzazione di questa pagina leggi la nostra guida sull'ottimizzazione dei siti con frame.
    Comunque puoi proporre la cosa di creare una scelta di pagine predefinite su "servizi".

    Ciao!

  11. #11
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Non trovo l'errore in quel sito del frameset!
    L'unica cosa che trovo riferita ai frame è:
    Codice:
    Attenzione! La pagina usa frame, difficilmente indicizzabile dai motori di ricerca. Per milgiorare le possibilità di indicizzazione di questa pagina leggi la nostra guida sull'ottimizzazione dei siti con frame.
    Comunque puoi proporre la cosa di creare una scelta di pagine predefinite su "servizi".

    Ciao!
    Verificalo qui http://www.tuttowebmaster.eu/seo/meta-tag-analyzer.php

    vedrai che legge un altro charset e non il mio utf-8

  12. #12
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Perché in quel sito stanno tentando di scrivere il tuo "UTF-8" nella pagina che è stata dichiarata "windows-1252". È normale che il charset sia sballato.

    Ciao!

  13. #13
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Perché in quel sito stanno tentando di scrivere il tuo "UTF-8" nella pagina che è stata dichiarata "windows-1252". È normale che il charset sia sballato.

    Ciao!
    Non ho capito, chi sta tentando di scriverlo?

  14. #14
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Quel sito ha preso il testo che hai scritto e l'ha scritto nella sua pagina. La sua pagina però ha la codifica "windows-1252" mentre il tuo testo è "UTF-8".
    Un po' come leggere da database un testo "UTF-8" e mostrarlo in una pagina "windows-1252" (ma invece di prenderlo dal database, è stato preso dal tuo sito).

    Ciao!

  15. #15
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Quel sito ha preso il testo che hai scritto e l'ha scritto nella sua pagina. La sua pagina però ha la codifica "windows-1252" mentre il tuo testo è "UTF-8".
    Un po' come leggere da database un testo "UTF-8" e mostrarlo in una pagina "windows-1252" (ma invece di prenderlo dal database, è stato preso dal tuo sito).

    Ciao!
    Gli ho scritto nella sez. Servizi, ma non mi rispondono, guarda qui che roba, il SEO non me lo valida, non trova i meta. Questa maschera non va bene, non puoi sollecitare anche tu gli admin visto che sei un moderatore?

    Devono capire che questa maschera inganna gli spider e non ti indicizzano.


  16. #16
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Citazione Originalmente inviato da gruppoalveo Visualizza messaggio
    Gli ho scritto nella sez. Servizi, ma non mi rispondono
    Ma il problema è di quel sito che non fa le dovute conversioni.

    Citazione Originalmente inviato da gruppoalveo Visualizza messaggio
    , guarda qui che roba, il SEO non me lo valida, non trova i meta. Questa maschera non va bene, non puoi sollecitare anche tu gli admin visto che sei un moderatore?

    Devono capire che questa maschera inganna gli spider e non ti indicizzano.
    Questo non lo so: sicuramente i meta non li trova perché è appunto una maschera e non contiene nessun contenuto di per sé. Secondo me il problema non è tanto la mascherina ma il fatto della mancanza del virtual hosting.

    Posso dirti che lo staff ha visto tutte le discussioni che hai aperto.

    Ciao!

  17. #17
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Ma il problema è di quel sito che non fa le dovute conversioni.



    Questo non lo so: sicuramente i meta non li trova perché è appunto una maschera e non contiene nessun contenuto di per sé. Secondo me il problema non è tanto la mascherina ma il fatto della mancanza del virtual hosting.

    Posso dirti che lo staff ha visto tutte le discussioni che hai aperto.

    Ciao!
    Lo staff ha visto, e che ha detto?

    Cos'è il virtual hosting?
    Ultima modifica di gruppoalveo : 16-07-2014 alle ore 00.19.35

  18. #18
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Citazione Originalmente inviato da gruppoalveo Visualizza messaggio
    Lo staff ha vista, e che ha detto?
    Nulla, sicuramente non possono modificare la cosa in un paio di giorni nemmeno volendo, e se hanno fatto la scelta di usare quella mascherina, un motivo ci sarà sicuramente.

    Citazione Originalmente inviato da gruppoalveo Visualizza messaggio
    Cos'è il virtual hosting?
    http://it.wikipedia.org/wiki/Virtual_hosting

    In pratica, far puntare i file direttamente al dominio di II livello.

    Ciao!

  19. #19
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Nulla, sicuramente non possono modificare la cosa in un paio di giorni nemmeno volendo, e se hanno fatto la scelta di usare quella mascherina, un motivo ci sarà sicuramente.



    http://it.wikipedia.org/wiki/Virtual_hosting

    In pratica, far puntare i file direttamente al dominio di II livello.

    Ciao!
    Facciano come vogliono, comunque devono anche sapere che uno non è disposto ha spendere tempo e soldi per mettere a puntino il SEO del suo sito e poi ritrovarsi che non viene indicizzato per colpa di quella maschera.

    Questa cosa ha 2 controindicazioni:

    1. l'utente inizia a pensare di cambiare server
    2. non fa sicuramente una buona pubblicità ad Altervista.


    Queste cose, gli admin, devono valutarle bene.

    Speriamo che lo leggano questo post e che trovino presto una soluzione.

  20. #20
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    No ma il sito di terzo livello è indicizzato correttamente. Non lo è (immagino) quello di secondo livello.
    Il dominio di secondo livello su altervista serve ad esempio per passare il proprio link in una forma più "mnemonica". Il sito è quello di terzo livello.

    Ciao!

  21. #21
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    No ma il sito di terzo livello è indicizzato correttamente. Non lo è (immagino) quello di secondo livello.
    Il dominio di secondo livello su altervista serve ad esempio per passare il proprio link in una forma più "mnemonica". Il sito è quello di terzo livello.

    Ciao!
    Il 3° livello non da problemi, però, siccome uno per avere il 2° deve pagare, è giusto che abbia un buon servizio, in questo caso il virtual host.

  22. #22
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    No, su altervista si compra soltanto il dominio. E il servizio c'é.

    Ciao!

  23. #23
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    No, su altervista si compra soltanto il dominio. E il servizio c'é.

    Ciao!
    Si, allora uno potrebbe acquistarlo da un altro server che ha il virtual host

  24. #24
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,737

    Predefinito

    Però non hai l'hosting altervista, con tutto quello che ne consegue. Nessuno vieta di utilizzare un'altro hosting.

    Addirittura il dominio che hai comprato è trasferibile verso altri operatori.

    Ciao!

  25. #25
    Guest

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Però non hai l'hosting altervista, con tutto quello che ne consegue. Nessuno vieta di utilizzare un'altro hosting.

    Addirittura il dominio che hai comprato è trasferibile verso altri operatori.

    Ciao!
    Ci sarà pur un server che ha tutto come Altervista, o no?

    Comunque preferisco qui perché c'è anche il forum.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •