Pagina 8 di 8 PrimoPrimo ... 678
Visualizzazione risultati 211 fino 230 di 230

Discussione: [php 5] Thread "ufficiale"

  1. #211
    Guest

    Predefinito

    No nessun errore, semplicemente lascia dei campi vuoti dove dovrebbero esserci dei testi.
    mi dicono sul forum da cui ho scaricato lo script che dovevo attivare il php5, l'ho fatto ma non cambia nulla...

  2. #212
    mattemod non è connesso AlterVistiano
    Data registrazione
    07-06-2002
    Residenza
    Livorno, Toscana, Italia
    Messaggi
    755

    Predefinito

    Forse è un problema di codifica.

    Ho notato giusto 1-2 settimane fa che PHP su AV ha seri problemi con le codifiche dei caratteri.
    Dovevo sostituire dei caratteri presenti nel mio DB da una codifica all'altra e lavorare sulle "HTML entities", solo che su AV le funzioni mi restituivano stringhe vuote ma nessun errore (nonostante ad inizio script avessi chiamato error_reporting(E_ALL)), mentre sul mio pc (su Gentoo Linux) ho la stessa versione di PHP installata e mi funziona tutto perfettamente.
    Per aggirare il problema ho dovuto copiare i dati dal DB di AV su quello del mio pc, modificarli lì e ricaricarli già modificati nel DB di AV.

    Ah, le codifiche in questione erano ISO-8859-1 ed UTF-8, per cui nessuna codifica strana o poco utilizzata/supportata...
    Matteo

    Hestiun World
    Drago Bianco
    Fantasy Art

    Gentoo Linux rsync - hybrid +amd64/~amd64 - last gentoo-sources

  3. #213
    spiderwebsystem non è connesso Neofita
    Data registrazione
    12-02-2009
    Messaggi
    1

    Predefinito

    Scusate, io ho un problema con joomla 1.5.15 e php5, ovvero abilitandolo non si vede più il sito, ovvero a parte un errore di autenticazione che mi dà accedendo come amministratore(sessione scaduta ecc) poi quando tento di accedere ad alcune pagine del front mi esce pagina 404 oppure altre anomalie, mi cambia il template ma nella pagina nessun contenuto.
    Se disabilito il php5 tutto funziona perfettamente, fatta eccezione per quei moduli che richiedono il php5, motivo per il quale ci terrei ad averlo abilitato.
    Ovviamente esiste una soluzione?
    Grazie

  4. #214
    L'avatar di assimo
    assimo non è connesso Utente attivo
    Data registrazione
    15-03-2006
    Residenza
    Voghera
    Messaggi
    378

    Predefinito

    non conosco come sono costruiti i moduli di altervista, ma potresti provare a creare un .htaccess che abilita php5 solo nella cartella dei moduli di Joomla, inserendolo nella cartella dei moduli stessa.
    Nota bene: soprattutto per il fatto di non essere mod/admin/quant'altro di AV, non fornisco assolutamente supporto via PM.

  5. #215
    Guest

    Predefinito

    Scusate, approfitto del thread ufficiale...

    Per poter sfruttare alcuni componenti joomla ho provato tramite gestione file ad attivare il supporto php5 nelle cartelle relative: non cambia nulla ed i vari componenti mi restituisono sempre lo stesso laconico messaggio... "looks like you have wrong older php4 version".

    Ho anche provato ad abilitare il supporto sulla root, ma in questo caso il sito si blocca.

    Sul blog altervista un post di giugno dice che "a breve" si migrerà verso php5, mantenendo supportato il php4. Qualcuno ha novità?
    Ultima modifica di istitutobilingue : 23-07-2010 alle ore 13.07.07

  6. #216
    L'avatar di dapeco
    dapeco non è connesso Community Manager
    Data registrazione
    21-10-2003
    Residenza
    Brusasco (To)
    Messaggi
    4,904

    Predefinito

    Citazione Originalmente inviato da istitutobilingue Visualizza messaggio
    Sul blog altervista un post di giugno dice che "a breve" si migrerà verso php5, mantenendo supportato il php4. Qualcuno ha novità?
    La migrazione è in atto su alcune macchine in sequenza, si viene avvertiti del cambio via email.

    Piuttosto sarebbe interessante capire il perché del blocco con php5 attivo sull'account. Hai informazioni utili?
    Ho visto cose che voi utenti non potreste immaginare... siti da combattimento irregolari al largo dei bastioni di Orione. E ho visto account balenare nel buio vicino alle porte di Tannhauser. E tutti quei momenti andranno perduti nel tempo come lacrime nella pioggia. È tempo di sospendere...

    ASD Brusasco - C'è altro sport oltre al calcio!

    "Io sono vivo, voi siete morti" (Philip Dick, Ubik)

  7. #217
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Nel blog si avverte che php5 diverra' semplicemente il default, anziche' dover essere attivato.

    Come richiesto da dapeco dovresti darci tutte le informazioni che hai, per capire dove sta il problema.
    Gianluca

  8. #218
    Guest

    Predefinito

    Citazione Originalmente inviato da dapeco Visualizza messaggio
    Piuttosto sarebbe interessante capire il perché del blocco con php5 attivo sull'account. Hai informazioni utili?
    ti riporto l'echo di joomla a seguito dell'attivazione supporto php5 nella root
    Codice:
    Call stack 
    # Function Location 
    1 JSite->dispatch() /membri/istitutobilingue/index.php:68 
    2 JComponentHelper->renderComponent() /membri/istitutobilingue/includes/application.php:124 
    3 JError->raiseError() /membri/istitutobilingue/libraries/joomla/application/component/helper.php:95 
    4 JError->raise() /membri/istitutobilingue/libraries/joomla/error/error.php:171 
    5 JException->__construct() /membri/istitutobilingue/libraries/joomla/error/error.php:136
    Alto tentativo. Tolgo il supporto php5 alla root, riprendendo il controllo del sito. Poi attivo il supporto php5 nella directory di un componente, ma eseguendone l'accesso questo mi restituisce
    Codice:
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' 
    in /membri/istitutobilingue/components/com_appointinator/controller.php on line 16
    il diagnostico non cambia, che sia attivato o meno il supporto php5

  9. #219
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Hai modo di sottoporre la cosa anche al forum di supporto di Joomla?
    Gianluca

  10. #220
    Guest

    Predefinito

    Nei forum joomla tutti i casi di "Parse error" sono stati risolti passando a php5. Per qualche motivo quindi la modifica htaccess nella mia cartella in AV per il supporto php5 non funziona.

  11. #221
    Guest

    Predefinito php4

    Salve sono nuovo di qui e vorrei chiedervi se nelle macchine dove gira php5 di default è possibile scegliere un'opzione per il php4 e come dovrei fare se fosse possibile. Grazie per quanto potrete dirmi

  12. #222
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,632

    Predefinito

    Citazione Originalmente inviato da frontone Visualizza messaggio
    Salve sono nuovo di qui e vorrei chiedervi se nelle macchine dove gira php5 di default è possibile scegliere un'opzione per il php4 e come dovrei fare se fosse possibile. Grazie per quanto potrete dirmi
    Attualmente la versione di default è la 4, per attivare PHP5 segui le istruzioni di questo post: [php 5] Thread "ufficiale"

  13. #223
    L'avatar di andreafallico
    andreafallico non è connesso Super Moderatore
    Data registrazione
    02-06-2009
    Messaggi
    1,981

    Predefinito

    Citazione Originalmente inviato da karl94 Visualizza messaggio
    Attualmente la versione di default è la 4, per attivare PHP5 segui le istruzioni di questo post: [php 5] Thread "ufficiale"
    In alcuni server la versione di defaul è la 5, per attivare php4 deve seguire la stessa procedura.

  14. #224
    karl94 non è connesso Staff AV
    Data registrazione
    03-10-2005
    Messaggi
    17,632

    Predefinito

    Citazione Originalmente inviato da andreafallico Visualizza messaggio
    In alcuni server la versione di defaul è la 5, per attivare php4 deve seguire la stessa procedura.
    Non lo sapevo, grazie per l'informazione!

  15. #225
    provamio100 non è connesso Neofita
    Data registrazione
    13-04-2009
    Messaggi
    2

    Predefinito

    Ancora non ci sono novità sull'implementazione di mysqli?
    Eppure sono in tantissimi a chiederne l'abilitazione. Come mai ancora non è stata abilitata? C'è un motivo particolare?
    Grazie per eventuali risposte

  16. #226
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    mysqli e' disponibile, gia' da molto tempo
    Gianluca

  17. #227
    Guest

    Predefinito

    Cito la risposta data nell'altro topic

  18. #228
    Guest

    Predefinito

    Perché non viene attivato l'IMAP PHP su Altervista? Penso sia una funzionalità molto utile a tutti coloro vogliono permettere la gestione della posta elettronica direttamente da un sito hostato sui server di Altervista!

  19. #229
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,774

    Predefinito

    Ma da quando è stato messo php 5.3.8 ??

    Proprio ieri, stavo facendo uno script usando "SQLite3" (non ricordandomi che su av non andava), quindi ho dovuto riconvertire con "PDO".

    E adesso scopro che in realtà PHP 5.3.8 è selezionabile???

    (comunque ormai è andata: lascio PDO ).

    Grazie!!

    Ciao!
    Ultima modifica di alemoppo : 07-01-2012 alle ore 23.53.53

  20. #230
    Guest

    Predefinito

    Quando si potrà avere php 5.4?

Pagina 8 di 8 PrimoPrimo ... 678

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •