Visualizzazione risultati 1 fino 12 di 12

Discussione: Pagina NON FUNZIONA dopo trasferimento da altro provider

  1. #1
    cristianlentini non è connesso Neofita
    Data registrazione
    16-05-2005
    Messaggi
    5

    Predefinito Pagina NON FUNZIONA dopo trasferimento da altro provider

    Buongiorno amici,

    ho trasferito da pochissimo il mio sito wordpress su https://cristianlentini.altervista.org/wp/ .
    Ho modificato correttamente wp-config.php e database mysql ma NON FUNZIONA. Verificate e leggere l'errore.

    Ho applicato alla lettera tutti i suggerimenti che ho letto su questo ed altri forum ma nulla. Non va. Perchè? Che succede? Non riesco neanche ad entrare più nel backend di Wordpress: https://cristianlentini.altervista.org/wp/wp-admin/

    Cosa devo fare? Esiste un supporto tecnico qui a cui rivolgermi???

    Grazie anticipatamente a tutti.

  2. #2
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,078

    Predefinito

    Salve,
    ha un altersito?

    Ha abilitato CloudFlare?

    Cordiali saluti.

  3. #3
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,755

    Predefinito

    Il tuo vecchio sito utilizzava HTTPS? Lo hai abilitato sul pannello di controllo?

    Inoltre, sei a conoscenza del tipo di account AlterBlog che ti permetterebbe di avere, tra le altre cose, una installazione pulita di Wordpress con spazio e banda illimitati?

    Ciao!

  4. #4
    cristianlentini non è connesso Neofita
    Data registrazione
    16-05-2005
    Messaggi
    5

    Predefinito

    Si è abilitato CloudFlare

  5. #5
    cristianlentini non è connesso Neofita
    Data registrazione
    16-05-2005
    Messaggi
    5

    Predefinito

    Sì, l'https è abilitato anche su questo ma risulta ancora in fase di attivazione. Potrebbe essere questo il motivo?

  6. #6
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,078

    Predefinito

    E' probabile che dipenda da CloudFlare, provi a disabilitarlo. Quando il sito sarà nuovamente visibile, eventualmente se le serve provi a rialbilitare CloudFlare.

    Nel caso in cui il problema con CloudFlare attivo dovesse persistere, le consiglio di disabilitarlo e lascialo disabilitato.

    Cordiali saluti.

  7. #7
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,035

    Predefinito

    WordPress impone WP_HOME e WP_SITEURL (per un non multisito) una url con il protocollo che nel suo caso risulta in https ma CloudFlare non è ancora pronto. Dal pannello di controllo altervista disabilita https e all'incirca dopo 24 ore lo riattiva e attenda altre 48 ore per vedere se stavolta il certificato sarà valido.
    Poi le occorrerà adeguarsi Abilitare e forzare HTTPS nel proprio sito in quel esempio RewriteBase è per la cartella root ovviamente se il file .htaccess risiede nella cartella wp sarà RewriteBase /wp/ comunque per WordPress originale avrà bisogno di Really simple ssl plugin (ovviamente in wp-config.php dovrà almeno impostare
    Codice PHP:
    $_SERVER['HTTPS'] = 'on'
    altrimenti wordpress non riconosce che sarà su https. Dopo aver installato e abilitato ssl dal plugin dovrà rimuovere il codice precedentemente inserito).
    A limite temporaneamente può impostare le due costanti nominate in precedenza con il protocollo http (con google trova la sintassi per modificare la url di WordPress) solo per vedere che il sito e i suoi contenuti sono presenti.
    Aggiornamento delle 23:28 adesso il certificato è emesso da altervista non è più in uso CloudFlare ma comunque il suo sito è accessibile.
    Ultima modifica di darbula : 21-09-2020 alle ore 12.18.11 Motivo: Variabile maiuscola

  8. #8
    cristianlentini non è connesso Neofita
    Data registrazione
    16-05-2005
    Messaggi
    5

    Predefinito

    Buongiorno,

    purtroppo dopo diversi altri tentativi non sono ancora riuscito a far funzionare nulla.
    Ho provato AlterBlog ma sono subito dopo ritornato ad AlterSito perchè non mi dava la libertà di customizzazione di cui ho bisogno.
    Ho anche eliminato la sottocartella wp/ per scongiurare complicazioni. Adesso wordpress è installato nella root.
    Ho disabilitato CloudFlare. Mentre HTTPS è abilitato.

    Continuo però ad avere il messaggio di errore: "cristianlentini.altervista.org ti ha reindirizzato troppe volte" sia da Chrome sia da Edge. Cosa posso fare? L'assistenza Altervista può aiutarmi?

  9. #9
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,035

    Predefinito

    Buongiorno cristianlentini, rilegga il messaggio precedente dove accenno alla soluzione per evitare il reindirizzamento e per scrivere la variabile in wp-config.php.
    Pagina NON FUNZIONA dopo trasferimento da altro provider
    Cosa non è chiaro? Forse come editare il file .htaccess e/o wp-config.php e/o installare il plugin Really simple ssl?
    Ultima modifica di darbula : 21-09-2020 alle ore 12.29.43

  10. #10
    cristianlentini non è connesso Neofita
    Data registrazione
    16-05-2005
    Messaggi
    5

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Buongiorno cristianlentini, rilegga il messaggio precedente dove accenno alla soluzione per evitare il reindirizzamento e per scrivere la variabile in wp-config.php.
    Pagina NON FUNZIONA dopo trasferimento da altro provider
    Cosa non è chiaro? Forse come editare il file .htaccess e/o wp-config.php e/o installare il plugin Really simple ssl?

    Da stamattina visualizzo la HP del sito ma non riesco ad entrare nel backend di Wordpress. Dopo il login, mi dice: Non hai il permesso di accedere a questa pagina.
    Inoltre nella HP ci sono le immagini standard del template e non quelle che avevo configurato. Ma questo è un problema minore.

  11. #11
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,035

    Predefinito

    Quindi lei può nuovamente visualizzare il sito, adesso sta descrivendo un un'altro problema.
    Per favore professore ingegnere capisco il disagio ma il topic è per un singolo argomento (oltre al fatto che è vietato dal regolamento altervista può confondere chi vuole aiutarla descrivendo molte opzioni) se poi riscontra problemi diversi deve aprire un topic per il problema medesimo.
    Utilizza qualche plugin per il Recaptcha? Forse lei ha cancellato l'utente cristianlentini nel suo database (per il login degli utenti)?
    Gentilmente può scrivere il codice contenuto dentro il suo file .htaccess nel tag code del forum?
    Comunque il codice è sempre in movimento attualmente il plugin qtranslate-x non è più supportato e causa errori poiché WordPress utilizza una nuova sintassi.
    Ultima modifica di darbula : 21-09-2020 alle ore 15.09.13

  12. #12
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,078

    Predefinito

    Il sito adesso è visibile, ma appare un banner scuro in alto con 2 messaggi di errore in riferimento a qtranslate-x.
    Codice:
    Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /membri2/cristianlentini/wp-content/plugins/qtranslate-x/qtranslate_frontend.php on line 497
    
    Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /membri2/cristianlentini/wp-includes/class-wp-hook.php on line 287
    Poichè tale plugin non è più supportato e genera errori, le consiglio disinstallarlo o almeno di disabilitarlo.

    Cordiali saluti.

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •