Pagina 1 di 2 12 UltimoUltimo
Visualizzazione risultati 1 fino 30 di 37

Discussione: HTTPS non funzionante

  1. #1
    corosangregorio non è connesso Neofita
    Data registrazione
    28-08-2007
    Messaggi
    7

    Unhappy HTTPS non funzionante

    Salve,

    vorrei segnalare mancata attivazione del protocollo HTTPS sul sito http://corosangregorio.altervista.org/.

    Nella pagina di configurazione appare quanto segue:

    "HTTPS
    L’attivazione di HTTPS è in corso, se nelle prossime 24 ore non è attivo per favore scrivi sul nostro forum."

    Sono trascorse oltre 24 ore ma non è cambiato ancora nulla, come è necessario procedere per attivare HTTPS?

    Grazie

    Gabriele

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,958

    Predefinito

    Spesso CloudFlare ha problemi nell'erogazione del certificato TLS: se non ti serve, disabilita CloudFlare, quindi abilita HTTPS di AlterVista.

    Ciao!

  3. #3
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Spesso CloudFlare ha problemi nell'erogazione del certificato TLS: se non ti serve, disabilita CloudFlare, quindi abilita HTTPS di AlterVista.

    Ciao!
    Quindi per avere un sito wp ospitato da AV con protocollo https e http riscritto https non c'è bisogno di Cloudflare? Non lo devo attivare?

  4. #4
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    allora le gradite indicazioni step by step disponibili su https://rigottofilippo.altervista.or...staWpHttps.pdf non sono valide?
    ma se non attivo Cloudflare, se non sbaglio, non si ha più la possibilità di ottenere la riscrittura di http in https
    Ultima modifica di imagoweb : 30-09-2020 alle ore 14.11.20

  5. #5
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,236

    Predefinito

    Salve,
    non è vero che serve CloudFlare per abilitare https. CloudFlare è solo un di più facoltativo, che migliora le prestazioni, almeno quando non da problemi.

    Gyardi la guida: Abiltare e forzare https

    Può abilitare https da pannello di controllo da qui.

    Il redirect da http a https può essere eseguito via .htacess. Nel caso si usi WordPress, è consigliato farlo tramite il plugin Really Simple SSL

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 30-09-2020 alle ore 15.16.16

  6. #6
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    @imagoweb tenga in mente il web è sempre in espansione le guide potrebbero essere obsolete o idone in alcune circostanze altrimenti si vanifica il corretto funzionamento. (Questo è il forum di supporto "tecnico", ne consegue che vogliamo realmente aiutarla per il suo problema).
    In genere un'impostazione errata dal pannello CloudFlare può far ricevere errori.
    Come già menzionato da @GraphOGLRisorse deve abilitare https dal pannello altervista e/o WordPress modificato impostazioni->https per la versione modificata da altervista senza alcun plugin e senza riscrittura tramite file .htaccess.
    Dopo deve solamente verificare online se il suo certificato è pronto e segua attentamente ciò che è stato scritto al messaggio precedente.
    Se non esiste impostazioni->https ti occorre semplicemente digitare la url WordPress con protocollo http: Dalla schermata Plugin, cliccare su Aggiungi nuovo e installare Really Simple
    SSL3
    , un efficace plugin di Rogier Lankhorst.
    • Dopo aver attivato il plugin, dal banner che compare in alto cliccare Ricarica in
    SSL: l’adeguamento di WordPress avviene in automatico se tutto è corretto.
    (Opzionalmente tramite file .htaccess potrai forzare in https).
    Passo indietro nel corso del tempo* in precedenza altervista offriva solamente https tramite CloudFlare ma già da tempo è stato ampliato anche il certificato autofirnato direttamente tramite altervista e Let's Encrypt.
    Ultima modifica di darbula : 30-09-2020 alle ore 16.18.27

  7. #7
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    [QUOTE=GraphOGLRisorse;1457408]Salve,
    non è vero che serve CloudFlare per abilitare https. CloudFlare è solo un di più facoltativo, che migliora le prestazioni, almeno quando non da problemi.

    Gyardi la guida: Abiltare e forzare https

    Innanzitutto ringrazio sentitamente per la sollecita risposta.

    Prendo atto che a quanto dice non c'è bisogno di attivare Clouflare: molto meglio così, meno cose, meno problemi (poi mica ho capito bene cosa è questo Cloudflare).

    Ho consultato il link che mi ha inviato. Interessante.

    Quindi, visto che ho creato un account/sito Altersito Hosting per WP in cui ho attivato Cloudflare, abilitato HTTPS, attivato riscrittura automatica link HTTP, attivato DB, caricato con Filezilla i file di WP (anche se continuavano ad apparire messaggi riguardanti certificati non validi, o qualcosa del genere), ma il sito restituisce il messaggio 'sito non sicuro' (parrebbe non avvenga la riscrittura automatica dei link http in https anche se il sito è raggiungibile sia con il protocollo http che https) e che il problema dovrebbe essere legato a Cloudflare e visto che voglio ospitare WP, come segue:
    - disattivo Cloudflare e attendo conferma;
    - accedo al pannello di controllo di WP del sito
    - installo il plugin Really Simple SSL3
    - attivo il plugin e dal banner che compare in alto clicco su 'Ricarica in SSL'

    Nel mio caso, ovvero sito Altervista Hosting con WP, qual'è il codice da utilizzare in .htaccess in alternativa alla procedura sopra descritta? È quello al link Abilitare e forzare HTTPS nel proprio sito?
    Ultima modifica di imagoweb : 30-09-2020 alle ore 20.12.37

  8. #8
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,236

    Predefinito

    Sì, il codice da inserire nell'.htacess è quello presente nel link che le ho fornito.

    Cordiali saluti.

  9. #9
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,958

    Predefinito

    Il tuo sito lato AlterVista è configurato correttamente per erogare TLS (vedi qui). Ora dovrai configurare WordPress per utilizzare l'HTTPS, puoi faro tramite il plugin indicato nella discussione indicata dagli altri utenti.

    Ti segnalo comunque che AlterVista ha un altro tipo di account, dove viene fornito già pronto una versione di WordPress con molte funzionalità integrate, vedi qui.

    Ciao!

  10. #10
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Sì, il codice da inserire nell'.htacess è quello presente nel link che le ho fornito.

    Cordiali saluti.
    caspita, sbadatamente non avevo sostituito, nel codice di cui al link Abilitare e forzare HTTPS nel proprio sito <nome>.altervista.org con il nome del mio sito. Ho aspettato circa
    Ho corretto, ma collegandomi a imagoweb.altervista.org, sito WordPress Altervista Hosting, pur apparendo il protocollo https la barra degli indirizzi del browser mi restituisce 'sito non sicuro'. Perchè?

    Inoltre digitando imagoweb.altervista.org/wp-admin vengo reindirizzato ancora a nome.altervista.org/wp-admin/ dove ovviamente mi viene restituito 'impossibile raggiungere il sito'. Sarà qualcosa inerente il DB di WP? Eventualmente cosa?

  11. #11
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Perché fai tutte queste domande?
    Per la soluzione al tuo problema non è necessario capire tutto il procedimento ma ti basta eseguire alla lettera ogni cosa letta qui sul forum. (Se fai o pensi altro stai prolungando il tuo problema, rileggi 10 volte la discussione inoltre è un forum di supporto diventa difficile spiegare tutto dall'inizio l'importante è risolvere l'errore)
    Comunque quando abiliti Really simple ssl e attivi SSL dal plugin, il plugin impostera la tua url con protocollo https (dentro al database, sarebbero le costanti WP_HOME e WP_SITEURL).
    Come già detto in precedenza ti conviene passare ad AlterBlog (così attivi https da un bottone e si spera tutto funzioni automaticamente).

    Per la seconda volta fai ciò che è scritto qui senza riscrittura https HTTPS non funzionante quando impostato il tutto inserisci la riscrittura https.
    Ultima modifica di darbula : 01-10-2020 alle ore 18.09.38

  12. #12
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Faccio delle domande perchè avevo capito, da quanto scritto da GraphOGLRisorse, ma posso aver mal interpretato, che per il mio Altersito con WP potevo seguire due strade :
    inserire codice nel file .htaccess come da Abilitare e forzare HTTPS nel proprio sito
    oppure installare il plugin 'Really simple ssl' in wp.

    Mi limito a descrivere quanto ho fatto:
    ho seguito la prima strada, però, me tapino, ho sbagliato e non ho sostituito <nome>.altervista.org con il <nome del mio sito>.altervista.org nel codice da inserire in .htaccess, ho corretto, ma ho questi risultati:
    digito imagoweb.altervista.org e mi viene restituita pagina nome.altervista.org con scritto 'Impossibile raggiungere il sito'
    digito imagoweb.altervista.org/wp-admin e mi viene resituita pagina nome.altervista.org/wp-admin con scritto 'Impossibile raggiungere il sito' e così non riesco ad accedere al pannello di controllo di WP del mio sito.

    Ecco perchè ho fatto quelle domande.

    In conclusione, con un po' di timore, devo chiedervi:
    - cosa faccio per risolvere il problema sopraesposto?
    - perchè il codice
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} off
    RewriteRule .* https://nome.altervista.org%{REQUEST_URI} [L,R=301]
    posto in .htaccess, dopo averlo corretto, non funziona?

    Confido nella vostra comprensione.

    Vi prego di tenere conto che c'è una certa difficoltà nell'esporre i problemi e i quesiti.

    Sentitamente ringrazio.
    Ultima modifica di imagoweb : 01-10-2020 alle ore 18.45.53

  13. #13
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Il problema non è come ti esponi ma ciò che comprendi. Non devi forzare in https, cosa non ti è chiaro su questo?
    Attiva il plugin, abilita ssl dal plugin e per dinci non scrivere mai alcun Redirect al file .htaccess.
    Potrai scrivere la riscrittura https solo dopo che te lo dirò io.

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Il redirect (o riscrittura), a me risulta correttamente funzionante, anche per wp-admin.
    Non funziona così per WordPress cioè leggi che sta effettuando erroneamente il redirect in http https://imagoweb.altervista.org/wp-l...in%2F&reauth=1 mentre con il plugin Really simple ssl attivato e abilitando ssl dal plugin sarà con https e riscrivera in https anche le altre url.
    Ultima modifica di darbula : 01-10-2020 alle ore 19.51.45

  14. #14
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,236

    Predefinito

    Il redirect (o riscrittura), a me risulta correttamente funzionante, anche per wp-admin.

    Ha provato anche dopo aver aggiornato la cache dal browser?

    Cordiali saluti.
    Ultima modifica di GraphOGLRisorse : 01-10-2020 alle ore 19.39.37

  15. #15
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    mi scusi, non capisco che cosa mi ha risposto. Ammesso che io non comprenda lei non ha risposto alle mie domande. Se rispondesse invece di dire che non comprendo sarebbe meglio per tutti.

  16. #16
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Il problema non è come ti esponi ma ciò che comprendi. Non devi forzare in https, cosa non ti è chiaro su questo?
    Attiva il plugin, abilita ssl dal plugin e per dinci non scrivere mai alcun Redirect al file .htaccess.
    Potrai scrivere la riscrittura https solo dopo che te lo dirò io.
    Perdinci, ma se rispondi così vuol dire che non hai letto le mie domande. Non riesco ad accedere alpannello di controllo di WP.

  17. #17
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Purtroppo non puoi forzare il redirect in WordPress devi prima installare e abilitare SSL dal plugin Really simple ssl e lui imposterà WordPress in https altrimenti rimarrai bloccato... dopo questa procedura puoi inserire il codice di redirect nel file .htaccess però è meglio che lo fai solo quando ti dirò io di farlo.
    Ho esaurito i metodi per indicarti per tre volte sempre la stessa cosa.
    Ciò significa per WordPress esiste quest'unica strada e non la riscrittura in https.
    Ultima modifica di darbula : 01-10-2020 alle ore 19.44.10

  18. #18
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Il redirect (o riscrittura), a me risulta correttamente funzionante.

    Ha provato anche dopo aver aggiornato la cache dal browser?

    ordiali saluti.
    Ok, ho capito, grazue. Ho cancellato la cache del browser. Perfetto, adesso digitando imagoweb.altervista.org vedo il sito. Però nonstante risulti il protocollo https sulla barra degli indirizzi appare 'non sicuro' in grigio. Questo non lo capisco. Inoltre mi appare un pannello di login di WP diverso dal consueto e non riesco ad accedere a WP pur immettendo nome utente e password.

  19. #19
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,236

    Predefinito

    Visualizza dei messaggi di errore o altro quando tenta il login?

    ordiali saluti.

  20. #20
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    Visualizza dei messaggi di errore o altro quando tenta il login?

    ordiali saluti.
    https://imagoweb.altervista.org/wp-l...in%2F&reauth=1 quando il protocollo https ma nella query string visualizzi http al posto di https significa che Wordpress usa ancora http mentre con il plugin Really simple
    ssl sarà configurato automaticamente per https.
    Ultima modifica di darbula : 01-10-2020 alle ore 19.57.15

  21. #21
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    https://imagoweb.altervista.org/wp-l...in%2F&reauth=1 quando il protocollo https ma nella query string visualizzi http al posto di https significa che Wordpress usa ancora http mentre con il plugin Really simple
    ssl sarà configurato automaticamente per https.
    ringrazio tutti dell'aiuto, quindi rispondo a tutti e due:

    - nella anomala pagina di login inserisco credenziali premo login e tutto si azzera

    - ho visto che nella query string c'è http e non https, quindi non ho capito (al solito), ma ho intuito (almeno).

    Quindi cosa facciamo ?

  22. #22
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,236

    Predefinito

    darbula lo sò, ma prima, quando avevo provato, il redirect da http a https avvevuiva sia per il sito che per il pannello di WordPress del login.

    Imagoweb prima aveva la riscrittura da .htacess e adesso l'ha tolta, come menzionava darbula?

    Al momento, ha attivo il plugin Really simple?

    Scusi se le faccio altre domande anzichè risponderle, ma prima vorrei avere chiara la sua situazione attuale.

    ordiali saluti.
    Ultima modifica di GraphOGLRisorse : 01-10-2020 alle ore 20.20.13

  23. #23
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    darbula lo sò, ma prima, quando avevo provato, il redirect da http a https avvevuiva sia per il sito che per il pannello di WordPress del login.

    Imagoweb prima aveva la riscrittura da .htacess e adesso l'ha tolta, come menzionava darbula?

    Al momento, ha attivo il plugin Really simple?

    Scusi se le faccio altre domande anzichè risponderle, ma prima vorrei avere chiara la sua situazione attuale.

    ordiali saluti.
    Attualmente ho aggiunto il codice consigliato in .htaccess e non ho attivo il Plugin Really Simple.

    Anche perchè non riesco ad accedere al pannello di WP
    Ultima modifica di imagoweb : 01-10-2020 alle ore 20.32.44

  24. #24
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Citazione Originalmente inviato da GraphOGLRisorse Visualizza messaggio
    darbula lo sò, ma prima, quando avevo provato, il redirect da http a https avvevuiva sia per il sito che per il pannello di WordPress del login.

    Imagoweb prima aveva la riscrittura da .htacess e adesso l'ha tolta, come menzionava darbula?

    Al momento, ha attivo il plugin Really simple?

    Scusi se le faccio altre domande anzichè risponderle, ma prima vorrei avere chiara la sua situazione attuale.

    ordiali saluti.
    Il redirect avveniva in https ma la query string era sempre in http... significa Wordpress non configurato per https la url corretta sarebbe http://imagoweb.altervista.org/wp-lo...in%2F&reauth=1 (con query string quella dopo ? In https).
    @imagoweb se davvero vuoi risolvere togli il redirect https nel tuo file .htaccess e usa il plugin really simple ssl.
    Ultima modifica di darbula : 01-10-2020 alle ore 20.44.16

  25. #25
    GraphOGLRisorse è connesso ora AlterGuru
    Data registrazione
    14-02-2015
    Messaggi
    1,236

    Predefinito

    A me attualemte risulta fare il redirect se cerco dicaricare la versione http del sito.

    Riguardo il pannelo di wp, ha provato col link ho dimenticato la password, a vedere se riesce ad accedere?

    ordiali saluti.
    Ultima modifica di GraphOGLRisorse : 01-10-2020 alle ore 20.47.16

  26. #26
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Signor @imagoweb le comunico il metodo b.
    Esegua una copia del suo wp-config.php inserisca tale codice
    Codice PHP:
    $_SERVER['HTTPS'] = 'on';
    define('WP_HOME''https://imagoweb.altervista.org');
    define('WP_SITEURL''https://imagoweb.altervista.org'); 
    Dal suo browser con il protocollo https provi adesso il login. Se poi installa il plugin Really simple ssl può togliere il codice precedentemente inserito nel wp-config.php.
    Il plugin riscrive le url in https per te e imposta la url del sito in https.
    Ultima modifica di darbula : 02-10-2020 alle ore 14.33.41

  27. #27
    imagoweb non è connesso Neofita
    Data registrazione
    28-09-2020
    Messaggi
    14

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    Signor @imagoweb le comunico il metodo b.
    Esegua una copia del suo wp-config.php inserisca tale codice
    Codice PHP:
    $_SERVER['HTTPS'] = 'on';
    define('WP_HOME''https://imagoweb.altevista.org');
    define('WP_SITEURL''https://imagoweb.altevista.org'); 
    Dal suo browser con il protocollo https provi adesso il login. Se poi installa il plugin Really simple ssl può togliere il codice precedentemente inserito nel wp-config.php.
    Il plugin riscrive le url in https per te e imposta la url del sito in https.
    Perdindirindina grazie, questo codice funziona (ovviamente una volta corretto altevista in altervista). Adesso accedo a tutto e con https.
    Grazie ancora.
    A tutti.
    Ultima modifica di imagoweb : 02-10-2020 alle ore 13.44.48

  28. #28
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Figurati però normalmente occorre il metodo A, senza riscrittura https e con il plugin really simple ssl si abilita https e poi si aggiunge la riscrittura https nel file.htaccess.

  29. #29
    Data registrazione
    02-03-2018
    Residenza
    Oriolo romano (Viterbo)
    Messaggi
    2

    Predefinito

    Buongiorno,
    ho un problema per configurare il mio sito in 'HTTPS' realizzato con alterpages, anche attivando CloudFlare. Cosa devo fare ?
    grazie..
    Renato

  30. #30
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    2,081

    Predefinito

    Signor @fimcislromarieti AlterPages è un vecchio applicativo che non viene più aggiornato, le consiglio di creare un nuovo account AlterBlog con wordpress preinstallato da altervista così da prendere confidenza con le molteplici funzionalità e nonché il supporto https con un click e spazio e banda illimitati.
    Il suo sito è già fruibile in https ma AlterPages non tiene conto del protocollo https, quindi la invito nuovamente nel creare un nuovo account in cui si può sbizzarrire con WordPress (al momento non trasformare il tuo AlterSito in AlterBlog ma appunto prova con un nuovo account se ti piace WordPress).
    Per ulteriori informazioni può chiedere qui sul forum, preferibilmente apra una nuova discussione (poiché non più pertinente al titolo e le ho spiegato il motivo per cui AlterPages non funziona con https), mi dispiace non esiste https per AlterPages.
    Ultima modifica di darbula : 02-10-2020 alle ore 19.02.14

Pagina 1 di 2 12 UltimoUltimo

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •