Visualizzazione risultati 1 fino 7 di 7

Discussione: Problema installazione Magic SEO URL per phpBB3

  1. #1
    plettrattiglio non è connesso Neofita
    Data registrazione
    10-10-2013
    Messaggi
    4

    Predefinito Problema installazione Magic SEO URL per phpBB3

    Buona sera.
    Ho tentato di installare la Magic SEO URL (software a pagamento), su un forum phpBB3 (versione 3.2.3 RC1) qui su Altervista.
    Mi appare questo messaggio di errore:


    Codice:
    [phpBB Debug] PHP Notice: in file [ROOT]/includes/magic_seo_url.php on line 17: Use of undefined constant MSU_REQUEST_URI - assumed 'MSU_REQUEST_URI'
    
    
    The Inveo Magic SEO URLs module requires at least one of the following PHP loaders:
    
    Zend Guard Loader for PHP 5.6 (64 bit) is available without charge at www.zend.com/products/loader/downloads.
    
    ionCube Loader (64 bit) is available without charge at www.ioncube.com/loaders.php.
    
    Inveo can assist you with loader installation on shared, VPS or dedicated servers. Should you need any help, feel free to contact us!
    Ho contattato il loro supporto tecnico, e mi hanno riferito che Altervista, in passato, aveva attivato tale modulo, ma su php 5.3 Extras; ma non posso fare girare phpBB 3.2.3, su quella versione di php.

    Pertanto, per favore, è possibile attivare Zend Guard Loader for PHP 5.6 (64 bit) e ionCube Loader (64 bit) come standard Altervista o come Voi ritenete più opportuno? Se c'è questa possibilità, con quali tempi?

    Grazie.
    Ultima modifica di plettrattiglio : 04-06-2018 alle ore 22.15.59

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,555

    Predefinito

    È stata presa in considerazione la tua richiesta e verrà aggiunto all'engine php nei prossimi aggiornamenti, ma non so dirti nulla riguardo alle tempistiche.

    Ciao!

  3. #3
    plettrattiglio non è connesso Neofita
    Data registrazione
    10-10-2013
    Messaggi
    4

    Predefinito

    Ringrazio Altervista per la disponibilità espressa. Mi rendo conto che può essere complicato dare delle tempistiche. Confido nel fatto, che la nuova funzionalità, quando resa disponibile, sarà ampiamente pubblicizzata; anche tramite newsletter. A quanto mi risulta, nell'ambito del phpBB3, non sono il solo a voler-dovere usare questa estensione SEO, che richiede le citate librerie. Dovere, perché "al momento", non esistono alternative stabili. Ed è un "momento", che si protrae da svariati mesi, da anni, praticamente, con estensioni SEO, perennemente in Beta.
    Grazie.

  4. #4
    plettrattiglio non è connesso Neofita
    Data registrazione
    10-10-2013
    Messaggi
    4

    Predefinito

    Buona sera.
    Al fine di agevolare il lavoro e la disponibilità di Altervista, Vi informo di quanto sono riuscito a mettere a fuoco nelle ultime 24-48 ore..

    1 - È sufficiente che sia presente solo una delle due librerie, e non entrambe.
    2 - Funziona anche con il php 7, a condizione che sia presente una delle due librerie.

    A me qui su AV, era apparso quel messaggio di errore, perché stavo usando il php 5.6. Ma presso altro host, sono riuscito ad installarla correttamente in prova, con questi requisiti:

    - php 7.1.13
    - ionCube Loader (64 bit)

    Grazie.

  5. #5
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,555

    Predefinito

    Grazie, già eravamo al corrente ed è stato preso in considerazione solamente ionCube:
    The Inveo Magic SEO URLs module requires at least one of the following PHP loaders:
    Ciao!

  6. #6
    plettrattiglio non è connesso Neofita
    Data registrazione
    10-10-2013
    Messaggi
    4

    Predefinito

    Immaginavo che Voi lo sapeste... ma per come avevo scritto il primo post, avrei potuto indurre in errore i lettori del Vostro Forum.
    Ho preferito rendere tutto corretto ed esplicito.

    Grazie.

  7. #7
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,555

    Predefinito

    Hai fatto benissimo

    Farò sapere quando ci saranno aggiornamenti.

    Ciao!

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •