Visualizzazione risultati 1 fino 28 di 28

Discussione: https risulta attivo ma non funziona

  1. #1
    nisinatura non è connesso Neofita
    Data registrazione
    10-02-2016
    Messaggi
    5

    Predefinito https risulta attivo ma non funziona

    Buongiorno, ho aggiornato grafica e contenuti del sito, e disattivato e riattivato l'https.
    Dal pannello altervista adesso l'https risulta essere attivo ma quando apro il sito all'indirizzo https://nisinatura.ssl.altervista.org/ la pagina non è raggiungibile perché mi dice che l'https non è attivo,
    C'è un modo di risolvere questo problema? grazie
    Ultima modifica di nisinatura : 12-03-2017 alle ore 11.25.06

  2. #2
    L'avatar di darkwolf
    darkwolf non è connesso Super Moderatore
    Data registrazione
    18-04-2007
    Residenza
    Reggiolo (RE)
    Messaggi
    6,552

    Predefinito

    Il tuo https è qui: https://nisinatura.altervista.org/
    » Salvatore Noschese - L'AltroWeb | Seguimi su: facebook | twitter | Google+
    # Che aspetti? Unisciti alla community! Tanti nuovi gruppi ti aspettano


  3. #3
    nisinatura non è connesso Neofita
    Data registrazione
    10-02-2016
    Messaggi
    5

    Predefinito

    Grazie mille!!!
    ora però il problema è che google ha indicizzato la versione con .ssl.

  4. #4
    Data registrazione
    23-12-2017
    Messaggi
    4

    Predefinito HTTPS Non Funziona

    Buongiorno
    Ho attivato il servizio https da circa un mese, ormai, e siccome esso non funzionava, quando avveniva la connessione al sito, l'ho disattivato e riattivato diverse volte. Nonostante io abbia eseguito questa operazione, il servizio https continua a non funzionare.
    L'URL del sito è http://www.bookingbreakfast.altervista.org

    Vorrei sapere il motivo e il metodo di risoluzione di questo malfunzionamento, e se potrei avere un'assistenza diretta da voi.

    Grazie

  5. #5
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Ciao, purtroppo ancora non è abilitato cloudflare sul tuo sito , procedi in questa maniera "DAL PANNELLO ALTERVISTA" attiva cloudflare o disattiva e riattiva cloudflare e poi https...
    Qui è un forum di supporto e solo in rare occasioni interviene lo staff.. Mi dispiace purtroppo nessuno può prometterti assistenza..

  6. #6
    Data registrazione
    23-12-2017
    Messaggi
    4

    Predefinito Non so se il servizio https funzionerà

    Cloudfire è ora attivo e ho attivato il servizio https, che si attiverà nell'arco di 24 ore. Ma so che, molto probabilmente, il servizio https non funzionarà quando mi connetterò al sito.
    Se si ripete ancora tale problematica, come mi dovrò comportare?
    URL sito: http://www.bookingbreakfast.altervista.org/

  7. #7
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,858

    Predefinito

    Citazione Originalmente inviato da BookingBreakfast Visualizza messaggio
    Se si ripete ancora tale problematica, come mi dovrò comportare?
    Se ancora non avrà https segnalalo qui.

    Ciao!

  8. #8
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Ti informo che cloudflare è attivo e con https abilitato.. https://www.bookingbreakfast.altervista.org/ inoltre ti ricordo che il certificato è valido per bookingbreakfast.altervista.org o www.bookingbreakfast.altervista.org attualmente altri sottodomini non usufruiscono di CloudFlare sia per https che http
    Ultima modifica di darbula : 04-02-2018 alle ore 18.47.11

  9. #9
    outer non è connesso Neofita
    Data registrazione
    05-02-2018
    Messaggi
    3

    Predefinito

    Buonasera, ho un problema simile, solo che a me dà ancora come messaggio, nonostante siano passati due giorni, "HTTPS in fase di attivazione". Che posso fare?
    Url sito: https://outer.altervista.org
    Grazie mille in anticipo!

  10. #10
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Sembra esserci un problema con il tuo https... Attiva o disattiva e riattiva https (per i piani free il certificato deve essere abilitato entro 24 ore se supera tale data apri un ticket su CloudFlare oppure riscivi qui)..
    Cmq. nella versione http vedo un Fatal error (questo non incide con CloudFlare)
    Ultima modifica di darbula : 07-02-2018 alle ore 19.14.21

  11. #11
    outer non è connesso Neofita
    Data registrazione
    05-02-2018
    Messaggi
    3

    Predefinito

    Ieri ho provato a fare come mi hai detto e ho anche disattivato e riattivato il cloudflare...nada, mi dà ancora lo stesso messaggio. Ma è un problema di altervista o di cloudflare? E cosa potrei fare altrimenti?

  12. #12
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    10,858

    Predefinito

    Io non vedo nulla nel tuo sito. Ricevi qualche errore se provi collegandoti nel pannello di controllo?

    Ciao!

  13. #13
    outer non è connesso Neofita
    Data registrazione
    05-02-2018
    Messaggi
    3

    Predefinito

    Dal pannello non ricevo alcun errore, anzi, posso gestire i file all'interno senza problemi. Io principalemnte avevo bisogno dell'account per programmare un bot di telegram, solo che a causa dell'https non abilitato (credo), l'errore che ricevo per la comunicazione di questo bot è il seguente :

    {"url":"https://outer.altervista.org/OUTerUnicycle_bot/index.php","has_custom_certificate":false,"pending _update_count":0,"last_error_date":1518076832,"las t_error_message":"SSL error {336151568, error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure}","max_connections":40}}

    E non è che ci capisca molto, ma credo che la causa sia proprio questa mancanza del protocollo ssl che non mi permette di comunicare con il bot...

  14. #14
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Si e no... Devi attivare https per il webhook e devi passare a MySQL 5.6 (per togliere l'errore di curl)..
    Vai sul sito https://www.cloudflare.com/a/forgot-password inserisci il tuo alias tuo_nome_utente@altervista.org in website tuo_nome_utente.altervista.org metti la spunta al captcha e ti arrivera un emeail, poi accedi a questo account e gli invii un feedback..
    Ultima modifica di darbula : 09-02-2018 alle ore 13.31.48

  15. #15
    Data registrazione
    23-12-2017
    Messaggi
    4

    Predefinito

    Quando io mi connetto al mio sito, scrivendo www.bookingbreakfast.altervista.org, il browser mi fa connettere con la versione non protetta, quindi con il protocollo http, invece di farmi connettere con la versione protetta dal protocollo https. Inoltre devo scrivere nella barra degli indirizzi del browser "https://www.bookingbreakfast.altervista.org" per connettermi con la versione protetta e sicura del sito.
    Vorrei sapere il motivo di questo strano funzionamento, e se il servizio https è realmente attivo e funzionante per il sito www.bookingbreakfast.altervista.org

  16. #16
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Se non specifichi il protocollo il browser applica http..
    Per visualizzare il tuo sito in https://www.bookingbreakfast.altervista.org/ mentre io mi riferivo che il certificato è abilitato per il dominio di terzo livello https://bookingbreakfast.altervista.org/ o il sottodominio di terzo livello (detto anche dominio di quarto livello) https://www.bookingbreakfast.altervista.org/
    Se vuoi tramite htaccess puoi forzare sempre in https.. però il sito https non è fruibile per i vecchi browser senza supporto SNI
    Ultima modifica di darbula : 12-02-2018 alle ore 19.57.24

  17. #17
    Data registrazione
    23-12-2017
    Messaggi
    4

    Predefinito

    Cosa devo fare per forzare l'https utilizzando l'httaccess?

  18. #18
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Da Impostazioni Php e clicca Modifica sorgente .htaccess (Avanzato) inserisce una nuova regola htaccess con il codice seguente
    Codice:
    RewriteEngine on
    RewriteBase /
    RewriteCond %{HTTP_HOST} !^www\.bookingbreakfast\.altervista\.org$ [NC,OR]
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteRule .* https://www.bookingbreakfast.altervista.org%{REQUEST_URI} [R=301,L]
    Questo codice controlla che sia il dominio di quarto livello e che usi htpps altrimenti fa il redirect in https... Tale codice deve essere posto esattamente prima di tutti gli altri.. Ovviamente se già fosse presente RewriteEngine RewriteBase deve inserire solo le righe successive che vede nel codice di esempio..
    Nota* si consiglia da fare un backup del suo file .htaccess prima che effettua modifiche..

  19. #19
    scopaelettrica non è connesso Neofita
    Data registrazione
    09-12-2017
    Messaggi
    2

    Predefinito

    Salve, anche io ho problemi con il protocollo ssl. Ho attivato Cloudflare e https ma non funzione la versione "sicura" del mio sito.

    L'indirizzo è questo: http://scopaelettrica.altervista.org/

    Mi potete aiutare per favore?

  20. #20
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Buonasera, si certamente..
    Lei utilizza WordPress preinstallato o Alterblog .. dal pannello amministrazione WordPress Impostazioni-https lo abiliti.. Ci tenga aggiornati.

  21. #21
    scopaelettrica non è connesso Neofita
    Data registrazione
    09-12-2017
    Messaggi
    2

    Predefinito

    Ottimo! Grazie! Adesso funziona.

  22. #22
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Ottimo sono contento per te :)

  23. #23
    foxspeakspro999 non è connesso Neofita
    Data registrazione
    03-05-2017
    Messaggi
    3

    Predefinito

    Buongiorno,
    il servizio https risulta in attivazione da diversi giorni.
    Ho attivato prima CloudFlare, e successivamente richiesto l'attivazione di https che però non sembra essere andata a buon fine.
    In particolare aprendo il sito da Chrome la pagina viene segnalata come "non sicura", nonostante abbia rimosso tutti i riferimenti http dal codice, e questo causa tra l'altro il blocco del microfono.
    Come posso fare una verifica per sapere se l'attivazione è in corso o c'è qualche altro problema?
    Grazie mille anticipatamente.

  24. #24
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Se non ci sono problemi il servizio si attiva entro 24-48 ore..altrimenti c'è un problema.
    Fai riferimento qui per conoscere che dati utilizzare per il recupero della password https://www.cloudflare.com/ leggi qui https risulta attivo ma non funziona
    Facci sapere

  25. #25
    foxspeakspro999 non è connesso Neofita
    Data registrazione
    03-05-2017
    Messaggi
    3

    Predefinito

    Ok problema risolto.
    Ho cambiato la password di CloudFlare come da istruzioni, e una volta effettuato l'accesso al pannello di controllo ho modificato le impostazioni presenti nella sezione Crypto, impostando SSL = Flexible (prima era su OFF) e Always use HTTPS = ON (prima era su OFF).
    Non so se la configurazione da me impostata sia corretta, in ogni caso ora il sito viene rilevato da Chrome come sicuro (lucchetto verde nella barra degli indirizzi) e i problemi di autorizzazione prima riscontrati sono spariti.
    Grazie infinite per la tempestività e l'utilità dell'assistenza, buon lavoro.

  26. #26
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    @foxspeakspro999 buonasera,
    Si le impostazioni sono corrette .. Flexible SSL significa che il visitatore vedrà https, mentre Always Use HTTPS indica che CloudFlare fornirà solo https per il tuo sito..
    Quando modifichi qualcosa fai molta cura in quello che fai, alcune impostazioni non sono supportate da altervista (rimedio fai il contrario di quello attivato o disattiva cloudflare direttamente dal pannello che fornisce altervista e non altri.. Cmq. Sia il tuo sito non verrà cancellato ma nel peggiore dei casi non sarà accessibile)..
    Espengo una mia nota personale, forzare via htaccess è meglio (perché altrimenti si può bypassare CloudFlare).
    Ultima modifica di darbula : 16-02-2018 alle ore 23.49.25

  27. #27
    foxspeakspro999 non è connesso Neofita
    Data registrazione
    03-05-2017
    Messaggi
    3

    Predefinito

    Citazione Originalmente inviato da darbula Visualizza messaggio
    @foxspeakspro999 buonasera,
    Si le impostazioni sono corrette .. Flexible SSL significa che il visitatore vedrà https, mentre Always Use HTTPS indica che CloudFlare fornirà solo https per il tuo sito..
    Quando modifichi qualcosa fai molta cura in quello che fai, alcune impostazioni non sono supportate da altervista (rimedio fai il contrario di quello attivato o disattiva cloudflare direttamente dal pannello che fornisce altervista e non altri.. Cmq. Sia il tuo sito non verrà cancellato ma nel peggiore dei casi non sarà accessibile)..
    Espengo una mia nota personale, forzare via htaccess è meglio (perché altrimenti si può bypassare CloudFlare).
    Grazie ancora per la disponibilità.
    Ho letto sopra come modificare htaccess. Se ho capito bene quindi lascio le modifiche a CloudFlare che ho effettuato e aggiungo al file htaccess il codice riportato sopra. E' corretto?

  28. #28
    darbula non è connesso AlterGuru
    Data registrazione
    24-04-2011
    Messaggi
    1,563

    Predefinito

    Si puoi semplicemente copiare quello

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •