Visualizzazione risultati 1 fino 22 di 22

Discussione: Errore 500 dopo ripristino database

  1. #1
    Guest

    Predefinito Errore 500 dopo ripristino database

    Salve,
    nella notte (dopo il salvataggio del database automatico) ho provato a passare da D6 a D7...quando ho visto che non c'era qualche problema, ho deciso di tornare indietro come detto con il backup di altervista.

    Appena ripristinato il tutto (database e spazio web), il sito non è più andato ridandomi un errore di questo genere



    [Lo stesso problema si ripropone anche se provo a ripristinare altri vecchi salvataggi]

    E' possibile che non c'è modo di risolvere questo problema?

    Grazie...

    Il sito è http://frenckcinema.altervista.org

  2. #2
    Guest

    Predefinito

    Aggiungo che ho provato a fare l'update e questo è il risultato:


  3. #3
    Guest

    Predefinito

    Dopo 20 minuti la situazione è questa (non ho fatto alcuna modifica nel frattempo)


  4. #4
    Guest

    Predefinito

    Questa invece la situazione dell'update


  5. #5
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Esattamente a che ora hai fatto l'upgrade?
    Gianluca

  6. #6
    Guest

    Predefinito

    Ciao Gianluca...
    allora il salvataggio automatico è impostato per le 4:30 circa ogni giorno....io ho messo la sveglia alle 5 ed ho iniziato a quell'ora .... ora il sito da pagina 404

  7. #7
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    Non c'è un orario preciso per il backup, generalmente avviene tra le 4 e le 8 del mattino, molto probabilmente hai eseguito l'upgrade mentre la generazione del backup era in corso.

    Per adesso il traffico verso il sito è stato bloccato, stiamo verificando la situazione pur non potendoti dare garanzie sull'effettivo ripristino, nel frattempo non eseguire alcuna operazione sul database.
    Gianluca

  8. #8
    Guest

    Predefinito

    si, ma perchè neppure quelli del giorno prima possono essere ripristinati? (ho già provato ed il problema resta lo stesso), hai dato un'occhiata agli screenshot che ti ho inviato?

  9. #9
    Guest

    Predefinito

    Ti aggiungo un piccolo particolare....dopo aver fatto l'upgrade a D7 ho installato il modulo Ckeditor ma qsti nn funziona con il formato testo Full HTMl...la mia mossa è stata quella di (disattivare) questo formato di testo per far si che coloro che scrivono sul sito potessero utilizzare di base Filtered Html...(l'unico approvato da ckeditor)...il risultato è stato che full html è stato cancellato e con esso tutti gli articoli scritti in passato con qsto formato (mossa stupida)... Questo è stato il motivo della decisione di ripristinare D6, avrei poi ripetuto l'upgrade senza fare quell'errore....ma il ripristino non è avvenuto...

    Potrebbe essere d'aiuto?

  10. #10
    Guest

    Predefinito

    Gianluca o chi altri, ma una qualsiasi informazione sulla situazione?
    Il mio è un sito da 1000 visite al giorno, non un big blog, ma con buon seguito e buone potenzialità, vorrei almeno capire se ci state lavorando su oppore no.

  11. #11
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    frenckcinema:

    come hai notato anche tu nessuno dei 7 snapshot disponibili risolve il problema, lo abbiamo verificato provando il ripristino di ciascuno di essi, in concomitanza con il ripristino dello spazio web.
    Non è chiaro il motivo per cui il problema non si sia ripresentato prima di ieri, considerando appunto che gli snapshot precedenti, che sono una copia esatta del sito nel momento in cui vengono creati, ne sono ugualmente interessati.

    Hai a disposizione un backup alternativo, magari molto più vecchio, che puoi provare a ripristinare?
    Gianluca

  12. #12
    Guest

    Predefinito

    No Gianluca, mi sono sempre affidato al backup di altervista (pagato all'inizio dell'anno oltre 20 euro), tanto è vero che la settimana scorsa avevo fatto lo stesso percorso (tornando indietro con backup giorno prima) con risultati soddisfacenti...

  13. #13
    Guest

    Predefinito

    Ma invece di ripristinare i backup, non è possibile risolvere gli errori segnalati all'interno degli screenshot scusa... Cliccando update vengono tutti fuori.... Oppure se provassi a passare a D8 (ho gia provato con D7 ma nulla)

  14. #14
    Guest

    Predefinito

    Se ci fai caso, la maggior parte degli errori riscontrati da update è inerente ai temi....

  15. #15
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    frenckcinema:

    Ma invece di ripristinare i backup, non è possibile risolvere gli errori segnalati all'interno degli screenshot scusa... Cliccando update vengono tutti fuori.... Oppure se provassi a passare a D8 (ho gia provato con D7 ma nulla)
    Questo è esattamente quanto abbiamo fatto, ogni snapshot è stato ripristinato e il relativo database sottoposto a check per individuare ed eliminare eventuali errori, testando poi se l'operazione avesse o meno risolto il problema, per questo motivo il traffico verso il tuo sito è stato bloccato per circa 4 ore, tempo che è stato necessario per questo lavoro.

    Il database attuale non presenta errori, come puoi verificare da phpmyadmin, questo non esclude però eventuali problemi con la consistenza dei dati, dal momento che hai eseguito nel tempo successivi tentativi di upgrade e downgrade dell'applicativo.

    Quello che ti consiglio di provare a fare è:

    1) Farti un dump della base dati attuale da phpmyadmin, magari splittato per tabella o gruppi di tabelle in modo da poterle ripristinare anche individualmente
    2) Aprire un altro account e installare una copia pulita di drupal della medesima versione che stai usando
    3) Fare un dump da quella nuova copia delle tabelle system e user (dove venivano segnalati errori)
    4) Adattare i contenuti del dump di quelle due tabelle alla vecchia installazione di drupal
    5) Ricaricarle nella vecchia installazione


    Guarda anche: http://davidherron.com/content/drupal-disaster-recovery-backup-and-migrate-module
    Ultima modifica di Gianluca : 30-01-2016 alle ore 19.26.30

  16. #16
    Guest

    Predefinito

    Ho contattato un webmaster esperto per seguire i passi descritti.....ma purtroppo le tabelle corrotte erano davvero troppe, tra queste quella fondamentale user...se non Ci sono altre strade da intraprendere, la mia esperienza su Altervista finisce qui....dopo 6 anni e oltre 2,5 milioni di pagine scaricate....

    Sinceramente speravo in un supporto maggiore dopo tanti anni da Altervista, invece mi sono ritrovato un backup che invece di aiutare, mi ha danneggiato, mie alcune colpe di sicuro, ma speravo in un aiuto maggiore...

    Da domani inizierò una nuova esperienza con dominio di proprietà su Aruba

    A presto

  17. #17
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    frenckcinema:

    mi rincresce leggere quanto scrivi dal momento che poco dopo la tua richiesta (alle 9 di Sabato mattina) è stata allocata una persona che ha lavorato senza stop per 4 ore consecutive per tentare di sistemare il tuo sito, gratis.

    Tutto questo è ovviamente al di fuori dei compiti di un hosting provider ed è stato fatto per te proprio alla luce dell'anzianità del tuo sito.

    Un'operazione del genere su un sito che già in passato si era rivelata problematica si sarebbe dovuta testare prima su un clone, o un altro account o in locale e solo dopo ripetuta in produzione, a costo di mettere per qualche ora il sito in manutenzione.
    Se tu prima avessi chiesto supporto ti avremmo dato una mano almeno nelle operazioni di clonazione / dump in locale del sito.

    In ogni caso se posti un indirizzo email valido (o confermi che ancora lo è quello associato al tuo account) siamo disponibili a contattarti per qualche ulteriore ragguaglio.

  18. #18
    Guest

    Predefinito

    l'indirizzo è confermato

  19. #19
    Guest

    Predefinito

    Gianluca comunque ho apprezzato che sabato mattina qualcuno si è adoperato sul sito, ma ciò non avrebbe proprio dovuto accadere visto che giusto la settimana scorsa avevo aperto un topic dove parlavo di problemi di aggiornamento da D6 a D7....tra l'altro ho usufruito del servizio backup di Altervista (pagato oltre 20 euro) ..... rimanendo fregato....sono adirato scusami perchè ora dovrò ricominciare da zero per un disservizio (o servizio non funzionante) vostro (backup). avevo ragazzi che scrivevano per me, oltre 1000 visitatori al giorno, contatti con Universal, Warner e tutte le maggiori case di distribuzione italiane, nonchè il sito era Media Partner di festival nazionali di cinema..... ora dovrò ricominciare tutto da capo....

    Ora vorrei sapere solo una cosa...come faccio a cancellare ogni traccia del sito frenckcinema.altervista.org dal web....è snervante pensare che ciò che è stato perso per sempre sia ancora li sui motori, con la gente che continua a cliccarci su...inutilmente...

    Grazie

  20. #20
    L'avatar di Gianluca
    Gianluca non è connesso Amministratore
    Data registrazione
    15-02-2001
    Messaggi
    18,026

    Predefinito

    frenckcinema:

    tutto questo non è assolutamente imputabile ad un non corretto funzionanento del backup ma ad un problema di consistenza dei dati a monte e chiaramente visibile dagli screenshot che hai postato, il backup ha semplicemente salvato uno status già problematico in partenza.
    Il problema si sarebbe presentato ugualmente al primo riavvio del database server o anche al semplice flush delle tabelle interessate.

    Riguardo al topic ho trovato questo: Primo Passaggio a Drupal 7 da Drupal 6 fallito... ma non mi sembra molto attinente a quanto ti ho scritto prima.

    In ogni caso abbiamo fatto un ulteriore intervento sul sito che ha permesso di recuperare le due tabelle che ti ho citato, ovvero users e system, questo è stato possibile lavorando direttamente sui file binari corrispondenti alle relative tabelle. Allo stato attuale quindi la situazione dovrebbe permetterti di ricostruire il resto.

    In ogni caso se vuoi eliminare il sito ti basta seguire la procedura che trovi qui: https://aa.altervista.org/account-delete.php
    Gianluca

  21. #21
    Guest

    Predefinito

    Gianluca, forse non ci siamo capiti, io non imputo a voi il casino, però è anche vero che questo è accaduto a causa di un backup andato male (scusa il mio essere poco conoscente dell'ambiente, ma il backup non dovrebbe riportare il sito ad una copia precedente funzionante?)

    Cmq dopo aver speso soldi inutili per far ricostruire il tutto domenica, il tecnico aveva infatti riscontrato errori irreversibili nelle cartelle user e system, ora non posso (tra l'altro ho già acquistato un nuovo dominio di primo livello) spendere altri soldi, questo recupero delle tabelle User e System arrivano tardi direi...ringrazio, ma tardi..

    Io (lo ripeto da profano) ora ho semplicemente cancellato la copia vecchia di drupal ed inserito una nuova via ftp....il risultato puoi riscontrarlo da solo sia cliccando sulla home del sito che accedendo a update...

    Qui si ferma ciò che posso fare...

  22. #22
    Guest

    Predefinito

    Ci rinuncio sono tornato al backup di stanotte, grazie lo stesso

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •