Visualizzazione risultati 1 fino 3 di 3

Discussione: XAMP e versioni php

  1. #1
    Data registrazione
    03-09-2013
    Residenza
    Los Angeles
    Messaggi
    186

    Predefinito XAMP e versioni php

    Buonasera sono tornato chiedo
    Ho installato XAMP con Php 7, ma ho il codice in php5
    1 come posso collegare database di XAMP con php7 e file scritti con php5?
    2 se installo php5 e la inserisco nella cartella di xamp una buona idea?? Come posso far funzionare i file, in base al codice con cui gli ho scritti ossia in php5 e/o php7 ?

    3 se volessi portare file da Altervista in xamp e viceversa ?

    e grazie
    Ultima modifica di Aforismadelgiorno : 05-06-2018 alle ore 13.45.52

  2. #2
    L'avatar di alemoppo
    alemoppo non  connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    17,725

    Predefinito

    Se il codice scritto bene, dovrebbe funzionare sia con PHP7 che con PHP5. Le interazioni con il db se le hai fatte con le vecchie funzioni mysql_* ti suggerirei di riscriverle con mysqli_* in modo che il codice sia funzionante su entrambe le versioni.

    Ciao!

  3. #3
    Data registrazione
    03-09-2013
    Residenza
    Los Angeles
    Messaggi
    186

    Predefinito

    tutto scritto con mysql
    dovrei cambiare solo il nome aggiungendo una "i" o anche tutta la sintassi? Se salvo php5 nella cartella di xamp dove c anche php7 ?

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •