Visualizzazione risultati 1 fino 12 di 12

Discussione: La funzione controllo versione delle estensioni non funziona più.

  1. #1
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito La funzione controllo versione delle estensioni non funziona più.

    Da quando ho aggiornato alla phpBB3 v 3.2.8 in settembre, nel ACP la funzione controllo delle estensioni non funziona più, quasi come se il sistema non fosse più in grado di connettersi alle relative pagine per ottenere le risposte per procedere.

    (Il controllo della versione del sistema invece funziona).

    Parlando con altri membri della comunità phpbb.com mi è stato detto che nessuno di loro ha questo problema con la 3.2.8, quindi mi chiedo se non sia l'host AlterVista che filtra il traffico e forse blocca alcuni indirizzi.

    Normalmente quando tutto funzionava bene, quando facevo il controllo delle versioni delle estensioni (le stesse che ho tuttora), i numeri corrispondenti diventavano verdi o rossi a seconda se erano già attuali o no, ora invece non cambiano assolutamente, e se vado a verificare uno per uno ogni estensione per risposta ottengo "Failed to obtain latest version information" (il mio sito è in lingua inglese).

    Successivamente, dal pannello di AlterVista relativo alle impostazioni php nelle Connessioni Server to Server ho provato a cambiare l'impostazione da "Accesso esterno limitato ai domini in whitelist" a "Collegamento esterno senza restrizioni", ho aspettato più di mezz'ora e ho riprovato a fare i controlli sopra menzionati, ma il risultato è il medesimo.

    Ho anche provato a riaggionare il sistema con il pacchetto completo (quindi non con quello automatico).
    Ultima modifica di allabouthd500x : 01-12-2019 alle ore 23.15.35

  2. #2
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    15,601

    Predefinito

    Scusami per il ritardo; intendi in questa schermata la "versione corrente" non viene aggiornata?

    Ciao!

  3. #3
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito

    Si, è quella la schermata, anche se nel mio caso è in inglese..

    Aggiungo anche che se vado nei dettagli di ogni singola estensione ottengo questo messaggio: Failed to obtain latest version information.

    Se poi sempre dall'interno della schermata dettagli faccio il re-check (ri controllo) il risultato non cambia.

    Sono in contatto anche con membri ed esperti del forum di phpbb.com, e faranno anche loro dei controlli sui logs dei loro servers per capire perchè le richieste di versione delle estensioni che partono dal mio sito ricevono errore 410 (lo so in base al risultato di un debug fatto con un file "version_helper.php" modificato e utilizzato solo per fare questo specifico controllo, ora il file è già stato ripristinato con l'originale).

    So che il loro server con il quale si controlla la versione phpBB3 installata è diverso da quello dove si controllano le versioni delle estensioni.

    E come ho detto nel precedente messaggio, la versione phpBB3 viene controllata bene senza problemi, mentre il controllo delle versioni delle estensioni non funziona.

    C'è da dire anche che tra i membri del forum di phpbb.com al momento non ci sono altri che lamentano lo stesso problema, il che mi fa pensare che il blocco probabilmente non dipenda dai servers di phpbb.com, altrimenti altri pure lo avrebbero fatto notare.
    Ultima modifica di allabouthd500x : 04-12-2019 alle ore 21.25.32

  4. #4
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    15,601

    Predefinito

    Dopo i dovuti controlli, AlterVista invia correttamente le richieste al loro server.

    L'unico dettaglio che può influire, è che lo user agent impostato dall'applicazione viene sovrascritto da uno AlterVista.
    Se effettuano controlli sull'user-agent, molto probabilmente si tratta di questo problema.

    Ciao!

  5. #5
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito

    Ok, grazie della risposta.

    Riferirò quanto mi hai detto a quelli del forum phpbb.com.

    E poi farò sapere gli sviluppi.

  6. #6
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    15,601

    Predefinito

    Grazie, a presto.

    Ciao!

  7. #7
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito

    Citazione Originalmente inviato da alemoppo Visualizza messaggio
    Dopo i dovuti controlli, AlterVista invia correttamente le richieste al loro server.

    L'unico dettaglio che può influire, è che lo user agent impostato dall'applicazione viene sovrascritto da uno AlterVista.
    Se effettuano controlli sull'user-agent, molto probabilmente si tratta di questo problema.

    Ciao!
    Ciao, potresti dirmi per favore se il rimpiazzare l'user agent con uno AlterVista è una novità introdotta di recente, o se è sempre stato così?

    Come ho già detto, la funzione di controllo della versione delle estensioni ha sempre funzionato bene con le precedenti versioni phpBB3, è solo da quando ho installato l'ultima 3.2.8 che si è verificato il problema.

    Mi sono chiesto quindi se non sia una coincidenza tra la mia ultima installazione a fine settembre 2019 ed un cambio di funzionamento da parte di AlterVista avvenuto più o meno nello stesso periodo.

    EDIT:
    sempre per le indagini sui servers di phpbb.com mi è stato chiesto quale sia il nome del user agent di AlterVista che sovrascrive quello dell'applicazione. Potresti riferirmelo per cortesia?
    Ultima modifica di allabouthd500x : 05-12-2019 alle ore 17.46.34 Motivo: domanda aggiuntiva

  8. #8
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    15,601

    Predefinito

    Citazione Originalmente inviato da allabouthd500x Visualizza messaggio
    sempre per le indagini sui servers di phpbb.com mi è stato chiesto quale sia il nome del user agent di AlterVista che sovrascrive quello dell'applicazione. Potresti riferirmelo per cortesia?
    Così:
    Codice:
    <tuosito>.altervista.org/<tuo IP> (compatible; MSIE 7.0)
    Puoi verificarlo eseguendo ad esempio questo script:
    Codice PHP:
    <?php
    if(isset($_GET['u']))
        echo 
    $_SERVER['HTTP_USER_AGENT'];
    else
        echo 
    file_get_contents("http://$_SERVER[HTTP_HOST]$_SERVER[REQUEST_URI]?u=1");
    Ciao!
    Ultima modifica di alemoppo : 05-12-2019 alle ore 22.45.36

  9. #9
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito

    Ok, grazie mille..

    Sai dirmi anche se il sovrascrivere l'user agent dell'applicazione con uno AlterVista è una novità introdotta di recente, o se è sempre stato così?

  10. #10
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito

    Aggiornamento importante e nuova richiesta!

    Dalle ultime indagini fatte con l'aiuto degli esperti di phpbb.com e grazie anche al tuo aiuto "alemoppo" ho avuto finalmente la conferma che il problema oggetto di questo thread è dovuto infatti proprio al user agent che AlterVista aggiunge alle richieste di verifica delle versioni installate delle estensioni.

    E' stato dimostrato che il loro server Titania (preposto anche al controllo delle versioni delle estensioni) rifiuta le query con la versione "MSIE" nel User-Agent impostata su un valore inferiore a 9.0, quindi l'user agent AlterVista contenendo MSIE alla versione 7.0 causa il rifiuto del loro server che risponde con errore 410.

    Inoltre questo limite sul user agent è stato da loro introdotto sui loro server di recente a partire da agosto 2019.

    Mi è stato detto anche che se l'user agent è mancante nelle query, anche queste richieste vengono accettate non generando alcun errore.

    Quindi alla luce di quanto è venuto a galla vi chiedo:
    sarebbe troppo chiedere a voi di AlterVista di aggiornare l'user agent in modo tale che il MSIE risulti essere almeno 9.0 (invece di 7.0)?

    Risolverebbe il mio attuale problemino ma soprattuto preverrebbe eventuali altri futuri malfunzionamenti (non solo al mio sito), anche di maggiore importanza.
    Ultima modifica di allabouthd500x : 06-12-2019 alle ore 16.05.49

  11. #11
    L'avatar di alemoppo
    alemoppo non è connesso Staff AV
    Data registrazione
    24-08-2008
    Residenza
    PU / BO
    Messaggi
    15,601

    Predefinito

    Tra pochi giorni sarà risolto. Ti farò sapere.

    Ciao!

  12. #12
    allabouthd500x non è connesso Neofita
    Data registrazione
    05-04-2018
    Messaggi
    28

    Predefinito

    Fantastico!
    Grazie!

    Ciao

Tags for this Thread

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •