Visualizzazione risultati 1 fino 3 di 3

Discussione: Sfondo DIV

  1. #1
    yakamoz non Ŕ connesso Neofita
    Data registrazione
    16-05-2013
    Messaggi
    11

    Predefinito Sfondo DIV

    buonasera,
    ho un problema nell inserire uno sfondo in un contenitore div
    ho una cartella CSS in cui c e il foglio di stile style.css (il foglio di stile per tutto il resto funziona correttamente)
    all interno del style.css
    .boxcontimmp2
    {
    height:450px !important;
    width: 20%;
    background-image: url(..\images\sfondoscri2.jpg);
    margin-left: auto;
    margin-right: auto;
    color:#3B495A;
    }
    nella root ci sono le pagine PHP tra cui una che richiama quel box :
    echo"<div class="boxcontimmp2">";
    echo "<h1>" .$imm2. "</h1>";
    echo "</div>";
    nella root c'Ŕ una cartella images in cui c'Ŕ effettivamente il file sfondoscri2.jpg
    cosa sbaglio?

  2. #2
    mzanella non Ŕ connesso AlterGuru
    Data registrazione
    29-12-2015
    Messaggi
    1,141

    Predefinito

    Intanto hai sbagliato sezione , questo andrebbe in HTML, XHTML e CSS.

    Poi, a occhio, hai sbagliato il percorso dell'immagine che dovrebbe essere
    Codice:
    background-image: url("../images/sfondoscri2.jpg");

    I suggerimenti che do pi¨ spesso:
    • Le funzioni mysql_* sono deprecate. Usa PDO o MySQLi.
    • Non memorizzare le password in chiaro nella base di dati. Usa password_hash().
    • Indenta correttamente il codice e usa nomi significativi per gli identificatori.


  3. #3
    yakamoz non Ŕ connesso Neofita
    Data registrazione
    16-05-2013
    Messaggi
    11

    Predefinito

    si effettivamente ho sbagliato sezione effettivamente avevo scritto background-image: url("../images/sfondoscri2.jpg");
    poi nelle varie prove ho tentato tutte le variabili ,
    alla fine ho scoperto che il problema era su cloudfare che aveva la cache abilitata , quindi qualsiasi modifica io facessi non veniva presa
    nonostante avessi gia attivato la modalitÓ di sviluppo questa era disattivata ! Ora riattivata e azzerata la cache vedo correttamente l immagine..
    Grazie lo stesso !

Regole di scrittura

  • Non puoi creare nuove discussioni
  • Non puoi rispondere ai messaggi
  • Non puoi inserire allegati.
  • Non puoi modificare i tuoi messaggi
  •